14:11:24 <tobberydberg> #startmeeting publiccloud_wg
14:11:25 <openstack> Meeting started Wed Feb  1 14:11:24 2017 UTC and is due to finish in 60 minutes.  The chair is tobberydberg. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:11:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:11:29 <openstack> The meeting name has been set to 'publiccloud_wg'
14:12:03 <tobberydberg> Welcome everyone :) I think we are 5-6 in the room right?
14:12:27 <zhipengh> yep
14:12:27 <Miouge> Sounds about right
14:12:47 <tobberydberg> You will have to be gentle - first meeting I'm the chair ;-)
14:13:04 <tobberydberg> ok..first topic..
14:13:30 <tobberydberg> #topic Reveiw last weeks agenda items (APs)
14:13:53 <tobberydberg> We had 3 actions from last meeting
14:14:17 <tobberydberg> in order - zhipengh - come up with a template for case studies
14:14:55 <zhipengh> so I've been discussing this matter with colleagues from product working group
14:15:21 <zhipengh> and I think it might be a good idea to use the pwg's user story to document our case studies
14:15:35 <zhipengh> they got repo, template, mechanism, everything
14:15:49 <zhipengh> #link http://specs.openstack.org/openstack/openstack-user-stories/
14:16:04 <zhipengh> #link https://github.com/openstack/openstack-user-stories
14:16:43 <zhipengh> any thoughts on that ?
14:17:01 <tobberydberg> I think that sounds good
14:17:17 <tobberydberg> Trying to have a look at it
14:17:30 <seanhandley> Looks sensible +1
14:17:38 <zhipengh> one example could be #link http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/baremetal-service.html
14:17:41 <yankcrime> i think some of the broader ones look fine as an example
14:17:42 <yankcrime> http://specs.openstack.org/openstack/openstack-user-stories/user-stories/proposed/lifecycle-management.html
14:17:54 <zhipengh> yes yankcrime
14:19:23 <yankcrime> i think the case studies we produce should reflect the diversity of workloads that public clouds typically entertain
14:19:36 <yankcrime> so a simple template with fairly generic and broad sections would work well imo
14:20:19 <zhipengh> agree, we reflect the public cloud specific requirements in the details
14:20:55 <tobberydberg> agree
14:21:34 <tobberydberg> More opinions about this?
14:21:41 <yankcrime> there'll be at least a couple of things common to all - why public cloud was a key requirement from a customer's pov, and what we as public cloud operators do with our infrastructure to make sure our openstack installations are up to the task
14:23:17 <tobberydberg> Agree
14:23:44 <Miouge> Yep
14:24:03 <tobberydberg> That one should definitely be there
14:24:38 <tobberydberg> Maybe we should have a couple more things to be in common?
14:25:12 <tobberydberg> Any thoughts?
14:26:46 <tobberydberg> If not, lets leave it for now and go to a vote about using that structure for the user stories?
14:26:48 <yankcrime> challenges that the customer faced, was there anything in particular about openstack that really helped (or even hindered) the project, problems and solutions really i guess
14:27:22 <tobberydberg> That's a good one as well!
14:27:22 <Miouge> Good stuff about lifecycle management, I would also see something around identity management and capacity management. As a Public Cloud those 2 point bring additional challenges compared to a private cloud or enterprise
14:27:37 <yankcrime> i say we take a cut of one of those templates and use that as a basis for an example public cloud case study, once we're happy with the structure and what's captured after we've updated the template can be used for further case studies
14:27:51 <yankcrime> Miouge: deffo
14:28:05 <yankcrime> capacity management is a big problem for smaller public cloud operators
14:28:14 <yankcrime> and let's face it we're all small in comparison to aws, microsoft et al ;)
14:28:23 <zhipengh> I think we could add a public cloud specfic section to the template
14:28:29 <tobberydberg> Hehe, we all are =)
14:28:41 <zhipengh> which is something like "implementation considerations"
14:28:53 <zhipengh> we could put id mgmt, capacity, lcm
14:29:04 <zhipengh> all in that section
14:30:49 <tobberydberg> I agree with you yankcrime about cutting a part of that template to an example
14:31:09 <tobberydberg> Is that the way to move forward?
14:31:18 <yankcrime> we probably need to get moving with this fairly quickly if we want to have something in place for boston, so that seems like a sensible way to get this moving along
14:31:50 <tobberydberg> Lets put that to a vote then
14:35:14 <tobberydberg> #startvote Can we agree on that we should create an example public cloud case story and then you that as template (Based up on the product working group template)? Yes, No
14:35:15 <openstack> Begin voting on: Can we agree on that we should create an example public cloud case story and then you that as template (Based up on the product working group template)? Valid vote options are Yes, No.
14:35:16 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:35:36 <yankcrime> #vote Yes
14:35:37 <seanhandley> #vote Yes
14:35:44 <tobberydberg> #vote Yes
14:36:16 <tobberydberg> More votes?
14:36:19 <zhipengh> #vote yes
14:36:55 <tobberydberg> #endvote
14:36:57 <openstack> Voted on "Can we agree on that we should create an example public cloud case story and then you that as template (Based up on the product working group template)?" Results are
14:36:58 <openstack> Yes (4): zhipengh, yankcrime, tobberydberg, seanhandley
14:37:36 <tobberydberg> Ok. zhipengh: Something you are interested in setting up?
14:38:02 <zhipengh> tobberydberg no problem
14:38:15 <tobberydberg> Thank you!
14:38:19 <yankcrime> \o/
14:38:34 <zhipengh> :)
14:38:37 <yankcrime> i don't mind helping zhipengh - feel like i've just created a load of work for you!
14:38:57 <zhipengh> yankcrime you could help reviewing :P
14:39:06 <yankcrime> no problemo
14:39:32 <tobberydberg> #action zhipengh setting up basic structure of user story example - with help =)
14:39:48 <tobberydberg> Next action from last meeting is on me
14:40:15 <tobberydberg> List of problem areas
14:40:31 <tobberydberg> and features missing for public clouds
14:40:44 <tobberydberg> I did send you a link yesterday
14:40:44 <tobberydberg> https://docs.google.com/spreadsheets/d/1Mf8OAyTzZxCKzYHMgBl-QK_2-XSycSkOjqCyMTIedkA/edit#gid=0
14:41:09 <yankcrime> tobberydberg: where was that sent to?  first time i've seen it tbh...
14:41:21 <tobberydberg> A start for that list - feel free to add items and edit as you wish
14:41:28 <Miouge> yankcrime: same here
14:41:32 <zhipengh> thx tobberydberg
14:41:52 <tobberydberg> Sorry, my bad
14:41:54 <yankcrime> looks like a really good start though tobberydberg
14:42:16 <tobberydberg> I just added it to the agenda at the etherpad...
14:42:34 <tobberydberg> So its understandable you haven't seen it before =)
14:42:50 <tobberydberg> Thanks! Had good help from @seanhandley
14:42:56 <zhipengh> :)
14:43:07 <Miouge> Great stuff
14:43:27 <seanhandley> It's a good start that list - I'm sure there's many more things we can add over time
14:43:38 <Miouge> What is implied with “Full support for tenant specific provider networks.” can we be more specific about things lacking?
14:44:12 <tobberydberg> I guess we keep that a living document for now and let it grow =)
14:44:19 <tobberydberg> Yes, of course
14:45:01 <tobberydberg> 15 minutes left...moving on a bit here it that is ok and if we have time we can discuss that more
14:45:25 <tobberydberg> Matt had the next - update wiki with agreed milestones for Boston
14:45:40 <tobberydberg> I believe he did?
14:45:51 <yankcrime> yup, under scope?
14:46:15 <yankcrime> i think that looks good
14:46:29 <tobberydberg> I think so to!
14:47:07 <tobberydberg> Next topic
14:47:13 <tobberydberg> #topic Discuss "User story template"
14:47:36 <tobberydberg> I guess we can say that we covered that one for this meeting already?
14:48:09 <tobberydberg> Or do we have more to add right now?
14:48:10 <seanhandley> Yeah tobberydberg
14:48:17 <seanhandley> i.e. I think we covered it
14:48:20 <yankcrime> i think that's done, yeah
14:48:30 <tobberydberg> good
14:48:35 <tobberydberg> #topic Forum submission
14:48:36 <yankcrime> there was one other action that was supposed to rollover btw, which was a 'definitions' section on the wiki
14:48:42 <yankcrime> that's been done, as you can see
14:48:59 <tobberydberg> aha, missed that one
14:49:05 <tobberydberg> ok, good!
14:49:11 <yankcrime> :D
14:49:49 <tobberydberg> ok, so thats all good then =)
14:50:57 <tobberydberg> Forum session submission .... It's more of a question to the group if you think we should submit for a session there. Thought about that?
14:51:19 <tobberydberg> ...at Boston summit that is...
14:51:31 <zhipengh> Forum is different from the usual CFP ?
14:51:43 <yankcrime> might be nice to do something that introduces the public cloud WG
14:51:48 <yankcrime> if that's what you mean?
14:51:50 <tobberydberg> https://wiki.openstack.org/wiki/Forum
14:52:17 <tobberydberg> The Forum is the part of Summit that replaces the Design Summit
14:53:05 <zhipengh> we should get the maximum exposure for sure
14:53:33 <tobberydberg> I think that we should submit for it
14:53:46 <yankcrime> let's put it to a vote
14:54:01 <yankcrime> (although i suspect we're all going to say yes ;) )
14:54:17 <tobberydberg> #startvote Submit for a forum session at the Boston summit? Yes, No
14:54:19 <openstack> Begin voting on: Submit for a forum session at the Boston summit? Valid vote options are Yes, No.
14:54:20 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
14:54:27 <tobberydberg> #Yes
14:54:30 <zhipengh> #vote yes
14:54:38 <seanhandley> #vote Yes
14:54:46 <yankcrime> #vote Yes
14:54:51 <tobberydberg> #vote yes
14:54:57 <tobberydberg> #endvote
14:54:58 <openstack> Voted on "Submit for a forum session at the Boston summit?" Results are
14:54:59 <openstack> Yes (4): zhipengh, yankcrime, tobberydberg, seanhandley
14:55:29 <tobberydberg> #action tobberydberg will check for deadline dates for submission
14:56:20 <tobberydberg> Good, I check deadline and we take it from there.
14:56:34 <tobberydberg> Time flies
14:57:05 <tobberydberg> Does anyone have something else they would like to put to discussion?
14:57:22 <tobberydberg> The last thing on the agenda can be pushed
14:57:29 <yankcrime> nothing from me
14:57:39 <zhipengh> i'm all good :)
14:58:04 <seanhandley> I got nothing :)
14:58:36 <tobberydberg> Ok. Lets push that one to next meeting since time is almost up.
14:58:44 <yankcrime> 👍
14:59:21 <tobberydberg> Thank you all for today then! ....and for beeing gentle with me =)
14:59:31 <yankcrime> thanks tobberydberg and good job :)
14:59:41 <zhipengh> thx tobias
14:59:49 <tobberydberg> Thank you =)
14:59:50 <seanhandley> You did well tobberydberg
14:59:54 <seanhandley> Take care folks - see you next time o/
14:59:59 <yankcrime> o/
15:00:01 <tobberydberg> #endmeeting