14:12:23 <mattjarvis> #startmeeting Public Cloud WG
14:12:24 <openstack> Meeting started Wed Dec  7 14:12:23 2016 UTC and is due to finish in 60 minutes.  The chair is mattjarvis. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:12:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:12:28 <openstack> The meeting name has been set to 'public_cloud_wg'
14:12:59 <mattjarvis> so we seem to have some names as attendees who aren't here - is anyone else lurking ?
14:13:09 <s3an2> o/
14:13:21 <mattjarvis> ah hello s3an2
14:13:51 <mattjarvis> so firstly thank you all for attending
14:14:02 <mattjarvis> this will be a bit of a work in progress for the first few meetings
14:14:05 <mcunietti> thank you for gathering us all
14:14:11 <mattjarvis> the most important things are to define goals and milestones
14:14:32 <mattjarvis> ah, one other thing - if you haven't done this already could you also add which organisation you are representing
14:14:34 <mattjarvis> in the etherpad
14:14:48 <mattjarvis> it's important that we have a representative quorum
14:14:48 <mcunietti> +1
14:14:52 <mattjarvis> and this helps us track
14:15:10 <mattjarvis> is VW here ?
14:15:18 <mattjarvis> he said he would try to join
14:15:18 <mcunietti> I suggest also to add URL and links to service
14:15:24 <mattjarvis> good idea mcunietti
14:16:11 <mcunietti> I see Memset also is here! good
14:16:48 <rmart04> Indeedy!
14:17:00 <mattjarvis> #topic Meeting cadence and communication methods
14:17:12 <mattjarvis> so on to our first topic
14:17:53 <mattjarvis> for some of the WG's IRC hasn't been a favourite choice, particularly when there are non-technical folks involved too
14:18:15 <mattjarvis> I hope this group will cover both technical and non-technical issues, so is IRC an issue for anyone right now
14:18:50 <mcunietti> in order to get an answer, let's add the job description to one's line on etherpad
14:19:31 <mattjarvis> I've also booked these meetings bi-weekly to begin with as I think there are some fundamental things we need to work out, which will probably involve collaboration around documents to begin with
14:19:44 <s3an2> If IRC was an issue for someone we may not get an answer here
14:19:49 <mgagne> I prefer IRC tbh as it helps overcoming the language barrier (for me) although I agree that video conference would help us get much higher communication bandwidth
14:19:58 <mattjarvis> s3an2,  that is true
14:20:21 <mattjarvis> mgagne, I suspect initially we will collaborate around documents until we work out some milestones, so that will be less of an issue
14:20:34 <mattjarvis> but I would also like to do face to face meetings at the midcycles and summits
14:20:46 * mgagne nods
14:21:04 <s3an2> mattjarvis, +1 for FTF
14:21:19 <mattjarvis> what are the groups thoughts on the assumptions I put in the ether pad for how this group might work ?
14:21:39 <rmart04> I’m easy IRC/FTF/VC
14:21:58 <mattjarvis> this was mainly stolen from the scientific WG, but I know the user committee is keen to see WG's have clearly defined goals and milestones rather than be talking shops
14:22:17 <mattjarvis> I see others have joined - welcome all
14:22:22 <mattjarvis> great turnout :)
14:22:31 <tobberydberg> Agreed mattjarvis
14:23:13 <mattjarvis> so in the absence of any disagreement, we will stick to bi-weekly and IRC for the minute, with the caveat that this may change, add etc.
14:23:13 <mcunietti> to answer to your question, i suggest we may start addressing competition with AWS. The last Re:invent almost killed me :-)
14:23:24 <mattjarvis> lol
14:23:30 <mgagne> I'm fine with the assumptions. They are high level enough that there is nothing to say so far about them.
14:23:50 <mattjarvis> ok, I think we need to take this step by step - we will get to setting goals :)
14:24:20 <mattjarvis> does anyone else have anything to add to this topic ?
14:24:41 <mattjarvis> in that case ...
14:24:58 <mattjarvis> #topic Who is our constituency - how do we ensure that we are representative
14:25:06 <jenk_s_> +1 on competition. Let's think about how to increase PC adoption and usability.
14:25:26 <mattjarvis> so I think this topic is important before we really do anything in this WG
14:26:06 <mattjarvis> IMO we need to define clearly who our constituency are - ie. what defines a public cloud. If we are going to attempt to represent a community, then we need to define what that community consists of
14:26:36 <mcunietti> stick to the good old NIST definition? ;-)
14:26:59 <mattjarvis> I have added a section to the ether pad entitled Who is our constituency. Perhaps the easiest way to do this might be if we take 5 minutes to add our thoughts to the etherpad under that section
14:27:13 <mattjarvis> the output of this I would like to be an agreed definition that goes onto our wiki page
14:27:29 <mattjarvis> so if I could ask you all to add your thoughts to that section
14:27:30 <mcunietti> "Public cloud. The cloud infrastructure is provisioned for open use by the general public. It may be owned, managed, and operated by a business, academic, or government organization, or some combination of them. It exists on the premises of the cloud provider."
14:27:56 <mattjarvis> great mcunietti - could you add that ? Is that the NIST definition ?
14:28:09 <mcunietti> yep
14:28:57 <mattjarvis> there has been some discussion on the lists about whether restricted community clouds also fall under the definition eg. some of the science clouds
14:28:58 <mgagne> yes, found the same
14:29:03 <mcunietti> also, I think we should limit to IaaS, shouldn't we?
14:29:40 <zhipengh> and of course, based upon OpenStack
14:29:58 <mgagne> I think the definition is broad enough to encompass most use cases of what should be a public cloud.
14:31:17 <jenk_s_> How should we factor into our WG other projects such as Tacker for NFV -- also very important to the providers.
14:31:56 <mattjarvis> jenk_s_, the way I would like that to happen is for this WG to be the focal point for interaction with the public cloud provider community
14:32:04 <mattjarvis> but TBC
14:32:25 <zhipengh> jenk_s_ I think NFV might be out of scope here
14:32:37 <mcunietti> I agree mattjarvis, this could be a "front-end" for the Openstack community when maybe involved in the market disputes or egulation auditions
14:32:38 <zhipengh> if we consider the classic public cloud definition
14:32:44 <mgagne> yea, looks more related to telco or enterprise wg
14:33:19 <mattjarvis> so my second question in this area - again part of the idea of being representative
14:34:05 <mattjarvis> do we represent public cloud operators as per the marketplace - ie. sponsors of the Foundation ?
14:34:15 <mattjarvis> or is our community wider than that
14:34:28 <mcunietti> I would split the representation concept in two: internal (towards the OS community) and external (the market, the customers, the other non-OS players)
14:34:55 <mcunietti> the press also, in the latter
14:35:01 <mattjarvis> ok, could you articulate that idea in the ether pad ?
14:35:12 <mcunietti> right away
14:35:19 <mattjarvis> ty
14:37:27 <mcunietti> done
14:37:59 <mgagne> so this is a way to represent our group to others? (internal: the community itself, external: the market/press)
14:38:41 <rmart04> We (Memset) are not currently listed on the OSFMP, making this a requirement could restrict smaller or newer public cloud operators from representing.
14:38:53 <logan-> ^ ++
14:39:07 <mattjarvis> rmart04, that is a valid point, could you add to the ether pad please
14:39:11 <rmart04> sure
14:39:59 <mattjarvis> although I would say that there is a low barrier of entry for start ups in terms of cost
14:40:38 <mattjarvis> IIRC you also can't use the OpenStack logos
14:40:45 <mgagne> As long as the cloud is offered publicly, I think it's fine. Counter example, we have a huge private cloud for dev and I wouldn't represent its interests in this group.
14:41:05 <mattjarvis> hello VW
14:42:09 <mattjarvis> some very good points raised there, looking at time I'd like to keep moving this time - but feel free to continue adding to the ether pad
14:42:24 <rmart04> Logos > Not for commercial use, I believe.
14:42:38 <mattjarvis> rmart04, I believe that is true
14:42:42 <mcunietti> VW= Vogels Werner, happy you finally joined the rebellion :-)
14:42:44 <mattjarvis> unless you have an agreement in place
14:43:22 <mattjarvis> so finally on the idea of being representative, I added a section about membership of the WG
14:43:26 <mattjarvis> suggestions again please
14:43:38 <mattjarvis> I know their are folks not on the lists who should be represented
14:43:43 <mattjarvis> I have reached out to a few I know
14:43:54 <mattjarvis> but it would be good to have the most representative consituency
14:44:16 <mattjarvis> if anyone has any other ideas, or has contacts with other providers who aren't here
14:44:26 <mattjarvis> it would be great to get as many people as possible
14:44:52 <mattjarvis> again this was something that came out of the scientific WG, and I know they found it useful
14:45:00 <mcunietti> would it be good to list all the publi cloud providers we know, and have direct emails to our contacts? I think we can cover pretty much all of them
14:45:19 <mattjarvis> mcunietti, can you take an action to add that list to the ether pad ?
14:45:24 <mcunietti> ok
14:45:26 <mattjarvis> I assume you mean from the marketplace
14:45:30 <tobberydberg> Sounds good
14:45:37 <mattjarvis> #action mcunietti to add list of public cloud providers to the etherpad
14:46:27 <mcunietti> I mean the ones where each of us has direct contacts and emails
14:46:50 <mattjarvis> both might be good information to have in one place
14:47:13 <mgagne> like word of mouth with people/cloud you know
14:48:02 <mcunietti> exactly
14:48:26 <mcunietti> I don't think that going through official contact points would work
14:49:36 <mattjarvis> so we have 10 minutes left for this meeting, does anyone else have anything to add to this topic for the minute ?
14:49:55 <mattjarvis> I'd suggest that we can regularly cycle back to the representation aspect as we move this WG forward
14:50:38 <mattjarvis> and please do add any further thoughts to the ether pad. At some point I will then collate, we can vote on the content and then add to our wiki page
14:51:26 <mattjarvis> given where we are with time, I would like to bump up topic 5 which will then leave us all the remaining time to add thoughts on purpose and goals
14:51:32 <mattjarvis> is that OK with everyone else ?
14:51:40 <mgagne> +1
14:51:42 <tobberydberg> go
14:51:45 <rmart04> +1
14:52:01 <mattjarvis> #topic Co-chair proposals <-- nominations and vote.
14:52:01 <mattjarvis> #topic co-chair nominations
14:52:28 <mattjarvis> so as with all WG's it is appropriate to have more than one chair
14:52:40 <mattjarvis> are there any volunteers to act as co-chairs ?
14:53:25 <mattjarvis> again this comes down to being representative, and also means that everything in terms of organisation isn't resting on one individual
14:54:18 <mattjarvis> lol
14:54:21 <mattjarvis> no-one ?
14:54:25 <mcunietti> ok matt, I step forward
14:54:26 <zhipengh> i could volunteer myself
14:54:46 <mattjarvis> excellent :)
14:55:18 <VW> sorry - I'm late - got tied up with things this morning
14:55:19 <mattjarvis> I actually see nothing wrong with 3 co-chairs, does anyone have any thoughts or issues ?
14:55:48 <mattjarvis> no worries VW - progress is on the etherpad
14:56:19 <tobberydberg> I can do it as well!
14:56:51 <mgagne> FYI, less than 3 minutes left.
14:57:30 <mattjarvis> ok, we should probably put this to a vote, but no time today, lets return to this next week and decide what to do
14:57:58 <mattjarvis> so before we have to leave, the last topics were to discuss purpose, goals and scope - all kind of linked together
14:58:28 <mattjarvis> I'd actually suggest the best way to do this would be to add ideas to the ether pad over the next two weeks and discuss once we've all added content
14:58:42 <mattjarvis> #topic Discuss purpose and goals
14:59:19 <mattjarvis> if you check out the bottom of the ether pad I have added sections on in scope, out of scope, and purpose
14:59:33 <mattjarvis> could everyone please add their thoughts in those sections for discussion at the next meeting ?
14:59:46 <zhipengh> sure
14:59:49 <VW> aye, captain
14:59:49 <tobberydberg> yes
14:59:58 <mattjarvis> this has been a great turnout, thank you all for participating
15:00:07 <mgagne> thanks!
15:00:09 <mattjarvis> next meeting will be in 2 weeks time
15:00:09 <mcunietti> thank you all
15:00:12 <tobberydberg> Thank you!
15:00:13 <rmart04> Sure, thanks for sorting this out!
15:00:20 <mattjarvis> look forward to great work with this WG !
15:00:21 <mcunietti> ok noted down
15:00:33 <mattjarvis> #endmeeting