09:10:33 <ttx> #startmeeting ptl_sync
09:10:34 <openstack> Meeting started Tue Dec  2 09:10:33 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:10:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:10:37 <openstack> The meeting name has been set to 'ptl_sync'
09:11:08 <ttx> Let's wait for John or Angus :)
09:11:13 <mikal> Works for me
09:11:16 <mikal> I'm just lurking really
09:11:22 <mikal> I see this as a John meeting now
09:16:21 <ttx> johnthetubaguy: o/
09:16:35 <johnthetubaguy> ttx: hey, sorry, bit late out the shower this morning
09:16:50 <ttx> No pb
09:16:51 <ttx> #topic Nova
09:17:07 <ttx> #link https://launchpad.net/nova/+milestone/kilo-1
09:17:11 <ttx> Two weeks to milestone
09:17:24 <johnthetubaguy> yeah, I didn't do the pushing out of stuff thats not in review yet
09:17:28 <johnthetubaguy> I should do that this morning
09:17:33 <ttx> Time to push back the stuff obviously not started, at least
09:17:44 <mikal> I think some of the stuff marked as in review is actually implemented
09:17:47 <mikal> https://blueprints.launchpad.net/nova/+spec/hyper-v-host-power-actions for example
09:17:51 * ttx checks
09:18:06 <johnthetubaguy> mikal: yeah, I plan to do a sweep, people tend not to update there blueprints much
09:18:35 <ttx> or anti-affinity-on-migration
09:18:55 <ttx> well, if our system was fully integrated, they wouldn't need to
09:19:18 <ttx> vmware-spbm-support might be completed too
09:19:29 <johnthetubaguy> ttx: agreed
09:19:44 <johnthetubaguy> about the middle statement, need to check the others
09:20:08 <ttx> protip: I use http://status.openstack.org/release/ to spot them
09:20:24 <ttx> blueprints that have all green dots have all the linked reviews in
09:20:38 <ttx> that doesn't mean they are complete, but they are generally good candidates
09:20:54 <johnthetubaguy> ttx: not see that one before, neat
09:21:20 <ttx> The report actually fetches reviews that are linked from the blueprint whiteboard and gets status from them
09:22:05 <ttx> so it relies on a weak association (gerrit adding a note to the whiteboard)
09:22:13 <ttx> but it's better than nothing
09:22:34 <mikal> johnthetubaguy: https://blueprints.launchpad.net/nova/+spec/log-request-id-mappings is interesting. The outstanding review at the end is an unapproved spec, I think that one shouldn't be approved?
09:23:05 <johnthetubaguy> mikal: its not approved, as such
09:23:30 <mikal> Oh, pending approval
09:23:35 <mikal> The "approver" being set confused me
09:23:38 <ttx> remember that the blueprint page is now more of an external communication tool, so deferring a BP to k2 is just saying "that's where it looks like it will land". We can move the BP back to k1 if it suddenly makes progress
09:23:54 <johnthetubaguy> mikal: I don't reset that one when I un approve, takes too long
09:24:03 <mikal> Fair enough
09:24:09 <johnthetubaguy> ttx: yeah, agreed
09:24:29 <mikal> We should definitely unassign milestones for the unapproved specs then
09:24:35 <ttx> "this is our best guess at what's coming in the short term"
09:24:36 <mikal> Which is ttx's script, yes?
09:24:54 <johnthetubaguy> mikal: they mosty are, its the ones that got into kilo, somehow, that mess things up :(
09:25:08 <ttx> mikal: well, sometimes you're pretty sure the spec will make it, so you still want to track it as a milestone objective
09:25:28 <ttx> (we mark them as blocked)
09:25:41 <ttx> (but don't think that's the case for this one)
09:25:46 <mikal> Another one is https://blueprints.launchpad.net/nova/+spec/nova-pagination -- most recent review is a spec, is marked approved.
09:25:50 <mikal> (I read the right field this time)
09:25:55 <johnthetubaguy> ttx: I keep wondering about doing that for stuff related to priority blueprints, so its easier to track the spec reviews, but not done that
09:26:15 <johnthetubaguy> mikal: not done my friday updating of specs yet
09:26:17 <ttx> yes, sounds like a good way to track "priority blueprints"
09:26:30 <ttx> lets them emerge from noise
09:27:19 <ttx> johnthetubaguy: I'll let you update the list off-sync
09:27:46 <johnthetubaguy> yeah, meant to do that yesterday, but I am slammed right now :(
09:28:03 <ttx> For the meeting today, remember it's a cross-project meeting and we announce it the day before now... so if you have topics to discuss, you should post them beforehand
09:28:19 <ttx> directly on https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
09:28:33 <ttx> we'll discuss "Convergence on specs process" today
09:28:43 <ttx> which you proposed last week
09:29:02 <johnthetubaguy> yeah… not done the ground work for that, but I can add some links to nova things
09:29:30 <ttx> johnthetubaguy: anything else ?
09:29:38 <johnthetubaguy> ttx: nothing from me
09:29:43 <ttx> johnthetubaguy: ok, ttyl!
09:29:52 <ttx> asalkeld: still around ?
09:29:55 <asalkeld> hi
09:30:00 <ttx> mikal: thanks for lurking!
09:30:01 <asalkeld> sorry i missed
09:30:05 <ttx> asalkeld: np
09:30:08 <ttx> #topic Heat
09:30:10 <mikal> ttx: NP, although I feel I said too much
09:30:24 <ttx> mikal: you should improve your lurking.
09:30:46 <ttx> https://launchpad.net/heat/+milestone/kilo-1
09:31:02 <ttx> 2 weeks to go, this looks in relatively good shape
09:31:09 <asalkeld> yeah
09:31:17 <ttx> All started, most done or in review
09:31:17 <asalkeld> 2 to follow up on
09:31:26 <asalkeld> the "started" ones
09:31:52 <asalkeld> the patches are in review, i'll try see what is going on with those
09:31:53 <ttx> yes, you should basically defer them to k2 once you're convinced they won't make it in k1
09:32:03 <asalkeld> ok, makes sense
09:32:19 <ttx> as I told John before, the idea is to use those pages to communicate when things are likely to land
09:32:27 <asalkeld> sure
09:32:29 <ttx> mostly to people external to your project
09:32:40 <ttx> our best guess
09:33:02 <asalkeld> yeah, i'll ping the author of those 2 bp's and see what's happening
09:33:17 <asalkeld> we are doing a bug cleanup today
09:33:24 <ttx> asalkeld: nice
09:33:33 <asalkeld> so we are having quite a bit of bug changes
09:33:44 <ttx> No other questions from me, did you have any ?
09:33:45 <asalkeld> trying to figure out what is happening with old bugs
09:33:57 <asalkeld> ttx, no all good from my pov
09:34:12 <ttx> asalkeld: awesome, thanks for your time!
09:34:16 <asalkeld> np
13:00:19 <eglynn> ttx: knock, knock ... ready when you are
13:01:04 <ttx> eglynn: o/
13:01:10 <ttx> #topic Ceilometer
13:01:15 <eglynn> #link https://launchpad.net/ceilometer/+milestone/kilo-1
13:01:21 <eglynn> further progress on the kilo-1 roster
13:01:26 <eglynn> ... but still a couple of BPs blocked on specs landing
13:01:31 <ttx> nice progress
13:01:40 <eglynn> I'm most concerned about instance-autorestart
13:01:51 <eglynn> since there hasn't been much recent traction on the reviews
13:01:58 <eglynn> I've emailed the author
13:02:00 <ttx> well, two more weeks
13:02:07 <eglynn> (she doesn't normally hang out on IRC)
13:02:10 <eglynn> yeap
13:02:17 <ttx> Once you're reasonably sure it won't make it, just move it to the k2 roster
13:02:33 <eglynn> yeap, will do
13:02:43 <ttx> The two Blocked are waiting for spec to be approved, right?
13:02:56 <eglynn> yep
13:03:03 <eglynn> there are enough stake-holders in the other blocked spec (RBAC) to ensure it'll land, IMO
13:03:04 <ttx> Is that likely to happen soon?
13:03:24 <eglynn> yeah, the rbac one is mostly a question of careful scoping
13:03:30 <ttx> ok
13:03:36 <ttx> careful speccing :)
13:03:55 <eglynn> (it currently includes some language about keystone v3 domains which are unused in the actual implementation)
13:04:00 <ttx> Looks like you're in great shape, no other question from me
13:04:06 <eglynn> cool
13:04:14 <eglynn> 2014.2.1 due out this week also
13:04:26 <ttx> yes, we'll mention it during the meeting today
13:04:27 <eglynn> #link https://launchpad.net/ceilometer/+milestone/2014.2.1
13:04:52 <ttx> so... 5 backports you'd like to include in it ?
13:05:11 <eglynn> yeap, I've a 5 freeze exceptions requested, but happy to go with just the landed backported if necessary
13:05:21 <eglynn> landed *backport
13:05:23 <eglynn> landed *backports
13:05:28 <ttx> ok, I suspect they are all on apevec radar ?
13:05:48 <eglynn> yeap, on the etherpad, spoke to him about it this morning
13:06:24 <ttx> ok great
13:06:28 <ttx> Other questions ?
13:06:38 <eglynn> nope, nothing else from me
13:06:47 <ttx> eglynn: ok, have a great day then
13:06:53 <eglynn> cool, thanks for your time!
13:06:55 <ttx> SergeyLukjanov: ready when you are
13:07:02 <SergeyLukjanov> ttx, ready
13:07:05 <SergeyLukjanov> ttx, hi
13:07:09 <ttx> #topic Sahara
13:07:22 <SergeyLukjanov> #link https://launchpad.net/sahara/+milestone/kilo-1
13:07:23 <ttx> https://launchpad.net/sahara/+milestone/kilo-1
13:07:32 <ttx> nice green
13:07:53 <SergeyLukjanov> ttx, mostly all of the features are now in review/gating state
13:08:10 <ttx> checking for some completion
13:08:36 <ttx> event-log might be completed already ?
13:09:01 <SergeyLukjanov> https://blueprints.launchpad.net/sahara/+spec/indirect-vm-access is implemented, but spec isn't completely approved
13:09:17 <ttx> exceptions-improvement might be completed too
13:09:19 <SergeyLukjanov> event-log will be most probably postponed to kilo-2, too many patch sets to review
13:09:25 <ttx> oh ok
13:09:43 <SergeyLukjanov> exceptions-improvement already implemented
13:10:12 <ttx> SergeyLukjanov: ok
13:10:23 <ttx> my script ran a few minutes ago :)
13:10:32 <SergeyLukjanov> ttx, :)
13:10:37 <ttx> Your buglist looks a bit wide
13:10:43 <ttx> like, too many unassigned things
13:10:55 <ttx> Are they all bugs you intend to fix before k1 ?
13:11:30 <SergeyLukjanov> ttx, I think nope, need to bug scrub them
13:11:42 <SergeyLukjanov> there are some very low prio or on-going things
13:11:48 <ttx> ok
13:11:53 <ttx> For the meeting today, remember it's a cross-project meeting and we announce it the day before now... so if you have topics to discuss, you should post them beforehand
13:12:01 <ttx> directly on https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
13:12:10 <ttx> That's all I had. Questions ?
13:12:15 <SergeyLukjanov> ttx, yup, thanks for the reminder
13:12:43 <SergeyLukjanov> ttx, I have a small note - we're migrating to the data-processing endpoint type
13:12:49 <SergeyLukjanov> (from data_processing)
13:12:53 <SergeyLukjanov> for consistency
13:13:04 <ttx> #info migrating to the data-processing endpoint type (from data_processing) for consistency
13:13:21 <SergeyLukjanov> that's all from my side
13:13:35 <ttx> does that break existing users ?
13:13:55 <SergeyLukjanov> ttx, nope, client has backward compat handler
13:14:05 <ttx> ok
13:14:13 <ttx> SergeyLukjanov: thx!
13:14:15 <SergeyLukjanov> ttx, tempest and devstack are configurable
13:14:18 <SergeyLukjanov> ttx, thx!
13:14:23 <ttx> dhellmann: ready when you are
13:14:33 <dhellmann> ttx: hi!
13:14:38 <ttx> #topic Oslo
13:14:40 <ttx> o/
13:14:55 <ttx> https://launchpad.net/oslo/+milestone/kilo-1
13:15:10 <ttx> https://launchpad.net/oslo/+milestone/next-kilo
13:15:38 <dhellmann> a couple of those for k1 are going to need to move to k2, but we have a review sprint on the 4th so I'd like to wait and see how far we get then before I move them
13:15:51 <dhellmann> certainly that one that's blocked can move now
13:15:52 <ttx> ok
13:16:52 <ttx> dhellmann: for the oslo.rootwrap release, do I need to do anything ?
13:17:03 <ttx> I'm fine running the script if you walk me through it
13:17:11 <dhellmann> you wrote the script! :-)
13:17:17 <ttx> ah. Hm.
13:17:19 <dhellmann> heh
13:17:27 <ttx> there is some extra things to do though iirc
13:17:33 <dhellmann> I can do it, if you're busy, but I thought I'd check with you before
13:17:43 <dhellmann> oh, yeah, the new release notes script
13:17:49 <ttx> yes, that;
13:18:09 <dhellmann> oslo-incubator/tools/release_notes.sh
13:18:26 <ttx> ok, will try to run that today
13:18:31 <dhellmann> http://git.openstack.org/cgit/openstack/oslo-incubator/tree/tools/release_notes.sh
13:18:34 <ttx> will ping you if I have issues
13:18:44 <dhellmann> that generates most of the body of the email you'd send to -dev
13:18:49 <dhellmann> sure, let me know if you run into trouble
13:19:04 <ttx> it's usually a good thing to get more people to run your scripts :)
13:19:05 <dhellmann> I'll take it off of my list
13:19:10 <dhellmann> definitely
13:19:20 <ttx> will try to do it today, otherwise first thing tomorrow. Will that work ?
13:19:25 <dhellmann> bnemec found some issues with my release process directions (I forgot about having to auth with launchpad)
13:19:54 <dhellmann> today or tomorrow is fine. I would wait until next week if you can't do it tomorrow, but that depends on whether you're available for the weekend to solve problems.
13:20:06 <ttx> ok
13:20:37 <ttx> That's all I had... question on your side ?
13:20:44 <ttx> +s
13:20:52 <dhellmann> I'm approving some specs, and discovering that the filenames don't match blueprint names
13:21:11 <dhellmann> how hard is it to check for that sort of thing in the gate? if I wrote a script, are there credentials for the jenkins user?
13:21:58 <ttx> hmm, Gerrit has, since it runs a number of bug/blueprint updates
13:22:04 <ttx> not sure about Jenkins those days
13:22:14 <dhellmann> actually, I wonder if I could run a query without authenticating
13:22:15 <ttx> there was one for sure
13:22:24 <ttx> you probably could.
13:22:26 <dhellmann> I just need to know if a blueprint exists matching the filename, I don't have to change it
13:22:31 <dhellmann> ok, I'll experiment with that
13:22:47 <ttx> anonymous is a lot simpler
13:23:00 <dhellmann> do you have any rootwrap reviews you want us to prioritize for the sprint?
13:23:10 <ttx> no, the roster is pretty empty
13:23:28 <ttx> the next stage is to get neutron to use the new daemon mode stuff
13:23:38 <dhellmann> ok, good. I'm looking forward to seeing how far we can get with clearing out our backlog
13:23:45 <dhellmann> ah, is there a bp for that work?
13:24:11 <ttx> the guy who was working on it moved to something else
13:24:17 <dhellmann> figures
13:24:19 <ttx> someone else proposed to take it over
13:24:30 <ttx> (in neutron)
13:24:36 <ttx> let me check if there is a spec for it
13:25:26 <ttx> Blueprint would be https://blueprints.launchpad.net/neutron/+spec/rootwrap-daemon-mode
13:25:38 <ttx> Yuriy moved on, Miguel proposed to take it over
13:27:05 * dhellmann nods
13:27:06 <ttx> (Miguel Angel Ajo Pelayo)
13:27:16 <ttx> can't find spec
13:27:58 <ttx> hmm
13:28:02 <ttx> https://review.openstack.org/#/c/93889/
13:28:26 <ttx> actually in better shape than I thought
13:29:02 <ttx> I think there is potential in future oslo.rootwrap to include some of the client code, as it will be a bit common among consumers
13:29:17 <dhellmann> makes sense
13:29:18 <ttx> but I'd like to let neutron shape it
13:29:50 <ttx> so that would be the next step for oslo.rootwrap, but today it's blocked
13:30:04 <ttx> anything else ?
13:30:21 <dhellmann> nothing from me this week
13:30:39 <ttx> shouldn't "tooz adoption" be "Implemented" now ?
13:30:51 <dhellmann> was that done?
13:30:56 <ttx> feels like all things merged
13:31:07 <ttx> at least the two reviews linked in the bp
13:31:09 <dhellmann> the repo needs to be renamed I think
13:31:30 <ttx> ah! ok
13:32:09 <dhellmann> I added a work item and set the status to "slow progress" to nudge jd__
13:32:31 <dhellmann> we might actually be waiting for infra to schedule downtime, and if that's true I'll set it to blocked
13:32:43 <ttx> or "needs infra"
13:32:53 <ttx> which is like the best use ever for this status
13:33:04 <dhellmann> haha, yeah, updated
13:33:14 <ttx> ok, have a good day!
13:33:22 <dhellmann> you, too!
15:05:49 <mestery> ttx: Here and at the ready sir.
15:06:32 <ttx> mestery: o/
15:06:36 <ttx> #topic Neutron
15:07:06 <ttx> https://launchpad.net/neutron/+milestone/kilo-1
15:07:21 <ttx> so.. only 4 ?
15:07:44 <mestery> YEs, it looks very low I know
15:07:56 <mestery> We have been reviewing some huge BPs this cycle, and most are landing for Kilo-2
15:08:03 <mestery> The refactoring is taking a lot of review time in the specs process
15:08:25 <ttx> ok, nothing will just get spec-approved and fasttracked in ?
15:08:33 <mestery> The team is spending the time up front to make sure things go smoothly
15:08:44 <mestery> There may be a few yet, I'm talking to some folks today/tomorrow
15:08:49 <mestery> The flavors stuff may
15:08:56 <ttx> well, I won't mind a peak at k2, that would change from the usual x3 peak
15:09:03 <mestery> And some of the core refactoring will be done next week, so may land yet in Kilo-1
15:09:07 <mestery> Right
15:09:08 <mestery> That's our hope
15:09:27 <ttx> as long as the page reflects what you think will get done, that's good
15:09:42 <ttx> anyone working on https://bugs.launchpad.net/bugs/1323658 ?
15:09:53 * mestery looks
15:10:20 <mestery> Not at the moment no, we've worked on this one off and on for a while now.
15:10:21 <ttx> was rtated critical adn targeted, although it's hardly new
15:10:25 <mestery> Right
15:10:35 <mestery> I know me, salv, and armax have spent time on it off and on during Juno
15:10:40 <mestery> I can priortize this one again
15:11:00 <ttx> maybe that can be downgraded to high, and removed from milestone until someone is assigned to it ?
15:11:22 <mestery> ++
15:11:46 <ttx> currently it looks as if it's a milestone-critical issue without an assignee :)
15:12:00 <ttx> which triggers all kind of weird flags
15:12:00 <mestery> :)
15:12:01 <mestery> Done
15:12:17 <ttx> but if it survived the last 6 months it hardly qualifies at critical in my book
15:12:23 <mestery> ++
15:12:36 <mestery> At various times it's been a nova and/or neutron issue.
15:12:56 <ttx> is there more to do on drop-rpc-compat ?
15:13:07 <ttx> I see 5 landed changes
15:13:40 <mestery> Yes, I spoke to russellb today, he has a few patches left, it should land in Kilo-1 though.
15:13:46 <ttx> ok
15:13:50 <ttx> that's all I had
15:14:22 <ttx> remember to file your topics for the cross-project meeting ahead of this sync now that it is cross-project we need to announce agenda with a bit of advance notice
15:14:28 <mestery> ++
15:14:33 <mestery> Thanks for the reminder ttx
15:14:41 <ttx> page is https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting
15:14:45 <ttx> that's all I had
15:14:54 <ttx> questions on your side ?
15:15:27 <ttx> oh. How are the new repos coming up ?
15:15:37 <mestery> They are coming.
15:15:42 <mestery> We have some new plugin repos approved
15:15:50 <mestery> And the services ones will be done next week while at the mid-cycle
15:15:55 <mestery> We have a spec close to approval there
15:15:58 <ttx> we didn't discuss impact for release management
15:15:59 <mestery> So we can do the work next week
15:16:20 <ttx> what release model would that use ?
15:16:47 <ttx> I remember not panicking reading the original email, so maybe that was covered there
15:16:48 <mestery> There are notes in the spec on that, let me grab the link, would be good to get your commenst in gerrit
15:16:57 <ttx> ++
15:17:03 <mestery> https://review.openstack.org/#/c/136835/
15:17:09 <ttx> ok, will read and comment there
15:17:34 <ttx> #action ttx to read and comment on split spec https://review.openstack.org/#/c/136835/
15:17:38 <mestery> Thanks ttx!
15:17:45 <ttx> thanks, have a great day !
15:18:12 <ttx> nikhil_k: ready when you are
15:18:19 <nikhil_k> ttx: o/
15:18:31 <ttx> #topic Glance
15:18:40 <ttx> https://launchpad.net/glance/+milestone/kilo-1
15:18:50 <ttx> All appear to be in review
15:19:00 <ttx> store-capabilities is missing a priority
15:19:09 <ttx> I guess that was a recent addition
15:19:17 <ttx> yep, 4 hours ago
15:19:31 <nikhil_k> ttx: yeah, was at vacation past few days and could not get a chance to look into it
15:19:42 <nikhil_k> there may be 1 more
15:19:55 <nikhil_k> or 2 (small ones)
15:20:03 <nikhil_k> will take a look at this today/tomorrow
15:20:09 <ttx> sounds good
15:20:52 <ttx> Things look in good shape oevrall. Will PM you about security issue when we are done
15:20:58 <ttx> questions on your side ?
15:21:03 <nikhil_k> :)
15:21:17 <nikhil_k> nothing, still catching up
15:22:06 <ttx> ok then, I won't keep you more
15:25:37 <ttx> david-lyle: we can talk now if you want, or you can go at your usual time (in 15min)
15:26:02 <david-lyle> ttx: now is fine
15:26:08 <ttx> #topic Horizon
15:26:22 <ttx> https://launchpad.net/horizon/+milestone/kilo-1
15:26:40 <ttx> A few undefined/unknown to clear up there
15:26:50 <ttx> but otherwise looks good
15:26:54 <ttx> 2 weeks from target
15:27:32 <david-lyle> yes, most work is on track
15:27:34 <ttx> instance-details-add-host-server is missing an assignee too
15:27:57 <david-lyle> I may just pick that up, it's a fairly small change
15:28:07 <ttx> ok
15:28:23 <david-lyle> was waiting to see if the author of the bp started work
15:28:53 <ttx> is separate-horizon-from-dashboard still likely to land for kilo-1 ?
15:29:07 <ttx> trying to anticipate the release artifact impact
15:29:35 <david-lyle> I doubt it. More likely early K-2
15:30:05 <david-lyle> I'll confirm in the Horizon meeting and move if my inclination is correct
15:30:13 <ttx> sounds good
15:30:27 <ttx> horizon_lib would be published a library on Pypi ?
15:30:31 <ttx> as a*
15:30:53 <david-lyle> yes, there is still some contention around naming
15:31:11 <david-lyle> which seems to be the main roadblock
15:31:26 <ttx> ok, so I guess apart from making the release artifact smaller, that shouldn't affect release management that much
15:31:56 <david-lyle> no, just adding another dependency really
15:32:04 <ttx> That's all I had. Questions on your side ?
15:32:47 <david-lyle> are you aware of any issues with the icehouse and juno neutron gate jobs?
15:33:06 <david-lyle> I can raise in infra as well
15:33:21 <ttx> hmm, nothing in particular -- which doesn't mean there isn't one.
15:33:35 * ttx gave up on knowing everything a few years ago
15:34:35 <ttx> david-lyle: anything else ?
15:34:40 <david-lyle> no worries, I'll continue to try and track down the cause
15:34:43 <david-lyle> no I'm good
15:34:53 <ttx> david-lyle: ok, have a great day!
15:34:56 <ttx> thingee: around?
15:35:05 <david-lyle> ttx: thanks, you too
15:35:45 <thingee> ttx: sorry was having connection problems here
15:35:50 <ttx> #topic Cinder
15:36:04 <ttx> thingee: np
15:36:09 <ttx> https://launchpad.net/cinder/+milestone/kilo-1
15:36:17 <thingee> now tethered to my phone :)
15:36:26 <ttx> did you get to the bottom of the "not started" stuff ?
15:37:22 <ttx> only two weeks to go, so I suspect they should at least have started work
15:37:49 <ttx> especially the brand-new drivers :)
15:38:36 <ttx> ...
15:40:59 <thingee> I have sent emails out, but haven't heard back from people. Going to be punting things this week.
15:40:59 <thingee> Same goes for drivers from people that haven't responded back to my emails.
15:41:00 <thingee> should be a smaller list the next time we talk
15:41:01 <thingee> agreed
15:41:02 <thingee> I've been making a point to tell people this is your only chance for Kilo, so no surprises.
15:41:04 <thingee> mercy there is a lot :)
15:41:06 <thingee> we finally got another one merged last week. there are others that are close.
15:41:06 <thingee> that's it for me.
15:41:26 <ttx> ok great
15:41:52 <ttx> thingee: no more questions from me
15:42:06 <ttx> thingee: have a godo day
15:42:09 <ttx> good*
15:42:30 <thingee> you too
15:42:36 <thingee> evening that is :)
16:49:27 <ttx> notmyname: ready when you are
16:49:39 <notmyname> ttx: good morning/evening
16:49:42 <ttx> #topic Swift
16:49:58 <notmyname> I see you put me on the project meeting schedule
16:50:06 <notmyname> about client dev work
16:50:11 <notmyname> what do you want to cover there?
16:50:11 <ttx> well, you and morganfainberg
16:50:14 <notmyname> right
16:50:21 <notmyname> summary or ....?
16:50:28 <ttx> I want to discuss the approach, see if there is a trend there
16:50:32 <notmyname> ok
16:50:37 <ttx> (I think there is)
16:50:40 <notmyname> great. looking forward to it
16:51:04 <ttx> It's more of a "should other projects also consider it if they find themselves in the same situation" thing
16:51:42 <notmyname> honestly the one thing that concerns me about "openstack-sdk" is the one-tool thing. trying to make one tool that works for all the openstack projects.
16:51:44 <notmyname> ok
16:52:01 <ttx> planning christmas holiday -- do you plan a swift release before end of year ?
16:52:01 <notmyname> but I want to address that if/when it's a problem
16:52:10 <notmyname> I was just looking at that
16:52:14 <ttx> or rather January+
16:52:54 <notmyname> we could either do something the week of the 15th (2 weeks from now) or we could wait until january. we haven't had anything major land, just a lot of smaller fixes
16:52:59 <notmyname> what works best for you?
16:53:37 <ttx> Should be around that December week. Your call
16:54:17 <ttx> Early in Jnaury works too. Maybe we can wait one more week and see how it goes ,
16:54:19 <ttx> ?
16:54:59 <ttx> Just avoid the weeks of the 22 and the 29
16:55:01 <ttx> :)
16:55:18 <notmyname> ttx: ok, let's propose 2.2.1 RC between dec 11 and 15 and final by the end of the week. does that work?
16:55:31 <ttx> That works. I should be around on the 22nd if we need to push it then.
16:55:36 <notmyname> ok, great
16:55:45 <notmyname> I'll put it on the agenda for tomorrow's swift meeting
16:55:59 <ttx> #info proposed plan to do 2.2.1 RC between dec 11 and 15 and final by the end of the week
16:56:07 <ttx> notmyname: great, thx
16:56:07 <notmyname> anything else?
16:56:11 <ttx> nothing from me
16:56:19 <notmyname> ok, thanks.
16:56:21 <ttx> have a great day!
16:56:23 <notmyname> you too
16:56:30 <ttx> morganfainberg: ready when you are
16:56:51 <morganfainberg> ttx: mostly here.
16:56:56 <morganfainberg> :)
16:56:58 <ttx> #topic Keystone
16:57:05 <ttx> morganfainberg: turkey issues ?
16:57:15 <ttx> https://launchpad.net/keystone/+milestone/kilo-1
16:57:27 <morganfainberg> Post holiday crud issues. Yay family! ;)
16:57:58 <ttx> token-provider-cleanup -> not started, still on track for dec 18 ?
16:58:02 <morganfainberg> Token provider cleanup is being punted to k2
16:58:09 <ttx> ok
16:58:30 <ttx> the rest looks reasonable
16:58:33 <morganfainberg> Hm is being merged / has been merged to master with 1-2 outstanding patches.
16:58:45 <morganfainberg> That are being rebased today.
16:59:07 <morganfainberg> I'll sweep through and make sure nothing else is missing.
16:59:11 <ttx> morganfainberg: remember we'll discuss the technique of openstack-sdking your incompatible client changes at the cross-project meeting today at 21:00
16:59:14 <ttx> (utc)
16:59:20 <morganfainberg> ++
16:59:37 <ttx> nothing else from me
16:59:39 <ttx> questions ?
16:59:45 <morganfainberg> Noting else on this end.
16:59:53 <ttx> alright then
16:59:56 <ttx> have a good day!
16:59:59 <morganfainberg> Next week though I will be delegating this to Dolph
17:00:12 <ttx> that is a fine thing to do
17:00:23 <dolphm> \o/
17:00:36 <morganfainberg> Wanted you to have a heads up
17:00:43 <dolphm> eek, i won't be available next tuesday, probably at all
17:00:43 <ttx> I'll prepare myself
17:00:51 <ttx> it's fine to skip
17:00:59 <morganfainberg> Ok I will find someone else or let you know we have a skip
17:01:14 <ttx> ack
17:01:21 <ttx> devananda: around ?
17:01:58 <devananda> ttx: g'morning!
17:02:18 <ttx> devananda: fine with syncing a bit early ?
17:02:23 <devananda> sure
17:02:29 <ttx> #topic Ironic
17:02:32 <ttx> https://launchpad.net/ironic/+milestone/kilo-1
17:02:43 <ttx> so.. elephant in the room
17:03:03 <ttx> new-ironic-state-machine, how is the spec going ? Who will be working on that ?
17:03:28 <devananda> right now, everyone is
17:03:38 <devananda> we have a bit of too-many-cooks-spoiling-the-soup going on, IMO
17:04:04 <devananda> I spent most of yesterday, and will probably spend several hours today, trying to sort this out with the team
17:04:08 <ttx> ok
17:04:16 <devananda> we also have several things slated for k2, k3 which depend on this
17:04:20 <ttx> everything else looks good
17:05:13 <devananda> getting progress on that is going to be my main focus for a bit
17:05:14 <ttx> no more questions from me -- did you have any ?
17:05:28 <devananda> hmm. nope!
17:05:37 <devananda> just one comment - the new spec2bp is fantastic
17:06:05 <ttx> the v2 one ?
17:06:11 <devananda> ya
17:06:17 <ttx> feel free to +1 it :)
17:06:21 <devananda> :)
17:06:33 <ttx> Also remember to file your topics for the cross-project meeting ahead of this sync now that it is cross-project we need to announce agenda with a bit of advance notice
17:07:04 <devananda> ah, thanks
17:07:06 <ttx> that's all I had.
17:07:21 <ttx> (agenda for crossproject lives at https://wiki.openstack.org/wiki/Meetings/CrossProjectMeeting)
17:07:22 <devananda> i dont think i have any cross-project agenda items, but appreciate the reminder
17:07:35 <ttx> I just won't be asking for topics during the sync anymore
17:07:46 <ttx> so just edit the wiki yourself
17:07:52 <devananda> :)
17:07:58 <ttx> devananda: have a great day!
17:08:06 <ttx> SlickNik: ready when you are.
17:09:45 <SlickNik> ttx: o/
17:09:54 <ttx> #topic Trove
17:10:10 <ttx> https://launchpad.net/trove/+milestone/kilo-1
17:10:32 <SlickNik> I'm working on cleaning up the BPs/bugs targeted to kilo-1
17:10:51 <ttx> well, that sounds rather reasonable to me already
17:11:20 <ttx> 2 weeks leftr, so next week it will probably be unreasonable to keep in k1 stuff not proposed for review yet
17:11:35 <SlickNik> There are a few bugs that I know won't make it that I'd like to move to k2.
17:11:39 <SlickNik> Yes, exactly.
17:11:56 <ttx> the idea being, to use that page to communicate what you think will happen, to the best of your prediction abilities
17:12:59 <ttx> SlickNik: your status looks good at this point, I don't really have more questions
17:13:05 <ttx> Questions on your side ?
17:13:23 <SlickNik> ttx: None from my side either.
17:13:35 <ttx> SlickNik: alright then, quick and easy
17:13:41 <ttx> have a great day!
17:13:57 <SlickNik> ttx: Thanks — see you at the cross project meeting!
17:14:04 <ttx> see you there!
17:14:05 <ttx> #endmeeting