21:02:54 <ttx> #startmeeting project
21:02:55 <openstack> Meeting started Tue Nov 18 21:02:54 2014 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:56 <devananda> ttx: i feel sad that i'm not on your project meeting ping list
21:02:56 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:58 <mestery> russellb: Ack, me too, I'm still catching up a bit from coming back from paternity leave :)
21:02:59 <openstack> The meeting name has been set to 'project'
21:03:06 <ttx> deva__: oh! my fault
21:03:22 <ttx> devananda: added to template
21:03:27 <ttx> Our agenda for today:
21:03:34 <mikal> Hi
21:03:36 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:39 <ttx> #topic Summary of 1:1 meeting syncs
21:03:47 <ttx> We had a number of 1:1 syncs today, you can see the log here if you're interested:
21:03:52 <ttx> #link http://eavesdrop.openstack.org/meetings/ptl_sync/2014/ptl_sync.2014-11-18-08.58.html
21:04:11 <ttx> mostly about setting release liaisons and turning autokick
21:04:16 <ttx> as well as testing the new 10-min format
21:04:30 <morganfainberg> o/ here too
21:04:33 <ttx> #link http://status.openstack.org/release/
21:04:34 <SlickNik> o/
21:04:37 <dhellmann> did everyone go over the 10 minutes, or was that just a few of us?
21:04:38 <ttx> now shows Kilo release status
21:04:44 <ttx> just a few
21:04:56 <ttx> most stayed within the alloted 10min
21:05:08 * dhellmann endeavors to do better next week
21:05:10 <ttx> #topic Turn this meeting into a PTL+CPL meeting ("cross-project meeting")
21:05:18 <ttx> So... As part of a big plan to scale out PTLs and our project leadership in general, we introduced the concept of Cross-Project Liaisons (CPLs) during the Juno cycle
21:05:30 <ttx> Release management liaisons are just one type of those, and I don't think this meeting should be limited to them
21:05:41 <ttx> This is our only cross-project meeting, and looking back at what we discussed here over the last cycle it was going far beyond release management
21:05:53 <ttx> I think it's time to turn this meeting into a true cross-project weekly meeting, not keep it release-cycle-management-oriented
21:06:00 <mestery> ++, Adding in more CPLs makes sense to me
21:06:01 <ttx> Inviting PTLs and all CPLs with an open agenda
21:06:12 <ttx> And maybe even rotating chairs (release management PTL, Oslo PTL, Infra PTL, QA PTL, Docs PTL..)
21:06:13 <morganfainberg> ++
21:06:21 * ttx opened trap
21:06:24 <annegentle> heh
21:06:28 <ttx> let's see who falls into it
21:06:29 <mestery> ++ to rotating chairs
21:06:30 <eglynn> ttx: do you mean *all* liaisons from all projects? (oslo, docs, qa, api-wg ...)
21:06:33 * mestery falls into the trap
21:06:47 * fungi saw the trap for what it was
21:07:03 * mestery thinks we should share the joys of chairing this meeting :)
21:07:12 <ttx> eglynn: I want us to be able to discuss cross-project topics, and I see CPLs as the cross-project specialists
21:07:14 * morganfainberg let someone else fall into the trap.
21:07:21 <dhellmann> mestery: you can have my share of that joy
21:07:26 <mestery> dhellmann: lol
21:07:27 <ttx> so I would be very happy if they showed up
21:07:35 <annegentle> I like the all liaisons idea.
21:07:36 <mtreinish> mestery: I just know when it was my turn to chair it, I'd forget
21:07:47 <eglynn> ttx: that's potentially a *lot* of people
21:08:06 <eglynn> ttx: ~4/5 per project times how many projects?
21:08:08 <mestery> I think a strict agenda with a strong chair will be helpful with the influx of new people
21:08:11 <ttx> eglynn: not that many, and we have no such thing as a mandatory meeting... the PTL can represent all
21:08:12 <dhellmann> ttx: I'll encourage the oslo liaisons to attend, but many of them only signed up to sling code so I'm not sure how many will do it
21:08:22 <dhellmann> mestery: ++
21:08:39 <ttx> basically, the PTLs can still represent all their team, but we should encouarge CPLs to join
21:08:43 <morganfainberg> i'd rather see the meeting be run cleanly before we rotate chairs.
21:08:57 <ttx> morganfainberg: sure, not throwing the towel just yet
21:09:05 <ttx> the second part was just a suggestion going forward
21:09:14 <ttx> basically, it shouold no longer be my meeting
21:09:25 <ttx> it should be everyone's :)
21:09:46 <devananda> ttx: aren't there already project-specific cross-project meetigns?
21:09:49 <mestery> ttx: ++
21:10:30 <eglynn> it might make more sense to have many 30min cross-project meetings focussed on individual concerns
21:10:32 <morganfainberg> devananda, are there? i'm not aware of many formalized ones beside topical e.g. HM
21:10:33 <eglynn> (i.e. all the oslo liaisons, all the qa liaisons, all the stable-maints etc.)
21:10:34 <devananda> ttx: I'm not sure I see what the goal of "get all CPLs and PTLs together" is, which is not served by just havign the PTLs together
21:10:49 <annegentle> devananda: because PTLs get overloaded
21:10:58 <devananda> eglynn: right -- i thought there were already topic-specific meetings for CPLs
21:10:59 <fungi> think of cpls as ptl delegates
21:11:00 <morganfainberg> annegentle, PTLs don't scale.
21:11:02 <devananda> but maybe I imagined that
21:11:03 <annegentle> devananda: and need API and docs liaisons for sure
21:11:04 <ttx> devananda: the idea is to have a meeting where all sorts of cross-project issues are discussed
21:11:04 <dhellmann> eglynn: the oslo liaisons are all supposed to be coming to the oslo meetings already -- that's a big part of what we do in our meetings
21:11:10 <ttx> whatever is on the agenda
21:11:21 <clarkb> corporals?
21:11:32 <ttx> that's already the case, but the meeting is still called the release meeting
21:11:33 <mestery> If we publish the agenda beforehand, we'll only need particualr CPLs for each meeting, which lightens the load from people having to attend all meetings
21:11:46 <sdague> devananda: it's still really hard to make a coherent cross project whole by just assuming a bunch of smaller cross projects facets will magically make it happen
21:11:47 <dhellmann> I think inviting all of those people to attend is a good way for us to foster new leadership within the project.
21:11:48 <devananda> ttx: for example, if there is an oslo issue that the oslo CPLs need to discuss, does that need to take up time from the docs and qa and api CPLs of every project?
21:11:51 <fungi> clarkb: cross-project liaisons
21:12:00 <SlickNik> dhellmann: ++
21:12:07 <mestery> dhellmann: ++
21:12:13 <devananda> dhellmann: that's a fair point as well
21:12:27 <dhellmann> devananda: I don't think the point is necessarily to talk about oslo issues, as much as to get the people who think about cross-project things together at a time when we're talking about cross-project issues
21:12:35 <ttx> dhellmann: ++
21:12:37 <anteaya> I think ttx is proposing an experiment, I'm for giving it a shot and re-evaluating at K2
21:12:37 <sdague> honestly, I think as long as the agenda is crisp, more people here is fine
21:12:40 <fungi> if it's an oslo-only issue, then it's likely off-topic anyway right?
21:12:45 <devananda> dhellmann: ack
21:12:45 <sdague> dhellmann: ++
21:12:52 <sdague> fungi: agree
21:12:53 <mestery> sdague: ++
21:12:55 <dhellmann> fungi: right, and we'd cover it in our oslo meetings
21:12:58 <devananda> ok, I'm ++ for the experiment as well
21:12:59 <morganfainberg> ++
21:13:13 <SlickNik> sdague: agreed about the crisp agenda
21:13:26 <dhellmann> ttx: are you going to send email to the -dev list inviting everyone? I'll mention it next monday in our oslo meeting, too
21:13:31 <SlickNik> I'm all in favor of the experiment for K1 as well.
21:13:37 <fungi> including cpls allows to avoid a ptl having to say, "oh i have a liaison handling that, i need to ask them and get back to you next week"
21:13:50 <dhellmann> fungi: also a good point
21:14:02 <asalkeld> is it optional for cpls?
21:14:03 <eglynn> does anyone see there being a practical scaling limit to the number of people who can effetcively participate in an IRC meeting?
21:14:20 <Vek> depends on how many talk in said meeting.
21:14:28 <mestery> eglynn: Yes, thus the proposal for a crips agenda and strong chair :)
21:14:34 <mestery> *crisp
21:14:35 <sdague> mestery: ++
21:14:39 <anteaya> depends on the displine of the participants
21:14:44 <ttx> sorry, my desktop just froze
21:14:46 <dhellmann> eglynn: I expect most people to lurk rather than talk, but yeah, that might become an issue
21:14:47 <fungi> asalkeld: i would think everything is optional to some degree. seems to me more like "encouraging" cpls to participate
21:14:52 <sdague> eglynn: there are already 433 people in this room right now
21:14:56 <ttx> at this point the only change is to rename it "cross-meeting project"
21:14:57 <eglynn> Vek: well if they don't get to talk, they might as well just read the logs after the fact IMO
21:15:08 <ttx> and then explain that the agenda is open (it already was)
21:15:16 <sdague> ttx: ++
21:15:20 <dhellmann> ttx: "cross-project meeting"?
21:15:24 <ttx> and that we encourage everyone to join (already the case too)
21:15:29 <eglynn> sdague: being on the channel != being at the meeting in any active sense
21:15:34 * dhellmann does not want a "meeting project"
21:15:37 <devananda> ttx: it sounds like another change would be to actually encourage specific other people to join / participate
21:15:42 <ttx> oops
21:15:43 <Vek> well, unless you're going to turn the channel +m, everyone has the opportunity to talk and contribute...
21:15:48 <ttx> "cross-project meeting" yes
21:15:49 <devananda> which, at least, is not something I have done within Ironic
21:15:54 <dhellmann> ttx: :-)
21:15:57 <sdague> eglynn: sure, but people can decide if it's relevant for them to participate
21:16:05 <sdague> and a strong chair can correct them when they are wrong
21:16:16 <ttx> frankly, it's more a change on the door signthan a change on the content of the room
21:16:19 <mestery> sdague: ++
21:16:34 <ttx> but I think it will go a long way to empower new people
21:16:39 <sdague> ttx: agree
21:16:47 <mestery> I think we already let people optionally attend this meeting anyways, nothing stops them at the moment.
21:16:48 <ttx> key word of the day "empowerment"
21:16:57 <russellb> :)
21:16:59 <eglynn> ttx: how did it work out back in the day when everyone attended the weekly release meeting?
21:17:00 <Vek> mestery: thus my presence :)
21:17:06 <mestery> Vek: Exactly!
21:17:19 <ttx> eglynn: back in the day it was called the "project meeting"
21:17:33 <ttx> and that was the allhands meeting
21:17:56 <ttx> it worked out well, but obviously didn't scale
21:18:07 * russellb imagines an all hands irc meeting these days ...
21:18:07 <ttx> so we turned it into a release meeting
21:18:17 <ttx> but than, that didn't scale...
21:18:40 <ttx> and we switched to 1:1 syncs, with special topics being discussed at the meeting
21:18:41 * dhellmann wonders how many cases we have where the same person is liaison for multiple facets, or multiple projects
21:18:42 * Vek imagines russellb's scenario...and the memory leak that would occur on all the IRC servers ;)
21:18:42 <ttx> and then...
21:18:55 <ttx> special topics were just not all about release
21:19:02 <annegentle> dhellmann: yea was wondering that also
21:19:11 <eglynn> so my recommendation would be to at least pick an individual cross-project concern to concentrate on each week
21:19:19 <ttx> hence the next logical step: call it "cross-project meeting" and not make those release dudes special anymore
21:19:23 <eglynn> oslo one week, docs the next, qa the week after
21:19:28 <sdague> eglynn: so I think that was the point of crisp agenda
21:19:38 <ttx> eglynn: I think that would prevent the hot topic of the day to be discussed
21:19:51 <ttx> in most cases, the hot topic is found the same day of the meeting
21:19:51 <eglynn> sdague: the point was to set the expectation of attendence explicitly
21:20:03 <ttx> (during the 1:1s)
21:20:03 * Vek prefers sdague's "crisp agenda" to eglynn's "one per meeting" too
21:20:21 <ttx> anyway, I'll put it in words and suggest it on the -dev ML
21:20:28 <eglynn> sdague: i.e. "calling all oslo liaisons to attend this week" as opposed to all CPLs feeling semi-obliged to turn up every week
21:20:33 <asalkeld> it seems fairly harmless to me
21:20:40 <sdague> Vek: yeh, because the relevant concerns are going to be topical based what we need now
21:20:52 <dhellmann> yeah, I don't know that we can predict in advance what facet will be important, but also the point is to bring together more people who have the general concern of cross-project issues to deal with whatever the hot topic actually is
21:21:01 <sdague> dhellmann: ++
21:21:12 <ttx> and frankly, some times there won't be any topic to discuss
21:21:14 <ttx> and that's fine
21:21:24 <dhellmann> because if we don't start growing our leadership team, we're going to have some new growing pains pretty soon
21:21:35 <ttx> I just want a predefined avenue to raise general online discussions
21:21:47 <ttx> and I want to get CPLs more recognition too
21:22:06 <ttx> anyway, will push to -ml
21:22:08 <mestery> dhellmann: ++
21:22:21 <ttx> #action ttx to put his "cross-project meeting" rename into more words and a thread
21:22:28 <ttx> #topic Mid-cycle meetups: what and why
21:22:37 <ttx> We are just back from the Design Summit, and we already see mid-cycle meetups being organized and announced
21:22:46 <ttx> On one hand that only makes sense, a cycle is only 6 months and last-minute travel planning is costly and painful
21:22:50 <dhellmann> eglynn: I think the really interested folks will self-select anyway, but an invitation may push some people to attend who might not have thought of it otherwise
21:22:58 <ttx> On the other hand... mid-cycle meetups can be seen as a failure to collaborate virtually with just 2 F2F meetings per year, and requiring more
21:23:12 <ttx> My personal view on meetups is that they should not be mandatory, they should not be for making project decisions in a hidden corner with a priviledged few
21:23:22 <ttx> They should be to get specific work done. They should be more like a sprint, a workshop, a hackathon, than a core subsummit.
21:23:35 <ttx> Last cycle, some of them were a bit too much direction-setting imho, mostly because we couldn't agree much on direction at the summit
21:23:46 <ttx> We took steps to fix that with a more team-oriented format in Paris
21:23:57 <ttx> annegentle has been reaching out to midcycle meetup organizers to check *why* they thought they needed one
21:24:08 <ttx> to make sure we cover all the bases
21:24:19 <ttx> annegentle: what was the feedback like ?
21:24:24 <annegentle> to make sure we get feedback on the summit changes, whether they were working also
21:24:24 <devananda> ttx: "like a sprint, a workshop, a hackathon" ++
21:24:45 <annegentle> so, I asked keystone reps, heat reps, and neutron reps and got answers back that were very insightful
21:24:47 <russellb> +1 to the description of when they could make sense
21:25:05 <ttx> I want us to keep calling them "midcycle sprints" to reinforce the results-driven approach
21:25:14 <mestery> ttx: ++
21:25:18 <ttx> rather than "meetups"
21:25:21 <asalkeld> my major issue with them is the financial burden on companies
21:25:28 <annegentle> some of the feedback was around the summit itself not really being good for deep design work, serious discussions, or team reviews and coding
21:25:31 <dhellmann> beating the alliteration is going to be challenging :-)
21:25:36 <annegentle> so that lends itself to the sprint model
21:25:38 <russellb> mestery: i think the description of the neutron one is good - it makes it clear that it's focused on sprinting on a small set of targeted efforts
21:25:43 <nikhil_k> Glance (by history): "like a sprint, a workshop, a hackathon" -> -1
21:25:47 <annegentle> the keystone input was around the release cycle model itself, and the timing
21:25:54 <annegentle> so that was a bit surprising, I hadn't thought of that
21:25:55 <nikhil_k> direction +1
21:25:58 <devananda> the co-location of ironic and nova's midcycles served a very useful purpose, which I believe could not have been served at the summit
21:25:59 <mestery> russellb: Thanks, and we've had success doing it that way.
21:26:09 <annegentle> everyone agrees it's costly and difficult to get people together more often than summits for F2F
21:26:22 <eglynn> so one aspect of midcycle that's positive is that there are essentially self-organized
21:26:23 <morganfainberg> and i stand by our use for cadence of release - and it's been successful (at least in my view) for keeping us hitting the targets.
21:26:32 <eglynn> i.e. the project team controlls the format
21:26:45 <sdague> eglynn: yes, part of the productivity has come from that
21:26:47 <eglynn> I'd be leery of smothering that aspect
21:26:50 <annegentle> it wasn't necessarily that we didn't get the "right" people to the summit
21:26:58 <mikal> Nova used the last meetup to track progress on features we'd promised at the summit
21:27:12 <mikal> That was a useful exercise that saw a number of things land which wouldn't have otherwise
21:27:24 <anteaya> I went to three last release and they were all useful
21:27:31 <annegentle> I think mestery said it well, it's for focus.
21:27:33 <mikal> I also have only received feedback about disliking meetups from employees of a single company (literally)
21:27:38 <annegentle> the summit doesn't offer or afford focus
21:27:38 <russellb> i don't think anyone argues they aren't useful
21:27:47 <anteaya> each program has its own style and all three meetups were very different in format
21:27:57 <anteaya> and all repsondants felt they were useful
21:28:05 <Vek> <annegentle> the summit doesn't offer or afford focus <- +1
21:28:13 <ttx> mikal: I think that's fine -- we just need to make sure they are optional, not that they are useless :)
21:28:18 <russellb> it's not a useful vs. not-useful question for me
21:28:22 <mikal> russellb: that's untrue -- I receive email telling me that "OpenStack has failed as an open source project" because we have physical meetings
21:28:23 <mestery> Neutron's are always optional, FYI
21:28:24 <annegentle> my take is, of course they're useful, they're high fidelity communications and focused.
21:28:25 <morganfainberg> devananda, keystone and barbican tend to get the same benefit (for at least an overlap day)
21:28:34 <mestery> annegentle: ++
21:28:36 <russellb> mikal: that doesn't mean work wasn't done
21:28:37 <annegentle> But I also have to say you can't just take input from those who go to them.
21:28:48 <anteaya> folks dealt with content they couldn't address at summit, mostly due to needing to multitask at summit
21:28:52 <russellb> it's about nurturing processes that are as inclusive as possible
21:28:54 <annegentle> not everyone is that privileged - either for budget or time reasons or location reasons, we can't expect that much travel
21:28:54 <dhellmann> annegentle: ++ to both
21:29:21 <mestery> annegentle: ++ to both as well
21:29:50 <eglynn> is the thought here to set cross-project standards on what a mid-cycle should be?
21:29:51 <annegentle> and honestly, I don't think the issue is about cost as much as choices. I don't choose to travel to all the midcycles I'm invited to. Heck I don't go speak at all the conferences I'm invited to. I have to pick and choose.
21:30:09 <annegentle> so I just wanted to bring it forward to ensure we have good guideance
21:30:11 <russellb> eglynn: or perhaps what they should not be
21:30:12 <anteaya> is the current communication limiting choice?
21:30:12 <annegentle> I can't spell :)
21:30:19 <ttx> FTR I'l not saying we should stop doing them -- I'm saying we should make sure they stay optional, and that we could technically get rid of them if they are not needed anymore
21:30:41 <russellb> ttx: ++, optional, tactical/sprint focused
21:30:42 <morganfainberg> ttx, ++ i would like to see them become, if needed, pure virtual meetings.
21:30:46 <asalkeld> ttx isn't that up to the project?
21:30:48 <mestery> ttx: +1 to optional
21:30:51 <morganfainberg> and stay focused on sprint/results
21:30:55 <morganfainberg> as well as optional.
21:30:56 <annegentle> we called a doc one a "boot camp"
21:31:04 <mikal> ttx: in what way are they non-optional now? I don't understand.
21:31:10 <anteaya> are there current sprints that are communicated as non-optional?
21:31:15 <eglynn> russellb: yeah, I think a general principle should be: "don't assume you need one, just all the cool kids seem to be having one"
21:31:17 <ttx> asalkeld: sure: my point ius, no project should feel compeeled to do one just because everyone else does
21:31:24 <nikhil_k> "pure virtual meetings" +1
21:31:29 <morganfainberg> mikal, i think it's a concern that they don't become "mandatory"
21:31:31 <sdague> ttx: so I agree with breaking that assumption
21:31:33 * devananda is back ... network dropped
21:31:34 <morganfainberg> mikal, not that they are required now
21:31:55 <fungi> yeah, of the two infra has done so far, one was an onboarding-focused get together, and the other was a join sprint with the qa team, but we're also trying not to just have one every cycle
21:31:55 <ttx> mikal: what morgan says.
21:32:03 <russellb> there's mandatory, and there's "expected/ *strongly* encouraged", and I don't think it should be either of those
21:32:10 <ttx> mikal: "stay optional" if youprefer
21:32:15 <mestery> russellb: ++
21:32:18 <mikal> nikhil_k: the TC can't even agree on a _tool_ for a short online meeting, how can we expect to get all of a large core team to one?
21:32:22 <eglynn> agreed on defaulting to not needing one, unless there's *specific* justification
21:32:38 <clarkb> fungi: ya I think the question we have asked in the past is "Do we have a specific reason to get together this cycle?"
21:32:42 <eglynn> but if the project team decides they want one, up to them how they format it
21:32:43 <russellb> mikal: who do you *expect* to show up to the nova one this time?
21:32:44 <anteaya> isn't that the default now?
21:32:45 <nikhil_k> mikal: haha, try vidyo ;)
21:32:45 <clarkb> sometimes we do and otehrs we don;t
21:32:50 <fungi> i mainly worry that there's pressure on some teams to have mid-cycle assemblies just because everyone else is doing it
21:32:54 <ttx> clarkb: "yes: skiing"
21:32:56 <dhellmann> so if we assume we don't need them until we find a reason, how do we deal with the issues around planning for them on short notice?
21:32:58 <clarkb> ttx: :)
21:33:06 <nikhil_k> mikal: and we did that for 17 odd folks (not sure what the size of nova core is)
21:33:08 <sdague> dhellmann: yeh, I think that's a pretty valid point
21:33:13 <morganfainberg> russellb, i will always say I prefer people to come if they can. Why, because i like working with them and get benefit from it. If they can't or don't want to, i expect them to keep contributing in the way everyone has since the beginging :) - and provide feedback we can include while people are there face-to-face
21:33:15 <eglynn> fungi: yep, status anxiety ;)
21:33:19 <devananda> while cost and travel burden are an issue, for many people, that is outweighed by the benefit of the f2f time
21:33:23 <fungi> ttx: skiing as a service? is that a new infra project?
21:33:25 <mtreinish> ttx: heh, that was the proposed qa/infra/rel-mgt one right? :)
21:33:31 <dhellmann> sdague: I'd hate for us to realize we need one and then not be able to put it together, too
21:33:34 <sdague> because I know that's one of the reason's mikal started working on tihs early, as there were complaints that there was not enough runway
21:33:40 <sdague> on the last nova one
21:33:42 <mikal> nikhil_k: I have people who will refuse to use vidyo because its proprietary
21:33:46 <mikal> nikhil_k: ditto google hangouts
21:34:01 <dhellmann> sdague, mikal : exactly
21:34:05 <morganfainberg> russellb, but we have at least 1 core that doesn't come because of distance.. i'd say impact has been generally minimal if anyone skips.
21:34:07 * mestery notes there is no perfect video solution that everyone is happy with
21:34:09 <nikhil_k> makes sense, that's a hard problem
21:34:27 <dhellmann> mikal: do those people use open source airplanes? :-)
21:34:34 <annegentle> lol
21:34:35 <ttx> agree with mikal on that -- pure virtual meetings, you can do them on IRC, that's what we do when we do bugdays and other "events"
21:34:39 <sdague> dhellmann: you should ask them :)
21:34:41 <russellb> mikal: you see my question above?  i'm curious what your view is on attendance at the nova one this time.
21:34:55 <ttx> and they won't replace spending time together anyway
21:34:55 <morganfainberg> mikal, i'd say the "it's proprietary" is a really annoying argument for not using something. but i don't like getting into flamewars or starting them so i avoid the question.
21:34:58 <russellb> or will it depend on a set of sprint topics not decided yet?
21:35:00 <russellb> or?
21:35:01 <asalkeld> time zones are a bigger issue than video software
21:35:12 <ttx> asalkeld: ++
21:35:13 <mikal> dhellmann: I have zero interest in arguing wiht people about software choices. You can do that for me if you'd like.
21:35:18 <eglynn> asalkeld: agreed
21:35:19 <morganfainberg> mikal, +++++++
21:35:25 <dhellmann> mikal: I'm with you, actually.
21:35:25 <mikal> russellb: I see the majority of nova core coming to this one, but I might be wrong.
21:35:44 * devananda hands mikal a wet cat to throw at fungi
21:35:51 <nikhil_k> ttx: "pure virtual meetings, you can do them on IRC" <- almost none participation
21:36:03 <nikhil_k> ttx: and also depends on the goal of the meetup
21:36:05 <dhellmann> fwiw, I think it's great that mikal has started planning the nova meetup so early (and others have too, I guess)
21:36:16 * fungi is willing to take on the "choosing proprietary alternatives is destructive to the open community" debate whenever
21:36:20 <ttx> nikhil_k: my point is, pure virtual meetings won't replace face-to-face sprints
21:36:32 <morganfainberg> we've done a couple hangouts for keystone - and voice communication often works better for communicating some concepts than IRC ever will
21:36:48 <ttx> you can't just have a pure virtual meeting with contributors all over the globe
21:36:54 <nikhil_k> ttx: ah, didn't read the next line. oops
21:37:00 <sdague> annegentle: so back to an earlier point about surveying not only the attendees, have you gotten good feedback from non attendees of the midcycles on their impacts (good and bad) to the contributor base?
21:37:02 <dhellmann> fungi: apparently we have some sort of asterix server we can use? how do we get access to that?
21:37:05 <russellb> fungi: you wrote a nice -dev post on that a few months ago :)
21:37:12 <devananda> ttx: is the point to have a general agreement on "mid cycle sprints should be optional for projects to have, andattendance of them should also be optional" ?
21:37:18 <fungi> dhellmann: there's a wiki. you dial into it with a phone or a free sip client
21:37:27 <annegentle> sdague: ah yes, so there's no way to do that is there? I guess that was my point. We can't take the survey from people who consider travel a perk :)
21:37:31 <eglynn> devananda: ++
21:37:31 <ttx> devananda: yes, and try to fish some ideas to make design summit time more efficient
21:37:39 <dhellmann> fungi: ok, I've used asterix so I was asking specifically about our server. I'll look in the wiki
21:37:46 <nikhil_k> ttx: just worried - topics like these might get messier with with all the CPLs
21:37:47 <fungi> dhellmann: https://wiki.openstack.org/wiki/Infrastructure/Conferencing
21:37:48 <sdague> annegentle: well you know who went right?
21:38:02 <eglynn> ttx: is this discussion somehwat related to the idea that the design summit and conference should be decoupled?
21:38:02 <sdague> and you know core team members that didn't go
21:38:06 <annegentle> sdague: mostly could figure it out
21:38:06 <devananda> ttx: i don't think the midcycles should have any bearing on the main summit -- if we say they do, then we've just said the midcycles are no more optional than the summit
21:38:11 <ttx> devananda: some people told me: "it's the only way to get only $PROJECT people in a room without bystanders
21:38:12 <sdague> so they could be asked directly
21:38:17 <dhellmann> fungi: thanks
21:38:25 <SlickNik> fungi: thanks for that link
21:38:26 <ttx> devananda: if that's the only reason, we can evolve the design summit format to allow for that
21:38:26 <annegentle> so is it "cores who couldn't make it" or "people who will never be core if they don't travel tons" or?
21:38:36 <Vek> ttx: I don't know that we can make design summit time more efficient; there's just too much going on, and several of us need to check out multiple worlds when we get a chance.
21:38:42 <mestery> ttx: That's a true statement. Whether that's a good statement or not is left up for debate.
21:38:43 <sdague> annegentle: so part B is harder to figure out
21:38:46 <devananda> ttx: i agree with that. almost. Friday made me think it was possible
21:38:46 <morganfainberg> ttx, i really hope thats not the goal of a midcycle. i'd rather have anyone come to ours that wants to and contribute...but just be focused on keystone work.
21:38:49 <sdague> but part A would be some data
21:38:50 <annegentle> we did toy around with "design summit in boring location" at one point
21:38:53 * morganfainberg shrugs.
21:38:55 * eglynn doesn't understand why bystanders are such an issue
21:39:05 <morganfainberg> eglynn, ++
21:39:15 <devananda> ttx: we had a half day on friday where only ironic ATCs stood at a white board and designed something
21:39:23 <devananda> ttx: it was awesome. and only about 2 hours long
21:39:53 <annegentle> I think another data point we need to gather going forward is more understanding across projects
21:39:54 <sdague> eglynn: you apparently weren't in the performance art have to be on the microphone sesssions in the nova room :)
21:40:06 <david-lyle> eglynn: ++
21:40:21 <Vek> heh
21:40:23 <morganfainberg> sdague, i heard keystone was the real performance art :P but i'm not surprised you have the same issues in nova.
21:40:24 <dhellmann> sdague: maybe we should not have mics at the next summit
21:40:26 <annegentle> do some teams meet midcycle because nova did it? because it became tradition? That sort of patterning might help
21:40:27 <SlickNik> eglynn: Often bystanders ask questions, and you don't really want to shut someone out who's trying to learn.
21:40:32 <russellb> heh, the microphone hostility doesn't exist in all rooms
21:40:43 <russellb> neutron room happily used the mic, and honestly, i didn't feel like it hurt the discussion
21:40:44 <SlickNik> eglynn: But that does come at a cost of time
21:40:50 <eglynn> sdague: I caught some of the performance art at the summit feedback session, very bizzare
21:40:58 <sdague> eglynn: :)
21:40:59 * mestery notes neutron has used the mic for many summits in a row now without major issues
21:41:06 <dhellmann> russellb: we used it some in oslo, but we had a smaller group and I have a loud voice so maybe we just didn't need it as much :-)
21:41:07 <eglynn> ... but that was the only disuptive randomer I saw all summit
21:41:19 <sdague> eglynn: that's not the issue
21:41:26 <nikhil_k> annegentle: for glance we started as nova did and then it became evident that mini-summits are power*100 more productive than the main event
21:41:29 <russellb> IT'S ABOUT MONEY!  WE HAVE TO FIX THE ECONOMY!
21:41:34 <russellb> (for anyone who was at the feedback session)
21:41:36 <sdague> the issue is there was noticable throughput difference in the non miced nova sessions
21:41:36 <mestery> I can only speak for neutron, but we've found midcycles important to close on important work: Icehouse it was QA/Tempest for neutron, Juno it was nova-network parity, and Kilo it's paying down technical debt.
21:41:36 <ttx> ECONOMY BAD
21:41:42 <sdague> and the miced ones
21:41:44 <morganfainberg> SlickNik, i think if you go in with a focus vs. the more general summit - the bystander issue would be less problematic
21:41:49 <annegentle> russellb: that was freaky
21:42:00 <ttx> I think we are going off-topic now, so it's time for...
21:42:01 <sdague> like the non miced ones probably covered 2 - 4x more content and agreement
21:42:03 <ttx> #topic Open discussion
21:42:12 <ttx> feel free to continue on the same topic though
21:42:18 <morganfainberg> annegentle, we all were a little shocked by that one.
21:42:29 <ttx> just want to signal it's fine throwing random comments starting from now
21:42:36 * dhellmann isn't sure whether to be glad or sad that he missed it
21:42:37 <eglynn> did we come to any specific conclusions above?
21:42:42 <russellb> eglynn: was just wondering that
21:42:42 <morganfainberg> dhellmann, it was special
21:42:43 <annegentle> ttx: I can write a summary email to the openstack-dev list if that helps on midcycle consistency
21:42:44 <Vek> dhellmann: ++
21:42:52 <russellb> trying to think of how we bring some closure to the mid-cycle discussions we keep having
21:43:02 <dhellmann> ttx, annegentle : is the goal for this discussion just to understand more, or are we seeking a specific change?
21:43:17 <ttx> eglynn: actually yes. I think theer is consensus around the "stay optional" and the "should be a sprint to get something done" ideas
21:43:20 <sdague> russellb: yeh, honestly, it feels like there is mostly a latency issue
21:43:20 <notmyname> our swift hackathons (mid-cycle whatevers) started with 2 rules: (1) no slides (2) no "intro to swift" sessions. and we started doing them in specific response to the summits (where we kept having lots of beginner/intro qeustions and topics)
21:43:28 <Vek> I think the basic problem is that the summit and the midcycles solve two distinct problems, both of which need to be solved for.
21:43:28 <annegentle> for me, it was just to gain more understanding, and test our Board/TC discussions with the real-world
21:43:29 <ttx> annegentle: ++
21:43:32 <morganfainberg> i think we just need to make it clear it's self-organising and that they are optional
21:43:48 <ttx> #action annegentle to write a summary email to -dev to foster midcycle consistency
21:43:57 <devananda> ++ keep them small ++ optional ++ actually get real work done
21:44:00 <anteaya> annegentle: I hosted the neutron mid-cycle in montreal last january as a direct response to the hong kong summit being ineffective for devs
21:44:02 <eglynn> key point from my PoV is to encourage projects to reflect on whether they *really* need one
21:44:04 <russellb> ttx: where should we capture that?  a governance resolution that expresses what we feel is appropriate async self-organized meetups outside of our normal process/tools?
21:44:05 <morganfainberg> devananda++
21:44:06 <sdague> because the mid cycle planning happened early, because last time people complained they didn't have enough time to plan
21:44:07 <eglynn> .. but leave the format up to them if they really feel that they do
21:44:12 <annegentle> dhellmann: the change we talked about at Board/TC was to communicate that midcycles are for focused sessions only and not to have them be the default/defacto operating process
21:44:14 <russellb> oh, i see the annegentle action ...
21:44:21 <anteaya> that situation is beginnnig to be better at summits, somewhat
21:44:33 <sdague> and now we change the summit format to hopefully make them less required, but the gears are in play, because they already were
21:44:34 <dhellmann> annegentle: we should write that down somewhere, as russellb suggests :-)
21:44:40 <ttx> russellb: i don't think that calls for a TC resoltuion, just a sane ML thread should do
21:44:51 <russellb> we've had non-sane ML threads already
21:44:53 <sdague> and I don't know if we'll know until they happen if they really feel less needed
21:44:54 <russellb> :-p
21:45:09 <annegentle> right dhellmann -- but russellb I think a ML thread is fine.
21:45:13 <morganfainberg> sdague, i agree we will likely see a 1 cycle lag on
21:45:16 <morganfainberg> "are these needed"
21:45:24 <dhellmann> sdague: right, it may take this full cycle before we know how well the summit changes worked, since we're already planning for some sprints this cycle
21:45:34 <eglynn> ttx: wasn't there a related topic at the joint TC/board meeting in Paris? ... what was the outcome of that discussion?
21:45:38 * Vek shakes his head at mikal :)
21:45:44 <sdague> so in some ways it feels a little premature to demonize the midcycles at this stage
21:45:45 <ttx> eglynn: didn't go very far
21:45:55 <mestery> sdague: ++
21:46:04 <dhellmann> eglynn: that's what annegentle was saying, that we seemed to agree on discouraging making attendance "mandatory"
21:46:14 <ttx> eglynn: was mostly about communication around them
21:46:21 <annegentle> sdague: yeah, not demonizing at all, they fill a need
21:46:31 <ttx> eglynn: like they should all be referenced in one place (https://wiki.openstack.org/wiki/Sprints)
21:46:35 * mestery wonders which mid-cycle had mandatory attendane as a requirement
21:46:38 <mestery> Does anyone know of one?
21:46:41 <mestery> I'm not aware of one
21:46:44 <sdague> mestery: none
21:46:51 <dhellmann> mestery: it may just have been an impression rather than an actual rule
21:46:54 <mestery> sdague: Right, so I don't get that argument by people then.
21:46:54 <ttx> mestery: some suggested that they should be mandatory for -core in their project
21:47:04 <anteaya> do they still?
21:47:08 <notmyname> mestery: explicit mandetory or implicit/social mandetory?
21:47:10 <fungi> the one time i saw it proposed, it got some fairly heated counterarguments on the ml
21:47:14 <Vek> there's also the question of whether it's mandatory for a project to have a midcycle...
21:47:25 <mestery> I think we need to make it explicit that attendance is optional
21:47:26 <sdague> Vek: right, and that should definitely be a no
21:47:29 <mestery> I've tried to do that for neutron
21:47:37 <mestery> I encourage others to do the same
21:47:42 <nikhil_k> "some suggested that they should be mandatory for -core in their project" <- bad
21:47:59 <nikhil_k> it would be hard to get cores from china to US for mid-cycle
21:47:59 <sdague> nikhil_k: so I think that straw man is beaten to death
21:48:04 * Vek has enough trouble trying to make it to the summits
21:48:17 <nikhil_k> sdague: lol, yeah no kidding
21:48:24 <fungi> well, attendance to anything is "optional" but i think it's worth stating that projects would rather core reviewers show up for the summits than the mid-cycles
21:48:31 <sdague> if feels like the mandatory thing is a straw man that never materialized, but that everyone wants to argue about :)
21:48:42 <devananda> there's the implicit social pressure -- core team members who can't attend may feel like they will be missing on some big discussions
21:48:42 <mestery> fungi: ++
21:48:44 <morganfainberg> fungi, ++
21:48:46 <Vek> sdague: agreed
21:48:47 <mestery> sdague: lol
21:48:48 <devananda> what can we do to lessen that?
21:48:55 <russellb> devananda: that.
21:49:02 <dhellmann> devananda: ++
21:49:06 <devananda> besides, of course, stress that it isn't a design / planning session
21:49:09 <devananda> but a hackathon
21:49:18 <Vek> "midcycle hackathon"
21:49:26 <devananda> that, however, was not my experience at any of them -- the three I attended were all planning sessions
21:49:30 <anteaya> but sometimes it is a design session
21:49:49 <anteaya> neutron had ideas for mulitnode testing that I took to the infra mid-cycle
21:49:49 <russellb> devananda: you're nailing the issue, IMO
21:49:59 <fungi> right, stress that you're going to miss out on face time and getting some specific work done is not so bad as stress that you're missing out on the planning and direction setting
21:50:08 <devananda> fungi: right
21:50:15 <sdague> russellb: so agreed, but at the same time, ironic driver would not have landed without portland
21:50:18 <devananda> so perhaps we should stress that planning should not happen in f2f meetings
21:50:20 <dhellmann> it's odd to say "it's ok to get together in a room and build something, just don't make any decisions about how to do that"
21:50:24 <fungi> anteaya: i saw that as a feature design, a la sprint-worthy
21:50:32 <mestery> dhellmann: ++
21:50:33 <devananda> as that is not in keeping with our principle of "open"
21:50:37 <annegentle> early on in formation, teams get a lot out of face to face
21:50:40 <russellb> sdague: "let's push on the ironic driver" would be a reasonable sprint i think
21:50:44 <Vek> dhellmann: also not something that's enforceable, either.
21:50:45 <anteaya> fungi: which it was, yes
21:50:45 <eglynn> on the hackathon question, do we have any sense that this is a productive way for an opensource community to write code?
21:50:47 <sdague> so there is definitely a balance there, because that was important to do
21:50:48 <ttx> devananda: at the very least we should discourage it, yes. We can't prevent it really
21:50:49 <annegentle> happened for the docs team for sure
21:50:54 <devananda> ttx: sure
21:50:54 <dhellmann> Vek: true
21:50:57 <devananda> that's what I mean :)
21:51:04 <mestery> eglynn: Not that I'm aware of, no.
21:51:23 <fungi> there is plenty anecdotal evidence that lots of projects participate in hackathons though
21:51:23 <dhellmann> eglynn: I'd love to lock the oslo cores in a room and having them do reviews. Wait, did I say "lock"?
21:51:24 <devananda> dhellmann: it's not "dont decide HOW to do it" -- I think that's fine in a midcycle
21:51:41 <dhellmann> devananda: just not "whether"?
21:51:43 <devananda> dhellmann: perhaps my thought is better phrased as "dont decide WHAT to do"
21:51:48 <devananda> or whether, sure. that alsow orks
21:51:50 <morganfainberg> there have been a couple things that came up for Keystone mid-cycle that were based on earlier development
21:51:54 <morganfainberg> that ended up being designed there
21:51:58 <morganfainberg> e.g. K2K federation
21:51:58 <eglynn> mestery: yep, so restricting midcycles to a hackathon style makes no sense to me ... we should be able to collaborate on code remotely
21:51:59 <mikal> nikhil_k: I think that's a reference to me, and that's not what I said
21:52:05 <mikal> nikhil_k: its a deliberate misquite
21:52:08 <mikal> misquote even
21:52:12 <devananda> to the ironic/nova example -- it was clearly known by all the core team members on both sides that we would be having taht discussion
21:52:13 <anteaya> I disagree with the discourage it angle, I would hate to see the shape neutron would be in if we hadn't meet in Montreal about tempest
21:52:15 <nikhil_k> dhellmann: "d love to lock the oslo cores in a room and having them do reviews. Wait, did I say "lock"?
21:52:19 <mikal> nikhil_k: what I said was they were "strongly encouraged" for cores
21:52:19 <nikhil_k> +1
21:52:22 <dhellmann> devananda: ok, but I think the question of how is often just as important
21:52:23 <wendar> the concerns about exclusion might be helped by planning a specific time in the middle of the sprint for remote participation
21:52:24 <ttx> morganfainberg: in that specific case I think the design summit failed for you
21:52:28 <Vek> I think the idea is that a midcycle needs to be focused on just a small handful of topics; the exact mechanics of how those topics are handled probably aren't important.
21:52:30 <morganfainberg> ttx, well sortof.
21:52:43 <morganfainberg> ttx, we didn't know where it was going at the summit time.
21:52:43 <sdague> anteaya: yeh, no kidding. We'd probably have thrown own neutron if we didn't have that.
21:52:49 <morganfainberg> ttx, it was a logical step once we saw how it worked.
21:52:52 <mestery> eglynn: We definitely can and do, but we've found the face time to be useful. Point noted however.
21:52:59 <anteaya> sdague: exactly
21:53:00 * mestery sees a future where mid-cycles don't exist
21:53:09 <devananda> counter-point to my own point ... the introduction of IPA to Ironic happened at a midcycle
21:53:13 <ttx> mestery: I have a dream too
21:53:14 <nikhil_k> mikal: gotcha, "strongly encouraged" +1
21:53:36 <anteaya> wendar: that doesn't work for all groups
21:53:39 <mestery> ttx: so, how can we change the summit to give us what the mid-cycles are giving people now? If we do that, we remove the need for mid-cycles
21:53:42 <morganfainberg> ttx, it wasn't a complete new feature it was an enhancement that would have either needed to wait another cycle or it would have not landed. was all the design done there? no, but the initial "use standards, don't reinvent the wheel" type stuff
21:53:44 <anteaya> wendar: the groups that can do that are already
21:54:07 <nikhil_k> dmellado: s/oslo/<some_project>/ -> lock cores in a room :)
21:54:07 <ttx> mestery: I think it will never give us full coverage.
21:54:07 <devananda> anteaya: but do they?
21:54:19 <nikhil_k> dhellmann: ^
21:54:21 <mestery> ttx: Maybe we can continue evolving it that way and see what happens though
21:54:23 <ttx> mestery: for example, we liked Friday because everyone was in some room somewhere predictable
21:54:26 <anteaya> devananda: yes, the ones that have a dynamic that includes that do already
21:54:27 <mikal> nikhil_k: the problem we are trying to solve for is there being no concensus on the core team about direction of nova
21:54:31 <morganfainberg> ttx, but that is definitely the exception to the rule for our hackathon(s).
21:54:31 <wendar> anteaya: ISTR, the regular project meeting is usually canceled in a sprint week
21:54:33 <ttx> and people like meetups because they are small and relaxed
21:54:35 <anteaya> devananda: the ones that don't, don't
21:54:46 <wendar> anteaya: even just holding that as a sync point could help
21:54:48 <mestery> ttx: Very true
21:54:49 <anteaya> wendar: sorry I am missing the point of the last comment
21:54:50 <ttx> you can't have both :)
21:54:51 <mikal> nikhil_k: and trying to solve that problem in the context of some people refusing to attend online meetings using proprietary software, or outside their normal work hours
21:55:06 <mestery> ttx: It's a tough nut to crack for sure
21:55:13 <ttx> so I think they can coexist. Do a meetup if one is needed to get some specific work done
21:55:16 <wendar> but... I would be interested to see one project experiment with a pure-virtual sprint this cycle, maybe just for one day
21:55:41 <mestery> wendar: Define "day", depends on where you're located :)
21:55:43 <ttx> I just felt like the ones for this cycle were organized not because they are needed, but becaus ethey need to be planned in advance
21:55:46 <anteaya> wendar: the infra manual spriont it scheduled for 48 hours
21:55:49 <anteaya> do attend
21:55:56 <wendar> (anteaya: then I probably just misunderstood what you meant)
21:56:09 <nikhil_k> mikal: agreed, I think nova is a special case as it's so many times more complex. we'd avoid generalizing the concept and that prolly happens due to mis-communication
21:56:12 <anteaya> #link https://wiki.openstack.org/wiki/VirtualSprints
21:56:16 <wendar> mestery: sure, but shifting to a different time-zone for one 12 hour period is doable
21:56:20 <morganfainberg> ttx, i think a 1 cycle delay on "are these really needed" is acceptible
21:56:22 <mikal> On another note, I hear stories of mid-cycles in exotic locations
21:56:30 <mikal> I think that would be a much more interesting conversation to have
21:56:30 <wendar> mestery: (may require a lot of coffee, but doable)
21:56:35 <mestery> wendar: True
21:56:39 <dhellmann> mikal: indeed
21:56:42 <ttx> morganfainberg: sure. The alternative (organize them at the last minute) is not great either ;)
21:56:48 <mestery> mikal: Exotic locations? Do tell?
21:56:49 <Vek> mikal: *nod*
21:56:49 <morganfainberg> ttx, ++
21:56:59 <sdague> ttx: so how does one handle the tension of giving people > 6 weeks notice for a midcycle vs. planning ahead assuming you need them
21:57:01 <ttx> mikal: like.. Australia ?
21:57:08 <mikal> I am very annoyed that I am trying to keep my costs down for people, but it is now assumed taht all mid-cycles are junkets
21:57:21 <mikal> So far I've heard of one in a Swiss ski resort, and one in South America
21:57:26 * mestery doesn't assume that and hopes others don't as well
21:57:29 <Vek> *cough*
21:57:37 <ttx> sdague: my point exactly
21:57:52 <ttx> sdague: (see my alternative answer to morgan)
21:57:56 <nikhil_k> mikal: organizing a video session that will scale to X dozen participants and is non proprietary -> prolly not happening for another 5 years :/
21:58:16 <anteaya> nikhil_k: have you considered audio with asterisk?
21:58:20 <mikal> nikhil_k: it also has to work on low bandwidth links, which rules out all the open webrtc thigns I've looked at
21:58:24 <fungi> mikal: south america is an exotic locale?
21:58:28 <dhellmann> how many people attend these midcycle things? I haven't been to one since the infra meeting in NYC
21:58:38 <dhellmann> fungi: for some people, in january, yes
21:58:40 <anteaya> #link https://wiki.openstack.org/wiki/Infrastructure/Conferencing
21:58:41 <mikal> fungi: if less than 25% of the team lives there, yes
21:58:44 * Vek hasn't been to any midcycles
21:58:47 <mestery> Neutron usually has approx. 20 people
21:58:49 <ttx> someone's exotic is omeone else's boring
21:58:52 <nikhil_k> yeah :/
21:59:03 <morganfainberg> Keystone is 15-22 people, if we overlap with barbican closer to 30 on that day
21:59:05 <anteaya> dhellmann: depends on the group, 20 to 30 is my experience
21:59:07 <sdague> the infra/qa one was 20 - 30
21:59:11 <fungi> mikal: we did our last get-together in a suburb of frankfurt, de. i'm sure some people thought that was exotic
21:59:12 <annegentle> yeah 30 is high
21:59:16 <nikhil_k> anteaya: not really, we've had luck with regular softwares and people not complaning
21:59:17 <dhellmann> anteaya: ok, a rough # was what I was looking for
21:59:20 * annegentle writes down the data we need to spread
21:59:23 <ttx> storyboard one was 16
21:59:23 <mikal> I persoanlly think we should find the center of mass for our contributors (per project) and run the meetup as close to that location as possible
21:59:29 <sdague> nova / ironic / containers was 50+, but that was 3 at once
21:59:34 <mikal> fungi: yes, it did double my travel spend for that meetup
21:59:34 <dhellmann> so we don't need any conferencing infrastructure to support many dozens of people
21:59:47 <mikal> fungi: Europe is 60 hours flying away from home for my people
21:59:47 <dhellmann> oh, well, except maybe the case sdague just listed
21:59:50 <morganfainberg> mikal, this is one of the reasons San Antonio is a target for Keystone's mid-cycle.
22:00:02 <morganfainberg> mikal, good mid-point for most everyone.
22:00:06 <fungi> mikal: we actually picked that location because it would be easier for european contributors to attend since they have trouble making it to north america sometimes
22:00:06 <sdague> dhellmann: it was 3 in one though
22:00:09 <morganfainberg> a little far for a couple european folks.
22:00:11 <ttx> ok, out of time
22:00:12 <mtreinish> sdague: for qa/infra we had exactly 30
22:00:23 <dhellmann> sdague: well, true, maybe that would be something we could do on a summit friday now
22:00:26 <ttx> thanks everyone, I think that was good feedback
22:00:27 * nikhil_k keep all mid-cycle meetups in hawii and problem solved
22:00:33 <mtreinish> which was our cap, we had a few people we had to turn away because we didn't have space
22:00:34 <ttx> hmm. hawaii
22:00:34 <fungi> mikal: you're simply making the case for an exotic infra metup in the australian outback
22:00:45 <mikal> fungi: no, I think it should be in idaho
22:00:50 <mestery> lol
22:00:54 <morganfainberg> ttx, hhhhmmm hawaii.
22:00:56 <mikal> fungi: somewhere in the US certainly
22:01:14 <ttx> thanks everyone!
22:01:17 * krotscheck runs off to found an openstack-based company on Maui.
22:01:17 <ttx> #endmeeting