21:01:19 <ttx> #startmeeting project
21:01:20 <openstack> Meeting started Tue Jul  9 21:01:19 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:23 <openstack> The meeting name has been set to 'project'
21:01:29 <ttx> #link http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:33 <markmc> here
21:01:42 <ttx> One week left to H2 ! We'll look into progress and defer appropriately.
21:01:48 <ttx> #topic General stuff
21:02:00 <ttx> I created the "future" series and sent you all an email about the BP tracking changes.
21:02:15 <ttx> Most of you switched already, will discuss the few that didn't yet in their respective subtopics.
21:02:30 <ttx> sdague, annegentle, jeblair/mordred: news from QA/Docs/Infra programs ?
21:02:37 <annegentle> \o
21:02:44 <ttx> annegentle: go for it
21:02:54 <jeblair> ttx: nak
21:03:02 <annegentle> Docs held our monthly meeting today and weekly office hours yesterday
21:03:05 <annegentle> meeting minutes:
21:03:10 <annegentle> #link http://eavesdrop.openstack.org/meetings/doc_team_meeting/2013/doc_team_meeting.2013-07-09-13.01.html
21:03:29 <annegentle> lots of discussion about Compute v3 api doc plan
21:03:38 <annegentle> and Admin docs -- big or small?
21:03:59 <annegentle> Also we have Japanese and Chinese versions of the Operations Guide soon to be posted to docs.openstack.org
21:04:02 <annegentle> that's all I got
21:04:25 <ttx> ok, then let's move on
21:04:31 <ttx> #topic Oslo status
21:04:37 <markmc> hey
21:04:37 <ttx> markmc: hi!
21:04:42 <ttx> #link https://launchpad.net/oslo/+milestone/havana-2
21:04:51 <markmc> just cleaning up bps a bit here, so refresh
21:04:59 <markmc> actually, had moved on to cleaning up h3
21:05:01 <ttx> Looking at tracked blueprints you're 71% implemented, 29% under review
21:05:14 <ttx> Looks very good to me
21:05:18 <markmc> yeah, and those reviews all are plausible for next week
21:05:26 <ttx> OK so the last 2 "medium" on track to make it ?
21:05:28 <markmc> and then I need to hook up oslo.config docs
21:05:34 <markmc> yeah, they look ok
21:06:04 <ttx> OK, no particular worry from me
21:06:06 <markmc> h3 plan is definitely a bit more up in the air
21:06:07 <ttx> markmc: anything you wanted to raise ?
21:06:26 <ttx> markmc: yes, it's a bit more crowded, but if everything in h2 makes it you might be ok
21:06:28 <markmc> stuff like oslo.messaging and secure messaging definitely in question
21:06:52 <markmc> that's it from me
21:06:55 * ttx doesn't really expect secure messaging to make it. We'll discuss in the next weeks but
21:07:16 <ttx> without the prereq in it sounds very unlikely
21:07:17 * markmc needs to check on kds progress
21:07:25 <ttx> Questions about Oslo ?
21:08:18 <ttx> #topic Keystone status
21:08:21 <dolphm> o/
21:08:22 <ttx> dolphm: hello!
21:08:26 <ttx> #link https://launchpad.net/keystone/+milestone/havana-2
21:08:37 <ttx> I see you did some updates today
21:08:41 <dolphm> lots!
21:08:48 <dolphm> we went through every bp targetted at h2 today during the keystone meeting
21:08:54 <ttx> Looks a bit better than when i last looked into it :)
21:09:10 <ttx> 33% implemented, 33% under review, 33% todo
21:09:18 <ttx> er
21:09:48 <dolphm> i believe all those ones showing good progress actually have reviews up, in one state or another
21:10:01 <ttx> actually makre that 28% 43% and 28%
21:10:31 <dolphm> percentages seem like overkill when there's only 9 blueprints lol
21:10:41 <ttx> heh
21:11:01 <ttx> Are all those still likely to make it ? Or should you just defer hte ones that are still in progress ?
21:11:25 <ttx> (since you have /some/ room left in H3)
21:11:45 <dolphm> considering they're actually in review, i have a lot of confidence they'll make it
21:12:12 <ttx> dolphm: should they be switched to "needs code review" then ? Are they fully proposed ?
21:12:36 <ttx> (pluggable-token-format and catalog-optional)
21:13:11 <dolphm> both are in a bit too much flux to say they're ready for review
21:13:17 <ttx> ok
21:13:22 <ttx> dolphm: Anything more about Keystone ?
21:13:25 <dolphm> they're technically complete, but have remaining todo's
21:13:41 <dolphm> don't believe so!
21:13:42 <ttx> Questions about Keystone anyone ?
21:14:09 <ttx> #topic Ceilometer status
21:14:12 <ttx> dhellmann: hey
21:14:13 <dhellmann> o/
21:14:16 <ttx> #link https://launchpad.net/ceilometer/+milestone/havana-2
21:14:25 <dhellmann> we have a lot of code up for review right now
21:14:40 <dhellmann> and a couple of low priority items that haven't been started
21:14:50 <dhellmann> I expect us to review that list on Thursday during this week's meeting
21:15:19 <dhellmann> oh, and jd__ said he has people working on the open bugs, so we expect to land those, too
21:15:21 <ttx> Looking good with 50% done, 42% under review
21:15:34 <ttx> (for the tracked stuff (> Low)
21:15:36 <ttx> )
21:15:59 <ttx> Was wondering if "one-meter-per-plugin" wasn't completed already ?
21:16:12 <ttx> you have more to propose ?
21:16:12 <dhellmann> there's a long stack of changes waiting for approval for that
21:16:45 <ttx> ok, somehow my script missed that long stack
21:16:49 <dhellmann> some of the early ones were approved, but I think folks are trying to get their own patches up for review :-)
21:16:56 <ttx> What's the status of alarm-service-partitioner ? Still likely to make it ?
21:17:04 <dhellmann> https://review.openstack.org/#/q/status:open+project:openstack/ceilometer+branch:master+topic:bp/one-meter-per-plugin,n,z
21:17:30 <dhellmann> I haven't spoken with eglynn, but I haven't heard anything to indicate a problem
21:18:09 <ttx> dhellmann: anything else you wanted to mention ?
21:18:20 <dhellmann> that's it, unless there are questions
21:18:24 <ttx> Questions on Ceilometer ?
21:19:04 <ttx> #topic Swift status
21:19:09 <ttx> notmyname: o/
21:19:13 <notmyname> hi
21:19:23 <ttx> notmyname: Should I enable the adjust_series_goal script for you right now ?
21:19:37 <ttx> At this point it would remove the series goal from object-replicator2 because it has no target milestone set.
21:19:48 <ttx> You should consider set that to 1.9.1 or future/next if you want to keep it on your radar
21:19:59 <notmyname> ya, I'll need to move it to next
21:20:15 <notmyname> sure. go ahead and enable it
21:20:25 <ttx> notmyname: ok, will do after the meeting
21:20:43 <ttx> notmyname: anything you wanted to raise ? I guess it's a bit early to talk about your next release :)
21:20:56 <notmyname> we released python-swiftclient 1.5.0 todya https://pypi.python.org/pypi/python-swiftclient/1.5.0
21:21:16 <notmyname> that's all I have for now
21:21:44 <ttx> Questions about Swift ?
21:22:18 <ttx> #topic Glance status
21:22:23 <ttx> markwash: o/
21:22:28 <ttx> #link https://launchpad.net/glance/+milestone/havana-2
21:22:30 <markwash> greetings
21:23:02 <markwash> a few notes about the listing there
21:23:12 <markwash> the low bps are just part of Multiple Image Locations
21:23:23 <ttx> 40% done, 60% under review, looks good -- a bit of review effort needed now
21:23:29 <markwash> the in-progress bug is about to be merged, just waiting on jenkins to merge it ( it is already approved)
21:23:50 <markwash> the other bps are very close, I think we'll land all of them
21:24:15 <markwash> I feel especially good about Multiple Image Locations and Registry Database Driver
21:24:26 <ttx> if the low ones are part of multiple image location... should we link them in and set them to Medium ?
21:24:35 <markwash> that or delete them
21:24:51 <ttx> I'll do the linking
21:25:01 <markwash> they were added very recently and aren't strictly necessary imo
21:25:08 <markwash> *necessary to track independently
21:25:43 <markwash> that's all from me, we have very active reviewers this week, and I'll  keep turning the thumbscrews
21:25:46 <ttx> #action ttx to link the two Low to multiple-image-locations and set them to med
21:26:33 <ttx> all looks good to me
21:26:35 <ttx> markwash: anything you wanted to mention ?
21:26:47 <markwash> nope, thanks!
21:26:56 <markwash> I'll clean up h3 after next week
21:27:03 <markwash> don't look now!
21:27:14 * ttx closes his eyes
21:27:16 <ttx> Questions on Glance ?
21:27:40 <ttx> #topic Neutron status
21:27:43 <ttx> markmcclain: hi!
21:27:46 <markmcclain> hi
21:27:46 <ttx> #link https://launchpad.net/neutron/+milestone/havana-2
21:29:21 <ttx> 30% done, 64% proposed
21:29:36 <ttx> looks mostly good, lots and lots to review though
21:29:50 <markmcclain> yeah.. renaming has slowed things up as folks had to rebase
21:30:15 <ttx> been through that myself
21:30:23 <ttx> How is configurable-ip-allocation doing ?
21:30:45 <markmcclain> it's revive an old patch.. either I'll fix it up tomorrow or kick it to H3
21:30:52 <ttx> should it be pushed to h3 ? might make more sense to focus on reviews right now
21:31:04 <ttx> ok
21:31:40 <ttx> https://blueprints.launchpad.net/neutron/+spec/hostid-vif-override is implemented but with "undefined" priority, could you set one ?
21:31:53 <ttx> doesn't really matter which at this point :)
21:32:03 <markmcclain> yeah.. I'll clean it up for posterity
21:32:25 <ttx> nec-plugin-test-coverage is marked implemented but has https://review.openstack.org/#/c/35807/ in progress ?
21:33:02 <markmcclain> yes.. did see it in the h2 milestone
21:33:17 <markmcclain> s/did/did't/g
21:33:30 <ttx> should I make it "under review" ?
21:33:37 <markmcclain> please :)
21:33:42 <ttx> ok
21:33:45 <ttx> https://blueprints.launchpad.net/neutron/+spec/ivs-interface-driver is marked implemented but targeted to h3... should I move it to h2 ?
21:34:05 <markmcclain> yes.. I'll fix it
21:34:17 <ttx> sdague raised bug 1194026 on the ML - i'd like to set it to critical and target it to H2...
21:34:19 <uvirtbot> Launchpad bug 1194026 in neutron "check_public_network_connectivity fails with timeout" [High,Confirmed] https://launchpad.net/bugs/1194026
21:34:35 <ttx> someone set it to High already
21:35:03 <ttx> would be nice to clean it up soon so that it doesn't impact the review rush to h2
21:35:07 <markmcclain> right.. we talked about it yesterday in our meeting
21:35:18 <markmcclain> have one of our cores looking into it
21:35:40 <ttx> markmcclain: can I bump it to criotical and target it to h2 ?
21:35:49 <markmcclain> sure
21:35:54 <ttx> sdague: you had another one ?
21:36:09 <sdague> markmcclain: cool, any chance you could set assigned on it? just to make it easy to know it's being worked
21:36:29 <markmcclain> sdague: done
21:36:39 <sdague> ttx: yes, there is also the issue with neutron on full gate, which is largely an issue that when you call network apis in nova...
21:36:58 <sdague> you get different return codes on fails if nova-network or neutron is behind it
21:37:09 <sdague> there has been some ML threads on this, another one kicked off
21:37:35 <ttx> sdague: bug# ?
21:37:38 <sdague> it would be good to get this nailed soon if we think we want neutron running through full tests by H3
21:37:49 <sdague> ttx: there are a series of them, I don't have them all right nwo
21:38:02 <ttx> sdague: ok, keep us posted on the ml
21:38:06 <sdague> yes, will do
21:38:10 <ttx> markmcclain: About the neutron rename, is there anything left to do ?
21:38:18 <ttx> (on the code side ?)
21:38:25 <markmcclain> yes.. have a few integrated projects to finish updating
21:39:02 <ttx> markmcclain: last time I looked there were still a few quantum-only files in bin/
21:39:33 <ttx> not sure what the plan is for those
21:39:42 <markmcclain> ttx: right those are for compatibility.. we're mostly using entrypoints for neutron-*
21:40:00 <ttx> markmcclain: ok
21:40:02 <ttx> markmcclain: I'd like to talk to you about enabling the adjust_series_goal automation, would you have some time after this meeting ?
21:40:12 <markmcclain> yes
21:40:18 <ttx> markmcclain: anything else you wanted to raise ?
21:40:44 <markmcclain> nothing other than the other integrate reviews which I'll post for Nova, Horizon, and Heat
21:40:55 <ttx> Questions on Neutron ?
21:41:15 <stevebaker> should those integrate reviews make it into h2?
21:41:16 <ttx> #topic Cinder status
21:41:24 <ttx> oops
21:41:26 <ttx> #undo
21:41:27 <openstack> Removing item from minutes: <ircmeeting.items.Topic object at 0x3156850>
21:41:36 <jgriffith> doh
21:42:04 <stevebaker> does the rename need to be coordinated in this release across projects?
21:42:07 <hub_cap> did sometrhing goofy just happen or am i crazy?
21:42:14 <ttx> markmcclain: I suspect it would be good if they did ?
21:42:16 <markmcclain> stevebaker: my preference is yes
21:42:19 <jgriffith> hub_cap: you're not crazy
21:42:20 <ttx> hub_cap: you crazy :P
21:42:29 <jgriffith> well... not because of the weird thing that happened
21:42:35 <hub_cap> heh ya
21:42:39 <hub_cap> sry for distracting
21:42:43 <ttx> #topic Cinder status
21:42:46 <markmcclain> stevebaker: the rename was planned to be phased since both neutron and quantum clients can be installed side-by-side for now
21:42:57 <ttx> jgriffith: hola!
21:43:01 <jgriffith> ttx: howdy
21:43:02 <ttx> #link https://launchpad.net/cinder/+milestone/havana-2
21:43:27 <jgriffith> slowwwwww
21:43:41 <jgriffith> but I still think that most of them are going to make it by Monday
21:43:46 <ttx> 53% done, 13% in review
21:44:01 <ttx> so a bit late, but not too bad
21:44:09 <jgriffith> The DB changes and the state machine are my only concerns
21:44:14 <ttx> Are all those "medium" still likely to make it ?
21:44:31 <ttx> so maybe not the The DB changes and the state machine
21:44:34 <jgriffith> ttx: w/ the exception of those I just called out yes
21:44:54 <ttx> Looking at critical bug https://bugs.launchpad.net/bugs/1197571 ...
21:44:57 <uvirtbot> Launchpad bug 1197571 in cinder "Upper bound on keystone-client in requires causes conflict" [Critical,In progress]
21:45:09 <ttx> The review about it was abandoned ?
21:45:16 <jgriffith> ttx: yeah, I need to file a bug against everybody else for that one
21:45:38 <jgriffith> ttx: common-reqs is out of sync with everybody else
21:45:41 <jgriffith> or vice versa
21:45:45 <jgriffith> so cinder matches
21:45:51 <jgriffith> but others don't have the upper bound
21:46:09 <jgriffith> so I can't change cinder to match without updating common
21:46:09 <ttx> jgriffith: you can probably reuse the same bug, just add project tasks to it
21:46:19 <jgriffith> ttx: will do
21:46:22 <gabrielhurley> FWIW, Horizon is shortly going to be requiring 0.3.0 or later
21:46:32 <ttx> do it soon, looks like something we'd like fixed by h2 too
21:46:32 <gabrielhurley> due to support for the v3 auth stuff
21:46:35 <jgriffith> gabrielhurley: and there's the dilema
21:46:49 <jgriffith> gabrielhurley: ttx there's some issues with 3.0 it seems though
21:47:10 <jgriffith> anyway... I'll look at it
21:47:13 <jgriffith> regardless it's a bug
21:47:18 <gabrielhurley> yep
21:47:34 <ttx> jgriffith: anything else on your mind ?
21:47:40 <jgriffith> is anybody requiring 3.0 now/today?
21:47:56 <jgriffith> I'd like to just sync all the projects and get it over with if possible
21:48:03 <jgriffith> then we can move together in the future
21:48:04 <gabrielhurley> unlikely since 0.3.0 was cut *for* Horizon to make v3 auth work
21:48:06 <ttx> jgriffith: no idea, no time to check. Maybe start an ML thread about that
21:48:14 <jgriffith> ttx: k
21:48:15 <gabrielhurley> we were the guinea pigs on it
21:48:15 <ttx> Questions on Cinder ?
21:48:19 <jgriffith> gabrielhurley: :)
21:48:40 <ttx> #topic Nova status
21:48:42 <russellb> o/
21:48:44 <ttx> russellb: hey
21:48:47 <ttx> #link https://launchpad.net/nova/+milestone/havana-2
21:48:55 <russellb> did a lot of cleanup on there today.
21:49:00 <russellb> still a ton up for review ...
21:49:03 * ttx refreshes
21:49:14 <russellb> sent a note to nova-core earlier asking for a big push on reviews this coming week
21:49:53 <ttx> 47% done, 37% in review
21:50:07 <ttx> good news is you have room in H3 to defer though.
21:50:23 <russellb> heh, have room?  80 blueprints in h3 already i think :-)
21:50:37 <ttx> I stopped looking at "Low" ones now :P
21:50:40 <russellb> ah!
21:50:46 <russellb> well then, yes, perhaps better looking then
21:51:08 <ttx> Looking at the whole release plan, I'm a bit worried about two things:
21:51:11 <ttx> deprecate-baremetal-driver and deprecate-nova-network
21:51:18 <russellb> so one thing that came up in the last week was that it's becoming clear that we need to include reviewer bandwidth in the planning process
21:51:34 <russellb> yeah, deprecate-baremetal-driver is dependent on ironic, and sounds like it won't be ready in time
21:51:39 <ttx> devananda reported recently that ironic just might not be ready by Havana release
21:51:43 <ttx> and we don't seem to have a magic way forward to solve deprecate-nova-network in the time remaining
21:51:44 <russellb> deprecate-nova-network ... no movement there still AFAIK
21:51:49 <russellb> yeah :(
21:51:57 <ttx> unless vishy has a magic wand
21:52:04 <russellb> i've started asking around to recruit some more help on it
21:52:16 <russellb> but even if some other start ramping up, it seems unlikely to be completed in time
21:52:19 <ttx> "include reviewer bandwidth in the planning process" what do you mean by that ?
21:52:41 <russellb> i mean, try to get the review team (nova-core) to help ack how much big stuff we think we can review in a cycle
21:52:54 <ttx> hmm, ok
21:53:08 <ttx> I think review prioritization could help though
21:53:10 <russellb> maybe i just need to communicate better about prioritizing reviews on Low vs. higher priority stuff
21:53:13 <russellb> yeah :)
21:53:18 <ttx> On the bugs side, Wanted to raise bug 1198040...
21:53:20 <uvirtbot> Launchpad bug 1198040 in nova "Nova-manage no longer operating due to neutron rename" [Critical,In progress] https://launchpad.net/bugs/1198040
21:53:21 <russellb> so, something i need to think about more / communicate better about ...
21:53:27 <russellb> orly!
21:53:30 <russellb> guess we should fix that
21:53:40 <ttx> Do you agree we should target it to h2 ?
21:53:54 <russellb> yeah
21:53:56 <russellb> just updated it
21:53:57 <russellb> and will review
21:54:21 <ttx> russellb: anything else you wanted to mention ?
21:54:40 <russellb> don't think so, thanks again for the blueprint process update work you did
21:54:53 <ttx> Any question on Nova ?
21:55:08 * ttx is running a bit late
21:55:10 <ttx> #topic Heat status
21:55:15 <ttx> speeding up
21:55:18 <ttx> stevebaker: o/
21:55:22 <ttx> #link https://launchpad.net/heat/+milestone/havana-2
21:55:23 <stevebaker> \o
21:55:44 <stevebaker> my gut says those 4 bps will be deferred
21:56:01 <ttx> 73% done, almost there
21:56:15 <stevebaker> there are a handful of reviews for bugs.
21:56:21 <ttx> stevebaker: not so much room in h3 to defer though :)
21:56:46 <ttx> stevebaker: we'll talk adjust_series_goal automation just after the meeting
21:56:51 <stevebaker> project meeting is in 24 hours, so I'll get some commitments then.
21:57:05 <stevebaker> what is the h2 branch date?
21:57:20 <ttx> EOD next tuesday
21:57:37 <ttx> one week and a 10 hours from now
21:57:43 <ttx> stevebaker: anything else you want to raise ?
21:57:56 <stevebaker> I don't think so
21:57:58 <ttx> Questions about Heat ?
21:58:06 <ttx> #topic Horizon status
21:58:11 <ttx> gabrielhurley: o/
21:58:14 <ttx> #link https://launchpad.net/horizon/+milestone/havana-2
21:58:16 <gabrielhurley> \o
21:58:56 <gabrielhurley> I'm a little uncertain about the Quantum/Neutron Security Groups bp... akihiro motoki said it was close a week ago but I haven't seen code.
21:59:02 <ttx> Not too bad, 40% done, 40% under review
21:59:07 <gabrielhurley> the other ones I'm feeling good about
21:59:13 <gabrielhurley> pared down the bug list too
21:59:15 <stevebaker> heat-ui is in !1!
21:59:19 <gabrielhurley> yay!
21:59:20 <ttx> not a lot of room in h3 for deferrals either
21:59:29 <gabrielhurley> no, I really don't want to see these slip
21:59:38 <gabrielhurley> I'll look at kicking stuff out of H3 soon as it is
22:00:07 <jeblair> gabrielhurley: can you join us in #openstack-infra after the meeting to discuss a horizon problem that is affecting the entire project?
22:00:12 <gabrielhurley> sure
22:00:14 <ttx> gabrielhurley: sounds good. anything else you wanted to mention ?
22:00:29 <ttx> gabrielhurley: remember you have a meeting after this one
22:00:32 <ttx> Questions on Horizon ?
22:00:34 <sdague> yeh, https://pypi.python.org/pypi/django_openstack_auth has broken the gate for everyone :)
22:00:39 <gabrielhurley> just to reiterate the bit about keystoneclient that came up in the cinder topic
22:01:06 <gabrielhurley> yeah, we'll sort it out after this meeting
22:01:24 <ttx> gabrielhurley: would be great to have a thread about it on the ml, looks like it will require a bit of coordination
22:01:31 <ttx> #topic Incubated projects
22:01:37 <ttx> any quick question / status update ?
22:01:39 <hub_cap> i <3 everyone
22:01:43 <hub_cap> that is all
22:01:52 <ttx> sounds good :)
22:02:02 <ttx> more time next week hopefully
22:02:05 <ttx> #endmeeting