21:01:24 <ttx> #startmeeting project
21:01:25 <openstack> Meeting started Tue Mar 26 21:01:24 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:28 <openstack> The meeting name has been set to 'project'
21:01:31 <ttx> markmc: better get used to it :)
21:01:35 <ttx> arrrh
21:01:41 <markmc> heh
21:01:46 <ttx> markwash: better get used to it :)
21:01:59 <ttx> this invasion of the marks is going to be a disaster i tell you
21:02:02 <ttx> Usual agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:18 <ttx> #topic General announcements
21:02:29 <ttx> #info TC direct seats voting under way, don't forget to vote, voting ends Thursday
21:02:41 <ttx> #info Last week to suggest sessions for the Havana Design Summit in Portland
21:02:45 <ttx> #link http://summit.openstack.org/
21:02:58 <ttx> markmc, jeblair/mordred, annegentle, sdague/davidkranz/jaypipes: Anything from Stable/CI/QA/Docs teams ?
21:03:01 <markmc> #info 2012.2.4 RC due next week: http://lists.openstack.org/pipermail/openstack-stable-maint/2013-March/000353.html
21:03:13 <ttx> aw. Can't I sleep all next week ?
21:03:29 <markmc> hehe
21:03:35 <ttx> markmc: isn't that the week after next ?
21:03:45 <jeblair> ttx: the pypi mirror --
21:03:45 <ttx> "2012.2.4 is due for release on 2013-04-11"
21:03:45 <sdague> ttx: I don't think anything from QA
21:03:55 <markmc> ttx, I said RC next week :)
21:04:02 <ttx> ah. eh
21:04:07 <davidkranz> ttx: We need to coordinate the process/qa tracks for overlap.
21:04:24 <jeblair> ttx: we're using our local pypi mirror exclusively for tests now, and it's generated from the requirements repo.
21:04:28 <davidkranz> ttx: You can schedule first and I'll work around it.
21:04:40 <ttx> davidkranz: no kidding. Lots of overlap. I'll try to make a pass with mordred and then we can discuss
21:04:43 <markmc> jeblair, w00t!
21:04:54 <ttx> davidkranz: will be in touch
21:04:59 <davidkranz> ttx: Sound good.
21:05:39 <ttx> jeblair: awesome news
21:06:09 <ttx> anything more before we switch to per-project updates ?
21:06:15 <annegentle> Definitely need more doc patches, though the queue has been steady for reviews.
21:06:50 <ttx> annegentle: less activity on the RC bug front, I hope that will translate into docs/releasenotes efforts now
21:07:17 <ttx> #topic Oslo status
21:07:26 <ttx> Not so much movement around here, which is good...
21:07:35 <ttx> markmc: Anything in oslo-incubator stable/grizzly that should definitely be copied to projects ?
21:07:36 <markmc> yeah, all quiet
21:07:44 <markmc> just triaging a couple of bugs here, but nothing major
21:07:51 <jgriffith> o/
21:08:12 <ttx> Looking at the Design summit, you have 13 proposals for 12 slots, not too bad
21:08:40 <ttx> I may suggest moving the session on Db migrations to oslo though
21:08:45 <ttx> (from process)
21:08:49 <ttx> we'll adjust
21:08:52 <markmc> this is the main stable/grizzly issue in oslo atm: https://code.launchpad.net/bugs/1158179
21:08:54 <uvirtbot> Launchpad bug 1158179 in nova/folsom "Lockutils - deletes directory rendering locks invalid" [High,Confirmed]
21:09:00 <ttx> Process/QA/Oslo is all a bit overlapping
21:09:14 <ttx> markmc: that one was adopted by most projects, I think
21:09:26 <markmc> I don't think there's much oslo atm that could move to process/qa
21:09:37 <markmc> pretty confident we'll have roughly the right number of talks for slots
21:09:41 <ttx> ok
21:09:43 <markmc> unless there's a deluge of latecomers
21:09:46 <ttx> Anything else on the oslo topic ?
21:09:51 <markmc> will merge some of the rpc one's together
21:09:55 <markmc> nope, that's it ... thanks
21:10:01 <ttx> #topic Keystone status
21:10:06 <ttx> heckj/dolphm: o/
21:10:07 <dolphm> o/
21:10:12 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-rc2
21:10:24 <ttx> Bug 1160504 was recently added
21:10:26 <uvirtbot> Launchpad bug 1160504 in keystone "Grizzly v2 catalog has slight formatting changes compared to Folsom" [Undecided,New] https://launchpad.net/bugs/1160504
21:10:34 <ttx> dolphm: When was this format actually changed ?
21:10:51 <dolphm> yes, it was changed to match spec -- considering reversing that patch now
21:11:10 <dolphm> and simply filing the discrepancy away as won't fix
21:11:12 <ttx> yeah, if it's lived for 6 months it's probably safer
21:11:25 <ttx> when was this format "fixed" ? any idea ?
21:11:27 <dolphm> longer -- it's probably been an issue in v2.0 since essex
21:11:44 <dolphm> recently, but i'm still digging through git log / git blame for the commit
21:11:49 <ttx> ok
21:11:55 <ttx> Didn't see anything else with a good benefit/risk ratio on the grizzly-rc-potential list
21:12:02 <dolphm> agree
21:12:06 <ttx> so I guess when that issue is solved we should be in good shape
21:12:10 <dolphm> we're not aware of anything else at this point
21:12:24 <ttx> RC2 should be ready sometimes tomorrow ?
21:12:30 <dolphm> +1
21:12:36 <ttx> Looking at the summit, you have 14 proposals for 9 slots, which sounds a bit overcrowded
21:12:46 <ttx> Did you look into it yet ? Is there enough duplication for everything to fit ?
21:13:11 <dolphm> yeah, we're talking through merging sessions now, and maybe moving one or two to lightning talks which might be a better format
21:13:30 <ttx> OK
21:13:33 <ttx> Anything more about Keystone ?
21:13:45 <dolphm> don't think so!
21:13:51 <ttx> dolphm: thx!
21:13:53 <ttx> #topic Swift status
21:13:56 <ttx> notmyname: o/
21:13:57 <notmyname> hi
21:14:00 <ttx> #link https://launchpad.net/swift/+milestone/1.8.0-rc2
21:14:16 <ttx> So what are the bugfixes you'd like to backport before final release ?
21:14:41 <ttx> Still being discussed ?
21:15:05 <notmyname> I'm getting a list together. I'd like to talk to you more about that after the meeting
21:15:26 <ttx> notmyname: sure
21:15:43 <ttx> Looking at the summit, you have 13 proposals for 8 slots
21:15:50 <ttx> Do you think you can make it all fit ?
21:15:50 <notmyname> fun :-)
21:15:58 <ttx> Hmm, maybe you can borrow "some" space from Horizon
21:15:59 <notmyname> 13? I think it may be 15
21:16:27 <notmyname> there are some duplicates, but we don't have space for e verything right now
21:16:29 <ttx> notmyname: indeed!
21:16:52 <ttx> ok, we'll see if you could get two extra slots from Horizon's allocation
21:16:59 <ttx> later in the meeting
21:17:10 <ttx> In related news, https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Object_Storage_.28Swift.29 needs some love :)
21:17:19 <ttx> Anything more on Swift ?
21:17:33 <notmyname> I'll update that before the relase
21:17:34 <notmyname> thanks
21:17:51 <ttx> #topic Glance status
21:17:58 <markwash> hey hey hey
21:18:05 <ttx> markwash: o/
21:18:08 <ttx> #info Glance RC1 is still on track
21:18:17 <ttx> will it survive?
21:18:32 <markwash> I think so
21:18:37 <ttx> On the grizzly-rc-potential list, nothing really justifying a respin yet
21:18:52 <ttx> markwash: that would be a first ;)
21:19:01 <markwash> so, that being said, I actually do like all the "high" priority rc-potential items
21:19:06 <bcwaldon> ttx: you're being SUCH a jerk today!
21:19:26 <ttx> bcwaldon: not at all! That would be the first time a RC1 goes all the way to release.
21:19:38 <ttx> Nothing derogatory to Glance :)
21:19:40 <bcwaldon> so we don't have anything that should block the release
21:19:46 <markwash> right
21:20:04 <ttx> markwash: we could do a quick RC2 with all the High stuff backported, if you feel confident
21:20:08 <bcwaldon> so it depends on how hardcore you want to be about release blockers being required to respin
21:20:28 <ttx> bcwaldon: At this point, not so hardcore. But as time passes by, I get more hardcore
21:20:40 <ttx> which is why doing it now might be a good idea
21:20:43 <markwash> ttx: should we revisit it next week, see if any of those are "fix committed" ?
21:20:48 <ttx> while it's still possible
21:20:58 <bcwaldon> I don't want to scramble to fix a bunch of bugs knowing rc2 is a potential
21:21:02 <ttx> markwash: I'd rather not touch anything next week.
21:21:13 <bcwaldon> so I only want to consider bugs fixed in master
21:21:21 <ttx> bcwaldon: agreed
21:21:22 <markwash> understood
21:21:35 <bcwaldon> ok - so let's keep marking things as rc-potential and revisit this next week
21:21:40 <markwash> you guys are the pros, I think we can live without any of those fixes
21:22:05 <ttx> bcwaldon: hmm
21:22:14 <bcwaldon> ok - that's enough rabble from the glance crew
21:22:46 <ttx> bcwaldon: next week i'd like to minimize disturbance to the force, which means only accepting critical issues
21:22:51 <bcwaldon> ok
21:23:06 <markwash> ttx: if I ping you later this week, could we land a few in an rc2?
21:23:24 <ttx> bcwaldon: so it might actually be a good idea to push the fixes for the "nice to have but not critical" in a RC2... like before THursday
21:23:31 <bcwaldon> ok
21:23:37 <bcwaldon> we can queue it up, even if we don't release it
21:23:49 <bcwaldon> what branch should we propose fixes to?
21:23:56 <markwash> before == during? :-D
21:23:59 <ttx> bcwaldon: i can open a RC2 window, then you just propose to milestone-proposed
21:24:19 <ttx> i'll approve anything that's fixed in master and targetd to RC2
21:24:28 <bcwaldon> ok
21:24:47 <ttx> #action ttx to open glance rc2 window
21:24:58 <ttx> for the last rounbd of "nice to have" fixes
21:25:08 <ttx> Looking at the summit, you have 2 proposals for 5 slots
21:25:19 <ttx> how many do you think you'll end up needing ? We could give one extra slot to Cinder or Ceilometer
21:25:31 <markwash> I also have some private input that I will be redirecting to the summit site
21:25:39 <markwash> and I need to propose something myself :-/
21:25:40 <ttx> oh, ok
21:25:46 <ttx> please do :)
21:25:52 <ttx> You should also plan to spend some time improving https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Image_Service_.28Glance.29
21:25:55 <markwash> I think we should keep all 5 for now. . its not like 5 is being greedy
21:26:04 <ttx> not really, agreed
21:26:10 <ttx> Anything more on Glance ?
21:26:13 <markwash> yes
21:26:21 <markwash> I'd like to have a weekly glance core meeting
21:26:30 <markwash> for blueprint triage, etc
21:26:46 <ttx> markwash: ok, pick an hour and edit the Meetings wikipage
21:27:20 <markwash> #action markwash to schedule glance weekly meetings
21:27:39 <ttx> markwash: anything else ?
21:27:44 <markwash> that's it
21:27:48 <ttx> #topic Quantum status
21:27:51 <ttx> marwash: thx!
21:27:54 <ttx> arh
21:27:58 <ttx> danwent/markmcclain: hi!
21:28:01 <markmcclain> hi
21:28:07 <ttx> #info Quantum RC2 was published early this morning
21:28:20 <ttx> Only bug 1160431 was suggested as grizzly-rc-potential bugs so far
21:28:22 <uvirtbot> Launchpad bug 1160431 in quantum "router.interface.{create|delete} notifications do not include the router or tenant IDs" [Wishlist,In progress] https://launchpad.net/bugs/1160431
21:28:31 <ttx> so at this point this looks like a winner
21:29:08 <markmcclain> yeah.. we are looking into other issue reported today
21:29:18 <markmcclain> but there's not a bug for it yet
21:29:27 <ttx> ok, well we'll see
21:29:37 <ttx> Looking at the summit, you have 17 proposals for 22 slots
21:29:53 <ttx> How advanced are you for that ? Expecting more stuff being submitted ?
21:30:09 <markmcclain> yeah.. I expect several more to be filed… we've been emphasizing release docs over proposals
21:30:26 <ttx> ok, so you'll definitely have use for your 22 slots ?
21:30:46 <markmcclain> yeah.. some of the topics will be too big to fit into a single slot
21:30:52 <ttx> ok
21:30:56 <ttx> Don't forget to edit https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Network_Service_.28Quantum.29 at some point
21:31:04 <ttx> Anything else on Quantum ?
21:31:12 <markmcclain> that's it
21:31:23 <ttx> #topic Cinder status
21:31:29 <jgriffith> Hey there
21:31:34 <ttx> jgriffith: hi!
21:31:44 <ttx> The RC2 rstlibectomy was incomplete so we need to respin
21:31:50 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-rc3
21:32:04 <ttx> Anything else from the grizzly-rc-potential buglist you'd like to include before we tag ?
21:32:07 <jgriffith> yes, quick before something else comes up :)
21:32:19 <jgriffith> I think we're in good shape as of right now
21:32:37 <jgriffith> The additional items don't warrant it IMO
21:32:44 <ttx> want me to tag after meeting ? Or tomorrow morning if nothing was targeted to it yet ?
21:32:56 <jgriffith> I'm fine either way
21:33:04 <jgriffith> It's been very quiet in Cinder channel today
21:33:20 <jgriffith> My testing seems pretty good so far
21:33:30 <jgriffith> I don't anticipate anything that's critical
21:33:38 <ttx> Will tag tomorrow morning if it's still clean (everythign targeted beingcompleted)
21:33:46 <jgriffith> works for me
21:33:52 <jgriffith> Hopefully I won't regret my optimism
21:33:59 <ttx> #action ttx to tag cinder rc3 tomorrow morning if still ok
21:34:05 <ttx> Looking at the summit, you have 16 proposals for 11 slots
21:34:10 <ttx> pretty busy
21:34:20 <jgriffith> I'll be combining a few
21:34:24 <ttx> hopefully there is enough duplication, yeah
21:34:27 <jgriffith> shouldn't have a problem fittin gthem
21:34:31 <jgriffith> fitting them
21:34:35 <ttx> Cool. Anything more in Cinder ?
21:34:43 <jgriffith> Don't think so
21:34:48 <ttx> jgriffith: thx!
21:34:51 <ttx> #topic Nova status
21:34:54 <ttx> vishy/russellb: o/
21:35:00 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-rc2
21:35:01 <russellb> hi there.
21:35:04 <vishy> hi
21:35:11 <ttx> 2 fixes left to backport...
21:35:17 <ttx> dansmith suggested bug 1160489 -- I'm not sure the benefit/risk trade-off is worth it
21:35:18 <uvirtbot> Launchpad bug 1160489 in nova "periodically seeing KeyError: 'old_instance_type_memory_mb' in compute.log" [High,In progress] https://launchpad.net/bugs/1160489
21:35:19 <russellb> I just proposed those 2
21:35:26 <ttx> This patch is screaming "danger" all over, and it looks like a corner case...
21:35:41 <ttx> vishy/russellb: thoughts ?
21:36:42 * russellb is looking at it
21:37:02 <ttx> just approved your two backports
21:37:08 <russellb> thanks
21:37:25 <russellb> guess we can take it as an action to review this
21:37:34 <ttx> we can discuss 1160489 off-meeting yes
21:37:38 <ttx> 7 bugs on the grizzly-rc-potential list, nothing jumping as particularly critical
21:37:38 <vishy> also considering https://review.openstack.org/#/c/24863/
21:37:53 <vishy> and https://review.openstack.org/#/c/25072/
21:38:03 <ttx> yeah, been wondering how sfae that was (24863)
21:38:05 <vishy> i guess i could add those to rc-potential
21:38:06 <ttx> safe*
21:38:19 <russellb> vishy: seems fine to me ... the performance difference was pretty sad
21:38:46 <ttx> vishy: both look reasonable to me, feel free to target
21:38:50 <russellb> and 25072 is pretty low risk
21:39:35 <ttx> yeah, you should squeeze those before I start being overly conservative
21:40:10 <ttx> as long as we do that RC2 before Thursday those should be fine
21:40:16 <vishy> targetted
21:40:35 <ttx> I think zul proposed some of those
21:40:39 <ttx> (backports)
21:41:09 <ttx> vishy: https://review.openstack.org/#/c/25399/
21:41:17 <ttx> Looking at the summit, you have 43 proposals for 31 slots
21:41:23 <ttx> Hopefully enough duplication in proposals to allow merging...
21:41:28 <russellb> yeah ...
21:41:31 <ttx> since we can't make the Nova space larger than 4 days.
21:41:44 <russellb> i've pushed some off to the unconference track
21:42:00 <russellb> there's opportunity for combining and merging stuff, too
21:42:05 <russellb> especially in the scheduler area
21:42:12 <ttx> ok
21:42:15 <russellb> will have no problem filling the 4 days, that's for sure.
21:42:24 <ttx> Any other question on Nova ?
21:42:40 <russellb> last resort, saying no to stuff that seems non-controversial enough to just be a -dev thread
21:43:17 <ttx> russellb: or you can have a catch-all session where you merge 5 non-controversial ones
21:43:29 <russellb> yeah, that's not a bad idea
21:43:36 <ttx> giving each their ( minutes of fame
21:43:38 <ttx> 5*
21:43:51 <russellb> i'll keep that in mind, thanks
21:43:54 <ttx> #topic Horizon status
21:43:58 <ttx> gabrielhurley: hey
21:44:01 <gabrielhurley> hi
21:44:05 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-rc2
21:44:14 <gabrielhurley> I blame nova
21:44:19 <russellb> :-p
21:44:22 <ttx> always a safe bet
21:44:24 <gabrielhurley> introducing a new quota at the last moment
21:44:29 * gabrielhurley shakes his fist
21:44:35 <russellb> gabrielhurley: just published a new novaclient release
21:44:36 * ttx plants head in the sand
21:44:38 <gabrielhurley> but it was a chance to fix a couple I'd had my eye on
21:44:43 <gabrielhurley> russellb: thanks. was gonna ask.
21:44:52 <russellb> yep - 2.12.0
21:44:55 <gabrielhurley> awesome
21:44:58 <russellb> has the new quota support
21:45:04 <gabrielhurley> yep. we'll fix that asap
21:45:19 <ttx> So... 4 bugs on list, still needing master fixes
21:45:26 <gabrielhurley> anyhow, RC2 is still quite small, and I don't expect it to grow, particular.ly
21:45:28 <markmcclain> gabrielhurley: might want to look at this one for RC2: https://bugs.launchpad.net/quantum/+bug/1160580
21:45:29 <ttx> gabrielhurley: ETA for RC2 completion ?
21:45:30 <uvirtbot> Launchpad bug 1160580 in quantum "Allow extensions already implemented in Quantum  in Brocade plugin" [Undecided,New]
21:45:44 <ttx> would be good to lock it down by Thursday
21:46:21 <gabrielhurley> markmcclain: way to pull out a brand new bug. I'll read it in more detail, but yeah, it might make the cut
21:46:36 <gabrielhurley> ttx: end of week
21:46:43 <gabrielhurley> thursday should be fine
21:46:51 <ttx> ok
21:46:58 <ttx> Looking at the summit, you have 2 proposals for 7 slots
21:47:01 <markmcclain> gabrielhurley: sorry just got it this afternoon
21:47:03 <gabrielhurley> refresh ;-)
21:47:27 <ttx> 5/7
21:47:27 <gabrielhurley> it's 5/7 now. I proposed some of the ones the other projects said they wanted but hadn't opened yet
21:47:41 <ttx> For the curious, secret URL at http://summit.openstack.org/cfp/topicstatus
21:48:04 <gabrielhurley> I'd like to hold off on giving up the last two slots until anyone else who wants to propose topics has had the chance
21:48:11 <gabrielhurley> I'm gonna remind again at the hroizon meeting after this
21:48:21 <gabrielhurley> it sounded like folks wanted to last week, but I didn't see any come in
21:48:39 <ttx> gabrielhurley: OK. notmyname could use one or two more, if you don't need them
21:48:51 <gabrielhurley> I'll keep that in mind
21:48:56 <ttx> Sometimes this week you should start improving https://wiki.openstack.org/wiki/ReleaseNotes/Grizzly#OpenStack_Dashboard_.28Horizon.29
21:49:12 <gabrielhurley> ah yes. I always publish them to horizon's docs and forget to add them to the wiki
21:49:25 <ttx> Anything more on Horizon ?
21:49:26 <gabrielhurley> http://docs.openstack.org/developer/horizon/releases/2013_1.html
21:49:33 <gabrielhurley> nope, that's everything.
21:49:52 <ttx> #info Horizon RC2 ready by Thursday/Friday
21:50:01 <ttx> #topic Incubated-in-Grizzly/Integrated-in-Havana projects
21:50:07 <ttx> #info Heat has its RC1 published
21:50:12 <ttx> #info Ceilometer had its RC1 publiched earlier today
21:50:15 <jd__> \o/
21:50:18 <ttx> published, even
21:50:33 <sdake> we had a recent suggestion for backports - hasn't been approved yet
21:50:54 <ttx> sdake: ping me if you want to respin
21:50:59 <sdake> will do
21:51:02 <ttx> I'll open the RC2 page for you
21:51:08 <sdake> thanks
21:51:08 <ttx> (if you ask)
21:51:21 <sdake> i can handle it unless you prefer ;)
21:51:52 <ttx> sdake: there is a small trick. You need to enter the right "short name" becasue it's used by some scripts :)
21:52:07 <ttx> but yeah, you can do it if I'm not available
21:52:18 <ttx> jd__, sdake: anything else ?
21:52:42 <sdake> no
21:53:00 <jd__> nop
21:53:06 <ttx> ok then
21:53:15 <ttx> #endmeeting