21:02:34 <ttx> #startmeeting project
21:02:34 <danwent> ttx: here
21:02:35 <openstack> Meeting started Tue Jan 29 21:02:34 2013 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:38 <openstack> The meeting name has been set to 'project'
21:02:48 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:58 <ttx> #topic General announcements
21:03:07 <ttx> So we now have a code name for next cycle: "Havana"
21:03:11 <heckj> o/
21:03:17 <ttx> I'll proceed and create series in Launchpad as appropriate
21:03:25 <ttx> #action ttx to create havana series in LP projects
21:03:36 <markmc> wow, that's surprising
21:03:38 <markmc> hood got beat
21:03:45 <ttx> yes, generally the option I vote for wins.
21:03:52 <markmc> cheat
21:03:52 <gabrielhurley> can we hvae the summit in Cuba?
21:03:55 <danwent> makes we want to light up, and I don't even smoke
21:04:04 <heckj> o_O
21:04:14 <markmc> I always thought there were two 'n's in Havanna
21:04:15 * markmc shrugs
21:04:17 <sdake_z> i'll smoke one for you danwent
21:04:27 <ttx> markmc: how is 2012.2.3 going ?
21:04:37 <markmc> ttx, pretty much ready to go
21:04:46 <soren> markmc: Double consonants in Spanish are extremely rare.
21:04:51 <markmc> we had a couple of patches merged accidentally post-freeze
21:04:58 <markmc> one of which caused a regression in quantum
21:05:04 <markmc> but we caught it, so ...
21:05:13 <markmc> no other issues reported since the call for testing
21:05:17 <ttx> the two security patches finally made their way in
21:05:26 <markmc> #info 2012.2.3 will be released on Jan 31
21:05:33 <ttx> cool.
21:05:36 <ttx> mordred/jeblair, annegentle, davidkranz/jaypipes: Update from CI/QA/Docs teams ?
21:06:02 <mordred> ttx: we'll need attention from folks to get version patches landed by g3
21:06:37 <ttx> mordred: sounds doable if both you and I chase them
21:07:06 * mordred imagines ttx and mordred running around waving sticks at people
21:07:15 <ttx> OK, let's jump into grizzly-3 status then
21:07:30 <ttx> #topic Oslo status
21:07:30 <mordred> markmc, dhellmann: could you guys re-look at https://review.openstack.org/#/c/20431/ - I added a comment explaining
21:07:37 <markmc> mordred, will do
21:07:39 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-3
21:07:42 <mordred> thx
21:07:49 <markmc> #link https://github.com/openstack/oslo-config w00t!
21:07:49 <ttx> Progress looks good
21:07:57 <mordred> w00t!
21:07:59 <ttx> wow
21:08:00 <markmc> yeah, we're doing ok
21:08:12 <markmc> common-db is the one that needs most attention, mine mostly
21:08:12 <mordred> god, it's almost lke something worked there
21:08:24 <ttx> mordred: don't get used to it too much
21:08:44 <markmc> will do a release of oslo-config soon and aim to get all projects using it for grizzly-3
21:08:46 <ttx> markmc: You also need to push usage of the newly-published lib to the projects that use it, right ?
21:08:50 <ttx> heh
21:08:55 <markmc> that
21:08:56 <markmc> good idea
21:09:20 <ttx> Nothing else from me
21:09:23 <ttx> Anything else on the oslo topic ?
21:09:24 <markmc> might sneak one last feature into cfg
21:09:35 <markmc> yeah, that's it from me
21:09:36 <Vek> which would be?
21:09:53 <markmc> https://blueprints.launchpad.net/oslo/+spec/cfg-filter-view
21:10:04 <markmc> basically, got a patch today to fix CONF.import_opt()
21:10:16 <markmc> that blueprint is my alternate suggestion, written before the patch
21:10:26 <markmc> don't like to nix the patch without implementing the alternative
21:10:38 * ttx moves on
21:10:41 <ttx> #topic Keystone status
21:10:41 <markmc> thanks
21:10:46 <heckj> o/
21:10:47 <ttx> heckj: welcome back!
21:10:51 <heckj> heh
21:10:52 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-3
21:11:14 <heckj> removed some BP's earlier today from that list - updated status on other
21:11:20 <ttx> You made some updates I see
21:11:34 <ttx> delegation was dropped ?
21:11:42 <heckj> request for action - some have already helped (thanks gabriel) - need review on https://review.openstack.org/#/c/20524
21:11:53 <heckj> ttx: what you're thinking of delegation is encapsulated under "trusts"
21:12:16 <ttx> heckj: sounds like a jedi mind trick
21:12:31 <ttx> heckj: Do you have news about stop-ids-in-uris ?
21:12:34 <heckj> re: review - I've spammed a number of folks directly, but that review conversation is key to implementing https://blueprints.launchpad.net/keystone/+spec/stop-ids-in-uris
21:13:19 <ttx> heckj: so it's on track but needs support on that review ?
21:13:21 <heckj> and the BP https://blueprints.launchpad.net/keystone/+spec/pluggable-identity-authentication-handlers is blocked on that setup
21:13:53 <heckj> ttx: yes, exactly. And specifically, feedback from folks across openstack, as this impacts what authn/authz data can get passed to services, and the format of it
21:13:54 <ttx> heckj, dolphm: default-domain seems to be progressing well, when do you think it will be completed ?
21:14:36 <heckj> I think most of it is in right now - dolphm wasn't available earlier today to check in with on it
21:15:05 <ttx> heckj: should we have a blueprint for this v3 token API work ? Or should it be considered included in stop-ids-in-uris ?
21:15:23 <heckj> I've been considering it covered in the stop-ids-in-urls
21:15:31 <ttx> ok, sounds good
21:15:34 <heckj> they're tightly coupled in implementation
21:15:52 <ttx> About domain-name-spaces, domain-scoping: should they be pushed off Grizzly ?
21:16:00 <ttx> domain-scoping seems to have code proposed...
21:16:35 <ttx> (that's Henry Nash's blueprints)
21:16:39 <heckj> It'll go in pretty easily, and there's very active work right now to make sure we can support V2 and V3 APi components simultaneously, so I do expect it to be there
21:17:02 <ttx> so maybe we should target both to g3 ?
21:17:30 <heckj> If they make it, I'll pull them in - trying to be conservative now, and will be updating each week as we close on G3 deadline
21:17:39 <ttx> ok
21:17:45 <ttx> Anything more about Keystone ?
21:18:18 <heckj> re: Docs - annegentle, etc - we're kicking in more reviews recently with DocImpact flags - just wanted to make sure you had a head's up
21:18:20 <ttx> #info https://review.openstack.org/#/c/20524 on Keystone critical path, reviews from other projects needed
21:18:37 <annegentle> heckj: been seeing 'em :)
21:18:42 <heckj> cool
21:18:47 <annegentle> much appreciated
21:18:50 <ttx> heckj: anything else ?
21:18:53 <heckj> good her
21:18:55 <heckj> here
21:19:03 <ttx> thanks!
21:19:04 <ttx> #topic Swift status
21:19:08 <ttx> notmyname: o/
21:19:14 <notmyname> good morning :-)
21:19:15 <ttx> Swift 1.7.6 was released last week...
21:19:23 <ttx> notmyname: stop bragging from down under :)
21:19:30 <ttx> python-swiftclient 1.3.0 is still blocked in the automatic publication process afaict
21:19:34 <notmyname> we had a little hiccup with the pypi release
21:19:38 <notmyname> ah, not resolved yet?
21:19:46 <ttx> notmyname: you need to beat mordred and jeblair with a stick
21:19:52 <ttx> can't reach them from Europe
21:20:01 <notmyname> ya, I'll probably see them in an hour or so
21:20:11 * notmyname sharpens his stick
21:20:15 <ttx> Next release on the map is:
21:20:18 <ttx> #link https://launchpad.net/swift/+milestone/1.8.0
21:20:21 <notmyname> ya
21:20:21 <ttx> Got any vague timeframe for that ?
21:20:28 <notmyname> nope. when it's ready
21:20:45 <ttx> hopefully that won't be while i'm skiing.
21:20:50 <ttx> Anything more on Swift ?
21:21:11 <notmyname> some interesting mailing list discussions, but no meeting things I can think of
21:21:13 <notmyname> questions?
21:21:56 <ttx> no question, then...
21:21:57 <ttx> #topic Glance status
21:22:02 <ttx> bcwaldon: o/
21:22:07 <bcwaldon> ttx: hello!
21:22:08 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-3
21:22:14 * ttx refreshes
21:22:36 <ttx> bcwaldon: Looks like glance-api-v2-image-sharing is not making a lot of progress ?
21:22:53 <bcwaldon> ttx: I'm drafting a tactical email for those invovled in g3 right now
21:23:02 <ttx> bcwaldon: do you have news on that front ?
21:23:12 <bcwaldon> ttx: will get some info about that - the direction is defined, just waiting to see work happen
21:23:21 <bcwaldon> ttx: multiple image locations is making progress
21:23:30 <ttx> How is glance-domain-logic-layer doing ?
21:23:31 <bcwaldon> a review came up this week for an iscsi store driver
21:23:43 <bcwaldon> ttx: stalled a bit
21:23:53 <bcwaldon> ttx: these last few weeks are going to be tight
21:23:53 <ttx> bcwaldon: yes, i'm not a big fan of introducing rootwrap to glance just for that, but meh
21:24:01 <ttx> (importing-rootwarp and iscsi-backend-store)
21:24:16 <bcwaldon> ttx: I'm not sold we should have an iscsi driver either
21:24:24 <bcwaldon> but I want to have a discussion about it
21:24:37 <ttx> Those two blueprints are proposed to grizzly at this point
21:24:47 <bcwaldon> yes, that's the big thing to report this week
21:25:25 <ttx> bcwaldon: there is a small drawback in adding rootwrap support, you add a potential root escalation hole where there wasn't any
21:26:05 <bcwaldon> ttx: yes, the rootwrap concern may go away if we agree to go a different direction with the volume driver
21:26:07 <ttx> so this represents additional cost in accepting that  iscsi driver thing
21:26:21 <bcwaldon> ok, good to know
21:26:35 <ttx> well, I see you're on it :)
21:26:46 <bcwaldon> ttx: yes sir
21:27:10 <ttx> Anything more on Glance ?
21:27:19 <bcwaldon> ttx: not from me
21:28:04 <ttx> would be nice to see some visible progress on glance-api-v2-image-sharing and (glance-domain-logic-layer or api-v2-property-protection) soon
21:28:15 <bcwaldon> ttx: you don't have to tell me twice :)
21:28:28 <bcwaldon> ttx: or whatever we're at now, 6 times or so
21:28:33 <ttx> next week I may not remember anything, damn belgian beers
21:28:46 <ttx> #topic Quantum status
21:28:53 <danwent> hi
21:29:01 <ttx> danwent: hi!
21:29:04 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-3
21:29:35 <danwent> down to 23 unmerged :)  I've been booting things out that aren't showing progress
21:29:47 <danwent> but still a tone
21:29:49 <danwent> ton
21:30:17 <ttx> Targeted to grizzly-3 but not approved in series goal yet:
21:30:21 <danwent> so I've just been trying to focus the core team on 'high' or above, and setting expectations for others
21:30:24 <ttx> brocade-quantum-plugin, quantum-floodlight-bigswitch-l3
21:30:53 <danwent> sorry, i will approve both of those.  not sure the later will make it, but its that devs only BP, so i'm going to keep it targeted.
21:31:05 <ttx> Looking into your "High" priority stuff...
21:31:22 <ttx> are those reviews going well so far ?
21:31:51 <danwent> xml is going well
21:32:14 <danwent> OVS security group is blocked on a nova change, which was blocked on ML discussion, but should be good.
21:32:33 <danwent> multi-agent stuff has reviweres, though there are some design discussions still happening
21:32:52 <ttx> ok, sounds under control
21:32:55 <ttx> Still two blueprints in the grizzly series goal but not in g3:
21:32:56 <danwent> and the lbaas stuff just got posted for the review (with the haproxy driver being posted later this week)
21:33:00 <ttx> quantum-v2-euca-compat, auto-associate-floating-ip
21:33:02 <danwent> yeah, high BPs are under control
21:33:06 <ttx> Should they be removed ?
21:33:20 <danwent> yes, already out of G-3, and thus, shoudl be removed from grizzly overall.  will do that.
21:33:50 <ttx> danwent: I'll do it now
21:33:54 <ttx> Anything else on Quantum ?
21:34:05 <danwent> need to ping you about one other thing, but will do that via email
21:34:31 <ttx> danwent: ok
21:34:39 <ttx> #topic Cinder status
21:34:43 <ttx> jgriffith: hi!
21:34:44 <jgriffith> hey there
21:34:48 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-3
21:35:16 <ttx> 8 blueprints have been proposed to grizzly-3 but not confirmed at:
21:35:22 <ttx> https://blueprints.launchpad.net/cinder/grizzly/+setgoals
21:35:33 <jgriffith> grrr...
21:35:41 <ttx> want me to approve them ?
21:36:09 <jgriffith> Not sure actually
21:36:18 <jgriffith> I have some questions on a few of them
21:36:31 <ttx> ok, will let you review them later then :)
21:36:34 <jgriffith> Mind waiting and letting me sort through them with the owners?
21:36:39 <jgriffith> ttx: thanks
21:36:44 <ttx> #action jgriffith to review https://blueprints.launchpad.net/cinder/grizzly/+setgoals
21:36:52 <jgriffith> ttx: sorry, missed those
21:36:53 <ttx> cinderclient-v2-support: what's the status of this ? Isn't that a python-cinderclient blueprint ?
21:37:01 <jgriffith> ttx: correct
21:37:26 <ttx> jgriffith: mind if I move it to python-cinderclient instead ?
21:37:29 <jgriffith> no problem
21:37:48 <ttx> update-snap-metadata: who is working on this ? What's the status ?
21:38:29 <jgriffith> which one?
21:38:35 <ttx> https://blueprints.launchpad.net/cinder/+spec/update-snap-metadata
21:38:43 <ttx> targeted but no assignee and unknwon status
21:39:17 <jgriffith> got it
21:39:23 <jgriffith> So I'll grab that one
21:39:40 <jgriffith> just FYI, I've been having issues with folks going in approving, targetting and adding my name as approver
21:39:40 <ttx> ok, set status to "Not started" while you're at it :)
21:39:51 <jgriffith> without me actually knowing about the BP :)
21:40:10 <ttx> yeah... the only thing you can prevent is the series goal setting
21:40:11 <jgriffith> This one is not an example of that but anyway
21:40:17 <ttx> Otherwise there seems to be slow progress on the high-prio stuff
21:40:22 <ttx> I think we should remove local-storage-volume at this point...
21:40:27 <ttx> unless you have fresh news ?
21:40:28 <jgriffith> ttx: Yeah, but the biggest problem is reviews
21:40:38 <jgriffith> and yes, sadly that one is out it seems
21:40:59 <ttx> jgriffith: ok if I remove it from g3/grizzly ?
21:41:06 <jgriffith> yes
21:41:30 <ttx> wow, a new one since this morning: coraid-volume-driver
21:41:41 <ttx> cinder is popular in the scope creep department
21:41:48 <jgriffith> yeah, literally 1 minute ago
21:41:55 <jgriffith> ttx: tell me about
21:42:05 <jgriffith> ttx: all the vendors love the idea of cinder all of a sudden
21:42:12 <ttx> now I understand why vish wanted it separate ;)
21:42:20 <jgriffith> ttx: that makes two of us :(
21:42:24 <ttx> Anything more in Cinder ?
21:42:35 <jgriffith> Nah... just driver after driver after driver
21:42:54 <ttx> ok then
21:42:55 <ttx> #topic Nova status
21:42:59 <ttx> vishy, russellb: o/
21:43:04 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-3
21:43:06 <vishy> hi
21:43:17 <russellb> hey
21:43:20 <ttx> Good progress overrall, though I'm fearing some review bottleneck around Feature Freeze
21:43:46 <russellb> seems pretty hard to avoid
21:44:03 <ttx> 3 blueprints targeted to g3 but not in series goal:
21:44:05 <Vek> agreed...
21:44:14 <ttx> migration-testing-with-data migrate-volume-block-migration host-maintenance
21:44:34 <ttx> you might want to review those
21:44:50 <russellb> i'll get 'em
21:44:54 <ttx> Should https://blueprints.launchpad.net/nova/+spec/show-availability-zone be marked completed ?
21:44:54 <vishy> migration-testing-with-data i brought back but forgot to put in goal
21:45:03 <ttx> vishy: ok, fixing
21:45:06 <russellb> just fixed that one
21:45:18 <ttx> ok
21:45:22 <vishy> ttx: I was just trying to figure that out myself
21:45:34 <vishy> officially the bp mentions adding an az display to instances as well
21:45:38 <vishy> which requires an extension
21:45:46 <vishy> the existing prop died
21:46:04 <vishy> so i'd say no for now.
21:46:11 <ttx> ok
21:46:18 <ttx> All the High stuff seems to be progressing well, except improve-block-device-handling and nova-quantum-security-group-proxy
21:46:25 <vishy> if there is no more progress we will scale back the bp to cover implemented functionality
21:46:37 <vishy> ttx: there is active work being done on both of those
21:46:39 <russellb> both of those have had recent movement
21:46:48 <russellb> so there is hope
21:46:54 <ttx> ok, good, just no code proposed yet
21:46:59 <ttx> xenapi-gpu-passthrough and multi-boot-instance-naming are not marked started yet... should they be postponed to H ?
21:47:22 <russellb> i thought i saw a patch posted for multi-boot-instance-naming
21:47:24 <vishy> multi-boot-instance-naming had a review up but it got abandoned for some reason
21:47:32 <russellb> weird
21:47:42 <vishy> xenapi-gpu-passthrough seems like a great one to postopone
21:47:46 <vishy> *postpone
21:48:01 <ttx> i'll let you do that (remove series goal and milestone)
21:48:15 <ttx> and as always, review early, review often
21:48:35 <ttx> the more we get in now the easier it will be in two/three weeks :)
21:48:41 <ttx> Any question on Nova ?
21:49:36 <ttx> #topic Horizon status
21:49:44 <ttx> gabrielhurley: hey
21:49:50 <gabrielhurley> hi
21:50:17 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-3
21:50:38 <ttx> Looks like you're falling a bit behind...
21:51:04 <ttx> still confident ?
21:51:13 <gabrielhurley> everything is actively being worked on, and I've talked to all of those folks in the course of the last week. several are up with POC's and/or code reviews.
21:51:33 <gabrielhurley> My intention is to encourage everyone to get at least some form of code up for review by next week to give a couple weeks to nail things down
21:51:34 <ttx> yeah, for some reason they aren't linked that much
21:51:48 <gabrielhurley> yep, totally distributed, little to no interdependance
21:51:58 <gabrielhurley> very parallelized this time, which is good
21:52:02 <ttx> gabrielhurley: ask them to mention the bp name in their review so that we get magic linking
21:52:13 <gabrielhurley> will do
21:52:20 <ttx> add-security-group-to-instance is the only one I could find code proposed for :)
21:52:32 <ttx> Anything more on Horizon ?
21:52:34 <gabrielhurley> other ones are up on github but not in gerrit
21:52:46 <gabrielhurley> I do have one BP that just got opened that I need to find out if it's gonna be a G3 item or not
21:52:51 <gabrielhurley> https://blueprints.launchpad.net/horizon/+spec/quantum-lbaas
21:53:10 <gabrielhurley> apparently it's under active development already. I got looped into the email thread this morning and wrote back
21:53:14 <gabrielhurley> should have an answer soon
21:53:21 <gabrielhurley> it's a "might slip in at the last moment"
21:53:29 <ttx> not sure how to best prevent last-minute bp introduction
21:53:36 <gabrielhurley> yeah
21:53:42 <gabrielhurley> I don't want to turn down finished work if it happens
21:53:47 <gabrielhurley> but I'm not counting on it
21:53:57 <gabrielhurley> I'm gonna leave it out of the ilestone until I see confirmation that it should land
21:54:36 <ttx> gabrielhurley: ok, anything else ?
21:54:45 <gabrielhurley> no, I think that's it for this week
21:54:51 <ttx> thanks!
21:54:52 <ttx> #topic Incubated projects
21:55:04 <ttx> ceilo/heat folks around ?
21:55:07 <sdake_z> yup
21:55:23 <ttx> #link https://launchpad.net/heat/+milestone/grizzly-3
21:55:31 <ttx> This looks a bit worrying, though I suspect all those represent a small unit of work ?
21:55:48 <sdake_z> we had 1 bp that had 7 different things in it, so we broke those up into 7 different  bps
21:55:53 <ttx> FWIW there is a "work item" system within blueprints that lets you track smaller tasks without having to create a separate blueprint for each.
21:56:04 <sdake_z> and the work is nearing completion in local repos
21:56:10 <ttx> ok
21:56:15 <sdake_z> some vpc resources may be deferred
21:56:21 <sdake_z> rather network resources
21:56:23 <sdake_z> (some of the 7)
21:56:32 <sdake_z> the others are fairly straightforward, although half developers at lca this week
21:56:38 <ttx> you also have a pretty significant targeted bug list
21:56:54 <sdake_z> agree, two weeks ago got devs to agree to fix 3 bugs a week
21:56:57 <sdake_z> which so far has been working out ok
21:57:03 <sdake_z> that should land us at zero bugs when done ;)
21:57:12 <ttx> sdake: heh
21:57:23 <ttx> sdake: anything else you wanted to mention ?
21:57:30 <Vek> unless the list of bugs grows faster than 3 bugs * n developers a week
21:57:34 <ttx> any ceilometer folk around ?
21:57:40 <sdake_z> bit of risk on the bug count but i think we are in good shape
21:57:43 <ttx> Vak speaks from experience
21:57:48 <ttx> Vek*
21:57:49 <sdake_z> agree vek
21:57:50 <Vek> :)
21:58:30 <ttx> ok then I guess we are done for today, woohoo
21:58:51 <ttx> #endmeeting