21:02:10 <ttx> #startmeeting project
21:02:11 <openstack> Meeting started Tue Dec 18 21:02:10 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:14 <openstack> The meeting name has been set to 'project'
21:02:18 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:02:21 <jgriffith> here
21:02:29 <ttx> #topic General announcements
21:02:44 <ttx> First, as discussed in the TC meeting, if the summit date ends up being Apr 29 - May 2, we should adapt the release schedule a bit
21:02:57 <ttx> In that case we would push back G2 to January 17, G3 to March 7 and final release to April 11
21:03:09 <ttx> would allow one more week before grizzly-2, which given the progress so far doesn't sound like a bad idea
21:03:22 <ttx> That should hopefully be confirmed later this week !
21:03:28 <heckj> o/
21:03:38 <ttx> Next question is whether we should hold release status meetings on December 25th and January 1st
21:03:46 * heckj would prefer not
21:03:50 <ttx> My suggestion would be to skip them, and I'll hunt you all down via email in case I need answers/status updates
21:04:21 <gabrielhurley> +1
21:04:22 <ttx> Is that ok for everyone ?
21:04:31 <jgriffith> +1
21:04:32 <markmc> yep
21:04:42 <ttx> #info Next release status meeting on january 8, happy holidays
21:05:02 <ttx> markmc, mordred, annegentle, davidkranz/jaypipes: Anything to report from Stable/CI/QA/Docs land ?
21:05:11 <markmc> Nova 2012.2.2 went out
21:05:25 <markmc> I've created 2012.2.3 milestones in launchpad for all projects
21:05:32 <markmc> January 31st AFAIR
21:05:37 <markmc> tentative date
21:06:06 <davidkranz> Nothing to report at the moment.
21:06:30 <ttx> OK, anything more to add before we move to project-specific topics ?
21:07:06 <ttx> #topic Oslo status
21:07:15 <ttx> #link https://launchpad.net/oslo/+milestone/grizzly-2
21:07:29 <ttx> Slightly late, but should be OK if I work on rootwrap tomorrow
21:07:48 <ttx> so you can start working on binary/rename-on-copy stuff
21:08:07 <markmc> yeah, I think we're mostly on track
21:08:08 <ttx> markmc: How is olso-config looking ?
21:08:13 <ttx> oslo-config*
21:08:17 * markmc digs up a link
21:08:57 <markmc> bah, can't find it quick;ly
21:09:04 <markmc> posted another version of the oslo-config repo
21:09:18 <markmc> with full history and proper setuptools handling of versions
21:09:26 <markmc> I think it's mostly ready
21:09:32 <markmc> just need mordred to sign off on it
21:09:42 <ttx> markmc: when do you expect projects start ripping out the code copy and use the lib ?
21:09:45 <markmc> then the CI folks to do their thing to import it, set up jobs, etc.
21:09:47 <ttx> post-g2 ?
21:09:54 <markmc> yeah, I guess so
21:09:58 <ttx> ok
21:10:08 <markmc> nova and keystone are using the latest cfg api
21:10:08 <ttx> Anything else on the oslo topic ?
21:10:16 <markmc> there are reviews pending for glance and cinder
21:10:23 <markmc> I'll get to quantum soon, I hope
21:10:25 <markmc> nope, that's it
21:10:51 <ttx> #topic Keystone status
21:10:59 <ttx> heckj: Hi! Enjoyed your vacation time ?
21:11:13 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-2
21:11:14 <heckj> ttx: it was nice, thanks
21:11:28 <ttx> This now looks quite late, but some of it is due to lack of status updates on blueprints
21:11:40 <ttx> user-groups: I see code was proposed -- ok if I set status to "NeedsCodeReview" ?
21:11:47 <heckj> ttx: yep
21:12:03 <ttx> About trusts: ayoung mentioned he had an implementation, but it wasn't posted yet ?
21:12:14 <heckj> store quota data will probably be deferred - no code up for review
21:12:35 <ayoung> ttx, still the case.
21:12:35 <heckj> ttx: he's been getting everything set up for it - finding more dependencies that he needs, will probably move to G-3
21:13:26 * ttx looks if G3 has free space
21:13:41 <ttx> yeah, your G3 wasn't that crowded
21:13:54 <heckj> we've been actively front-loading as much as possible
21:14:16 <ttx> execpt delegation is a big thing in G3
21:14:38 <ttx> OK, that's all I had
21:14:41 <ttx> Anything more about Keystone ?
21:15:11 <ttx> heckj: defer early when you know it won't make it
21:15:18 <heckj> ttx: will do
21:15:23 <ttx> (helps setting expectations right)
21:15:30 <ttx> #topic Swift status
21:15:35 <ttx> notmyname: o/
21:15:40 <ttx> #link https://launchpad.net/swift/+milestone/1.7.6
21:15:44 <notmyname> hi
21:15:55 <ttx> notmyname: You had an action last week to update that -- shall I defer that to next time ?
21:15:58 <notmyname> updating LP is still on my todo list
21:16:10 <notmyname> I've been traveling quite a bit this last week
21:16:19 <ttx> ok, re-action-ing
21:16:20 <notmyname> I'll update it "Real soon now" ;-)
21:16:21 <ttx> #action notmyname to update https://launchpad.net/swift/+milestone/1.7.6 with objectives
21:16:30 <ttx> you have until next year now :)
21:16:38 <ttx> post-apocalypse
21:16:48 <notmyname> we're shooting for a release in January, so it needs to be done by the next meeting anyway :-)
21:16:53 <ttx> notmyname: Got my email on the proposed RC process ?
21:17:21 <notmyname> ya, I haven't had time to formulate a response (+ or -)
21:17:34 <ttx> notmyname: no problem
21:17:49 <notmyname> ttx: it's not time critical is it?
21:17:59 <ttx> notmyname: no
21:18:16 <ttx> notmyname: I'll need to know by end of january, I'd say
21:18:20 <notmyname> sure
21:18:23 <ttx> notmyname: Anything else on Swift ?
21:18:42 <notmyname> not from me right now
21:19:08 <ttx> #topic Glance status
21:19:11 <ttx> bcwaldon: o/
21:19:16 <bcwaldon> ttx: hello!
21:19:16 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-2
21:19:24 * ttx refreshes
21:19:28 <bcwaldon> didn't make much progress this past week
21:19:34 <bcwaldon> bumped image sharing to G3
21:19:38 <ttx> refreshing doesn't work as well as last cycle
21:20:08 <bcwaldon> we released python-glanceclient v0.7.0 on 12/12/12
21:20:34 <bcwaldon> ttx: that date works for both of us!
21:20:43 <ttx> should have bumped version to 12.12.12
21:20:46 <bcwaldon> nothing else to report
21:21:10 <ttx> api-v2-property-protection: on track or you could use the extra week ?
21:21:22 <bcwaldon> markwash just verbally committed to finishing that for G2
21:21:32 <ttx> markwash is assigned two concurrent essential features :)
21:21:36 <bcwaldon> yep
21:21:38 <bcwaldon> he's a hard worker
21:21:46 <bcwaldon> and the domain-logic bp is coming to completion
21:22:05 <comstud> he's finishing his cloning technology today
21:22:19 <bcwaldon> yes, don't bother him
21:22:26 <ttx> comstud: hopefully that cloning thing will merge faster than the cells stuff
21:22:31 <comstud> lol
21:22:32 <bcwaldon> burn
21:22:34 <comstud> fair enough
21:22:44 <markwash> its gonna be like when there were 3 jack donaghys
21:22:46 <ttx> bcwaldon: Anything more on Glance ?
21:22:47 <comstud> i could use his technology
21:22:56 <bcwaldon> ttx: not at all, let's get this meeting back on track
21:22:59 <bcwaldon> and ignore these jokers
21:23:05 <comstud> hush
21:23:16 <ttx> let's get serious.. networking
21:23:18 <ttx> #topic Quantum status
21:23:23 <salv-orlando> hi
21:23:23 <ttx> salv-orlando: hi!
21:23:29 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-2
21:23:41 <salv-orlando> Not at lot of progress last week unfortunately
21:23:45 <ttx> I like all this purple
21:23:50 <salv-orlando> we're waiting to see what happens on friday
21:23:56 <ttx> salv-orlando: Is there some core team bottleneck there ? Or just complex reviews that take time ?
21:24:01 <salv-orlando> long reviews
21:24:21 <salv-orlando> we have several patches with 1000+ lines
21:24:40 <salv-orlando> however we are making progress especially on load balancing blueprints
21:24:41 <ttx> salv-orlando: ideally you would prioritize reviews based on blueprint priority, but I guess you kind of already do that naturally
21:24:59 <ttx> I had a few questions about blueprint status:
21:25:05 <salv-orlando> yes, that's how core reviewers are using their review cycles
21:25:10 <salv-orlando> ttx: shoot
21:25:18 <ttx> rpc-for-l3-agent is marked Implemented but still has an active review @ https://review.openstack.org/15476 ??
21:25:25 <ttx> That's cheating.
21:25:42 <salv-orlando> that's a follow-up patch. Yes the author should have filed a bug for this addendum
21:25:47 <ttx> You can't evade my evil scripts
21:25:56 <ttx> salv-orlando: ok :)�
21:26:00 <ttx> :)*
21:26:03 <salv-orlando> ttx: wait a sec
21:26:09 <ttx> make-string-localizable has a number of merged changes -- is it complete or are there more to come ?
21:26:18 * ttx freezes
21:26:19 <salv-orlando> that is a patch which was given -2
21:26:35 <salv-orlando> afaik it's going to stay -2
21:26:57 <ttx> salv-orlando: ok, that should be solved by auto-andonment if nobody abandons it before
21:27:16 <salv-orlando> ttx: frankly I don't know when make-string-localizable could be considered complete
21:27:36 <ttx> yeah, I don't like those "infinite tasks" blueprints that much
21:27:56 <ttx> better tracked in some other way
21:28:16 <salv-orlando> ttx: agreed. Should I ask for filing a distinct bug for each patch
21:28:17 <salv-orlando> ?
21:28:18 <ttx> it should be removed from plan... or considered complete on some measurable milestone
21:28:43 <ttx> salv-orlando: no, could be a single bug in reference
21:29:05 <ttx> or even no bug at all, in that specific case
21:29:24 <ttx> I found a few other issues on the published plan:
21:29:38 <salv-orlando> ttx: ok. I'll report to danwent and the core team and we will find a solution
21:29:49 <ttx> https://blueprints.launchpad.net/quantum/+spec/tempest-tests-api : not in series goal, no priority -- remove milestone or add seriesgoal ?
21:30:44 <ttx> same question for https://blueprints.launchpad.net/quantum/+spec/extended-tempest-tests-api
21:31:00 <ttx> they are "proposed for grizzly" currently
21:31:19 <ttx> should they be "accepted" ?
21:31:26 <salv-orlando> ttx: thanks for pointing that out. Those blueprints have been registered last friday. I don't think they're officially in any plan at the moment.
21:31:51 <ttx> I guess we can sort them out next time if they still stand out
21:32:03 <ttx> finally: quantum-scheduler (g2/High) depends on quantum-multihost (no milestone/Medium)
21:32:25 <ttx> Looks like quantum-multihost should be g2/high, or the dependency removed
21:32:41 <salv-orlando> ttx: right. We will fix this too. From what I gather it seems we're going to bump to G-3
21:32:49 <ttx> ok
21:32:54 <ttx> Anything else on Quantum ?
21:33:08 <salv-orlando> Nothing worth mentioning here
21:33:20 <ttx> #topic Cinder status
21:33:24 <ttx> jgriffith: hi!
21:33:27 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-2
21:33:37 <jgriffith> Yo
21:33:37 <ttx> Nice progress here
21:33:53 <jgriffith> I had to push a couple more out but the rest I'm feeling good about
21:33:54 <ttx> You bumped local-storage out ?
21:33:59 <jgriffith> ttx: :(
21:34:07 <jgriffith> local storage, and expect-delete
21:34:23 <jgriffith> Haven't heard from vincent in a couple weeks
21:34:40 <jgriffith> If something changes and we get it, that's great, otherwise G3
21:34:52 <ttx> add-cloning-support-to-cinder: I see code proposed, should I just set to NeedsCodeReview ?
21:35:04 <jgriffith> ttx: correct
21:35:19 <ttx> https://blueprints.launchpad.net/cinder/+spec/emc-volume-driver : targeted at grizzly-2 but not in series goal. Should I just add it ?
21:35:39 <jgriffith> ttx: I would wait... on that
21:35:52 <jgriffith> ttx: I have a question for folks at the end of the meeting related to that :)
21:36:12 <jgriffith> ttx: or I guess I could ask quickly now...  up to you
21:36:12 <ttx> at the end of the meeting ? Why not ask now ?
21:36:16 <jgriffith> hehe
21:36:16 <ttx> ask
21:36:32 <ttx> new format, no more open discussion at the end
21:36:33 <jgriffith> So EMC has their own client published on pypi that they rely on
21:36:40 <jgriffith> Needed for their unit tests
21:36:59 <jgriffith> how do we feel about adding it to openstack requirements ?
21:37:18 <jgriffith> Just wasn't sure of the precedence given 99.9% user don't need/want it
21:37:19 <ttx> jgriffith: link to that lib ?
21:37:29 <jgriffith> ttx: don't have it, he published last night
21:37:54 <ttx> jgriffith: obviously depends on the licensing around that lib
21:38:07 <jgriffith> ttx: Ahaaaa... excellent point
21:38:09 <ttx> jgriffith: and should raise a new dependency thread on openstack-dev
21:38:27 <jgriffith> ttx: Ok, I'll look at both of those things
21:38:31 <ttx> jgriffith: maybe it's a big pile of crap no distro will want to package
21:38:31 <jgriffith> ttx: that's it.. thanks
21:38:46 <jgriffith> ttx: well, there's that :)
21:38:56 <ttx> Anything more in Cinder ?
21:39:18 <ttx> #topic Nova status
21:39:22 <ttx> vishy: o/
21:39:27 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-2
21:39:30 * ttx refreshes
21:39:48 <ttx> vishy: Generally a bit late I think, especially in the High priority stuff
21:40:16 <vishy> hi
21:40:36 <ttx> aggregate-based-availability-zones: I see code proposed, should I set NeedsCodeReview ?
21:40:44 <vishy> i don't think I'mrove Block Device handling will make it
21:40:48 <vishy> yes please
21:40:57 <ttx> instance-actions: same question
21:41:47 <vishy> i think https://blueprints.launchpad.net/nova/+spec/xenapi-volume-drivers might be done
21:42:00 <ttx> vishy: how about pushing back Improve Block Device Handling to g3 ?
21:42:08 <jog0> ttx: yes
21:42:23 <vishy> yes needs code review
21:42:29 <vishy> ttx: yes sounds good
21:42:39 <ttx> no-db-compute-manager: A number of changes were merged... are there more expected ?
21:43:50 <vishy> russellb, dansmith: ^^
21:44:06 <ttx> I'll try to confirm xenapi-volume-drivers completion with mate-lakat
21:44:14 <ttx> #action ttx to confirm xenapi-volume-drivers completion with mate-lakat
21:44:32 <ttx> apis-for-nova-manage: same question (A number of changes were merged... are there more expected ?)
21:45:14 <russellb> more are expected
21:45:21 <russellb> but should be finished by grizzly-2
21:45:24 <ttx> And finally: coverage-extension: looks like it's implemented ?
21:45:59 <vishy> ttx: i think the apis there are a few more
21:46:06 <vishy> yes implemented
21:46:17 <ttx> nova-compute-cells: Are we making progress on the review ?
21:46:19 * comstud .
21:46:24 <comstud> it's all on me
21:46:26 <ayoung> dtroyer, can you point me at why requests is beter than httplib?
21:46:33 <comstud> right now, anyway
21:46:50 <comstud> was fixing tests late last week.. discovered a couple tiny things here before I put up next round
21:47:01 <vishy> ayoung: might want to take that to -dev
21:47:04 <ttx> comstud: a new round of fixes on the changes ? ok
21:47:11 <comstud> yah, round of reviews
21:47:24 <comstud> i think there's like 8 reviews?
21:47:24 <ttx> comstud, vishy: feeling like it can still hit before g2 ?
21:47:24 <comstud> hehe
21:47:32 <comstud> i'm confident
21:47:39 <comstud> i think this will address people's concerns
21:48:03 <ttx> it's one of those things I'd really prefer to have in an early milestone
21:48:08 <ttx> Any question on Nova ?
21:48:13 <comstud> yep
21:48:18 <comstud> (no question)
21:48:51 <ttx> #topic Horizon status
21:48:56 <ttx> gabrielhurley: hey
21:48:58 <gabrielhurley> hi
21:49:01 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-2
21:49:12 <ttx> Looks a bit late too
21:49:18 <gabrielhurley> clarified a lot of the quantum BPs, got some more started, but still late.
21:49:18 <ttx> Could you make use of an additional week ? :)
21:49:26 <gabrielhurley> I will not complain about having extra time
21:49:32 <ttx> resource-introspection: how is that progressing ?
21:49:42 <gabrielhurley> that's my pet proejct of the holiday
21:49:50 <gabrielhurley> s/of/for
21:50:13 <ttx> file-upload-redux: same question
21:50:42 <gabrielhurley> Progress is good last I heard. I'm gonna get an update at the Horizon meeting after this.
21:51:09 <ttx> The quantum-related blueprints are not "accepetd" for grizzly yet. Should I fix that ?
21:51:14 <gabrielhurley> oh
21:51:14 <gabrielhurley> yeah
21:51:15 <ttx> accepted*
21:51:18 <ttx> will do
21:51:35 <ttx> gabrielhurley: i should accept all of them ? improve-quantum-summary-table quantum-floating-ip quantum-l3-support quantum-vnic-ordering quantum-network-topology quantum-security-group
21:51:56 <gabrielhurley> I'll go through and double-check
21:52:04 <gabrielhurley> I'll do that as soon as we're done here
21:52:22 <ttx> ok, then i'll let you review those
21:52:53 <ttx> You can find them all at https://blueprints.launchpad.net/horizon/grizzly/+setgoals
21:53:01 <gabrielhurley> perfect
21:53:03 <ttx> that's all I had
21:53:11 <ttx> Anything more on Horizon ?
21:53:35 <ttx> #topic Incubated projects
21:53:42 <ttx> Anyone from Ceilometer or Heat ?
21:53:46 <stevebake> hi
21:53:52 <ttx> Heat goes first
21:53:56 <ttx> #link https://launchpad.net/heat/+milestone/grizzly-2
21:54:14 <ttx> I see you added a new one since last week :)
21:54:19 <ttx> so it's no longer all-completed :)
21:54:33 <stevebake> Not much to report. Is there a way of listing bugs which have no milestone attached?
21:55:04 <ttx> stevebake: mayyyybe.
21:55:22 <ttx> If not, I could script that for you
21:55:32 <ttx> I'l check off-meeting
21:55:37 <stevebake> there are a bunch of bug which should have milestones, I can always to it manually
21:55:47 <ttx> In other news you have a tarball job now... I'm trying to get it fixed so that the tarballs are properly versioned
21:55:58 <stevebake> anyway, we're all testing, fixing, packaging and documenting here
21:56:10 <stevebake> ah, yes. what does the docs job actually do?
21:56:45 <stevebake> we have a docs change about to land. sphinx laid out like other projects
21:56:50 <ttx> stevebake: not sure, I think it extracts rst docs from code and posts it somewhere
21:57:04 <ttx> stevebake: you should ping annegentle about that
21:57:08 <ttx> On the general grizzly plan, https://blueprints.launchpad.net/heat/+spec/raw-template-db is missing implementation status and priority
21:57:14 <ttx> otherwise it's all sane
21:57:20 <stevebake> yep, she be helping us
21:57:25 <ttx> Nobody from ceilometer ?
21:57:27 <stevebake> ok
21:57:37 <ttx> stevebake: other questions ?
21:57:46 <stevebake> no
21:59:11 <ttx> ok then if we don't have the ceilometer crowd around, let's end this
21:59:26 <ttx> #endmeeting