21:03:04 <ttx> #startmeeting project
21:03:05 <openstack> Meeting started Tue Nov 20 21:03:04 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:03:07 <openstack> The meeting name has been set to 'project'
21:03:15 <ttx> Agenda @ http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:27 <ttx> Note that the agenda order was slightly reworked in order to have common topics first
21:03:46 <ttx> so when you're done you can more easily ignore the rest of the meeting :)
21:03:53 <ttx> #topic General announcements
21:03:55 <stevebake> o/ for heat
21:04:17 <ttx> #info At the end of today (i.e. tomorrow European morning), I'll cut the milestone-proposed branches for the projects that do grizzly-1
21:04:32 <ttx> In this meeting we'll look into grizzly-1 status and defer bugs/blueprints where appropriate
21:04:42 <ttx> mordred, annegentle, davidkranz: Anything in CI, QA or Docs that you want to bring to the general attention ?
21:04:54 <markmc> ttx, if you want common stuff first, maybe put stable branch in there too
21:05:05 <markmc> ttx, this week is supposed to be 2012.2 release week
21:05:08 <ttx> markmc: good point
21:05:16 <ttx> markmc: go ahead
21:05:16 <annegentle__> yes, we now have a new Basic Install guide at http://docs.openstack.org/folsom/basic-install/content/
21:05:37 <markmc> ok, so at the summit we agreed a tentative schedule
21:05:42 <davidkranz> ttx: Just that attempts to run the ful tempest gate are now failing quite often.
21:05:46 <markmc> #link https://etherpad.openstack.org/process-stable-branch
21:05:54 <markmc> 2012.2 was put in for November 22nd
21:06:00 <markmc> didn't realize it was thanksgiving at the time
21:06:09 <markmc> but we're in pretty good shape for a release IMHO
21:06:09 <davidkranz> This bug: https://bugs.launchpad.net/nova/+bug/1079687
21:06:11 <uvirtbot> Launchpad bug 1079687 in nova "Flaky failures of instances to reach BUILD and ACTIVE states" [Undecided,New]
21:06:12 <markmc> bugs fixed:
21:06:22 <markmc> 37 nova
21:06:22 <markmc> 25 quantum
21:06:22 <markmc> 9 glance
21:06:22 <markmc> 6 keystone
21:06:22 <markmc> 3 cinder
21:06:23 <markmc> 1 horizon
21:06:27 <markmc> 81 total
21:06:43 <markmc> I'm thinking of going ahead and announcing RC tarballs
21:06:52 <markmc> and pushing the release as planned on Thursday
21:07:03 <markmc> don't want to do it the same week as grizzl-1
21:07:10 <markmc> don't see the need to push it out 2 weeks
21:07:10 <ttx> markmc: not worth waiting one more week ?
21:07:16 <davidkranz> ttx: Perhaps this group can figure out how to get that issue involved as it is not clear where the problem lies.
21:07:27 <ttx> markmc: grizzly-1 is this week
21:07:37 <markmc> ttx, ah, perfect - I got mixed up
21:07:45 <markmc> ttx, ok, let's do it next week
21:07:51 <ttx> markmc: sounds good
21:07:55 <markmc> I'll send out a mail
21:08:03 <markmc> if PTLs know of fixes that need backporting
21:08:06 <markmc> nows a good time
21:08:08 <ttx> #info 2012.2.1 scheduled for next week
21:08:39 <ttx> davidkranz: looks like Nova failures ?
21:08:48 <davidkranz> ttx: Yes.
21:08:58 <davidkranz> ttx: But it could be an infrastructure issue.
21:09:09 <ttx> davidkranz: ok, we can cover it in the Nova topic, hopefully we'll have vishy by then
21:09:21 <davidkranz> ttx: Great.
21:09:24 <ttx> Anything else for the general crowd before we dive into project-specific topics ?
21:10:07 <ttx> #topic Oslo status
21:10:20 <ttx> markmc: welcome back
21:10:25 <markmc> thanks, I've been a little AWOL
21:10:28 * markmc done with travelling
21:10:38 <ttx> Incomplete action item: markmc to file blueprint for oslo-config release
21:10:50 <markmc> #link https://launchpad.net/oslo/+milestone/grizzly-1
21:10:54 <markmc> ttx, ah, good point
21:11:02 <ttx> #action markmc to file blueprint for oslo-config release
21:11:09 <markmc> also need to dig into the release version thing
21:11:13 <markmc> both are related
21:11:13 <ttx> ok, looking at g1
21:11:22 <ttx> cfg-argparse: should it be considered implemented ?
21:11:25 <heckj> o/
21:11:32 <ttx> oh it was
21:11:44 <markmc> yeah, want to get all the projects using it
21:11:46 <ttx> in the last 5 minutes
21:11:50 <markmc> but that'll be grizzly-2 at this point
21:12:09 <ttx> oslo-release-versioning: defer to g2 ?
21:12:13 <markmc> yep
21:12:14 * markmc does that
21:12:43 <ttx> ok
21:12:44 <markmc> bit behind on bug triage too, but don't see anything too scarey
21:12:44 <ttx> markmc/others: Anything you wanted to raise on oslo, before we switch to next topic ?
21:13:22 <ttx> #topic Keystone status
21:13:28 <ttx> heckj: hello!
21:13:34 <heckj> ola!
21:13:35 <ttx> #link https://launchpad.net/keystone/+milestone/grizzly-1
21:13:44 <heckj> (refresh if you haven't recently - was cleaning in past 30 minutes)
21:13:49 * ttx refreshes
21:14:13 <ttx> implement-v3-core-api: how far are we ?
21:14:17 <heckj> two blueprints are pending code reviews, and look to be complete by Thursday
21:14:38 <heckj> For a tech preview, we're looking good - starting to log new bugs, etc. and deal with issues as they've been coming up
21:14:40 <ttx> heckj: trick is, we are supposed to cut the branch at the end of today, not the end of Thursday
21:14:58 <heckj> Ah - thought the date was the 22nd
21:15:11 * gabrielhurley thought that too
21:15:14 <jgriffith> heckj: That makes two of us
21:15:15 <ttx> the branch lives for two days before being released
21:15:42 <ttx> with only the theoretical bugfix backports
21:15:45 <ttx> hmmmkay
21:15:57 <heckj> I think we'll want to update the Grizzly Release page with that detail - I certainly didn't expect that
21:16:11 <jgriffith> +1
21:16:19 <ttx> http://wiki.openstack.org/PTLguide#Special_actions_on_Milestone_delivery_week
21:16:37 * gabrielhurley never saw that page
21:16:59 * jgriffith says "well crap"
21:17:01 <ttx> it's only g1, so I guess we could do the milestone cut slightly later
21:17:15 <heckj> two pending reviews to complete the V3 API - that's all that remains
21:17:25 <ttx> would Thursday EU morning be OK with you ?
21:17:33 <heckj> yep
21:17:41 <gabrielhurley> +1
21:17:42 <ttx> then I can publish the milestone on Friday morning, while it's still Thursday somewhere
21:18:07 <ttx> ok, let's do that.
21:18:25 <ttx> Sorry I thought that was clear (that's how we did all the folsom milestones, no change in that area)
21:19:12 <ttx> heckj: so implement-v3-core-api and rbac-keystone-api should be in by EOD tomorrow ?
21:19:30 <heckj> Yes. In other news, ton of bugs nailed down, including auth_token into a separate repo (keystoneclient)
21:19:42 <ttx> Anything more about Keystone ?
21:19:50 <heckj> that's it from me
21:20:11 <ttx> #topic Swift status
21:20:14 <notmyname> o/
21:20:17 <ttx> notmyname: o/
21:20:26 <ttx> 1.7.5 was released last week...
21:20:41 <ttx> notmyname: Anything planned yt for 1.7.6 ?
21:20:45 <ttx> yet*
21:20:51 <notmyname> dates? no
21:21:12 <vishy> back
21:21:13 <ttx> notmyname: did you get to the bottom of your -announce issues ?
21:21:30 <notmyname> ttx: I sent several messages, all rejected (as expected)
21:21:38 <ttx> for what reason ?
21:21:56 <ttx> it should say "message held for moderation", not "rejected"
21:22:04 <ttx> then I can whitelist you
21:22:31 <ttx> but at this point your emails don't even show up on the moderation panel
21:22:32 <notmyname> You are not allowed to post to this mailing list, and your message has
21:22:32 <notmyname> been automatically rejected.
21:22:54 <ttx> notmyname: hmm, weird. Are you a list member ?
21:23:04 <notmyname> no
21:23:21 <ttx> maybe that would explain the difference with others that we could moderate in
21:23:36 <ttx> notmyname: your call, jhoin the list and repost, or forward me the email contents and i'll post it for you
21:23:51 <notmyname> I'll try again
21:23:59 <ttx> That's all I had. Anything else about Swift before we move to Glance ?
21:24:42 <ttx> #topic Glance status
21:24:45 <ttx> bcwaldon: hi!
21:24:48 <bcwaldon> ttx: hello!
21:25:05 <ttx> #link https://launchpad.net/glance/+milestone/grizzly-1
21:25:14 <bcwaldon> don't act like you're not impressed
21:25:21 <ttx> so *you* are done
21:25:32 <bcwaldon> indeed
21:25:40 <ttx> because *you* knew that Tuesday is always the cut date.
21:25:46 <ttx> just saying
21:25:47 <bcwaldon> right...
21:26:01 <ttx> On the general grizzly plan, did you sort out streaming-server priority?
21:26:06 <bcwaldon> oooh
21:26:08 <bcwaldon> maybe not
21:26:09 <ttx> Maybe set it to Low and keep it as a target of opportunity ?
21:26:25 <bcwaldon> doing it now
21:26:45 <bcwaldon> ttx: ah, I untargeted it already
21:26:46 <bcwaldon> huzzah
21:26:49 <ttx> so I can cut milestone-proposed for Glance tomorrow morning ? and let it live with the occasional backport for a few days ?
21:26:57 <bcwaldon> yes you may
21:27:11 <ttx> bcwaldon: so I should remove the series goal too, so that it doesn't pollute the view
21:27:21 <ttx> done
21:27:23 <bcwaldon> fine with me
21:27:38 <ttx> bcwaldon/others: Anything more on Glance before we switch to Quantum ?
21:27:51 <bcwaldon> ttx: Released python-glanceclient v0.6.0 last night
21:28:00 <bcwaldon> writing up a note for the list today
21:28:09 <ttx> nice. Anything we should know about it ?
21:28:29 <bcwaldon> #link http://docs.openstack.org/developer/python-glanceclient/#id1
21:29:01 <ttx> bcwaldon: anything else ?
21:29:02 <heckj> nice!
21:29:09 <bcwaldon> ttx: that would be it
21:29:29 <ttx> #topic Quantum status
21:29:34 <ttx> danwent: o/
21:29:36 <danwent> o/
21:29:41 <ttx> #link https://launchpad.net/quantum/+milestone/grizzly-1
21:29:46 <danwent> btw, refresh if you didn't in last 30 mins :)
21:29:53 <ttx> oooh
21:29:58 <ttx> I like that
21:30:05 <danwent> we had a couple "just misses" in terms of features
21:30:15 <danwent> but i figured there was no need to try to cram for G-1, so we moved them to G-2
21:30:24 <ttx> there are two ryu blueprints that are targeted to g2 but already completed...
21:30:28 <danwent> there's only one bug that really MUST be in G-1 that is not merged
21:30:39 <ttx> dansmith: shoulds I move them to g1 ?
21:30:44 <ttx> danwent: ^
21:30:53 <danwent> ttx:  sure.. i think those where the one's I was pestering for an update on :)
21:31:00 <danwent> https://bugs.launchpad.net/bugs/1081259
21:31:03 <uvirtbot> Launchpad bug 1081259 in quantum "hasattr check for get_*_counts is invalid " [Critical,In progress]
21:31:20 <danwent> this one is a regression introduced in a previous fix, so we need to get this in.  just needs one more +2, so we should be in good shape
21:31:39 <ttx> moved both ryu things to g1
21:31:50 <danwent> yup, looks good
21:31:53 <ttx> danwent: for bugfixes you have until Thursday anyway
21:32:09 <danwent> ttx: yup, bug given the holidays, i'm trying to clear the deck
21:32:11 <ttx> danwent: so I can cut milestone-proposed tomorrow morning and we can backport that fix ?
21:32:23 <danwent> yeah, if its not merged in by then, we can backport it
21:32:38 <danwent> remember that you'll be contacting salv-orlando for the milestones, as I am connection-less :(
21:33:00 <salv-orlando> yeah no thanksgiving for me...
21:33:10 <ttx> for the other two bugs, if they are not in at the end of today, they will be g2 ?
21:33:18 <danwent> salv-orlando: i've give up my thanksgiving for a wifi connection
21:33:35 <danwent> ttx: yes.  we're just targeting them for g1, as we'd like to backport them sooner rather than later
21:33:45 <danwent> (backport to stable/folsom that is)
21:33:54 <ttx> ok
21:34:01 <danwent> and people are targeting G-1 as a point for releasing 2012.1, I believe
21:34:32 <danwent> (though I just saw a flurry of emails on this, so perhaps that date was moved up?)
21:34:33 <ttx> well, if you want the fix in 2012.2.1 that wil help
21:34:45 <ttx> 2012.2.1 should be next week
21:35:02 <ttx> Anything more on Quantum ?
21:35:20 <danwent> ttx: ok, great.  maybe markmc is just taking care of items that are already in in preparation for the official 2012.1 release next week
21:35:39 <ttx> danwent: yes
21:36:03 <ttx> #topic Cinder status
21:36:07 <ttx> jgriffith: o/
21:36:11 <ttx> #link https://launchpad.net/cinder/+milestone/grizzly-1
21:36:14 <jgriffith> Hello
21:36:25 <ttx> so looks like you could use another day or two :)
21:36:28 <jgriffith> I'm still hopeful for all of them by tomorrow
21:36:35 <jgriffith> ttx: :(
21:37:04 <ttx> jgriffith: let's do it like for Keystone, one more day before I cut the g1 branch
21:37:12 <jgriffith> ttx: Thanks, that would be great
21:37:24 <ttx> jgriffith: and we'll see how far we are tomorrow
21:37:43 <ttx> driver-cleanup: is there anything more to it than the two commits already merged ?
21:38:03 <jgriffith> ttx: yeah... some minor org changes (moving things under a drivers directory)
21:38:11 <ttx> ok
21:38:18 <jgriffith> ttx: If rnirmal can't get to it I'll finish it tonight or tomorrow morning
21:38:29 <ttx> cinder-apiv2: this looks a bit far away... is there a point in trying to get it in g1 ? or defer to g2 ?
21:38:41 <jgriffith> ttx: I need to reword that BP and have it in phases
21:38:47 <ttx> couldn't really find code proposed for it
21:38:55 <jgriffith> ttx: The initial framework piece should be G1, the rest G2 and on
21:39:08 <ttx> jgriffith: sounds good, just explode it in multiple blueprints
21:39:24 <jgriffith> ttx: Yep, there are 5 outstanding reviews for it already
21:39:37 <jgriffith> ttx: I'll clean up the BP this afternoon
21:39:55 <ttx> sounds good. I'll talk to you tomorrow to check progress
21:40:04 <ttx> everyone ready to switch to Nova ?
21:40:08 <jgriffith> ttx: Looking forward to it :)
21:40:18 <jgriffith> tomorrow that is...
21:40:38 <ttx> #topic Nova status
21:40:41 <ttx> vishy: hey
21:40:48 <ttx> #link https://launchpad.net/nova/+milestone/grizzly-1
21:40:50 <vishy> hi
21:41:19 <ttx> so, let's see
21:41:44 <ttx> do you want to play the "i forgot we cut on Tuesday" card to get another day ?
21:42:00 <ttx> or it won't really help ?
21:42:07 <vishy> i don't know that it will help
21:42:07 <vishy> j
21:42:10 <vishy> just looking
21:42:27 <ttx> let's have a look at them
21:42:28 <ttx> xenapi-volume-drivers: looks a bit far away ?
21:42:40 <ttx> server-count-for-nova-flavors: same ?
21:42:49 <ttx> better-libvirt-network-volume-support: looks like it's almost there ?
21:43:05 <vishy> i'm not sure if the volume driver patch is done
21:43:06 <vishy> the
21:43:13 <vishy> last current review got sent in
21:43:32 <ttx> general-bare-metal-provisioning-framework: looks like it's still at least one week away?
21:43:47 <ttx> quota-instance-resource: same ?
21:43:58 <ttx> hyper-v-config-drive-v2: unknown status, not in series goal... should I just un-milestone it ?
21:44:32 <vishy> baremetal is going to be another few days
21:44:47 <ttx> not sure any of those would get in given an extra day
21:44:55 <vishy> quota-instance no code, don't know what happened so i delayed
21:45:02 <vishy> i think the hyper-v config drive is in
21:45:03 <vishy> jus
21:45:11 <vishy> t didn't get linked to the blueprint properly
21:45:12 <vishy> lo
21:45:16 <vishy> ooking for it
21:46:38 <ttx> vishy: I can clarify that off-meeting
21:47:11 <ttx> vishy: should I cut tomorrow morning with what's in ? and defer the rest ? or wait until eod tomorrow ?
21:47:25 <vishy> tomorrow morning should be fine
21:47:45 <ttx> vishy: ok, let me know if I should assume otherwise
21:47:50 <ttx> On the bug side, we have bug 1076109
21:47:50 <uvirtbot> Launchpad bug 1076109 in nova "nova rest /v2/ call returns v1.1 documentation" [Medium,In progress] https://launchpad.net/bugs/1076109
21:48:13 <ttx> is that a milestone-blocking bug ? Or should I defer to g2 if not complete by eod ?
21:48:28 <vishy> ok it is in
21:48:35 <vishy> no not a blocker imo
21:48:40 <ttx> ok thx
21:48:42 <ttx> On the grizzly general plan, I see that your quest for assignees wasn't very successful so far
21:48:49 <ttx> Still planning to send a "take it or it will be H" email about those ?
21:48:55 <ttx> Alternatively you could set them to Low priority to keep them as targets of opportunity
21:49:09 <vishy> ttx: i didn't get a chance to send out the email
21:49:13 <vishy> i will do it today
21:49:14 <ttx> #action vishy to send email about missing blueprint assignees
21:49:32 <vishy> so the only unknown bp is the xenapi volume driver one
21:49:40 <vishy> i don't know if it is complete
21:49:59 <ttx> davidkranz raised a CI issue that seems to point to a Nova problem... any chance you could help him narrow it down ? Or someone else from Nova ?
21:50:28 <vishy> sure
21:50:30 <ttx> will try to contact mate_lakat on that bp status
21:50:33 <davidkranz> https://bugs.launchpad.net/nova/+bug/1079687
21:50:34 <uvirtbot> Launchpad bug 1079687 in nova "Flaky failures of instances to reach BUILD and ACTIVE states" [Undecided,New]
21:50:47 <ttx> because we don't have enough time to investigate it in-meeting
21:51:08 <davidkranz> vishy: We also want to bring stress tests online which is made hard by https://bugs.launchpad.net/nova/+bug/1079210
21:51:15 <uvirtbot> Launchpad bug 1079210 in nova "Successful full gate jobs show ERRORs and stacktraces" [Medium,Confirmed]
21:51:27 <ttx> vishy: so in summary, I'll cut MP tomorrow morning from master, unless you tell me otherwise (IRC or email)
21:51:38 <davidkranz> vishy: We can discuss this offline.
21:51:46 <ttx> vishy/others: anything more on Nova ?
21:52:20 <ttx> #action davidkranz and vishy to look into bug 1079210
21:52:20 <uvirtbot> Launchpad bug 1079210 in nova "Successful full gate jobs show ERRORs and stacktraces" [Medium,Confirmed] https://launchpad.net/bugs/1079210
21:52:49 <ttx> #topic Horizon status
21:52:52 <ttx> gabrielhurley: hi!
21:52:55 <gabrielhurley> hey
21:52:56 <ttx> #link https://launchpad.net/horizon/+milestone/grizzly-1
21:52:58 <gabrielhurley> Blueprints are in the process of merging... I kicked my other core reviewers to go get everything in progress reviewed and hopefully merged (there were 7 that needed a second +2). Most of them will be taken care of shortly. I have three bugs I need to code up today, but the only blocker is the one about the files missing from the tarball. I'll make sure things are ready to go within 24 hours.
21:53:41 <ttx> ok, so I'll wait until EOD tomorrow before cutting MP
21:53:45 <gabrielhurley> thanks
21:54:00 <ttx> note that we can still backport bugfixes between then and "Thursday"
21:54:11 <gabrielhurley> noted, but hopefully not needed
21:54:54 <ttx> we'll talk tomorrow, but is there any bug in that g1 list that is a milestone blocker ?
21:55:02 <gabrielhurley> only the tarball one
21:55:08 <gabrielhurley> and I'll deal with that right now
21:55:09 <ttx> i.e. which I should not just defer to g2 if incomplete by tomorrow eod ?
21:55:12 <ttx> ok
21:55:38 <ttx> Anything more on Horizon ?
21:55:42 <gabrielhurley> one thing
21:55:51 <gabrielhurley> I'll be starting a regular Horizon project IRC meeting like the rest of the projects. Announcement of time will be forthcoming on the ML.
21:56:06 <ttx> cool! more meetings.
21:56:12 <gabrielhurley> iknowright?
21:56:23 <ttx> we should soon need an #openstack-meetings2 room
21:56:26 <gabrielhurley> haha
21:56:33 <ttx> #topic Incubated projects
21:56:38 <ttx> Anyone to talk Ceilometer ?
21:57:12 <eglynn_> nijaba: there?
21:57:14 <ttx> stevebake: still around ?
21:57:19 <stevebake> yep
21:57:25 <ttx> let's do Heat first
21:57:42 <ttx> https://launchpad.net/horizon/+milestone/grizzly-1
21:57:44 <ttx> err
21:57:49 <ttx> Incomplete action item: heat crew to align Launchpad teams with openstack model
21:57:55 <ttx> Let me know if you need help with that, otherwise I'll just postpone that action to next week
21:58:08 <nijaba> ttx o/
21:58:09 <stevebake> Nothing has really changed since last week. We've changed our meeting time and haven't met at the new time yet
21:58:11 <stevebake> https://launchpad.net/heat/+milestone/grizzly-1
21:58:38 <stevebake> ttx: we'll figure out what is outstanding on that and get back to you
21:58:43 <ttx> #action heat crew to align Launchpad teams with openstack model
21:58:48 <ttx> The next step after that would be to move your code repository under openstack/heat
21:58:58 <ttx> you'll have to sync with CI on that
21:59:14 <asalkeld> k, who do we need to chat to?
21:59:17 <stevebake> yep, we can coordinate for the gerrit downtime
21:59:25 <ttx> asalkeld: jeblair
21:59:31 <asalkeld> thanks
21:59:36 <ttx> ok, one minute for ceilometer now :)
21:59:41 <ttx> Incomplete action item: ceilometer crew to pimp up their grizzly roadmap
21:59:44 <eglynn_> #link https://launchpad.net/ceilometer/+milestone/grizzly-2
21:59:57 <ttx> interesting.
22:00:09 <nijaba> I just finished pimping that up
22:00:13 <ttx> haha
22:00:19 <eglynn_> nijaba has done a good job of getting us with the blueprint program ;)
22:00:20 <ttx> The ceilometer-tarball job looks sane now. You said you would skip g1 milestone ?
22:00:28 <nijaba> yes
22:00:31 <ttx> OK, then I should bump your next milestone to g2 soon
22:00:36 <nijaba> we will join at g2
22:00:41 <ttx> #action ttx to bump ceilometer next milestone to g2
22:01:02 <ttx> I'll review your grizzly roadmap and discuss it at next meeting
22:01:10 <ttx> we need to clear the room now
22:01:21 <ttx> nijaba, stevebake: any question ?
22:01:30 <nijaba> thanks ttx, none here
22:01:32 <ttx> just hit me on IRC any time
22:01:38 <ttx> #endmeeting