21:00:13 <leong> #startmeeting product_working_group
21:00:14 <openstack> Meeting started Mon Jun 12 21:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:17 <openstack> The meeting name has been set to 'product_working_group'
21:00:21 <leong> #chair shamail leong
21:00:22 <openstack> Warning: Nick not in channel: shamail
21:00:23 <openstack> Current chairs: leong shamail
21:00:35 <leong> #topic Rollcall
21:00:37 <shamail> hi everyone.
21:00:50 <leong> say hi if you are here for Product WG meeting L)
21:00:53 <leong> 0/
21:01:57 <shamail> hmm
21:02:00 <shamail> just us? ;]
21:02:05 * leong waiting....
21:04:12 <Arkady_Kanevsky> hello PWG
21:04:26 <leong> hi Arkady
21:04:32 <rockyg> o/
21:04:45 * leong waiting for more folks to join in...
21:05:06 <annabelleB> hello!
21:05:16 <shamail> hi annabelleB!
21:05:23 <shamail> hi rockyg!
21:05:23 <Arkady_Kanevsky> hello all
21:05:24 <leong> hi annabelle
21:05:29 <shamail> Welcome back ArchiFleKs
21:05:33 <shamail> Welcome back Arkady_Kanevsky
21:05:40 <Arkady_Kanevsky> LoL
21:05:50 <leong> ArchiFleKs???
21:05:52 <leong> haha
21:05:56 <shamail> Ar{tab} :)
21:06:10 <leong> lol
21:06:11 <Arkady_Kanevsky> Argh
21:06:15 <rockyg> Hey all!
21:06:38 <leong> shamail: are we good to start? or want to wait for a few more moment?
21:06:56 <shamail> Let’s proceed, we have 5 of us
21:07:02 <AndyU> Hi All  o/
21:07:31 <Arkady_Kanevsky> status on AI for Andy and me - still in progress. Nothing to report yet
21:07:49 <Arkady_Kanevsky> That is on wiki page improvements
21:08:33 <AndyU> @Arkady - want to have a web meeting together and plan the what, who, etc?
21:08:54 <Arkady_Kanevsky> AndyU - yes.
21:08:55 <leong> ok.. the agenda can be found here
21:08:58 <leong> #link agenda: https://wiki.openstack.org/wiki/Meetings/product-team
21:09:08 <Arkady_Kanevsky> Lets two of us teake of offline
21:09:21 <leong> #topic Review of action items
21:09:24 <AndyU> @Arkady - ok, I'll pm you and we can figure out a time
21:09:46 <leong> #info AR1: Arkady_Kanevsky and AndyU to work on updating/simplifying PWG wiki
21:10:09 <Arkady_Kanevsky> thanks Andy.
21:10:46 <leong> #action Arkady_Kanevsky and AndyU to schedule a web meeting for AR1
21:10:59 <leong> #info AR2: mrhillsman and AndyU to work on standalone wiki page for video, moderator template, ops meetups moderator guide, FAQs
21:11:03 <leong> any updates on the AR2?
21:11:25 <AndyU> I have no update on AR2 as yet
21:12:19 <mrhillsman> sec
21:12:46 <mrhillsman> https://wiki.openstack.org/wiki/Moderator_Guide
21:13:05 <mrhillsman> after last meeting i pulled some stuff from a number of places to that
21:13:59 <leong> thanks mrhillsman
21:14:12 <leong> looks good to me on the first glance :)
21:14:19 <rockyg> Cool. But I'm wondering whether it's worth thinking about once pulling all the stuff together, we remove the other sites so there is one definitve site for all to read and improve?
21:14:31 <Arkady_Kanevsky> looks like moderator template copy has some extras
21:14:35 <rockyg> Would need a discusstion with the other page maintianers, but might be worth it.
21:14:36 <leong> #link Moderator Guilde: https://wiki.openstack.org/wiki/Moderator_Guide
21:14:52 <AndyU> Thanks mrhillsman. I can put the etherpad templates in there.
21:15:04 <mrhillsman> ok cool, you're welcome
21:15:15 <Arkady_Kanevsky> mrhillsman, should we review the page and sent you and ANdyU feedback?
21:15:18 <mrhillsman> very rough right now
21:15:23 <mrhillsman> definitely
21:15:47 <Arkady_Kanevsky> OK. I will take that AI. Probable the same for all.
21:15:49 <rockyg> Really good to get all this stuff collected and visible.
21:16:11 <rockyg> Arkady_Kanevsky, ++
21:16:33 <leong> #action all to review Moderator Guide and provide feedback to mrhillsman and AndyU
21:16:47 <leong> #info AR3: all to review existing+wip proposals and decide which one is ready to move forward with wider participation from PTL/core
21:16:55 <leong> anyone got a cchance to look at AR3?
21:17:34 <Arkady_Kanevsky> partially. I looked at mine and they are not ready till gap analysis is merged
21:17:38 <Arkady_Kanevsky> Had not reviewed others
21:18:17 <shamail> I haven’t reviewed them yet either
21:18:41 <Arkady_Kanevsky> suggest adding a pointer to proposals to agenda
21:18:56 <Arkady_Kanevsky> https://github.com/openstack/development-proposals/tree/master/development-proposals/proposed
21:19:19 <Arkady_Kanevsky> I can add it if everybody is OK with it
21:19:34 <AndyU> LCOO will be picking up the 'Cloud Native' proposal and giving it a tune up to give it a more specific focus around the needed enablers for containerized deployments/upgrades of openstack
21:20:11 <Arkady_Kanevsky> AndyU, do not see it in the folder
21:20:43 <leong> for information, development proposals needs to have a good level of details in order to move into gap-analysis/bp/spec
21:20:46 <Arkady_Kanevsky> unless it is categorized-configs.rst
21:20:54 <leong> Arkady_Kanevsky: that is still in gerrit review
21:21:11 <Arkady_Kanevsky> OK. I will review it this week
21:21:15 <AndyU> Hmmm... still WIP I think; which is good.
21:21:43 <leong> i shall keep this AR again for next week..
21:21:55 <Arkady_Kanevsky> leong Thanks
21:22:00 <leong> #action all to review existing+wip proposals and decide which one is ready to move forward with wider participation from PTL/core
21:22:06 <AndyU> We were going to archive "security-policy-enforcement.rst" earlier but I asked to keep it alive. Long story short, that one can be archived again.
21:22:14 <Arkady_Kanevsky> lest add the link to AR
21:23:08 <leong> #link Existing Proposal: https://github.com/openstack/development-proposals/tree/master/development-proposals/proposed
21:23:23 <leong> #link Proposal in review: https://review.openstack.org/#/q/project:openstack/development-proposals+status:open
21:23:50 <leong> #info AndyU proposing archive "security-policy-enforcement.rst"
21:23:51 <AndyU> @Arkady - this is the 'cloud native' one I was thinking of earlier: https://review.openstack.org/#/c/444611/
21:23:59 <leong> #link Security Policy Enforcement: https://github.com/openstack/development-proposals/blob/master/development-proposals/proposed/security-policy-enforcement.rst
21:24:45 <Arkady_Kanevsky> I see it ANdyU. I reviewed it and posted 10 comments a while back. Looking for updated proposal
21:25:28 <AndyU> If a Dev Proposal (WIP) is going to be substantially re-written, would it be best to just abandon the original and start a new one??
21:25:57 <Arkady_Kanevsky> your call. I am good either way
21:25:59 <AndyU> Arkady. Yes. It's going to get a substantial overhaul.
21:26:09 <leong> AndyU: if substantially, i'm fine to just abandon and create a new one, but please indicate that in references
21:26:13 <Arkady_Kanevsky> then I suggest go with new submission
21:26:25 <rockyg> agree with everyone
21:26:28 <leong> :)
21:26:31 <AndyU> Ok. We'll see. Might be easier to just start fresh.
21:26:50 <AndyU> @Leong - got it.
21:27:00 <leong> AndyU: are you still working on the "containerizing control plane"?
21:28:44 <AndyU> I think that's going to go away in lieu of just contributing use cases as needed to the specific projects working on that (like OpenStack-Helm, kolla)
21:29:09 <leong> ok.. can you update the status on gerrit?
21:29:13 <leong> thanks AndyU
21:29:31 <leong> anything else in relation to this topic
21:29:54 * leong calling 3... 2... 1...
21:30:13 <leong> next agenda :)
21:30:16 <leong> #topic Action Plan
21:30:26 <AndyU> But we expect to have 4 Dev Proposals that will have real commitment/resources behind them:  (1)Extreme Testing (already underway), (2)Logging (we'll be reaching out soon Rocky - still getting things together on my end)
21:30:32 <leong> i am keeping this two action plans in Agenda..
21:30:40 <leong> #info Value 1: Properly documenting ideas, getting a structured workflow, and integration into development workflow
21:30:49 <leong> #info Value 2: Periodic coordination/collaboration across WGs/Product Managers
21:31:30 <leong> few of the AR above are working towards value 1 and value 2
21:31:30 <rockyg> AndyU, I'm tracking the stuff happening on the dev side.  It's moving along.  But some hiccups.
21:31:44 <AndyU> (3) Containerized OpenStack upgrade/migration enablers (actual name TBD) and (4) Role Based Access Control (focused on use cases to meet operator needs)
21:31:55 <Arkady_Kanevsky> I think we still have rolling_upgrades and instance_HA going from before
21:32:12 <Arkady_Kanevsky> Leong, are you owning rolling_upgardes now?
21:32:18 <leong> Arkady_Kanevsky: nope
21:32:19 <leong> :)
21:33:22 <leong> i don't think we have a replacement since after kenny left?
21:33:38 <leong> anyone want to take up ?
21:33:43 <Arkady_Kanevsky> Carol and Kenny where owning it before
21:33:58 <leong> primarily Kenny
21:34:53 <AndyU> @Rocky, we've good some good people committed to working on logging from AT&T; we're getting them oriented. We will want to get logging wg, other lcoo contrib's, etc., together (maybe in ~2or3 weeks?) to kick start. I'd like to connect with you (and ?) to strategize over how we should focus efforts.
21:35:06 <rockyg> I'm following bits on the dev ML, but...
21:35:09 <leong> as far as i know, most dev work for rolling upgrade for "core" is near complete except neutron
21:35:16 <Arkady_Kanevsky> HA VM was driven by Adam and Pete Chadwick
21:35:44 <rockyg> AndyU, sounds good.  Sounds like a phone call minimum, though
21:35:49 <Arkady_Kanevsky> so I think we are good on HA VM
21:36:32 <Arkady_Kanevsky> I think there is still work going on rolling upgrades in Ironic. Not sure about other non-core projects
21:36:41 <AndyU> @rockyg - yes. I'll send you an email and we can arrange something.
21:36:49 <rockyg> One issue on rolling upgrade with regards to Keystone is the way they do the DB upgrades is trigger based, which messes up Postgres installations
21:37:24 <Arkady_Kanevsky> I thouhg that postgres was dropped from support list???
21:37:40 <rockyg> But, it works.
21:38:08 <Arkady_Kanevsky> you can not upgarde to something that is no longer supported upstream.
21:38:26 <Arkady_Kanevsky> In any case my point is that we do need owner for rolling upgrades
21:38:38 <Arkady_Kanevsky> it is not done yet
21:38:39 <leong> #info Owner needed for rolling upgrade
21:39:30 <leong> let's move on to next agenda...
21:39:41 <AndyU> Regarding: "#info Value 2: Periodic coordination/collaboration across WGs/Product Managers" - I was given a contact with Red Hat and another with Mirantis that we can reach out to about this.
21:39:52 <leong> cool.. that's great to hear AndyU
21:40:11 <leong> just keep that on our agenda we can update as needed
21:40:25 <leong> #info
21:40:45 <leong> #info AndyU was given contact with Red Hat and Mirantis for collaboration with Product Manager
21:40:57 <leong> #topic PTG
21:41:04 <leong> a quick question from PTG
21:41:07 <AndyU> Should the PWG perhaps schedule a web meeting to plan/discuss that (Periodic coordination/collaboration across WGs/Product Managers)?
21:41:10 <leong> do we plan to having a session at PTG?
21:41:22 <shamail> I might be there
21:41:28 <shamail> not sure yet*
21:41:29 <leong> i don't think i will be there
21:41:36 <Arkady_Kanevsky> I plan to attend Denver one
21:41:59 <leong> do we have enough quorum to organize a meeting at PTG?
21:42:11 <leong> very high chances that I won't be there
21:42:12 <Arkady_Kanevsky> We are on agenda for it.
21:42:17 <AndyU> Is there an opportunity to educate about the Dev proposal process, and other PWG value points?
21:42:23 <Arkady_Kanevsky> That is why added it to today's agenda
21:42:53 <Arkady_Kanevsky> should we organize an etherpad to start planning and see who is coming
21:43:01 <rockyg> hmm.  Right now looking unlikely for me.
21:43:29 <Arkady_Kanevsky> UC is meeting
21:43:39 <leong> Arkady_Kanevsky: i think an email will do to ask if anyone from PWG is going...
21:43:41 <AndyU> It's a possibility for me... depends on if there is reason enough to go.
21:43:44 <Arkady_Kanevsky> https://docs.google.com/spreadsheets/d/1xmOdT6uZ5XqViActr5sBOaz_mEgjKSCY7NEWcAEcT-A/edit#gid=397241312
21:43:51 <Arkady_Kanevsky> leong: OK
21:44:07 <leong> btw, i believe PTG is for each WG/Project to organize work, so is more like a "WG discussion meeting"
21:44:22 <leong> like what we did at Milan operator meetup
21:44:56 <leong> #action leong to email if anyone from PWG is attending PTG and if a WG meeting is needed
21:45:08 <leong> #topic Midcycle
21:45:14 <leong> next one is midcycle :)
21:45:39 <leong> do we want to organize midcycle meetup, collacated with ops midcycle ? i think is at Mexico?
21:46:43 <AndyU> Yes, I'd like to have mid-cycle info sooner rather than later
21:47:00 <Arkady_Kanevsky> me too. If we have that I will skip PTG
21:47:11 <AndyU> Ops Meetup is in Mexico City right?
21:47:33 <rockyg> Right.  PWG usually syncs with ops.  But that was before PTG
21:48:01 <Arkady_Kanevsky> so UC meets both at Ops summit and PTG?
21:48:10 <Arkady_Kanevsky> feels like too much.
21:48:12 <rockyg> But, PTG could get more of our asks focused on.  We could sell BPs/Specs to the various teams that we need to.
21:48:32 <rockyg> Only has met at the Ops midcycle, or separately.
21:48:38 <rockyg> Not PTG yet.
21:48:51 <rockyg> Interop coincides with the PTG
21:48:58 <Arkady_Kanevsky> agree with rockyg
21:49:12 <shamail> PWG still makes sense to sync with Ops… UC is generally at Ops and not PTG
21:49:27 <rockyg> shamail, ++
21:49:33 <shamail> This time, however, UC will be at PTG due to a joint Board/TC/UC meeting.
21:49:34 <leong> shamail: +1
21:49:59 <rockyg> I don't think we are at a point to shop around Specs or gap fillers to devs yet.  When we are, getting on PTG schedule would be good.
21:50:11 <AndyU> If we colocate midcycle with PTG would we meet before the PTG? Or during?
21:50:14 <leong> we have a very tight travel constraint this year.. don't think i can be at either PTG or Ops Mexico
21:50:18 <shamail> rockyg: +1, although the Forum could be a strong point of intersection as well
21:50:43 <shamail> Forum = requirements gathering, PTG = Release planning
21:51:00 <leong> does the team here want to organize the PWG ops midcycle?
21:51:13 <Arkady_Kanevsky> ops summit is also requirements gathering
21:51:22 <shamail> I won’t be able to make it to the Ops Midcycle in Mexico either
21:51:35 <Arkady_Kanevsky> I am for mid cycle.
21:51:49 <Arkady_Kanevsky> The questoin to me is better to do it with PTG or ops meeting?
21:52:12 <leong> ok..i will send an email and ask... if we have quorum, we can plan to organize one
21:52:14 <Arkady_Kanevsky> should we conduct doodle ask on it?
21:52:33 <AndyU> FWIW, it will be easier for me to get travel to Denver approved than to Mexico.
21:52:46 <leong> #action Leong to ask PWG if need to organize midcycle, colocated with Ops Midcycle at Mexico
21:52:47 <Arkady_Kanevsky> me too.
21:53:06 <leong> alright, move on..:)
21:53:11 <leong> #topic Post-forum report
21:53:44 <leong> i have a patch need to fix a few minor issue on ##hashtag result
21:53:52 <leong> #link hashtag review: https://review.openstack.org/#/c/469267/
21:54:05 <Arkady_Kanevsky> Leong I will review it tonight
21:54:12 <leong> anyone got a chance to review the ##result
21:54:24 <leong> #link Hashtag Result: https://github.com/openstack/development-proposals/tree/master/forum/201705-bos
21:55:03 <shamail> I have not reviewed them yet, who all volunteered to help with this? Could we maybe divide the files?
21:55:10 <leong> looks like this etherpad is still quite empty :)
21:55:23 <leong> #link Data mining for forum etherpad: https://etherpad.openstack.org/p/PWG-forum-analysis
21:55:37 <rockyg> I looked at some of it back when you first posted.  It looks like it could be interesting.  It would also be useful if we could get the people summarizing the sessions to add hashtags as they review them.
21:56:02 <Arkady_Kanevsky> agree.
21:56:04 <Arkady_Kanevsky> 5 min left
21:56:24 <leong> #action All please look at the hashtag results and sign up for the data-mining
21:56:45 <leong> #topic Open
21:56:47 <leong> any open?
21:58:19 <leong> anything else?
21:58:21 <AndyU> I have one. At the March mid-cycle we discussed having web meetings / conference calls along with IRC. I still think that would be valuable.
21:58:54 <Arkady_Kanevsky> if everybody can use skype I can host it.
21:59:15 <leong> AndyU: i think we tried to make a vote few months back but was postponed
21:59:19 <rockyg> I think I can once I'm on our guest network.
21:59:25 <Arkady_Kanevsky> AndyU, I can try with with you to see if it works and then propose for full team
21:59:40 <AndyU> @Arkady - that works for me. And their is a free Skype for Business client available to download for any who might need one.
21:59:51 <leong> the matter is not on the tools...
21:59:58 <AndyU> Arkady  sounds good.
22:00:01 <leong> is more on the format :)
22:00:10 <AndyU> agree :)
22:00:24 <leong> i think we hit the hour... let's keep that in next meeting agenda
22:00:29 <leong> thank you folks!
22:00:33 <leong> #endmeeting