21:00:01 <shamail> #startmeeting product_working_group
21:00:04 <openstack> Meeting started Mon Jan 16 21:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:00:08 <openstack> The meeting name has been set to 'product_working_group'
21:00:11 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:00:18 <shamail> Hi everyone, who’s here for the PWG meeting?
21:00:24 <pchadwick> o/
21:00:26 <shamail> Agenda is in the link I posted
21:00:33 <MeganR> o/
21:00:38 <shamail> Carol and Leong are off today
21:00:48 <Arkady_Kanevsky> hello
21:00:51 <shamail> Hi pchadwick, MeganR, and Arkady_Kanevsky
21:01:11 <leong> o/
21:01:15 <shamail> wow, leong showing up on his day off
21:01:19 <shamail> hi!
21:01:20 <leong> :)
21:01:32 <leong> just this hour.. :-)
21:01:38 <Arkady_Kanevsky> he just want to make sure he is given any AR
21:01:42 <shamail> let’s give it a couple of minutes to see if we get quorum
21:02:14 <Arkady_Kanevsky> shamail, if oyu can review my 2 patched for persona I will be grateful.
21:02:21 <Arkady_Kanevsky> I think they are ready for merge now
21:02:42 <shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
21:02:49 <shamail> Agenda for today since I posted the link way to quick initially
21:02:50 <rlpple> o/
21:02:51 <Arkady_Kanevsky> ditto for other reviewers
21:02:54 <shamail> will do Arkady_Kanevsky
21:03:05 <shamail> Looking at the topics, do we have enough people to discuss?
21:03:20 <leong> who else here?
21:03:22 <shamail> Attendee list: pchadwick, MeganR, Arkady_Kanevsky, leong, shamail
21:03:29 <heidijoy> Hello all!
21:03:35 <rlpple> Hello all!
21:03:36 <shamail> and heidijoy  :)
21:03:36 <Arkady_Kanevsky> we have tracking of stories. I saw one submission and tenplate one
21:03:37 <shamail> hi
21:03:39 <shamail> hi rlpple
21:03:41 <shamail> awesome.
21:03:43 <Arkady_Kanevsky> I am astill behind on it
21:03:53 <shamail> Let’s proceed then (we have a decent showing)
21:04:05 <shamail> #topic User Story Tracker Discussion
21:04:18 <pchadwick> I need to turn myself in as I was not able to work on the user stories (either users or tracker) and am not sure when I will be able to do so.
21:04:38 <shamail> lol pchadwick, it’s okay. :)
21:04:48 <shamail> Email me and maybe I can help you with the tracker
21:04:55 <Arkady_Kanevsky> I had commented on template.
21:04:56 <pchadwick> Many balls in the air right now.
21:05:09 <shamail> We are working towards having actual trackers built out for our user stories that have finished gaps analysis
21:05:11 <shamail> #link https://review.openstack.org/#/c/419674/
21:05:22 <Arkady_Kanevsky> I think we need to agree how we will track blueprints and specs.
21:05:31 <shamail> I have updated the tracker template to reflect the changes that the FeatureTracker development team had to make for the UI
21:05:38 <shamail> #link http://featuretracker.openstack.org/
21:05:55 <Arkady_Kanevsky> currently we include pointer for one but not another/
21:06:04 <shamail> Arkady_Kanevsky: We should have pointers for both
21:06:09 <shamail> Some projects don’t use both though
21:06:33 <Arkady_Kanevsky> if we use spec or if we use blueprint then nwe need a pointer for it for tracking.
21:06:43 <shamail> for example, if you look at line 25-30 in the review I posted
21:06:53 <shamail> It shows that for the project, we are asking for blueprints and specs
21:07:02 <Arkady_Kanevsky> do not suggest we create both for the same things per project
21:07:26 <mrhillsman> o/
21:07:30 <shamail> We won’t, the tracker format can accomodate either but we will most likely reference one of them only per “task"
21:07:31 <shamail> hi mrhillsman
21:07:47 <Arkady_Kanevsky> for spec we include pointer to it in tracking in template.
21:07:57 <shamail> It would be helpful if everyone can review the updated tracker format
21:08:04 <Arkady_Kanevsky> But for blueprint we do not include pointer, only name
21:08:29 <GeraldK> o/
21:08:39 <shamail> Yes, correct Arkady_Kanevsky.  That is because the bp path is known (always the same for projects) whereas the spec structure is unique so we need the full URI
21:08:43 <shamail> Hi GeraldK
21:09:36 <Arkady_Kanevsky> shamail, how from the page generate by tracking one gets ot blueprint?
21:09:51 <shamail> The tool adds “https://blueprints.launchpad.net/<project>/+spec” for blueprints
21:10:05 <shamail> You click on the link
21:10:09 <Arkady_Kanevsky> we have a name of blieprint, so one can go to a project name and search for name of blueprint
21:10:13 <shamail> This is a good seque to a question
21:10:40 <shamail> Does everyone think we should schedule a session to give an overview of the tracker file format, demo the FeatureTracker tool, and general Q&A on those topics?
21:10:51 <mrhillsman> +1
21:10:52 <Arkady_Kanevsky> I am game
21:10:54 <leong> +1
21:10:56 <pchadwick> +1
21:10:59 <GeraldK> +1
21:11:19 <shamail> Okay, I can arrange a doodle… how’s everyone’s availability?  Should I send dates/times for later this week or next week?
21:11:20 <Arkady_Kanevsky> i was epxecting htat we are doing it here
21:11:34 <shamail> Arkady_Kanevsky: It will be much easier via Zoom :)
21:11:42 <pchadwick> Either is fine for me.
21:11:45 <Arkady_Kanevsky> agree
21:11:47 <mrhillsman> same
21:12:12 <shamail> cool, how about MeganR, leong, heidijoy, GeraldK?
21:12:24 <leong> either way is fie
21:12:25 <MeganR> it will just depend on my schedule, but would like this week
21:12:25 <leong> fine
21:12:27 <GeraldK> just propose few dates on doodle
21:12:38 <shamail> Thanks
21:12:39 <MeganR> GeraldK +1
21:12:43 <heidijoy> +1
21:12:44 <shamail> I’ll do two dates this week and two next
21:12:48 <GeraldK> +1
21:13:06 <shamail> #action shamail to send out doodle poll for Tracker/FeatureTracker overview including dates for this week and next
21:13:20 <Arkady_Kanevsky> shamail, I specifically want to cover what the trackser should look like before gap analysis and aftre
21:13:27 <leong> i will probably help to do once for 'Regional Meeting'
21:13:40 <Arkady_Kanevsky> + leong
21:13:45 <Arkady_Kanevsky> +1 leong
21:13:50 <shamail> Sure thing Arkady_Kanevsky
21:13:56 <shamail> Thanks leong
21:14:09 <shamail> Okay moving on
21:14:18 <shamail> #topic PWG at Forum Event
21:14:40 <shamail> Carol and I had a conversation with Tom last week to discuss how the PWG could participate in Forum
21:15:06 <shamail> one of the options that we brainstormed was to help moderate some of the sessions that are cross-project/user need centric or strategic
21:15:29 <shamail> There seem to be three types of sessions that will be in the Forum: project specific, cross-project, and strategic
21:15:40 <shamail> Examples:
21:15:43 <Arkady_Kanevsky> I thought that we are missing Atlanta meeting.
21:15:55 <Arkady_Kanevsky> as a group
21:15:58 <shamail> project specific: nova team requesting feedback on recent changes and needed capabilities
21:16:03 <shamail> Arkady_Kanevsky: Forum will be in Boston
21:16:22 <leong> Arkady_Kanevsky: Forum, not PTG
21:16:29 <Arkady_Kanevsky> OK. termonology issue on my end. I still call it summit
21:16:31 <shamail> cross-project: sessions including both operators and developers on specific cross project specs or topics (e.g. scalability in OpenStack)
21:17:04 <leong> would "user stories" be discussed in the Forum?
21:17:18 <shamail> strategic: community level discussions on topics such as “what are the core needs OpenStack should deliver?”, “what are your expections of the TC, UC, etc?"
21:17:32 <shamail> leong: yes, but they would probably fall under the “cross project” track
21:17:49 <Arkady_Kanevsky> Is this part of PWG driving cross functional requirements?
21:18:03 <shamail> We discussed the possibility of PWG members helping moderate sessions or helping to build a standard moderation template to ensure we get uniform feedback
21:18:20 <Arkady_Kanevsky> That technical group asked?
21:18:26 <shamail> And if we have people that are subject-experts in a certain market or user need they could facilitate those sessions
21:18:43 <Arkady_Kanevsky> +1 shamail
21:18:54 <Arkady_Kanevsky> will be happy to help and moderate
21:18:57 <shamail> Arkady_Kanevsky: no, this aligns better with PWG helping to aggregate user needs and facilitate actionable outcomes from Forum
21:19:03 <pchadwick> How do we define "markets"
21:19:14 <shamail> verrrrry loosely
21:19:17 <pchadwick> Or more importantly prioritize them?
21:19:36 <shamail> I am using the term in broadly such as telco, enterprise, financials, healthcare, SMB, etc
21:19:58 <pchadwick> Could also be geo specific
21:20:04 <shamail> pchadwick: +1
21:20:24 <shamail> We wouldn’t necessarily prioritize them as the committee selecting the Forum sessions would make the schedule
21:20:40 <pchadwick> OK
21:20:46 <shamail> We could however influence by proposing sessions based on markets/geos represented on this team
21:21:21 <shamail> The key goal from the Forum is to have both users and developers participate and have good representation
21:21:25 <Arkady_Kanevsky> how do we snure that we generate a single requirement list of technical committee and now a reqs list per market?
21:21:42 <shamail> Would others on the team be willing to help moderate sessions or be more involved with Forum planning if the opportunity arises?
21:21:51 <Arkady_Kanevsky> PTG strength to prioritize across them and choose user story to drive it
21:22:04 <Arkady_Kanevsky> yes from me
21:22:12 <shamail> Thanks Arkady_Kanevsky
21:22:33 <shamail> I think we will have some additional work on determining the ideal outputs
21:23:01 <Arkady_Kanevsky> right. I want to make sure we define the goals and then dfeine a plan to get there.
21:23:11 <shamail> Are others up for this too?  We don’t want sign-up our team unless we have folks to help :)
21:23:16 <MeganR> yes, I would be avail. to help moderate the sessions, really interested in a template for outcomes
21:23:29 <pchadwick> Tentative for me.
21:23:36 <shamail> Thank you
21:23:37 <leong> i can help to moderate as well..
21:23:49 <shamail> Moving to the next topic
21:23:51 <shamail> #topic Gap Analysis - Template and Location in Repo
21:24:10 <shamail> GeraldK and leong do you want to lead this topic, I added it based on the email thread last week
21:24:13 <Arkady_Kanevsky> can ypou post a pointer to template?
21:24:33 <shamail> There is none currently
21:24:35 <shamail> ;)
21:24:45 <Arkady_Kanevsky> understand.
21:24:46 <GeraldK> there is the draft I had shared via email
21:24:54 <Arkady_Kanevsky> I owe gerald respond on it
21:24:55 <shamail> #link https://etherpad.opnfv.org/p/promise_gap_analysis
21:25:21 <GeraldK> this is the gap analysis for the capacity mgmt user story
21:25:54 <GeraldK> can someone put the link to the template pls. i am not in front of my work pc
21:26:08 <leong> and this is for bare metal user story.
21:26:08 <leong> https://etherpad.openstack.org/p/bare_metal_service_gap_and_overlap_analysis
21:26:09 <shamail> Is that not the template GeraldK (the link I posted)?
21:26:45 <leong> suggestion is to create a common gap-analysis template and keep it in the repo
21:27:02 <shamail> leong and GeraldK +1
21:27:03 <GeraldK> shamail: no, the two links are the actual gap analysis documents
21:27:12 <GeraldK> let me get the link...
21:27:31 <leong> i believe geraldk drafted one:
21:27:32 <leong> https://etherpad.openstack.org/p/template_gap_and_overlap_analysis
21:27:49 <leong> #link draft-gap-analysis-template - https://etherpad.openstack.org/p/template_gap_and_overlap_analysis
21:27:53 <shamail> Thanks leong
21:27:57 <GeraldK> thanks leong
21:28:18 <GeraldK> i have compiled this template based on the two gap analysis documents
21:28:29 <leong> the template looks ok in general...but we can remove the "priority" section as that will be included in the user-story-template
21:28:33 <GeraldK> wanted to discuss via etherpad first, then we can create the rst file for the repo
21:28:54 <shamail> Is this template for gaps analysis or is it covering both gaps analysis and implementation plan?
21:29:07 <GeraldK> so far only gap analysis.
21:29:09 <shamail> I see the section for patches which is usually the next step
21:29:16 <leong> can everyone take a look at the template and made suggestion by end of this friday?
21:29:26 <shamail> I see your comment now GeraldK (“Gerald: I would suggest to remove this section as this will be captured in the user story tracker”)
21:29:27 <GeraldK> according to the work flow, we first have to discuss the gaps with the projects then derive the implementation plan
21:29:36 <shamail> leong: +1
21:29:41 <shamail> GeraldK: +1
21:29:43 <GeraldK> so, i believe we should keep it separate
21:29:48 <shamail> I agree as well
21:29:54 <Arkady_Kanevsky> agree. implenentatoin is after we accept gap analysis
21:30:05 <leong> after friday, can geraldk summit a patch to include that template into the git repo?
21:30:17 <shamail> Implementation is what drives the population of the tracker with actual artifacts
21:30:25 <GeraldK> the "1. gap on the problem definition" is there for bare metal but was difficult to do for capacity mgmt
21:30:57 <GeraldK> do we need this section?
21:31:46 <GeraldK> on the ID in "2. gaps on user stories": should we update the user story template to ask for IDs for each user story?
21:32:20 <leong> isn't every story has a "problem definition"?
21:32:39 <pchadwick> GeraldK: +1
21:32:47 <shamail> Good point, I think that would make sense
21:32:50 <Arkady_Kanevsky> somehere we need to define each projects impacted and if sime reqs canont be mapped to any project(s) that become a candidate for new project
21:32:51 <leong> geraldk, i think all user story needs to be updated to includes "IDs"
21:32:58 <GeraldK> leong: yes. baremetal had a bullet list so it was easy to derive the gaps. in capacity mgmt we have running text so it is more difficult
21:33:40 <GeraldK> okay. so I will take your comments in the etherpad by Friday EOB and create a rst file
21:34:21 <Arkady_Kanevsky> prefer pull request route. Easier to see comments from all and progress
21:34:32 <Arkady_Kanevsky> thanks GrealdK
21:34:37 <leong> i think either bullet list or paragraph on the user-story-template is fine.. the gap-analysis is to identify the list of gaps out from the "problem statement"
21:34:51 <GeraldK> arkady: can you explain: pull request route?
21:34:55 <leong> if both can relates 1-1, that is best. if not, i think it is also fine.
21:36:21 <Arkady_Kanevsky> sumit pull request with draft of template. I can always find pull request in review but mus know exact etherpad
21:37:06 <GeraldK> arkady_kanevsky: okay.
21:37:17 <leong> if someone can't derive a gap from the user story problem statement, would that means the "problem statement" is not adequate??
21:37:41 <shamail> I think this is a good discussion
21:38:10 <shamail> Let’s go with leong’s suggestion of providing feedback by this Friday and move towards a patch next week (RST format)
21:38:24 <Arkady_Kanevsky> +1
21:38:42 <leong> "problems statement" will leads to "gap", doesn't matter if the statement is written in paragraph or bullet list...
21:38:44 <leong> +1 shamail
21:38:57 <shamail> #action Please review gaps analysis template (https://etherpad.openstack.org/p/template_gap_and_overlap_analysis) and provide feedback by Friday 1/20
21:39:06 <shamail> moving on for now
21:39:16 <shamail> #topic Roadmap update/request
21:39:22 <shamail> heidijoy: do you want to cover this topic?
21:39:29 <GeraldK> leong: it might also lead to duplication as the gaps in the problem statement and the user stories will overlap
21:39:51 <heidijoy> Yes please!
21:39:56 <GeraldK> shamail: can we also have a look at the capacity mgmt user story first?
21:40:03 <heidijoy> We have a potential solution for the problem of trying to corral PTLs and produce videos that preview the next release’s major features (e.g. Mitaka Design Series videos). We have 32, 40-minute slots available to host the PTLs to each do a project update talk at the Boston Summit.  The PWG could select which 32 projects to feature, and could propose a format for the PTLs’ slides to answer key questions (such as fo
21:40:28 <shamail> GeraldK: I’ll come back to it, sorry had already changed topics
21:40:36 <GeraldK> shamail: okay
21:41:24 <Arkady_Kanevsky> heidi do oyu have a list of 32 projects?
21:41:26 <shamail> heidijoy: your message got cut off
21:41:36 <pchadwick> Are the project update talks done in front of a live audience or is it in a studio?
21:41:45 <shamail> Arkady_Kanevsky: She would like for us to help select them
21:42:05 <heidijoy> Ideally the PTLs would present for 20 min and answer questions for 20 minutes. The resulting videos would be posted to the Project Navigator, YouTube & elsewhere. 
Would the PWG would like to steer this effort? (Heidi Joy will team captain the organization side - looking for your strategic input, particularly on which projects, presentation format, and prepping the PTLs in advance.)
21:42:16 <Arkady_Kanevsky> OK. we will select 32 project to interview.
21:42:42 <pchadwick> Not intending to be rude, but are there 32 projects that are worth doing this for?
21:43:04 <pchadwick> Worth = significant interest in community.
21:43:14 <heidijoy> @pchadwick I went through and there are 25 significant projects with community adoption
21:43:21 <pchadwick> Ok
21:43:36 <Arkady_Kanevsky> our CPL list only contains 20
21:43:41 <heidijoy> Also considering there are 60+ big tent projects, I would recommend we fill the remaining 7 slots with "emerging projects of interest"
21:43:44 <Arkady_Kanevsky> https://wiki.openstack.org/wiki/CrossProjectLiaisons#Product_Working_Group
21:44:13 <heidijoy> Or consider having a recently TC approved project that spawned from another project present with its parent project
21:44:25 <heidijoy> I have a list of suggested projects here: https://etherpad.openstack.org/p/PTLupdatesBoston
21:44:30 <shamail> heidijoy: +1
21:44:52 <shamail> heidijoy: when would you need our feedback by on projects?
21:45:41 <heidijoy> I suggest we give feedback via the etherpad, wrap it up by the end of Jan? I'd like to extend invites no later than Feb. 5. It would be fine if we hadn't filled every slot by then, but most should be.
21:45:57 <shamail> #link https://etherpad.openstack.org/p/PTLupdatesBoston
21:46:00 <shamail> heidijoy: +1
21:46:25 <shamail> #action Review/Add projects to PTL Updates etherpad by end of January (all)
21:46:35 <heidijoy> That's all for now, I'll also circulate this to the PWG ML.
21:46:54 <shamail> For the questions, we could use something similar to what we used for the Design Series
21:47:01 <shamail> thanks heidijoy!
21:47:05 <Arkady_Kanevsky> ehidi do oyu have a draft of slide template to fill?
21:47:13 <Arkady_Kanevsky> We can use frm last time.
21:47:28 <shamail> No slide to fill for now Arkady_Kanevsky
21:47:50 <shamail> We are just helping select projects and the questions for video interviews that will be scheduled in Boston
21:47:54 <heidijoy> I will have a draft template with the new branding, and will ask those who sign up on the etherpad to contribute to it
21:47:58 <pchadwick> Won't we want to guide the PTLs on the key items to cover?
21:48:01 <Arkady_Kanevsky> The slide we will ask PTL to fill in interview or us feeling from interview
21:48:15 <heidijoy> Yes exactly pchadwick
21:48:30 <shamail> We will pchadwick, I was just saying no resulting slide work necessary from it currently
21:48:33 <Arkady_Kanevsky> like key deliverables in Ocata, key areas for Pike...
21:48:40 <shamail> Arkady_Kanevsky: +1
21:48:47 <pchadwick> shamail: OK - thanks.
21:49:09 <shamail> Next up....
21:49:13 <shamail> #topic review capacity management gaps analysis
21:49:16 <pchadwick> Is this part of the forum track or the main sessions?
21:49:33 <GeraldK> We have performed the gap analysis of the capacity mgmt user story with a focus on the reservation part that we had added to the user story. links to related specs/RFEs have been added.
21:49:39 <heidijoy> Main sessions
21:49:40 <GeraldK> #link https://etherpad.opnfv.org/p/promise_gap_analysis
21:49:43 <heidijoy> And video recorded
21:49:52 <pchadwick> hiedijoy: thanks
21:49:58 <heidijoy> But not part of the traditional CFP process
21:50:30 <GeraldK> will need also feedback/input especially from the others who had contributed to this user story
21:51:18 <GeraldK> once we have agreed on the template this can be converted into rst
21:51:43 <GeraldK> we have identified 3 related projects: Blazar, Nova, Neutron
21:53:05 <GeraldK> from previous chats with PTLs introducing such feature will require cross-project coordination and here PWG can be of help
21:53:54 <GeraldK> looking at the time, what about all checking this offline and commenting in the Etherpad?
21:54:01 <heidijoy> =1
21:54:03 <heidijoy> +1
21:54:08 <leong> +1 geraldk
21:54:09 <pchadwick> +1
21:54:23 <MeganR> +1
21:54:46 <GeraldK> when/where would be a good time/place to discuss this with the projects and to derive the implementation plan?
21:55:35 <heidijoy> @geraldk please sign up on the etherpad and I will follow up with you directly. I'll also post invitation to contribute on the PWG ML
21:57:04 <leong> heidijoy: geraldk is refering to user-story gap-analysis for capacity management
21:57:05 <GeraldK> thanks heidijoy
21:57:15 <heidijoy> oops sorry :-/
21:57:22 <shamail> GeraldK: generally I would recommend scheduling a cross-project IRC meeting and advertising on the mailing list
21:57:29 <shamail> this will ensure you get proper coverage
21:57:48 <shamail> You can also look at the cross-project spec liaisons page and find the CPSLs for the needed projects and invite them
21:58:04 <shamail> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
21:58:13 <GeraldK> okay. if it's IRC, let's schedule it once we have incorporated your comments on the gap analysis
21:58:17 <Arkady_Kanevsky> do you have IRC for cross-project?
21:58:38 <shamail> You have to create one or just use the openstack-meeting-cp channel when its available
21:59:23 <Arkady_Kanevsky> I expected a permanent IRC you can join and chat and then scehdule one off as needed
21:59:38 <Arkady_Kanevsky> for x-project
22:00:36 <GeraldK> okay to use openstack-meeting-cp channel
22:00:43 <Arkady_Kanevsky> out of time.
22:00:53 <pchadwick> bye
22:00:57 <shamail> Take care all
22:00:59 <Arkady_Kanevsky> bye all
22:01:02 <shamail> #endmeeting