01:59:23 <leong> #startmeeting product_working_group
01:59:24 <openstack> Meeting started Tue Apr  5 01:59:23 2016 UTC and is due to finish in 60 minutes.  The chair is leong. Information about MeetBot at http://wiki.debian.org/MeetBot.
01:59:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
01:59:27 <openstack> The meeting name has been set to 'product_working_group'
01:59:52 <kencjohnston> o/
01:59:57 <kei> o/
02:00:00 <leong> o/
02:00:02 <hughhalf> o/
02:00:02 <samP> o/
02:00:03 <kencjohnston> hi kei !
02:00:03 <fredli> o/
02:00:11 <kei> hi kencjohnston!
02:00:15 <leong> this is our first product working group regional meeting...
02:00:20 <leong> agenda can be found here..
02:00:24 <shintaro> hi
02:00:24 <leong> let do a roll call
02:01:35 <kencjohnston> leong Should we do type our names and companies?
02:01:38 <leong> #link Agenda https://wiki.openstack.org/wiki/Meetings/product-team
02:01:46 <leong> yes.. let's do a quick introduction
02:01:51 <leong> i shall start first...
02:01:56 <leong> This is leong, from Intel
02:02:02 <fredli> Hi all, I am Fred Li, from Huawei.
02:02:19 <hughhalf> Hugh, from Rackspace, Hi! :)
02:02:20 <kencjohnston> Howdy, I'm Kenny Johnston from Rackspace and OSIC
02:02:30 <shintaro> Hi all, Shintaro Mizuno from NTT
02:02:31 <samP> Hi, I am Sampath Priyankara from NTT
02:02:34 <kei> Kei Tokunaga from Fujitsu.  Hi everyone.
02:02:36 * hughhalf adds he's in Australia and realises that might be good context for everyone to note
02:02:49 <leong> good to see people from various companies!
02:02:57 * kencjohnston and remembers that he's in Kansas City, USA
02:03:26 <leong> does anyone know the purpose of this regional meeting?
02:03:50 <kencjohnston> leong To get more people involved in the Product Work Group?
02:04:02 <hughhalf> Facilitate APAC-ish timezones
02:04:12 <leong> the reason that we put up this regional meeting is to encourage participation from other region countires
02:04:47 <leong> so the input from this regional meeting will be feedback to the 'main' Product WG meeting
02:05:28 <leong> same thing.. the discussion of the 'main' Product WG meeting will be summarized here, so that both team can have better transparancy and collaboration
02:05:45 <hughhalf> leong I think this is an excellent step, thank you for setting it up
02:05:48 <kencjohnston> leong +1
02:05:56 <shintaro> leong: sounds good
02:06:06 <kei> leong: thank you.
02:06:25 <leong> for this couple of week, i will try to chair the meeting.. however, moving forward, i would suggest someone from "regional" could co-chair the meeting
02:06:40 <hughhalf> where are you based leong  ?
02:06:57 <leong> I'm based in Portland USA hahaha
02:07:08 <hughhalf> Ah, well that's the "P" in APAC :)
02:07:13 <kencjohnston> hughhalf ha
02:07:21 <leong> LOL
02:07:49 <hughhalf> But yes, someone regional can chair, I think this is a good idea.
02:07:58 <leong> i can try to kickstart this regional meeting for now, but that's not going to be a long-term path for me...
02:08:00 <samP> isnt it better some one in the region could co-chair?
02:08:19 <leong> yup. samP and hughhalf, that's what i'm trying to proposing here
02:08:21 <hughhalf> I would be happy to chair or co-chair along with someone else too if that makes sense
02:08:33 <shintaro> maybe someone who can join both "main" and "regional"?
02:08:35 * hughhalf is UTC+10 - Sydney
02:08:47 * hughhalf nods at shintaro
02:08:51 <hughhalf> I can usually do both
02:09:04 <leong> it will be even better if both chair/co-chair are from "regional"
02:09:12 <hughhalf> if not, I can read the minutes of the North America/EU ones
02:09:14 <kei> leong: You asked me to be a co-chair in the original meeting before.  So I'd like to try.
02:09:20 <kei> :)
02:09:22 <leong> +1
02:09:26 <hughhalf> where are based Kei ?
02:09:30 <leong> Kei is from NTT, Japan
02:09:37 <hughhalf> Oh, perfect!
02:09:50 <hughhalf> Domo arigato gozaimasu kei
02:09:57 <kei> leong: from Fujitsu :-)
02:09:59 <samP> excellent
02:10:02 * hughhalf stops pretending to speak Nihon
02:10:07 <kei> hughhalf: I'm based in Japan
02:10:08 <leong> sorry.. Kei is from Fujitsu....oopss
02:10:46 <kei> leong: :)
02:10:56 <leong> does anyone else interested to be the co-chair or chair?
02:11:06 <hughhalf> I am happy to chair/co-chair, yes
02:11:25 <leong> that's great..
02:11:58 <leong> are we ok here for Kei and Hughhalf to chair/co-chair this regional meeting onwards?
02:12:05 <leong> i will try to join this biweekly though...
02:12:09 <samP> +1
02:12:11 <fredli> +1
02:12:12 <kencjohnston> +1
02:12:21 <leong> +1
02:12:22 <kencjohnston> Is it a weekly or bi-weekly meeting?
02:12:33 <kei> bi-weekly
02:12:50 <kencjohnston> Even though I'm not in region, this time is much better for me. Do you guys mind if I'm an adopted APAC meeting member?
02:12:53 <leong> #agree The team agree for Kei and Hughhalf to chair/co-chair this regional meeting onward
02:13:04 <leong> Kencjohnston, this will be bi-weekly for now..
02:13:07 <hughhalf> Thanks :)
02:13:23 <leong> however, depending on the participants in this meeting, we can change this to a weekly meeting
02:13:30 <leong> this channel is reserved for weekly
02:13:51 <leong> kencjohnston, i think that is fine!
02:14:04 <hughhalf> I think bi-weekly will be a good start, yes
02:14:25 <fredli> we can start with biweekly, and then change if necessary
02:14:34 * hughhalf nods at fredli
02:14:45 <leong> would everyone agree that we start with biweekly, then change whenever needed
02:14:51 <hughhalf> +1
02:14:52 <kencjohnston> leong +1
02:14:55 <shintaro> +1
02:14:56 <fredli> +1
02:14:56 <samP> sure
02:15:07 <kei> +1
02:15:16 <leong> #agree The team agree to meet biweekly for now. The team will decide if need to change the frequency in the future.
02:15:24 <leong> cool..
02:15:36 <samP> do we need to update http://eavesdrop.openstack.org/#OpenStack_Product_WG
02:15:37 <leong> i think we have covered the first two agenda item...
02:15:43 <leong> does anyone has any question so far..
02:16:04 <leong> would both chair kei and hughhalf comfortable with the irc meeting logistics/commands?
02:16:10 <kencjohnston> samP it should update iftself if this meeting is in governance, and if we are using the meetbot
02:16:22 <hughhalf> leong yes I think so, I have watched a few meetings now
02:16:28 <samP> ah..OK then
02:16:29 <leong> samP it will be automatically updated by meetbot
02:16:50 <leong> ok.. i have a IRC meeting cheatsheet, i can share with the team if needed
02:16:58 <kei> leong: I think so too.
02:17:17 <hughhalf> leong cheat sheets are always welcome, thankyou
02:17:25 <kei> leong: that'd be great.
02:17:26 <kencjohnston> wait samP is right, we might need to update who the eligible chairs are to start the meeting
02:17:29 <leong> #action Leong to share irc cheatsheet
02:18:32 <kencjohnston> #link How to Chair an IRC Meeting https://wiki.openstack.org/wiki/Meetings/ChairaMeeting
02:18:36 <leong> #topic product workgroup user story workflow
02:19:02 <leong> next agenda, does everyone know the new product wg user story workflow?
02:19:06 <kei> kencjohnston: thanks for the info.
02:19:20 <fredli> no, I don't
02:19:34 <leong> #link Product WG User Story Workflow https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
02:20:04 <leong> so.. basically anyone can propose a user story to the product wg repository
02:20:17 <leong> the team will commend and review the proposal on the review.openstack.org
02:20:38 <kencjohnston> #link User Story Repository https://github.com/openstack/openstack-user-stories
02:21:23 <leong> the team will "merged" the proposal once the team think that this user story has sufficient information for the requirements
02:21:36 <fredli> thanks, I will read that
02:21:48 <leong> then we will bring this user-story into cross-project spec
02:22:08 <leong> I will advice all members here to have a look at the above link
02:22:46 <leong> #action All to read the Product WG User Story Workflow https://wiki.openstack.org/wiki/ProductTeam/User_Stories#User_Story_Workflow
02:22:53 <leong> any questions?
02:23:08 <kencjohnston> How can I find user stories to provide reviews on?
02:24:01 <leong> #link Existing user stories on repo: https://review.openstack.org/#/q/user-stories
02:24:21 <kencjohnston> This one might be better - https://review.openstack.org/#/q/status:open+project:openstack/openstack-user-stories
02:24:39 <leong> thanks kencjohnston
02:24:54 <leong> #link Existing user stories on repo https://review.openstack.org/#/q/status:open+project:openstack/openstack-user-stories
02:25:04 <kencjohnston> One easy way to get started is to start reviewing existing open user stories
02:25:06 <leong> we have a couple of user stories being proposed today...
02:25:21 <kencjohnston> it will give you an idea of what we look for in User Stories and familiarity with the gerrit review system
02:25:47 <leong> in today 'main' Product WG meeting, we have identified/prioritize the top 5 that we want to drive forward prior to Austin summit
02:25:53 <kencjohnston> And the fact that you don't have to propose a fully formed user story, start with the basics to get the conversation started and iterate from there
02:26:12 * kencjohnston shuts up now to hear about the priority
02:26:48 <leong> the top 5 user story: 1. Rolling upgrade; 2. HA VM; 3. Baremetal service; 4. Capacity Mgmt; 5. Fleet Mmgmt
02:27:16 <samP> is there any minimum required items before propose a story?
02:27:44 <leong> we don't have minimum requirement for proposing a story...
02:27:47 <kencjohnston> samP No, just a description to propose.
02:27:53 * kencjohnston looks for a link to the template...
02:28:08 <kencjohnston> #link User story template https://github.com/openstack/openstack-user-stories/blob/master/user-story-template.rst
02:28:38 <leong> thanks kencjohnston.. that the link to the template.. anyone can use that template and propose a new user story
02:28:40 <samP> got it.
02:28:50 <fredli> kencjohnston: thanks
02:28:51 <samP> thax
02:29:23 <leong> I would like to encourage/invite everyone to look at the top 5 user stories
02:29:49 <leong> we aim to finalize and 'merged' them before Austin summit, so that we can bring them into design summit for discussion
02:31:01 <leong> user story 'rolling upgrade' is already merged.
02:31:37 <leong> #link Rolling Upgrade https://github.com/openstack/openstack-user-stories/blob/master/user-stories/proposed/rolling-upgrades.rst
02:31:52 <leong> #link HA VM https://review.openstack.org/#/c/289469/
02:32:22 <leong> #link Baremetal https://review.openstack.org/#/c/289627/
02:32:57 <leong> #link Capacity Mgmt https://github.com/openstack/openstack-user-stories/blob/master/user-stories/proposed/capacity_management.rst
02:33:04 <kencjohnston> #link Fleet Managemenet https://review.openstack.org/#/c/299531/
02:33:15 <leong> cool...
02:33:22 <leong> that's the link to the top 5
02:33:40 <leong> we need more reviews especially for HA VM, Baremetal and Fleet Mgmt
02:33:56 <leong> questions?
02:34:24 <kei> leong: would you also share the information of what exactly we're planning to do with the top 5 in design summit (of course once all of them are merged)?
02:35:28 <leong> we will bring them into cross-project / project discussion, get commitment from relevant project team so that these 'feature' will be one of their priority list
02:36:12 <fredli> leong: how detailed should we prepare for the user stories? for example, should we provide BPs if ready?
02:36:20 <kei> leong: thanks.
02:36:41 <leong> the more detail the better, so of the user-stories might already have related bp/spec
02:36:57 <leong> some of the user-stories might already have related bp/spec
02:37:21 <kencjohnston> fredli Although if it is within a single project (ie a specific blueprint for say Nova) we typically don't create User Stories for those.
02:37:44 <kencjohnston> fredli You would be better served creating a spec within the given projects spec repo.
02:38:48 <fredli> leong: got it. thanks
02:39:14 <leong> we want to focus more on the "requirements" first
02:39:34 <leong> and then trying to identify the existing gap in openstack
02:40:34 <shintaro> what about cross-project spec, will they be the same as the user story?
02:40:53 <leong> the user story will be the 'input' to the cross-project spec
02:41:11 <kencjohnston> shintaro We modeled the User Story template to fit into certain sections of the Cross Project Spec template
02:41:33 <kencjohnston> But Cross Project spec is where the gaps and technical implementation should be fleshed out.
02:41:58 <shintaro> kencjohnston thanks
02:43:12 <leong> we have about 18 mins for the meeting.. anything we want to discuss with respect to User Story?
02:43:49 <kencjohnston> I'll throw out a few links to User Stories I've drafted that I'd like feedback on
02:43:54 * kencjohnston finds link
02:43:58 <leong> ok
02:44:13 <kencjohnston> actually we already referenced fleet management
02:44:19 <kencjohnston> one other one is Centralized Config,
02:44:32 <kencjohnston> #Link Centralized/Categorized Config Options https://review.openstack.org/#/c/291406/
02:44:53 <kencjohnston> I'd appreciate reviews
02:45:28 <kencjohnston> Nothing else from me.
02:45:57 <shintaro> quick question, what is the criteria for user stories to get merged?
02:46:37 <kencjohnston> shintaro I'm not sure it is officially documented other than the normal 2 +2s from cores and passing the Jenkins gate
02:46:38 <fredli> shintaro: good question
02:46:51 <kencjohnston> but we generally look for team agreement on user stories
02:47:12 <kencjohnston> and fleshed out Usage Scenarios, problem description and appropriate external references
02:47:12 <leong> "technically" require to +2... but generally is an agreement within the Product WG team
02:47:51 <leong> the key criteria is: Trying to capture all necessary requirements into the user story, so that it is 'solid' enough to present to the developer community
02:48:20 <rockyg> ++
02:48:22 <leong> there are a few sections in the template
02:49:04 <leong> such as Usage Scenario, Requirements, External References
02:49:19 <rockyg> Sometimes it is important to get initial story out to devs then add to it barred on dev comments
02:49:57 <leong> agreed rockyg, that's why we want to get these prepared for the design summit
02:50:00 <fredli> leong: are there cores in product-wg? if so, who are the cores. I didn't find it.
02:50:05 <shintaro> thanks
02:50:26 <leong> i think right now we have 'core' as kenny, carol, shamail
02:50:37 <kencjohnston> leong and rocky
02:50:42 * kencjohnston finds link to official list
02:51:05 <kencjohnston> #link User Stories Cores https://review.openstack.org/#/admin/groups/1042,members
02:51:15 <leong> i don't think i'm on the core list yet.. haha
02:51:52 <fredli> kencjohnston: thanks. I searched by "product-wg".
02:52:08 <kencjohnston> yeah our repo is openstack/openstack-user-stories
02:52:22 <fredli> I have no more questions.
02:52:29 <leong> ok...let's move on to open
02:52:31 <leong> #topic Open
02:52:40 <leong> any open questions?
02:52:50 <kei> one thing I'd like to double-check.  pwg only treats user stories that require cross-project activities?
02:52:56 <kencjohnston> For those interested in help getting started, either with git, gerrit or RST I'm available
02:53:43 <kencjohnston> kei Good call out. That has been an unspoken rule to date, we originally said we'd focus on cross-project multi-release items
02:54:00 <kencjohnston> but I do think a single project User Story is likely better handled as a project spec
02:54:14 <leong> agree with kencjohnston
02:54:21 <kencjohnston> although I could be convinced otherwise...
02:54:45 <kencjohnston> if it is something that you think would help get other members of the Product Work Group informed about and behind.
02:55:57 <leong> btw, here's my irc cheatsheet
02:55:58 <leong> #Link IRC cheatsheet: https://docs.google.com/document/d/1m--DFSwTPqKmxGNxP7ThDYuNr017wI_bUQOtqyaeyG0/edit?usp=sharing
02:56:08 <kei> kencjohnston: i agree a single project user story is better handled as a project spec.  so pwg doesn't treat a project spec at this moment, right?
02:56:21 <kencjohnston> kei correct.
02:56:33 <kei> kencjohnston: ok.  thanks.
02:56:47 <samP> leong: thanks
02:57:00 <kei> leong: thanks.  will take a look at it.
02:57:36 <kencjohnston> only other open I have is thanks leong for advocating for and organizing this meeting!
02:57:41 <leong> kei, kencjohnston, i think we might want to discuss how to handle single project user story soon...
02:57:50 <leong> my pleasure!
02:58:10 <rockyg> ++ thanks leong
02:58:12 <shintaro> Thanks leong!
02:58:16 <hughhalf> thanks leong
02:58:22 <samP> Thanks leong!
02:58:23 <leong> nice chat with you all, hoping that this regional meeting can generate impact to the Product WG and OpenStack community as a whole....
02:58:24 <kei> thanks, leong
02:58:37 <fredli> Thanks leong
02:58:41 <hughhalf> kei shall we exchange email so we can coordinate the next sessions ?
02:58:46 <kei> leong: +
02:59:01 <kei> hughhalf: absolutely.
02:59:10 <hughhalf> I'm hugh@blemings.org
02:59:28 <leong> #action key and hughhalf to plan for next meeting
02:59:34 <hughhalf> :)
02:59:56 <leong> 'see' you all next time
02:59:58 <kei> hughhalf: mine is tokunaga.keiich@jp.fujitsu.com
03:00:33 <fredli> nice to chat with you all. see you next time.
03:00:37 <samP> Thank you all and CU on next meeting
03:00:47 <kencjohnston> thanks all!
03:00:53 <kei> see you all
03:00:54 <leong> #endmeeting