21:01:26 <carolbarrett> #startmeeting Product Working Group
21:01:26 <openstack> Meeting started Mon Feb 22 21:01:26 2016 UTC and is due to finish in 60 minutes.  The chair is carolbarrett. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:30 <openstack> The meeting name has been set to 'product_working_group'
21:01:31 <kencjohnston> 0/
21:01:34 <hughhalf> o/
21:01:41 <kencjohnston> whoops, I meant o/
21:01:41 <KrishR> o/
21:01:41 <shamail> Here, but mobile client today
21:01:50 <carolbarrett> Hi All - Let's start with role call
21:02:01 <carolbarrett> meant roll call :)
21:02:13 <hughhalf> o/
21:02:16 <KrishR> o/
21:02:31 <thingee> o/
21:02:34 <sgordon> o/
21:02:39 <MeganR> o/
21:02:45 <leong> o/
21:02:55 <carolbarrett> i hear that the gold member meeting is occurring now too, which may impact some folks
21:03:19 <leong> let's continue on what we have
21:03:22 <carolbarrett> #link: https://wiki.openstack.org/wiki/Meetings/product-team
21:03:30 <carolbarrett> Here's the link for today's agenda
21:03:32 <rockyg> o/
21:03:46 <carolbarrett> Let's start off with Roadmap discussion
21:03:52 <shamail> Sounds good
21:03:52 <carolbarrett> #topic Roadmap Update
21:03:56 <carolbarrett> Shamail - can you lead this?
21:04:05 <shamail> Sure, thanks carolbarrett
21:04:49 <shamail> So at the mid-cycle we had a productive discussion about the roadmap process.  This resulted in some minor changes to the process... We also heard about our deadlines from Heidi Joy
21:05:17 <shamail> We need to get the 10000, 1000, and 100 ft views to Heidi Joy the week of 3/15
21:05:31 <shamail> Therefore the deadline for getting updates from projects is 3/11
21:05:42 <shamail> (To give time to generate 10K and 1K views)
21:06:11 <shamail> At the mid-cycle, people volunteered to help with the roadmap process (CPLs generally help with their respective projects)
21:06:30 <shamail> Please look at the linked spreadsheet as it contains names for the owners for the roadmap cycle
21:06:38 <shamail> carolbarrett: can you add link in IRC please?
21:06:51 <shamail> (Switching apps is hard on phone)
21:06:56 <carolbarrett> #link https://docs.google.com/spreadsheets/d/1md7lEvq4SbLLefiq8cL3UIYMfWE6nLETm84YoqDi6nE/edit?pref=2&pli=1#gid=1358080590
21:07:23 <shamail> Does anyone see their name next to a project that does NOT have the time to participate in gathering the information?
21:07:38 <shamail> Also, the projects in yellow are "required", all others are optional
21:07:47 <shamail> The criteria was adoption data from the user survey
21:07:52 <kencjohnston> shamail I see Phil Williams on there and he's not in this meeting, but I'll confirm his coverage of swift
21:08:09 <shamail> If you have both an optional and required project, please complete the required first
21:08:23 <shamail> As the optional projects are not needed for marketing launch
21:08:30 <shamail> Thanks Kencjohnston
21:08:53 <hughhalf> lgtm shamail, thanks
21:08:55 <shamail> So everyone here is fine with their assignment?
21:08:59 <kencjohnston> shamail I was going to see if hughhalf wanted to take Docs from me, given he is in the same timezone as the PTL.
21:09:01 <shamail> Thanks hughhalf
21:09:12 <shamail> hughhalf: up for that?
21:09:13 <hughhalf> kencjohnston sure, can do man
21:09:17 <shamail> Thanks
21:09:20 <leong> Do we need to put our name in if anyone of us can help?
21:09:24 <rockyg> Is there a list of questions we should get answered?  First time data gatherer here
21:09:34 <shamail> In the agenda, I have also linked the template for the 100 ft view
21:09:56 <shamail> We can use the actual data for mitaka (such as the PTL interview video and links to specs/repos)
21:10:12 <shamail> But we will need to still ask PTLs about the future releases
21:11:00 <shamail> leong: please add your name as backup if there is already an assignment
21:11:05 <shamail> Otherwise you can sign up
21:11:10 <leong> ok
21:11:18 <kencjohnston> shamail confirmed with phil that he is good for swift
21:11:42 <shamail> rockyg: we will be sending a template email with questions, I think Heidi Joy has that AR
21:11:53 <rockyg> excellent.  Thanks.
21:11:55 <kencjohnston> sgordon I can also serve as backup for magnum
21:11:59 <sgordon> nok
21:12:02 <sgordon> *ok
21:12:44 <shamail> So, the plan is to get info from PTLs and send over the completed 100 ft views by 3/11
21:12:58 <carolbarrett> Good stuff - anything else Shamail?
21:13:13 <shamail> I'm thinking we should have a weekly sub-team meeting... Do people agree?
21:13:14 <carolbarrett> Or questions from anyone else on this?
21:13:18 <shamail> Kind of like we did last cycle
21:13:26 <shamail> If we want to do one, I can send out a doodle
21:13:43 <MeganR> sub-team meeting for the roadmap?
21:13:47 <shamail> Yes
21:13:55 <MeganR> sure, I think that is a good idea
21:13:55 <shamail> A weekly 30 min checkpoint
21:14:09 <shamail> We can make it one hour after release marketing is done
21:14:09 <kencjohnston> shamail works for me
21:14:15 <carolbarrett> Sounds good
21:14:32 <leong> +1
21:14:34 <shamail> Last comment: We are doing two exercises... Gathering data for release marketing (this is the one with hard deadlines)
21:14:35 <carolbarrett> Shamail: Do you want to send out a doodle to set a time?
21:14:52 <shamail> And building the roadmap for our session, which we can continue to build after 3/15
21:15:03 <shamail> And will include the optimal projects
21:15:11 <shamail> Yes, I will carolbarrett
21:15:16 <shamail> Please assign me the action
21:15:19 <shamail> That's all I had
21:15:21 <carolbarrett> #action Shamail send out Doodle to set time for roadmap sub-team meeting
21:15:35 <KrishR> So the Mitaka info has to be done by 3/11, right?
21:15:49 <shamail> Yes, please
21:16:08 <shamail> I'll be available by email for any questions during the collection phase
21:16:53 <kencjohnston> shamail given the timing we should press the urgency for the question formatting.
21:17:06 <kencjohnston> I'd like to send out the initial emails today/tomorrow.
21:17:12 <shamail> Will do carolbarrett
21:17:13 <rockyg> ++
21:17:30 <MeganR> +1
21:17:34 <leong> +1
21:17:56 <carolbarrett> +1
21:17:57 <shamail> I'll talk with HeidiJoy
21:18:04 <carolbarrett> Thanks Shamail
21:18:33 <carolbarrett> Ok - let's move along
21:18:45 <carolbarrett> #topic Midcycle Update
21:19:03 <carolbarrett> We had a good 2 day working session after the Ops Midcycle
21:19:13 <carolbarrett> Thanks to Kenny and Rackspace for hosting us!
21:19:20 <MeganR> +1
21:19:25 <leong> +1
21:19:42 <shamail> +1
21:19:46 <carolbarrett> We're not going to cover the outcome in detail today, that's on the agenda for next week.
21:20:07 <carolbarrett> But do want to share a link to an etherpad that has a summary of the midcycle
21:20:19 <carolbarrett> #link:  https://etherpad.openstack.org/p/PWG-LON16-MidCycle_Summary
21:20:33 <carolbarrett> Also includes the ARs from the emails from Kenny and Shamail
21:20:43 <shamail> Great mid-cycle filled with energetic/passionate discussions!!
21:20:55 <carolbarrett> shamail: Is there a link to the updated work flow that we can provide too?
21:21:02 <rockyg> ++
21:21:21 <shamail> Not yet carolbarrett, sorry
21:21:32 <shamail> I'll have it up somewhere by Wednesday
21:21:38 <shamail> Went directly to a conference :(
21:21:56 <shamail> I'll also summarize the new workflow via email so we can discuss in a future meeting
21:22:06 <leong> shamail, do you want to send the ppt to me and i can try help to update the diagram to wiki?
21:22:07 <carolbarrett> Is the final slide deck that we used at the London OpenStack Users Group available online? We could give that link
21:22:33 <shamail> I'll add it Leong, just travel slowed me down
21:22:48 <leong> no problem...just let me know if you need help
21:22:52 <shamail> Not sure if it's up, I did give it to the organizers
21:23:00 <shamail> Thanks Leong!!
21:23:02 <carolbarrett> Is Nate on?
21:23:36 <shamail> I don't believe so
21:23:57 <shamail> Brb, I'll check user group sute
21:24:00 <shamail> Site*
21:24:05 <carolbarrett> OK - I'll look for a link to the meetup and send out the link
21:24:09 <carolbarrett> shamail: Thanks!
21:24:42 <carolbarrett> For people who didn't attend the midcycle (and even if you did)...pls review the etherpad, there's info and action requests for all of us!
21:24:58 <carolbarrett> moving on...
21:25:06 <carolbarrett> #topic Gerrit Team Training
21:25:18 <carolbarrett> This came up in the midcycle and we wanted to discuss here
21:25:22 <shamail> carolbarrett: I don't see it on there, I'll send out an email by Wednesday with workflow
21:25:36 <carolbarrett> shamail: Thanks
21:26:05 <carolbarrett> The new version of Gerrit has a web interface for editing. This lowers the barrier of configuration/complexity for people to edit and comment on reviews
21:26:48 <carolbarrett> We would like to increase the volume of folks reviewing user stories and adding comments/contents to improve them, so am wondering if we want to have a team training
21:26:58 <carolbarrett> Show of hands for who is interested in this?
21:27:06 <cloudrancher> I am
21:27:09 <KrishR> i vote for Gerrit team training
21:27:09 <MeganR> I am
21:27:14 <shamail> I can volunteer to help with the training
21:27:14 <carolbarrett> o/
21:27:17 <kencjohnston> carolbarrett +1, and I'm happy help lead the session
21:27:32 <carolbarrett> shamail: Thanks will take you and Kencjohnston up on the offers!
21:28:04 <rockyg> ++
21:28:04 <carolbarrett> Shamail/kencjohnston: How long do you think we need for it? 30mins? 60 mins?
21:28:37 <shamail> kencjohnston: thoughts?  I'm thinking 60 to leave room for questions/Murphy?
21:28:40 <mbonell> o/
21:28:46 <kencjohnston> shamail +1
21:29:01 <kencjohnston> if we are getting folks setup with git and git-review that will take awhile
21:29:01 <carolbarrett> Sounds good
21:29:02 <leong> +1
21:29:03 <carolbarrett> #action carol send out doodle to set time for team training on gerrit
21:29:04 <kencjohnston> we can send out prework
21:29:23 <carolbarrett> kencjohnston - good
21:29:26 * hughhalf nods
21:29:29 <vmtyler> Maybe focus on live edit in gerritt
21:29:29 <carolbarrett> anything else on this one?
21:29:30 <leong> there's a video available for setting up git/git-review on windows
21:29:41 <kencjohnston> leong link?
21:30:08 <carolbarrett> #link https://www.youtube.com/watch?v=uAVPDyK8flc
21:30:13 <carolbarrett> that's for gerrit on Windows
21:30:16 <kencjohnston> carolbarrett thanks
21:30:19 <carolbarrett> here's for setting up account
21:30:19 <leong> https://www.youtube.com/watch?v=uAVPDyK8flc
21:30:23 <vmtyler> Also http://vmtyler.com/contributing-to-openstack-documentation/
21:30:28 <carolbarrett> #link https://www.youtube.com/watch?v=yJBSWYzWGv4
21:30:38 <vmtyler> Has git git-review setup
21:30:40 <carolbarrett> thanks vmtyler
21:30:57 <shamail> Nice vmtyler and leong
21:31:24 <carolbarrett> moving along...
21:31:29 * kencjohnston is reminded that at the summit the infra team said we should exclusively use - http://docs.openstack.org/infra/manual/developers.html#getting-started
21:31:34 <kencjohnston> #link http://docs.openstack.org/infra/manual/developers.html#getting-started
21:31:49 <leong> the developer getting started is mainly targetted on Linux environment.
21:32:13 <carolbarrett> kencjohnston: that's a good doc, but didn't have enough detail to help me get setup
21:32:16 <leong> the video link that posted earlier is purely targetted on Windows environment
21:32:27 <kencjohnston> leong carolbarrett I agree, but maybe we should work to improve that doc
21:32:32 <carolbarrett> +1; that was my issue.
21:32:38 * kencjohnston makes a note to talk to the infra team about that
21:32:45 <carolbarrett> kencjohnston: good point
21:32:48 <leong> +1
21:32:57 <shamail> I think it might've been Windows vs Linux details
21:33:11 <carolbarrett> #action kencjohnston talk to talk to the infra team about adding more detail on Windows setup to docs
21:33:23 <leong> and also proxy for folks within within corporate env
21:33:25 <carolbarrett> should that action be to talk to docs team?
21:33:50 <thingee> yeah pretty sure the infra team doesn't care, just someone has to do it
21:33:51 <rockyg> no.  the doc is owned by infra
21:33:57 <kencjohnston> carolbarrett no, I think that URL shows the doc is owned by  infra
21:34:18 <sgordon> or more accurately, in an infra repo and owned by everyone...
21:34:20 <carolbarrett> gotcha
21:34:22 <sgordon> ;)
21:34:26 <kencjohnston> sgordon :)
21:34:39 <carolbarrett> anything else on this one?
21:35:13 <carolbarrett> #topic Planning for Austin
21:35:14 <shamail> Gerritt is going to be critical for new workflow, so I'm glad we are doing this
21:35:32 <carolbarrett> As you'll see in the midcycle summary etherpad, we talked about Austin team meeting plans
21:35:40 <carolbarrett> A proposal was made to plan a full day working session on Friday of the conference (4/29)
21:35:50 <carolbarrett> Thoughts & Discussion?
21:36:17 <kencjohnston> carolbarrett pros - Entire day of discussion to draft and review user stories
21:36:34 <hughhalf> My only concern with a full day Friday is if it prevents folk from attending other project sessions that are relevant.  Istr Friday pretty quiet though usually
21:36:35 <kencjohnston> carolbarrett cons - we will all be burnt out and want to go to the lake
21:37:09 <carolbarrett> hughalf: Friday is design summit only, so likely less busy for people
21:37:20 <carolbarrett> kencjohnston: definitely a concern
21:37:30 <leong> what about a half-day?
21:37:34 <KrishR> suggest do 9am-1pm...tough to keep everyone going beyond that on a Friday
21:37:43 <kencjohnston> KrishR +1
21:38:00 <sgordon> hughhalf, that is my concern also
21:38:27 <kencjohnston> sgordon hughhalf It was pointed out that many projects end up blowing off Friday due to burnout anyway
21:38:27 <shamail> I'm fine with either options
21:38:29 <sgordon> carolbarrett, less busy but if you are involved in all of 1 other project it's a guaranteed clash
21:38:35 <sgordon> as opposed to a 50% chance of one ;)
21:39:00 <kencjohnston> sgordon we would have the same clash if we tried to do a significant block of time any other day of the week
21:39:00 <hughhalf> sgordon I agree - otoh, I think Friday is probably still the better option overall
21:39:17 * hughhalf idly wonders if Friday could be held at the lake, thus killing two birds with one stone.
21:39:22 <sgordon> hughhalf, well what i am getting at is, is there an agenda that mandates a full day
21:39:26 <carolbarrett> Agree, Friday isn't perfect, but it does seems like the best option
21:39:28 * hughhalf nods at kencjohnston
21:39:28 <sgordon> as opposed to a half day
21:39:52 <kencjohnston> sgordon I think a half day would be appropriate
21:39:56 <sgordon> because if we a schedule a full day and then end up knocking off after lunch anyway it's kind of sub optimal
21:39:57 * hughhalf nods
21:40:01 <shamail> I think if we only do one session then it won't be a working session since we usually get so many new people that it turns into an intro session
21:40:09 <rockyg> friday is always working day for the projects.  So, lots of coding, little discussion for most.
21:40:26 <carolbarrett> I think a half day is a good option
21:40:31 <kencjohnston> shamail good point, everyone should keep in mind, we discussed doing this as a workign session  in addition to our "Bird of a feather" intro session
21:40:32 <sgordon> disagree at least from my experience with docs and nova
21:40:34 <sgordon> limited coding
21:40:42 <sgordon> maximum sorting out issues we didnt get to earlier in the week
21:40:44 <shamail> kencjohnston: +1
21:40:52 <carolbarrett> good point kencjohnston & shamail
21:41:06 <leong> kencjohnston +1
21:41:25 <kencjohnston> in my mind the working session would be a chance to live review and collaborate on user stories
21:41:54 <carolbarrett> It sounds like the proposal is BoF session during the Summit to socialize the WG and reach out to new members; Plan a halfday session on Friday.
21:42:08 <kencjohnston> carolbarrett +1
21:42:13 <hughhalf> carolbarrett +1
21:42:22 <shamail> carolbarrett: +1
21:42:22 <carolbarrett> Friday session is a hands-on working session
21:42:30 <leong> carolbarrett +1
21:42:32 <vmtyler> +1
21:42:39 <carolbarrett> Anyone opposed to this plan or have another one they want to propose?
21:42:42 <KrishR> +1
21:43:16 <carolbarrett> If not, then I'll take the action to talk with the Foundation folks about a room - unless one of them is here now...?
21:43:40 <carolbarrett> #action carol talk with the Foundation folks about a room for Friday halfday working session
21:43:54 <carolbarrett> I have already put in a request for the BoF session
21:44:03 <sgordon> i think for the friday sessions it is probably ttx
21:44:13 <sgordon> as those are effectively design summit blocks
21:44:17 * sgordon could be wrong though
21:44:26 <carolbarrett> sgordon: Thanks will check with him
21:44:40 <carolbarrett> Anything else on this?
21:45:05 <carolbarrett> moving along...
21:45:20 <carolbarrett> #topic Persona working session
21:45:27 <carolbarrett> Piet - Are you here?
21:45:48 <carolbarrett> I'm assuming Piet added this to our agenda. Or did someone else?
21:45:51 <piet> Chatting with Michael
21:46:03 <carolbarrett> Can you cover the agenda item you added?
21:46:29 <kencjohnston> carolbarrett looks like no. Should we move it to next week?
21:46:46 <carolbarrett> Sounds good kencjohnston
21:46:52 <carolbarrett> Will make the change
21:46:56 <carolbarrett> #topic Opens
21:47:03 <kencjohnston> carolbarrett I have two
21:47:08 <carolbarrett> Go for it
21:47:18 <kencjohnston> First, we got a lot of feedback on the Rolling Upgrades user story
21:47:23 <kencjohnston> #link https://review.openstack.org/#/c/281787/
21:47:29 <kencjohnston> and have cleared a number of the -1s
21:47:39 <kencjohnston> so I'd request that core reviews +2 at this point
21:47:57 <kencjohnston> I have a number of actions for the story post this review merging which I'll work as soon as it does
21:48:11 <kencjohnston> any concerns with that?
21:49:10 <carolbarrett> not from me
21:49:24 <kencjohnston> ok
21:49:34 <kencjohnston> Brief update for those who weren't at the mid-cycle
21:49:51 <kencjohnston> actually, let me not go there just yet
21:49:55 <kencjohnston> second item,
21:50:03 <kencjohnston> #link
21:50:06 <kencjohnston> #link https://review.openstack.org/#/c/281787/3
21:50:17 <kencjohnston> This review is to change our template to more align with the Cross Project Spec template
21:50:33 <kencjohnston> I'd like to get core reviewer eyes on this asap as well
21:50:52 <kencjohnston> now, for the brief update. :)
21:50:55 <carolbarrett> shamail's irc connection died - asked me to say he'd +2
21:51:21 <leong> kencjohnston, should the rolling upgrade story be at link https://review.openstack.org/#/c/274969/
21:51:30 <rockyg> so second link is same as first...
21:51:46 <rockyg> thanks leong
21:51:50 <kencjohnston> At the mid-cycle we suggested our new process be to merge stories in the proposed repo, and then submit a specific patch to suggest they be submited as cross project specs
21:51:56 <kencjohnston> leong +1, too many tabs open
21:52:11 <kencjohnston> so folks watching the repo will see this user story merge
21:52:25 <kencjohnston> then a commit that requests that we agree to submit it as a cross project spec
21:52:41 <kencjohnston> and then finally a commit that adds a link to the cross project spec commit
21:53:05 <kencjohnston> that's all i had.
21:53:13 <carolbarrett> kencjohnston: good summary - thanks. Will look at both
21:53:31 <carolbarrett> anyone have Qs for kencjohnston?
21:53:32 <carolbarrett> Or any other Opens?
21:53:47 <leong> i thought we need a section for "ready for submission to cross project spec"?
21:54:16 <leong> or is that just a commit message in the "patch"?
21:55:31 <carolbarrett> I think it's just a commit message, but need to verify that from the meeting notes
21:56:45 <rockyg> I think it's a one liner in the template at/near the top, with either aa status or state and what the current state is.
21:57:00 <rockyg> Defcore does stuff ike this.
21:57:03 <kencjohnston> leong yeah I think I added some of that int he patch that covers the new template
21:57:07 <carolbarrett> Here's what I get from the notes: You create a tracker (with only the user story entry) and put a link to that in the User Story tracker field, then add this message
21:57:14 <kencjohnston> leong if I'm missing it please review and add comments.
21:57:38 <leong> kencjohnston +1
21:57:51 <carolbarrett> Let's verify and update next week when we do the detailed work flow walk thru
21:58:07 <carolbarrett> Anything else (2 mins to go...)
21:58:33 <carolbarrett> Ok - it's a wrap. Have a good week!
21:58:44 <KrishR> bye
21:58:47 <carolbarrett> #endmeeting