19:02:55 <Shamail> #startmeeting Product Working Group
19:02:56 <openstack> Meeting started Mon Jul 27 19:02:55 2015 UTC and is due to finish in 60 minutes.  The chair is Shamail. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:03:00 <openstack> The meeting name has been set to 'product_working_group'
19:03:17 <Shamail> Hi all! Who's here today? (roll call)
19:03:55 <MeganR> Hi
19:04:18 <Shamail> Just us two?
19:05:12 <Shamail> Hmm, if it's just us then I might cancel it for today.  Thoughts?
19:05:30 <MeganR> I guess so - that works
19:06:21 <Shamail> There a lot of midcycles and stuff in progress now.
19:06:27 <Shamail> There are a lot*
19:07:10 <MeganR> and vacations as well
19:07:10 <Shamail> I will probably start a discussion of the agenda items on the ML.  We have a lot of things to get done and not much buffer.
19:07:14 <Shamail> good point
19:08:05 <sarob_> o/
19:08:11 <Shamail> Hi sarob_!
19:08:24 <sarob_> Shamail: hi
19:08:42 <Shamail> I am debating if we have enough to cover the agenda items.
19:08:45 <Shamail> #link https://wiki.openstack.org/wiki/Meetings/product-team
19:08:53 <Shamail> We have MeganR, you, and I.
19:09:11 <Shamail> Should we pick and choose some items from the agenda that we can address? (e.g. BoD update review, etc)
19:09:30 <sarob_> i advised rocky on the repo patch
19:09:41 <sarob_> im not sure where she took it
19:09:46 <Shamail> #topic Use Case Repo Update - Rocky and Sean
19:10:02 <Shamail> Did she submit a patch set? If so, can you link it?
19:10:13 <sarob_> not that i ever saw
19:10:21 <sarob_> ill double check
19:10:24 <sarob_> hold a sec
19:10:28 * Shamail checks too
19:10:52 <Shamail> #link https://review.openstack.org/#/c/197754/
19:11:08 <sarob_> yup
19:11:43 <sarob_> it needs a few more TC +1
19:11:53 <Shamail> Yeah
19:11:57 <Shamail> It looks good though
19:12:33 <Shamail> Great!
19:12:45 <Shamail> #topic Board Update Slide Deck Final Review
19:12:56 * Shamail copying link... hold on.
19:13:16 <Shamail> #link https://my.syncplicity.com/share/zrlahrrakidkc29/Product%20WG%20BoD%20Update%20-%20July%202015%20draft%2013
19:13:36 <Shamail> This is the latest draft of the presentation that Carol and I will use tomorrow
19:13:51 <Shamail> We have incorporated feedback from the User Committee and several Board Members
19:14:14 <Shamail> Do you want to take 5 minutes to look through the slides and then we can open up the discussion?
19:14:34 <MeganR> yes please
19:14:44 <Shamail> Sounds good
19:15:51 <sarob_> looks good
19:16:56 <Shamail> Thanks, the main edits were along how tightly coupled this group is to the User Committee and the addition of the "Recognize" objective.
19:17:08 <Shamail> MeganR: Did you go through it too?  Any feedback?
19:17:15 <MeganR> slide #6 is cutting off the Cross Project Coordination section
19:17:22 <MeganR> might just be my viewer
19:17:52 <sarob_> MeganR: there is a delay for rendering
19:18:08 <Shamail> Maybe, it is formatted properly in my screen.
19:18:17 <Shamail> Are you using the "view" option?
19:18:29 <Shamail> If so then, as sarob_ said, rendering is laggy
19:18:38 <MeganR> I am - and yes, it took a bit for some of the slides to load
19:18:52 <MeganR> looks good - there is a lot of information in these slides!
19:19:05 <Shamail> Good news is that we have 30 minutes on the agenda now.
19:19:12 <Shamail> still a lot to cover!
19:19:18 <MeganR> wow - that's great
19:20:00 <Shamail> Alright, thanks for the feedback.  If you look at them again and you notice something, please email me.  I will be able to make changes until 8A tomorrow. ;)
19:20:14 <MeganR> ok, that sounds good!
19:20:29 <Shamail> I haven't looked at the exact time for the Product WG agenda item but as soon as I find it... I will send an email to the ML so that interested parties can dial-in for the update portion.
19:20:46 <Shamail> Rocky and Nate will be attending in person
19:20:48 <MeganR> ok, good idea - thank you
19:21:08 <Shamail> #topic Recognition Discussion
19:21:59 <Shamail> As a part of the deck review, we were told to consider recognition for people helping complete the user story implementation
19:22:11 <Shamail> and making general, strategic, contributions
19:22:46 <Shamail> We brainstormed to come up with some of the ideas on slide 9 but wanted to have the discussion in our meeting since we (as a team) have never discussed this as something we would be doing.
19:23:09 <Shamail> sarob_: This partly ties into one of the unstructure sessions at CLS that we both attended too
19:23:21 <sarob_> hmm, okay
19:23:36 <Shamail> I'll start the conversation with a question
19:23:44 <Shamail> questions*
19:24:15 <Shamail> Should we work with the Foundation to help operate a recognition program for contributions that "Solve problems that prevent future technical debt in an area that has a diverse/broad impact that can appreciated by the majority of the OpenStack community"
19:24:16 <Shamail> ?
19:24:50 <Shamail> And secondly, if so... Is that our charter or do we recommend spinning up some other group/effort to manage that criteria, operations, and general program?
19:25:28 <MeganR> I think a recognition program is a great idea, however, I agree with a sub-team to run with this - I can see this taking a lot of time
19:25:49 <sarob_> i forgot where we left it with ttx
19:25:51 <MeganR> how would we receive "nominations"
19:26:08 <sarob_> was he planning on following up as well?
19:26:22 <Shamail> No, but I think a follow up is probably in order.
19:26:35 <Shamail> Other people wanted to figure out strategic contributions too.
19:26:59 <Shamail> MeganR: Good question, the very loose critera right now is: Reduce technical debt, implement the most prioritized user stories in a single release, reduce barriers to adoption, reduce LoC w/o impairing functionality, etc.
19:27:14 <MeganR> ok, that's a good start
19:27:17 <Shamail> But A) Is this the right list? B) How do you track those items?
19:27:31 <Shamail> Seems more qualitative
19:27:41 <Shamail> I'll mark that as an action sarob_ (to follow up with ttx)
19:28:12 <Shamail> #action Discuss the "recognition" topic with ttx as a follow-up to CLS discussion
19:28:33 <sarob_> okay
19:28:43 <Shamail> MeganR: Sub-team seems like a good start.  That will let us make progress and also gauge the level of effort.
19:28:49 <Shamail> Alrighty, moving on!
19:29:01 <sarob_> i think the simplest is to create an apache badge fork project
19:29:17 <sarob_> but ill continue to discuss with ttx
19:29:35 <Shamail> Sounds good
19:29:48 <Shamail> Please feel free to pull in any of as you see fit
19:30:03 <Shamail> #topic Ops Mid cycle Meetup Session Coverage Plan
19:30:49 <Shamail> We were told multiple times that the ops summit is a great place to build user stories but that we would have to offer scribe type services to get the most feedback possible.
19:31:21 <Shamail> We need to figure out how many of us are attending and how to spread ourselves for converage.
19:31:29 <Shamail> Carol has put an Product WG overview on to the ops agenda
19:31:34 <MeganR> I just added my name to the etherpad
19:31:49 <Shamail> We are hoping that we can share the user story template by then
19:31:53 <Shamail> Thats great Carol!
19:31:57 <Shamail> MeganR: !
19:32:01 <MeganR> :)
19:32:04 <Shamail> sorry I was about to write something that Carol said lol
19:32:31 <Shamail> Carol also wanted us to figure out the Cross Project Liaisons for key project teams
19:32:52 <nateziemann> we have a list for attendance at the PWG meet-up.  is there an etherpad to track how many of us will be at Ops?
19:33:27 <Shamail> nateziemann: not that I know of...
19:33:37 <Shamail> Do you want to take a poll on the ML?
19:33:56 <Shamail> That would be a great starting point to know how much we can accomplish at the ops summit
19:34:31 <nateziemann> it would be a subset of the folks that updated our etherpad right.  Can we just update that and send out to the ML?
19:35:02 <Shamail> There is a more definitive source than the etherpad.. let me find it... brb
19:35:23 <Shamail> #link https://wiki.openstack.org/wiki/Sprints/Product_WGLibertySprint
19:35:28 <Shamail> This is the definitive list
19:35:36 <Shamail> and, yes, it would probably be a subset.
19:36:12 <MeganR> Thank you - I will update the Wiki page
19:36:22 <Shamail> We can add an Ops Summit column and send it to the ML so that people can enter that data
19:36:25 <Shamail> Thanks MeganR
19:36:34 <nateziemann> perfect
19:37:29 <Shamail> There, I just updated the page with the new column
19:38:14 <Shamail> nateziemann: Do you mind sending the email asking people to update the newly added column?
19:38:53 <Shamail> Okay, so I think we need to park the ops summit topic until we get a better sense of attendance.  Agree?
19:39:29 <MeganR> Agree
19:39:31 <nateziemann> agree.
19:39:37 <Shamail> Thanks!
19:39:40 <Shamail> Last topic...
19:39:42 <nateziemann> I will send out request to ML.
19:39:45 <Shamail> #topic Product Work Group Mid cycle Meetup Agenda
19:39:50 <Shamail> #link https://etherpad.openstack.org/p/productwg-liberty-midcycle-meetup
19:40:15 <Shamail> Please start proposing ideas for topics at the upcoming Product WG mid-cycle...
19:40:36 <Shamail> I plan to add Roadmap as a discussion item
19:40:49 <MeganR> perfect - I was going to ask about that
19:41:05 <Shamail> Heidi Joy from the OpenStack Foundation will be joining us partly for the mid-cycle and she will be working with our team on the roadmap updates
19:41:35 <Shamail> We have made great progress over the last couple of weeks in terms of cadence, responsibilities (Product WG and Foundation), and next steps.
19:41:52 <Shamail> I am hoping we can spend time at the mid-cycle to move into execution
19:42:22 <Shamail> MeganR: I haven't sent out updates yet because of travel... I am hoping we can start the feedback collection by milestone-3
19:42:32 <Shamail> Thanks for adding it to the etherpad nateziemann
19:43:33 <Shamail> If you can think of additional topics then lets add them to the proposed agenda.
19:43:48 * Shamail thinks the two day mid-cycle will be insanely productive
19:43:49 <nateziemann> how about finalizing the use case template.
19:44:00 <Shamail> +1 (if not done before then)
19:44:13 <Shamail> I plan to send an email out about it later this week.
19:44:27 <Shamail> Have received a lot of good feedback...
19:45:25 <Shamail> sarob_: which day would you be in Seattle? first or second?
19:45:36 <sarob_> first
19:45:57 <Shamail> Thanks
19:46:13 <Shamail> Let's try to propose items by next week and then start planning the actual schedule.
19:46:21 <Shamail> That is all that we had for today.
19:46:26 <Shamail> #topic Open Session
19:46:38 <sarob_> nothing more from me
19:46:39 <Shamail> Anything else that we should discuss?
19:47:24 <Shamail> Great!  I will send the schedule details about the Product WG update to the board
19:47:28 <Shamail> See you tomorrow nateziemann!
19:47:46 <Shamail> #endmeeting