13:03:38 <esberglu> #startmeeting powervm_driver_meeting
13:03:39 <openstack> Meeting started Tue Mar 14 13:03:38 2017 UTC and is due to finish in 60 minutes.  The chair is esberglu. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:42 <openstack> The meeting name has been set to 'powervm_driver_meeting'
13:06:09 <esberglu> #topic In Tree Driver
13:06:33 <efried> Getting feedback, working through comments.
13:06:45 <efried> mriedem is... thorough.
13:07:11 <efried> Some stuff is easily addressed.  Some stuff may not have a good answer, and may take a nontrivial amount of back and forth before it can be resolved satisfactorily.
13:07:24 <efried> But - working on it.
13:08:20 <efried> Once I've put up another rev on that first change, I'll need to rebase the whole pile again.  At least one comment is going to need to be applied manually to all the change sets.
13:08:52 <efried> After all of that, I'm not sure it's terribly productive for me to keep piling change sets on top until we've started to get some serious traction.
13:09:19 <esberglu> Okay. I was just about to say I need to rebase from #2, but sounds like I will hold off
13:09:28 <efried> Yeah, I'll take care of that.
13:09:44 <efried> That's all I have for in-tree.
13:10:13 <esberglu> #topic OOT driver
13:10:28 <adreznec> efried: is there anything breaking that we can't/wouldn't want to apply from the comments from your perspective? I didn't notice anything breaking, though he's right about the VIOS startup pause
13:10:55 <efried> adreznec Breaking how?
13:11:44 <adreznec> efried: Things that would be painfully heavy to maintain differently between IT and OOT, for example
13:11:56 <efried> I don't have a problem with the other 80% of his comments.  The copyright thing took some churn, but I've got a lengthy response for which the TLDR is that I'm gonna whack the "All Rights Reserved" throughout (which is the thing I need to carry forward into the other change sets).
13:12:03 <adreznec> Or cause major functional changes in how the driver behaves for people switching from OOT to IT down the road
13:12:13 <efried> But yeah, the Session timeout is going to be painful to resolve.
13:12:33 <efried> But as far as maintaining sync between IT/OOT, nothing's a real big deal.
13:12:44 <adreznec> Mostly worried about maintainability and consistency for eventual end users of the IT driver
13:13:04 <adreznec> Ok
13:13:05 <efried> Functionally I don't think there's anything that's going to change
13:13:17 <efried> (depending on the outcome of the Session timeout discussion)
13:13:32 <efried> But most of the things I'm changing IT, I'm proposing corresponding backports to OOT.
13:13:37 <efried> where appropriate.
13:13:42 <efried> Especially when they're improvements.
13:14:07 <efried> Okay, back to OOT?
13:14:13 <efried> esberglu Would changing our setuptools req in networking-powervm's requirements.txt allow us to pass CI in ocata?
13:14:40 <efried> We've got a consumer waiting for a fix that's not merging because of that snafu.
13:14:58 <esberglu> Depends. Let me check if the tempest change merged yet one sec
13:15:06 <efried> It didn't
13:15:10 <efried> at least as of 10 minutes ago.
13:15:51 <esberglu> Then no
13:16:07 <efried> bogus.
13:16:10 <esberglu> I believe you need both
13:16:31 <efried> How hard would it be for us to pull down that change set from gerrit when we clone tempest?
13:17:30 <esberglu> Not that hard, it would just take a CI redeploy. And then another redeploy once it merges
13:17:43 <esberglu> Or reusing that logic to not apply patches already in the commit chain
13:18:14 <esberglu> I thought these would merge faster...
13:18:24 <efried> "CI redeploy" sounds annoying.
13:18:56 <esberglu> Just the management nodes, but yeah it's annoying that's why the initial plan was to just wait it out
13:19:00 <efried> svenkat How urgently do you need https://review.openstack.org/443956 ?
13:19:17 <svenkat> efried checking...
13:19:48 <svenkat> it can wait.. not very urgent.
13:20:05 <efried> Okay.  So esberglu let's just sit on it.
13:20:41 <esberglu> Okay. Apparently they don't want to restrict setuptools to <34.0.0 so we might keep hitting this issue
13:20:46 <esberglu> on new versions of setuptools
13:21:04 <efried> Guess we'll burn that bridge when we come to it.
13:21:06 <esberglu> Until setuptools fixes the issue on their end
13:21:15 <adreznec> esberglu: Are other people not impacted by this? Or have they worked around it some other way in other CIs?
13:22:07 <esberglu> Not sure, didn't really look further into it once we had a fix lined up
13:22:25 <efried> You would think there would be more chatter if others were affected.
13:22:39 <efried> which leads one to wonder whether there's an easy workaround we're missing.
13:22:48 <adreznec> Right
13:22:56 <efried> esberglu Maybe ask in #openstack-qa ?
13:23:25 <efried> and/or try to find a launchpad bug?
13:24:12 <esberglu> Will do
13:24:16 <efried> oh, which reminds me (sorry to be jumping topics) - I think we should backport the VTerm 404 fix to ocata.
13:24:28 <esberglu> I can do that
13:24:39 <esberglu> #action esberglu: Port vterm 404 to ocata
13:24:44 <efried> This entails opening a launchpad bug and including it in the Closes-Bug: tag on the cherry-pick.
13:25:03 <esberglu> #action esberglu: Follow through on setuptools issue
13:25:15 <esberglu> Ok
13:25:44 <efried> I assume you know how to do all of that; let me know if you need help.
13:25:58 <esberglu> Anything else OOT? I don't have anything
13:26:14 <efried> Don't think so.
13:26:22 <esberglu> #topic CI
13:26:29 <adreznec> tjakobs is looking at starting on iSER support, but that's really it
13:26:38 <efried> what's iSER?
13:26:47 <adreznec> iSCSI extensions for RDMA
13:26:56 <adreznec> Basically faster/better performing iSCSI
13:27:12 <adreznec> Should be relatively small extensions to the existing rest/pypowervm/nova-powervm iSCSI flow
13:27:12 <efried> Wow, that's some serious nested acronymage.
13:30:40 <efried> Anything else?
13:30:41 <adreznec> Anyway, that's all I had there. Back to CI, the land of rainbows and unicorns
13:31:03 <esberglu> Merged that glance api tempest change
13:31:14 <efried> good
13:31:18 <esberglu> So we should be back to seeing passing master OOT and IT
13:31:57 <esberglu> That's it for me
13:34:54 <esberglu> Any other topics?
13:36:07 <adreznec> Anything Drew would normally be doing that we're missing?
13:37:04 <efried> Hah
13:37:22 <efried> Drew would be doing like presentations to execs and stuff.
13:37:24 <adreznec> Nope, ok, guess Drew wasn't doing anything
13:37:25 <adreznec> :P
13:37:30 <efried> He doesn't do *real* work anymore.
13:38:22 <adreznec> Poor guy
13:38:28 <efried> ikr
13:39:15 <efried> wedone?
13:39:23 <efried> callit
13:39:30 <adreznec> Looks like it
13:39:32 <esberglu> #endmeeting