19:02:36 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:02:37 <openstack> Meeting started Thu Jul  9 19:02:36 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:02:40 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:02:43 <amitgandhinz> #topic Roll Call
19:02:53 <obulpathi> o/
19:03:10 <miqui> 0/
19:03:54 <sriram> _/\_
19:04:04 <tonytan4ever> o/
19:04:27 <anantha> o/
19:04:37 <amitgandhinz> #link agenda https://wiki.openstack.org/wiki/Meetings/Poppy
19:05:53 <sriram> alright, action items.
19:05:54 <amitgandhinz> #topic Last Weeks Actions
19:06:05 <sriram> i know malini landed a lot of testing patches.
19:06:06 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-07-02-19.01.html
19:06:53 <amitgandhinz> malini: malini to get the outstanding security patches fixed and merged
19:07:05 <malini> I havent been able to work on tht
19:07:13 <malini> got pulled into something else
19:07:13 <amitgandhinz> #action malini to get the outstanding security patches fixed and merged
19:07:20 <amitgandhinz> malini to clean up/fix the many test related patches that have been out there for a while
19:07:26 <malini> same story :(
19:07:37 <amitgandhinz> i see the end to end tests got fixed?
19:07:45 <malini> finally one!
19:07:50 <amitgandhinz> we need some reviews https://review.openstack.org/#/c/198097/
19:07:51 <malini> yes - thwy can run now
19:08:09 <amitgandhinz> also this one https://review.openstack.org/#/c/199214/
19:08:22 <malini> I will also need to add tests for hostheader, ip/geo restriction
19:08:33 <amitgandhinz> ok
19:08:42 <sriram> ok will review them
19:08:55 <amitgandhinz> #action malini to clean up/fix the many test related patches that have been out there for a while
19:09:22 <amitgandhinz> #topic Liberty 2 Updates
19:09:24 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-2
19:09:48 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/geo-restrictions
19:09:52 <amitgandhinz> this needs reviews
19:09:58 <amitgandhinz> its been sitting there for a while now
19:10:05 <tonytan4ever> Yes
19:10:16 <amitgandhinz> tonytan4ever: looks like its in merge conflict
19:10:21 <amitgandhinz> https://review.openstack.org/#/c/163598/
19:10:30 <miqui> geo restrictions depend on the provider ?
19:10:33 <tonytan4ever> I will resolve that.
19:10:43 <amitgandhinz> tonytan4ever: also i commented on https://review.openstack.org/#/c/163563/13 earlier
19:10:55 <sriram> #action sriram to review all patches
19:10:58 <amitgandhinz> its almost there, just a minor change needed in validation
19:11:13 <amitgandhinz> it too is now in merge conflict
19:11:18 <amitgandhinz> did something get merged lol
19:11:42 <tonytan4ever> OK I will address those merge conflict first.
19:11:47 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/ip-restrictions
19:11:52 <amitgandhinz> this is also now in review right?
19:11:55 <tonytan4ever> That one is in review as well
19:12:01 <tonytan4ever> Yes.
19:12:15 <amitgandhinz> #action tonytan4ever to hound people to review his stuff
19:12:18 <malini> we need to start adding the bp tag in commit messages
19:12:31 <miqui> tonytan4ever: count me in...
19:12:33 <sriram> malini: +1
19:12:58 <amitgandhinz> #agreed add bp tag to branch names
19:13:11 <tonytan4ever> Will do
19:13:14 <amitgandhinz> btw its in the contributing docs to do this
19:13:23 <amitgandhinz> bug// tag if its a bug
19:13:24 <tonytan4ever> add bp tags.
19:13:40 <sriram> yeah, we need to enforce it on reviews as well.
19:13:44 <amitgandhinz> so the above branch should be bp/ip-restriction-implementation
19:13:45 <amitgandhinz> and so on
19:13:59 <amitgandhinz> if its a bug, it should be bug/12312414
19:14:12 <sriram> it should also says implements bp in the commit message
19:14:17 <sriram> s/says/say
19:14:25 <amitgandhinz> yes that too
19:14:40 <amitgandhinz> lets enforce that when we are code reviewing also
19:15:01 <amitgandhinz> ok bugs
19:15:07 <amitgandhinz> malini: https://bugs.launchpad.net/poppy/+bug/1468877
19:15:07 <openstack> Launchpad bug 1468877 in Poppy "Get the end to end tests running" [Critical,In progress] - Assigned to Malini Kamalambal (malini-pk)
19:15:23 <malini> to add tht in commit messge too :/
19:15:23 <amitgandhinz> malini needs to add the Closes Bug in her commit messages ;-0
19:16:09 <amitgandhinz> i will keep it in progress.  malini if you can update the commit message, then the bug will update its status automagically
19:16:14 <malini> ok
19:16:23 <amitgandhinz> sriram: https://bugs.launchpad.net/bugs/1425556
19:16:23 <openstack> Launchpad bug 1425556 in Poppy "dns-exception-handling" [Low,New] - Assigned to Sriram (thesriram)
19:16:23 <sriram> magic!
19:16:39 <sriram> amitgandhinz: i'm working on a patch for that.
19:16:46 <sriram> will have a patchset out soon.
19:16:55 <amitgandhinz> ok cool, updated its status
19:17:05 <sriram> it will reduce the running time of the api tests by a loooot
19:17:11 <amitgandhinz> woot!
19:17:29 <amitgandhinz> ok anything else being worked on?
19:17:34 <malini> On tht note, we need to take a look at the api tests for coverage gaps
19:17:42 <sriram> +1
19:17:43 <malini> the log delivery was a nasty reminder
19:17:46 <amitgandhinz> can we automate that?
19:17:53 <amitgandhinz> get a nice number output
19:18:01 <malini> I am not sure how to, I will start poking around
19:18:08 <amitgandhinz> cool
19:18:20 <sriram> I know we can do coverage for unit tests
19:18:24 <amitgandhinz> we also need to get our code coverage back up (im not sure where we are right now)
19:18:26 <sriram> i'm not sure about api.
19:18:41 <sriram> amitgandhinz: we are in the low 80s I think
19:18:55 <miqui> amitgandhinz: what are we using for code coverage?
19:19:02 * sriram has to run test suite soon for his patch anyway
19:19:05 <amitgandhinz> nosetests
19:19:16 <miqui> ah ..k. thanks
19:19:21 <amitgandhinz> miqui: this might be one you can start contributing to
19:19:41 <amitgandhinz> you can pick a class at a time that needs its code coverage improved
19:19:54 <miqui> k, sounds good..
19:19:56 <amitgandhinz> if you run tox it will output a report at the end of the tests showing code coverage
19:20:04 <miqui> is there a bp for it?
19:20:15 <amitgandhinz> not yet.  feel free to create one
19:20:24 <miqui> ok, will do...
19:20:27 <amitgandhinz> thanks miqui
19:20:47 <amitgandhinz> ok any other bp or bugs being worked on?
19:21:10 <obulpathi> I am working on rootdomain validation
19:21:19 <amitgandhinz> is there a bug for that?
19:21:21 <obulpathi> working on api tests, will send out the pr soon
19:21:27 <obulpathi> not sure
19:21:33 <obulpathi> I will create one, if its not there
19:21:54 <sriram> lets create bps/bugs for any features we work on
19:21:54 <amitgandhinz> ok...moving on now
19:21:58 <amitgandhinz> _1
19:21:59 <amitgandhinz> +1
19:22:05 <amitgandhinz> +1
19:22:06 <sriram> probably needs to be an action item
19:22:15 <sriram> so thats a +3? :P
19:22:16 <amitgandhinz> i put it as an agreed item
19:22:20 <sriram> cool
19:22:33 <amitgandhinz> no, the first is a negative.  the second makes it zero.  the third makes it a +1
19:22:53 <sriram> technically thats an underscore.. :P
19:22:58 <amitgandhinz> #topic Tokyo
19:23:06 <amitgandhinz> #link https://etherpad.openstack.org/p/poppy_tokyo
19:23:25 <amitgandhinz> Okay, this is what we discussed last week for the submission
19:23:34 * sriram clicks
19:23:40 <amitgandhinz> are these two proposals good to go?
19:23:53 <amitgandhinz> i want to make my submissions today
19:24:36 <malini> Can one of the tracks be 'Related OSS Projects' ?
19:25:00 <sriram> malini: umm, similar to poppy?
19:25:01 <amitgandhinz> IMO that track is a bit harder to get ino
19:25:03 <amitgandhinz> into
19:25:16 <malini> aah..ok.I have no clue
19:25:26 <amitgandhinz> the past 2 summits i have submitted under related
19:25:43 <amitgandhinz> i think we can get a broader audience under networking
19:26:04 <malini> we shud have getting high on poppy under Hands-on Labs  ;)
19:26:23 <malini> FYI - tht was not serious
19:26:59 <sriram> lol
19:27:10 <sriram> the proposals look good to me.
19:28:22 <miqui> +1
19:28:32 <tonytan4ever> +1
19:28:44 <miqui> i wonder if CDN is high on an operators list....
19:28:58 <miqui> am going to ask the Helion team....
19:29:12 <amitgandhinz> that would be great miqui
19:31:02 <amitgandhinz> ok if no updates i will make these submissions after some minor cleanups
19:31:12 <amitgandhinz> #topic Open Discussion
19:31:18 <amitgandhinz> anything else on peoples minds?
19:31:52 <miqui> how can poppy api be tested effectivly without using a provider?
19:32:18 <sriram> mimic?
19:32:30 <miqui> i mean how do you folks test locally?
19:32:31 <amitgandhinz> the fastly mimic driver should? work
19:32:50 <amitgandhinz> you can also sign up for a free fastly dev account (no cc needed)
19:32:56 <miqui> sometimes i dont understand what the api is returning...
19:32:59 <malini> miqui: https://github.com/rackerlabs/mimic has fastly integrated
19:33:15 <miqui> perhaps the route is working...i just understand the meaning of the payload..
19:33:27 <miqui> thanks malini
19:33:31 <malini> miqui: you can run the mimic server & point to mimic endpoint instead of fastly in poppy.conf
19:33:43 <miqui> hmm
19:34:01 <miqui> so why not make mimic the default?
19:34:11 <malini> default in ?
19:34:15 <miqui> poppy.conf
19:34:18 <amitgandhinz> i think right now the default is the mock driver
19:34:24 <amitgandhinz> which really just needs to go away
19:34:33 <amitgandhinz> thats prob whats confusing you
19:34:48 <miqui> hmm perhaps..
19:35:10 <miqui> ok..will dig some more...thanks..
19:35:15 <amitgandhinz> ok, i will spend some time this week to see if i can make the mimic fastly driver the default also
19:35:26 <amitgandhinz> #action amitgandhinz to make mimic fastly the default driver
19:37:35 <amitgandhinz> ok anything else?
19:37:56 <miqui> thats it for me.. thanks guys!
19:38:05 <amitgandhinz> np
19:38:05 <sriram> nope, I'm good
19:38:09 <tonytan4ever> I am good
19:38:18 <amitgandhinz> #endmeeting