19:01:38 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:01:39 <openstack> Meeting started Thu Jul  2 19:01:38 2015 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:01:43 <sriram> o/
19:01:43 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:01:47 <malini> o/
19:01:54 <amitgandhinz> #topic roll call
19:02:05 <mpanetta> o/
19:02:16 <tonytan4ever> o/
19:02:43 <miqui> 0/
19:02:55 <amitgandhinz> #link Agenda https://wiki.openstack.org/wiki/Meetings/Poppy
19:03:01 <amitgandhinz> #topic Review Last Weeks Items
19:03:13 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2015/poppy_weekly_meeting.2015-06-25-19.00.html
19:03:38 <amitgandhinz> amitgandhinz and malini to groom the bugs
19:03:41 <amitgandhinz> this is done
19:03:47 <malini> thx amitgandhinz
19:03:50 <amitgandhinz> i also made the liberty-1 release
19:04:00 <sriram> woot
19:04:04 <sriram> that is great
19:04:06 <amitgandhinz> groomed the liberty-2 backlog items that we should aim to accomplish
19:04:12 <amitgandhinz> liberty-2 ends July 30
19:04:32 <amitgandhinz> malini to work with michaelxin to get the outstanding patches merged
19:04:38 <amitgandhinz> malini: any update on that?
19:04:51 <malini> they have been  busy :/
19:05:07 <malini> maybe I can pick up the outstanding ones & fix them
19:05:17 <malini> its mainly pep8 & addressing review comments
19:05:32 <amitgandhinz> yeh i think anyone should be able to fix the issues with the patches that are out there
19:05:48 <malini> I will pick those up
19:05:48 <amitgandhinz> there are also a whole bunch of test related patches that either need to be fixed or abandoned
19:06:05 <sriram> yeah
19:06:08 <malini> I will clean up those as well
19:06:11 <amitgandhinz> #action malini to get the outstanding security patches fixed and merged
19:06:38 <amitgandhinz> #action malini to clean up/fix the many test related patches that have been out there for a while
19:06:59 <amitgandhinz> #topic Liberty-2 Updates
19:07:01 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/liberty-2
19:07:21 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/security-testing
19:07:26 <amitgandhinz> malini: can i reassign this to you?
19:07:33 <malini> hmm..no
19:07:44 <malini> I will just fix the outstanding
19:07:49 <amitgandhinz> isnt this just getting those patches merged?
19:07:58 <amitgandhinz> or are there more that we havent even seen yet?
19:07:58 <malini> but the new ones should come from michael
19:08:06 <malini> there are more to come
19:08:10 <amitgandhinz> ok
19:08:30 <amitgandhinz> im thinking then to move this out of liberty-2 and make it ongoing
19:08:42 <malini> +1
19:08:48 <amitgandhinz> changed
19:09:11 <amitgandhinz> miqui: https://blueprints.launchpad.net/poppy/+spec/devstack
19:09:29 <miqui> hi amitgandhinz, am about to give up on this one....
19:09:49 <amitgandhinz> ok i will take your name off it then
19:10:16 <miqui> might switch to fixing defects...etc..etc..
19:10:38 <malini> do we even need devstack?
19:10:41 <amitgandhinz> ok.  there are a bunch of low hanging bugs that can be picked up.  that might be a good place to start
19:10:51 <miqui> k, amitgandhinz
19:10:52 <amitgandhinz> malini: if we want to be part of big tent i think it would be a good idea
19:10:52 <malini> maybe containerize the whole thing & use tht to run tests at the gate?
19:11:04 <amitgandhinz> malini: for the gate, docker +1
19:11:27 <amitgandhinz> but for openstack, we should have devstack as that is what they are used to
19:11:31 <miqui> dont we have poppy already containerized?
19:11:52 <malini> miqui: we need the mimic stuff etc. added
19:12:00 <amitgandhinz> miqui: yes, but its been broken for the poppy api service part ever since we moved to using taskfow and workers
19:12:02 <miqui> ah...i see..
19:12:14 <amitgandhinz> ive been working on fixing that the past couple of days
19:12:21 <amitgandhinz> i think im almost done getting it fixed
19:12:26 <miqui> ah k.
19:12:30 <malini> it'll be great to have the api tests running at the gate
19:12:38 <sriram> +1
19:12:44 <amitgandhinz> malini: i agree.  for that we need to be able to mimic the providers
19:12:49 <malini> I am spending quite some time fixing the broken stuff
19:12:56 <amitgandhinz> and then run docker with the mimic stuff
19:13:05 <malini> we can start with one provider?
19:13:08 <amitgandhinz> ya
19:13:14 <malini> fastly is already mimic -ked
19:13:24 <amitgandhinz> might be a good place to start then
19:13:28 <malini> akamai is almost there
19:13:31 <amitgandhinz> cool
19:14:01 <amitgandhinz> ok...moving back on topic
19:14:11 <amitgandhinz> tonytan4ever: https://blueprints.launchpad.net/poppy/+spec/geo-restrictions
19:14:27 <tonytan4ever> This one I would say it's under review
19:14:43 <amitgandhinz> updated/
19:14:49 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/ip-restrictions
19:15:00 <amitgandhinz> tonytan4ever: are you planning on picking this one up>
19:15:01 <tonytan4ever> I am still waiting for Akamai's feedback on how to implement their policy, but PR is ready for review
19:15:15 <tonytan4ever> I am getting it started today.
19:15:21 <tonytan4ever> the IP restriction one.
19:15:38 <tonytan4ever> So I would say it is in Started status.
19:15:55 <amitgandhinz> updated
19:16:03 <tonytan4ever> k
19:16:07 <amitgandhinz> https://blueprints.launchpad.net/poppy/+spec/akamai-ssl-driver
19:16:22 <amitgandhinz> this one needs some discussion before we can pick it up
19:16:42 <tonytan4ever> Yeah, next Tuesday we have a design session on it.
19:16:46 <amitgandhinz> ya
19:17:08 <amitgandhinz> bugs
19:17:10 <amitgandhinz> malini: https://bugs.launchpad.net/bugs/1468877
19:17:10 <openstack> Launchpad bug 1468877 in Poppy "Get the end to end tests running" [Critical,New] - Assigned to Malini Kamalambal (malini-pk)
19:17:21 <malini> I am working on tht
19:17:34 <malini> it isn't as bad
19:17:41 <amitgandhinz> cool
19:18:02 <amitgandhinz> ok, anything else in progress we need to talk about?
19:18:30 <amitgandhinz> #topic New Items
19:18:42 <amitgandhinz> #link https://etherpad.openstack.org/p/poppy_tokyo
19:18:50 <amitgandhinz> #topic Poppy Submission for Tokyo
19:18:52 <amitgandhinz> #link https://etherpad.openstack.org/p/poppy_tokyo
19:18:53 <sriram> I just want to address that https://bugs.launchpad.net/poppy/+bug/1425556 also needs to be worked on
19:18:53 <openstack> Launchpad bug 1425556 in Poppy "dns-exception-handling" [Low,New]
19:18:58 <sriram> and I'll take it up.
19:19:15 <amitgandhinz> assigned
19:19:33 <amitgandhinz> ok, lets talk about Tokyo
19:19:39 <amitgandhinz> the deadline for submissions is July 15
19:19:49 <amitgandhinz> i want to brainstorm our submission(s)
19:19:54 <amitgandhinz> we can do more than one submission
19:21:40 <sriram> the content is going to be more or less the same right?
19:22:31 <sriram> do we want showcase something in particular?
19:23:20 <amitgandhinz> i think we still have a tough job getting mindshare
19:24:32 <amitgandhinz> can everyone put their name against their color in the dropdown window
19:24:44 * amitgandhinz thinks malini see's me typing before i hit enter
19:25:10 <malini> I think thts how it is -rt?
19:25:13 <tonytan4ever> Where is the etherpad ?
19:25:23 <amitgandhinz> https://etherpad.openstack.org/p/poppy_tokyo
19:34:19 <amitgandhinz> ok i think these are two good submissions
19:34:30 <amitgandhinz> i'll tweak these a bit next week and then submit then
19:34:41 <sriram> ok cool
19:34:54 <amitgandhinz> #topic Open Discussion
19:35:07 <amitgandhinz> any thing anyone wants to discuss/
19:35:34 <sriram> I'm good
19:36:33 <amitgandhinz> ok if nothing else, then everyone have a great 4th of July weekend!
19:36:59 <sriram> woot
19:37:02 <amitgandhinz> #endmeeting