19:00:22 <amitgandhinz> #startmeeting Poppy Weekly Meeting
19:00:23 <openstack> Meeting started Thu Dec 18 19:00:22 2014 UTC and is due to finish in 60 minutes.  The chair is amitgandhinz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:26 <openstack> The meeting name has been set to 'poppy_weekly_meeting'
19:00:29 <amitgandhinz> #topic Roll Call
19:00:33 <malini> o/
19:00:37 <mpanetta> o/
19:00:45 <catherineR> o/
19:01:15 <obulpathi> o/
19:01:18 <tonytan4ever> o/
19:01:32 <miqui_> hello
19:01:33 <wbrothers> o/
19:01:41 <amitgandhinz> #link https://wiki.openstack.org/wiki/Meetings/Poppy
19:01:53 <amitgandhinz> #topic Review Last Weeks Action Items
19:02:02 <amitgandhinz> #link http://eavesdrop.openstack.org/meetings/poppy_weekly_meeting/2014/poppy_weekly_meeting.2014-12-11-19.00.html
19:02:19 <amitgandhinz> i had the only action item - amitgandhinz to set up a design discussion on the Message Queue Driver in early January
19:02:28 <amitgandhinz> i'll set that up after the break
19:02:35 <amitgandhinz> * as in the holiday break
19:02:46 <tonytan4ever> Sounds good to me.
19:02:46 <amitgandhinz> #action amitgandhinz to set up a design discussion on the Message Queue Driver in early January
19:03:02 <miqui_> where does the discussion take place?
19:03:03 <miqui_> in irc?
19:03:08 <amitgandhinz> miqui_: yes
19:03:14 <miqui_> ah k..
19:03:44 <amitgandhinz> i will set up a time probably arrange it at the next weekly meeting, and we can all chat about the design onthe normal irc channel at the agreed upon date/time
19:03:46 <cpowell> \o
19:04:00 <miqui_> +12
19:04:10 <amitgandhinz> #topic Review Blueprints and Bugs
19:04:13 <amitgandhinz> #link https://launchpad.net/poppy/+milestone/kilo-2
19:04:26 <amitgandhinz> okay....going through the blueprints....
19:04:46 <amitgandhinz> miqui_: any update on the home doc?
19:05:20 <miqui_> not much....sorry guys, very slow progress on it...although spent some time doing reviews instead...
19:05:34 <amitgandhinz> thanks for the reviews =)
19:05:40 <miqui_> sure..
19:05:48 <amitgandhinz> always great to get them and a great way to learn and keep up
19:06:10 <miqui_> indeed...
19:06:24 <amitgandhinz> malini: any update to moving the provider urls to conf files?
19:06:36 <malini> no
19:06:41 <malini> tht'll be in jan too
19:06:42 <amitgandhinz> whats left on this one?
19:07:07 <malini> we currently have this for fastly & akamai
19:07:16 <malini> need to add the rest of the providers too
19:07:40 <obulpathi> we have for dns too
19:07:58 <malini> cool obulpathi
19:09:09 <amitgandhinz> sorry just updating the work items on that...
19:09:48 <amitgandhinz> ok...
19:09:59 <amitgandhinz> py34 support (thats me!)
19:10:16 <amitgandhinz> this is implemented, i do need to update the gate jobs to start running the py3 packages
19:10:41 <amitgandhinz> also relating to that, py33 jobs are currently failing in Jenkins due to an issue with sphinx stuff (unrelated to poppy)
19:11:01 <amitgandhinz> someone upstream is working on it - there has been some discussion on the dev list regarding this
19:11:17 <amitgandhinz> obulpathi: DNS plugin for Mimic
19:11:26 <obulpathi> I finished the identity part of it
19:11:28 <tonytan4ever> amitgandhinz: py34 will be affected by this issue too.
19:11:39 <amitgandhinz> tonytan4ever: thats correct
19:11:40 <obulpathi> make the identity plugin support global endpoints
19:11:47 <obulpathi> and the rest is in same status
19:12:02 <obulpathi> once I fix the dns bugs
19:12:05 <obulpathi> will move to this one
19:12:22 <amitgandhinz> ok
19:12:34 <amitgandhinz> any other blueprints in progress not captured/discussed here?
19:12:58 <malini> https://blueprints.launchpad.net/poppy/+spec/endtoend-tests
19:13:15 <wbrothers> should the akamai mimic be represented there?
19:13:21 <malini> I was smart enough not to refer to tht in my commit message :-$
19:14:10 <amitgandhinz> whats the status on this bp?
19:14:36 <malini> amitgandhinz: the patch is merged - I have another patch for review eith some minor additions
19:14:40 <malini> good progress
19:15:50 <amitgandhinz> cool, anything else?
19:16:04 <malini> wbrothers had a question
19:16:18 <malini> Shud we capture MImic + Akamai in bp?
19:16:19 <amitgandhinz> wbrothers: yes i think it should
19:16:33 <wbrothers> okie dokie
19:16:51 <amitgandhinz> we should also update the wiki for providers to indicate that they should build mimic plugins for their api's
19:17:06 <malini> amitgandhinz: +1
19:17:22 <amitgandhinz> can you take care of that malini or wbrothers?
19:17:27 <obulpathi> +1 for mimic api
19:17:31 <malini> I can
19:17:52 <wbrothers> I will assist malini
19:18:00 <amitgandhinz> #action malini to add doc to cdn vendor wiki page on how to add a mimic plugin for their api
19:18:07 <malini> thanks wbrothers
19:18:16 <amitgandhinz> ok....
19:18:19 <amitgandhinz> #topic bugs
19:18:39 <amitgandhinz> #link https://bugs.launchpad.net/bugs/1401306
19:18:41 <uvirtbot> Launchpad bug 1401306 in poppy "returned links don't show https when required" [Critical,New]
19:18:59 <amitgandhinz> i believe this is waiting on nginx setup before poppy work begins?
19:19:05 <tonytan4ever> This one seems to be in progress by Dev guys.
19:19:05 <amitgandhinz> mpanetta: tonytan4ever ?
19:19:27 <mpanetta> amitgandhinz: nginx is set up now.  Is that one in master yet?
19:19:31 <amitgandhinz> does poppy need updated code to look at the X-Forwarded-For header?
19:19:53 <mpanetta> If it does not have it, yes.  And also X-Forwarded-Proto
19:20:09 <amitgandhinz> mpanetta: no, i dont think code has been written yet.  thats what we are trying to determine
19:20:15 <mpanetta> Ah ok
19:20:26 <amitgandhinz> so its the X-Forwarded-For and X-Forwarded-Proto headers?
19:20:29 <amitgandhinz> what do those contain?
19:20:30 <tonytan4ever> I need to test this out in poppy to determine if any code is needed.
19:20:49 <amitgandhinz> ok tonytan4ever please work with mpanetta to figure this out and the changes needed
19:21:04 <mpanetta> X-Forwarded-For contains the IP of the person connecting to the API, X-Forwarded-Proto is either http or https
19:21:11 <amitgandhinz> oic
19:21:46 <mpanetta> In nginx I am currently forcing that header to https
19:22:02 <mpanetta> Much better then doing it in poppy config IMO... Once we get this working that is.
19:22:18 <tonytan4ever> repose need to add that head to whitelist too, right ?
19:22:29 <tonytan4ever> I mean header.
19:22:29 <cpowell> no repose is fine
19:22:33 <mpanetta> I don't believe so, but I can test to determine.
19:22:53 <mpanetta> We didn't need to whitelist the other header.
19:23:17 <cpowell> we are not doing whitelisting, we are blacklisting
19:23:52 <mpanetta> Yep
19:24:02 <tonytan4ever> OK. I will work with you guys further to see if any code should be added.
19:24:19 <amitgandhinz> cool
19:24:33 <amitgandhinz> #link https://bugs.launchpad.net/bugs/1394720
19:24:34 <uvirtbot> Launchpad bug 1394720 in poppy "API Tests failing for Service Actions" [Medium,New]
19:24:39 <tonytan4ever> If pecan is aware of this header then no code is needed.
19:24:57 <amitgandhinz> this one requires the use of mimic to mimic the deploy status on the provider end
19:25:15 <amitgandhinz> i think this is the last major chunk of apitests that are currently failing
19:25:26 <malini> yeap
19:25:44 <amitgandhinz> we probably just need tox to spin up docker instances with mimic linked and it should hopefully work
19:26:00 <amitgandhinz> the next bug is...
19:26:12 <amitgandhinz> #link https://bugs.launchpad.net/bugs/1401636
19:26:13 <uvirtbot> Launchpad bug 1401636 in poppy "service gets struct in "create in progress" status" [Medium,New]
19:26:20 <obulpathi> I am working on this one
19:26:26 <amitgandhinz> ok cool
19:26:32 <obulpathi> I am adding tests to make sure dns has 100% test coverage
19:26:37 <amitgandhinz> awesome
19:26:45 <obulpathi> will roll out a fix tomorrow along with the tests
19:27:00 <amitgandhinz> #link https://bugs.launchpad.net/bugs/1375341
19:27:01 <uvirtbot> Launchpad bug 1375341 in poppy "Error Messages in test logs" [Low,Invalid]
19:27:06 <amitgandhinz> miqui_: i saw your comments on this
19:27:13 <miqui_> yup
19:27:27 <amitgandhinz> i had a look at the sample also, and saw the lines have TRACE, ERROR etc already assigned
19:27:39 <miqui_> i hope i made a good point...
19:27:41 <amitgandhinz> so i think this was just a config setting missing when running the tests
19:27:46 <amitgandhinz> you did =)
19:27:47 <miqui_> yeah...
19:27:54 <amitgandhinz> i marked the bug as invalid
19:27:57 <miqui_> k
19:27:58 <amitgandhinz> is that ok?
19:28:04 <miqui_> sure +1
19:28:15 <miqui_> is invalid = closed?
19:28:31 <amitgandhinz> kind of - there is no closed option
19:28:39 <miqui_> k
19:28:47 <amitgandhinz> #link https://bugs.launchpad.net/bugs/1381114
19:28:48 <uvirtbot> Launchpad bug 1381114 in poppy "Create Flavor - Flavor Limits not validated or saved" [Low,Confirmed]
19:29:12 <amitgandhinz> im thinking of marking this as invalid too since we have a bp for this -> https://blueprints.launchpad.net/poppy/+spec/flavor-limits
19:29:28 <malini> works for mw
19:29:30 <malini> me
19:30:23 <obulpathi> good for me
19:30:37 <tonytan4ever> k
19:30:42 <amitgandhinz> ok everything else has a patch needing review/merge or is already done
19:30:49 <amitgandhinz> lots of bugs found and closed so good work =)
19:30:58 <malini> wooot!
19:31:04 <obulpathi> wooot :)
19:31:10 <amitgandhinz> just need the py3 issue resolved upstream so more can be merged lol
19:31:14 <wbrothers> Yay!
19:31:25 <cpowell> yes
19:31:30 <miqui_> ...nice...
19:31:54 <amitgandhinz> #topic New Items
19:32:01 <amitgandhinz> Nothing on the agenda here =P
19:32:06 <amitgandhinz> #topic Open Discussion
19:32:22 <amitgandhinz> anyone want to discuss anything - note there will be no meeting the next 2 weeks
19:32:39 <amitgandhinz> Christmas Day and News Years Day both are on Thursday
19:32:49 <miqui_> amit
19:33:05 <amitgandhinz> yes miqui_
19:33:05 <miqui_> on the openstack project TC decision
19:33:06 <tonytan4ever> That is not coincidence
19:33:15 <miqui_> then i think this is good for poopy right?
19:33:32 <amitgandhinz> #link http://governance.openstack.org/resolutions/20141202-project-structure-reform-spec.html
19:34:03 <amitgandhinz> so for context, the TC has been reevaluating how projects are accepted into Openstack
19:34:10 <amitgandhinz> the incubation and graduation process etc
19:34:33 <amitgandhinz> and how it stretches various parts of the openstack org as more projects come on board
19:34:50 <amitgandhinz> so we should start to see more fleshed out decisions on this in the new year
19:34:58 <amitgandhinz> but i think this is a good direction
19:35:12 <amitgandhinz> it means that new projects such as poppy have a better chance of being widely accepted
19:35:21 <miqui_> would this help in faster incubation for projects like poopy?
19:35:26 <miqui_> poppy...
19:35:30 <miqui_> gees i cant type today...
19:35:41 <amitgandhinz> i think the concept of incubation and graduation go away
19:35:47 <miqui_> hmmm
19:35:54 <amitgandhinz> instead it becomes "are you following the openstack process"
19:35:58 <miqui_> ..interesting...
19:36:06 <obulpathi> thats better
19:36:07 <amitgandhinz> and if you meet certain requirements then you become "openstack"
19:36:09 <miqui_> make sense...
19:36:17 <amitgandhinz> and there is a core openstack that is distributed
19:36:34 <amitgandhinz> but then all these other projects that work within the ecosystem are also available
19:36:43 <malini> it becomes sort of like publishing an app in the app store
19:36:44 <amitgandhinz> they arent required to be installed by every openstack vendor
19:36:47 <malini> the best app wins
19:36:47 <amitgandhinz> but they are available
19:36:59 <amitgandhinz> and they will work with all distributions
19:38:12 <amitgandhinz> any questions/concerns on this
19:38:21 <amitgandhinz> i think we will get more info in the coming months on this
19:38:23 <miqui_> ..nope...thanks all clear
19:38:30 <amitgandhinz> cool
19:38:37 <amitgandhinz> thanks for bringing it up
19:38:46 <miqui_> our goal does not change: make poppy a good option to use
19:38:53 <amitgandhinz> exactly
19:39:15 <amitgandhinz> To provide a generic, vendor-neutral API that wraps provisioning instructions for CDN vendors that support it.
19:39:51 <amitgandhinz> ok
19:40:02 <amitgandhinz> anything else ya'll want to talk about?
19:40:20 <obulpathi> nothing from me
19:40:28 <malini> nothing from me
19:40:33 <tonytan4ever> I am good
19:40:37 <wbrothers> it's "y'all"
19:40:39 <miqui_> am good
19:40:48 <catherineR> good here!
19:40:56 <wbrothers> Good Here
19:40:59 <malini> wbrothers: there is more than one right way
19:41:14 <amitgandhinz> okay, thanks ya'll ! =P
19:41:19 <amitgandhinz> happy holidays
19:41:20 <malini> :S
19:41:25 <miqui_> thanks...and have a good break folks!
19:41:29 <wbrothers> :|
19:41:31 <amitgandhinz> #endmeeting