19:00:40 <sriram> #startmeeting poppy
19:00:41 <openstack> Meeting started Thu Oct  1 19:00:40 2015 UTC and is due to finish in 60 minutes.  The chair is sriram. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:45 <openstack> The meeting name has been set to 'poppy'
19:00:55 <sriram> o/
19:00:56 <tonytan4ever> o/
19:01:14 <sriram> hello hello, anyone else joining us?
19:01:25 <cathR> o/
19:02:04 <sriram> #topic Review last weeks Action Items
19:02:29 <sriram> #link http://eavesdrop.openstack.org/meetings/poppy/2015/poppy.2015-09-24-19.00.html
19:02:41 <sriram> well, what do we have here..
19:03:00 <cpowell> \o
19:03:06 <sriram> amit isnt here today, so I guess his action item will be carried forward.
19:03:13 <sriram> hello there cpowell
19:03:39 <sriram> #action amitgandhinz to resurrect https://review.openstack.org/143192
19:04:03 <sriram> Thats it under action items
19:04:22 <tonytan4ever> Yeah, just roll over to next one.
19:04:25 <sriram> Moving on.
19:04:39 <sriram> #topic Liberty-3 updates
19:04:49 <sriram> #link https://launchpad.net/poppy/+milestone/liberty-3
19:05:12 <sriram> https://blueprints.launchpad.net/poppy/+spec/akamai-ssl-driver
19:05:16 <sriram> tonytan4ever: ^
19:05:40 <tonytan4ever> I will leave this one still in good progress.
19:05:54 <sriram> do you have any patchsets to be reviewed?
19:06:01 <tonytan4ever> The first part, create ssl cert endpoint is released and read for test.
19:06:07 <sriram> lets put them up as actions items ;)
19:06:21 <tonytan4ever> Ok
19:06:53 <sriram> #action Everyone to review https://review.openstack.org/#/c/224955/
19:06:57 <tonytan4ever> https://review.openstack.org/#/c/224955/ this one needs further review
19:07:11 <sriram> I read your mind there ;)
19:07:19 <tonytan4ever> And this one; https://review.openstack.org/#/c/227009/
19:07:25 <tonytan4ever> could use some review as well,
19:07:35 <sriram> #action Everyone to review https://review.openstack.org/#/c/227009/
19:08:02 <sriram> awesome, we now have some action items, that means we cant get away without doing any work haha
19:08:19 <tonytan4ever> Yeah
19:08:26 <sriram> https://blueprints.launchpad.net/poppy/+spec/mimic-racksapce-dns
19:08:55 <sriram> I think amit was working on this for a while, but he un-assigned himself.
19:09:10 <sriram> if anyone has leverage, feel free to pick that up!
19:09:26 <sriram> https://blueprints.launchpad.net/poppy/+spec/code-coverage
19:09:40 <sriram> is miqui here?
19:10:03 <sriram> I dont think so, I remember him mentioning that it was slow progress.
19:10:16 <sriram> so I guess we can keep it at that
19:10:25 <sriram> https://blueprints.launchpad.net/poppy/+spec/gate-api-tests
19:10:55 <sriram> Again amit had some work there, I can pick that up soon.
19:11:12 <sriram> the last one is Devstack
19:11:12 <sriram> https://blueprints.launchpad.net/poppy/+spec/devstack
19:12:14 <sriram> miqui had picked it up, and had been working through it. malini also has some experience working with devstack, so if anyone wants to work on that.
19:12:22 <sriram> They could be your go-to people.
19:12:29 <sriram> tonytan4ever: ^
19:12:53 <tonytan4ever> OK
19:13:06 <sriram> I think that pretty much covers our blueprints..
19:13:33 * ametts arrived late.  The dog ate his homework.
19:13:42 <sriram> anyone else have any updates on blueprints/bugs?
19:13:47 <sriram> ametts: thats ok
19:13:55 <sriram> we assigned you all the bugs
19:14:00 <sriram> and you have one day! ;)
19:14:15 <ametts> Drat.  I hate it when that happens...
19:14:27 <sriram> ha
19:14:47 <sriram> I know there was one bug we referenced during last week,
19:14:58 * sriram looks it up
19:15:26 <sriram> https://bugs.launchpad.net/poppy/+bug/1443979
19:15:26 <openstack> Launchpad bug 1443979 in Poppy "API Tests - Negative tests fail for the wrong reason" [Medium,Confirmed]
19:16:04 <sriram> malini had a patch in the works for this, which would make sure that if a negative test failed, it would be for the right reason.
19:16:24 <sriram> example: domain_name too long, should not fail because there was a protocol error
19:16:25 <sriram> etc
19:16:29 <sriram> so on and so forth.
19:16:45 <sriram> I think addressing that will help a lot with our troubleshooting.
19:17:06 <sriram> https://bugs.launchpad.net/poppy/+bug/1486103
19:17:06 <openstack> Launchpad bug 1486103 in Poppy "Fix Flaky tests due to Cassandra inconsistency issues" [Undecided,Confirmed] - Assigned to Sriram (thesriram)
19:17:22 <sriram> I have been dealing with this for a quite a while.
19:18:05 <sriram> reading about how batching works in cassandra, noticed that there is no isolation of statements within the batch, its atomic but eventually consistent.
19:18:29 <sriram> that is batchlog being written to co-ordinator nodes and two other nodes, but those operations could fail.
19:19:01 <sriram> and the cassandra-driver could still report success, which leaves the result in a inconsistent state.
19:19:12 <sriram> and no-way to prove which state is consistent.
19:19:19 <sriram> baah cassandra :P
19:19:31 <sriram> Moving on from my rant haha.
19:19:54 * tonytan4ever looking at this cassandra feature
19:20:06 * ametts was starting to think sriram is the only on in this meeting
19:20:10 <sriram> https://bugs.launchpad.net/poppy/+bug/1494430
19:20:10 <openstack> Launchpad bug 1494430 in Poppy "Services go into pending after exhausting max DNS retries" [Undecided,Fix committed] - Assigned to Sriram (thesriram)
19:20:14 <sriram> ametts: lol
19:20:22 <sriram> Now that bug has been fixed
19:20:30 <tonytan4ever> Yeah
19:20:59 <sriram> we added logic to failover, and mark entire service state as failed, if our dns retries didnt succeed.
19:21:04 <tonytan4ever> I need to show my presence. I think this is the fix about fail task on retry exception
19:21:12 <sriram> tonytan4ever: hahaha
19:21:13 <tonytan4ever> lol
19:21:27 <tonytan4ever> we could possibly use on_failure to do this
19:21:40 <sriram> tonytan4ever: good point.
19:22:02 * sriram looks at the list of bugs
19:22:28 <sriram> https://bugs.launchpad.net/poppy/+bug/1421276
19:22:29 <openstack> Launchpad bug 1421276 in Poppy "api does not allow multiple origin with same IP, but different protocol" [Medium,New]
19:22:34 <sriram> tonytan4ever: does that bug still exist?
19:23:12 <tonytan4ever> That one should have been fixed,
19:23:34 <sriram> tonytan4ever: could you please confirm, that we can mark status on the bug to be fixed.
19:23:44 <sriram> s/that/then
19:24:04 <tonytan4ever> We will abandon protocol fields on origin in the future. I think it should be marked as invalid.
19:24:17 <sriram> ok
19:24:20 <sriram> https://bugs.launchpad.net/poppy/+bug/1496446
19:24:21 <openstack> Launchpad bug 1496446 in Poppy "API test domain replacement" [Undecided,New]
19:24:26 <sriram> tonytan4ever: you reported this bug.
19:24:39 <sriram> now, we already randomize our domains right?
19:24:44 <tonytan4ever> Yes
19:24:58 <tonytan4ever> So we can say it is fixed.
19:25:03 <sriram> aah
19:25:25 <sriram> ok
19:25:31 <tonytan4ever> That is specifically targeted on the shared ssl domain replacement issue I fixed the other day.
19:26:01 <sriram> ok just marked that as invalid.
19:26:32 <sriram> https://bugs.launchpad.net/poppy/+bug/1408301
19:26:32 <openstack> Launchpad bug 1408301 in Poppy "PATCH Requests for Domains Returns Confusing Error Message" [High,Confirmed]
19:26:53 <sriram> this bug has been sitting around for a long time.
19:27:12 <sriram> I'll assign it to myself
19:27:15 <sriram> and work in it.
19:27:58 <sriram> alrighty, I think that covers housekeeping on bugs.
19:28:11 <sriram> Moving on to my favorite topic…..
19:28:17 * sriram drum roll
19:28:25 <sriram> #topic Open Discussion
19:28:49 <ametts> Well, that was certainly anti-climactic.
19:29:00 <cpowell> hahaha
19:29:04 <sriram> alright, what do you guys want to talk about, tonytan4ever, cathR, ametts, cpowell
19:29:06 <sriram> :P
19:29:34 <tonytan4ever> Well there is a discussion on ip restriction support on CIDR formatted Ip address.
19:30:07 <tonytan4ever> Right now poppy does not support CIDR yet, but Akamai policy API supports it.
19:30:36 <tonytan4ever> So We need to check in a PR to allow that.
19:30:40 <sriram> tonytan4ever: hmm, how does that play out with us having same set of features across providers?
19:30:56 <sriram> what about fastly, maxcdn etc/
19:31:39 <tonytan4ever> I don't know about those providers yet.
19:31:54 * tonytan4ever look fastly, maxcdn's ip restriction spec up.
19:32:23 <sriram> #action tonytan4ever to look at fastly, maxcdn's ip restriction spec
19:32:38 <sriram> after that we can make a decision.
19:33:20 <sriram> alright, anything else?
19:34:06 <sriram> going once
19:34:33 <sriram> going twice
19:34:40 <sriram> …..
19:34:54 <sriram> alright, thanks for coming folks.
19:34:59 <ametts> Thanks, everyone.
19:35:03 <sriram> see ya''ll next time.
19:35:12 <sriram> #endmeeting poppy