15:30:16 <DinaBelova> #startmeeting Performance Team
15:30:17 <openstack> Meeting started Tue Nov 28 15:30:16 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:21 <openstack> The meeting name has been set to 'performance_team'
15:30:30 <DinaBelova> hello tovin07 o/
15:30:38 <tovin07> hello DinaBelova
15:30:58 <DinaBelova> sorry for being absent last time
15:31:14 <DinaBelova> it was a bit unexpected + no internet access :D
15:31:34 <tovin07> oh, that's sad
15:32:14 <DinaBelova> so i was unable to chair the meeting
15:32:25 <DinaBelova> okay, let's wait for a few moments
15:32:30 <DinaBelova> if someone will join
15:32:36 <DinaBelova> ilyashakhat o/
15:33:09 <DinaBelova> msimonin1 o/
15:33:37 <DinaBelova> hm, it looks like none is here :)
15:33:50 <DinaBelova> #topic Action Items
15:34:11 <DinaBelova> last time we did not have any action items, so i'm just skipping this section
15:34:16 <DinaBelova> #topic Current status
15:34:24 <DinaBelova> tovin07 the floor is yours :)
15:34:33 <tovin07> yes
15:34:40 <tovin07> last time
15:35:04 <tovin07> I had a lightning talk in Sydney
15:35:10 <tovin07> really short :D
15:35:33 <tovin07> just mirror the link here
15:35:39 <DinaBelova> how it was?
15:35:54 <tovin07> #link OSprofiler ft. OpenTracing https://www.openstack.org/videos/sydney-2017/openstack-osprofiler-ft-cncf-opentracing-distributed-tracing-from-cloud-through-container
15:36:08 <tovin07> I think it is good
15:36:21 <DinaBelova> very good :)
15:36:55 <tovin07> however, there were a few people attended it (because of the end of the day)
15:37:03 <tovin07> hi mis
15:37:15 <tovin07> hi msimonin
15:37:19 <msimonin> hi all
15:37:22 <msimonin> sorry I'm late
15:37:26 <tovin07> np
15:37:43 <DinaBelova> msimonin o/
15:37:47 <msimonin> I just realize I was also one hour late last time :)
15:37:52 <tovin07> and, last week, I focus on filter error traces
15:38:04 <DinaBelova> tovin07 good to know
15:38:09 <tovin07> this week, in Vietnam, we have an OpenStack meetup
15:38:26 <DinaBelova> from my side I promise to go through osprofiler review queue
15:38:27 <tovin07> I am an organizer of OpenStack community in Vietnam
15:38:47 * tovin07 is preparing slide for the meetup
15:39:02 <DinaBelova> tovin07 wow, so this is big event fro you :)
15:39:25 <tovin07> thanks DinaBelova
15:39:46 <DinaBelova> tanks tovin07 for the update
15:39:47 <tovin07> OpenStack community in Vietnam is a little bit small for now
15:39:57 <tovin07> for the review queue
15:40:42 <tovin07> I saw only one new patch from Omer https://review.openstack.org/#/c/521385/
15:41:14 <tovin07> that's all from my side for now
15:41:17 <DinaBelova> tovin07 yeah, it looks like you're right
15:41:20 <DinaBelova> thanks tovin07
15:41:29 <DinaBelova> msimonin the word goes to you :)
15:41:32 <tovin07> msimonin do you have any update?
15:41:49 <msimonin> yes
15:42:08 <msimonin> So first of all, if you got and review https://review.openstack.org/#/c/491818
15:42:17 <msimonin> if you could go*
15:42:33 <msimonin> I think it's in good shape now
15:42:38 <DinaBelova> sure, I was doing it several times already
15:42:39 <DinaBelova> :D
15:42:40 <msimonin> :)
15:43:01 <DinaBelova> it looked good for me even previously
15:43:02 <msimonin> Yes I saw it, thanks
15:43:02 <DinaBelova> lemme review it again
15:43:14 <msimonin> does it need 2 +2 ?
15:43:20 <msimonin> to get merged
15:43:51 <DinaBelova> yes, Ill review it and get mrged
15:44:00 <msimonin> great, thanks :)
15:44:27 <msimonin> So
15:44:54 <msimonin> Beside that we are making progresses on the implementation of this test case
15:45:15 <msimonin> In parallel I've checked how to enable osprofiler in oslo.messaging directly
15:45:29 <DinaBelova> msimonin you promised to give first results soon some time ago :D
15:45:36 <DinaBelova> when can we expect them? :)
15:46:02 <msimonin> you got me !
15:46:12 <DinaBelova> ;)
15:46:45 <msimonin> There are several test_case in the review, we are implementing one after another
15:46:58 <msimonin> and each test case requires different communication middleware
15:47:19 <msimonin> And, well (hum hum) it takes more time than I expected
15:47:28 <DinaBelova> it's ok
15:47:32 <DinaBelova> thanks for the update
15:47:46 <msimonin> So I a mentionned osprofiler in oslo.messaging
15:47:49 <DinaBelova> okay, going back to the  osprofiler in oslo.messaging
15:47:50 <DinaBelova> yeah
15:47:51 <DinaBelova> :D
15:47:54 <msimonin> Ok :)
15:47:57 <DinaBelova> please go ahead
15:48:17 <msimonin> So adding the decorator in some places in oslo.messaging seems ok so far
15:49:17 <msimonin> But I'm not sure how to move forward on this
15:50:04 <msimonin> if it something people need, we probably need to define what we expect more precisely by putting the probe in oslo library
15:50:15 <DinaBelova> well, this is what tovin07 mentioned last time - this approach seem to be temporary for some testing needs
15:50:31 <DinaBelova> we need to find some better approach for permanent solution
15:51:05 <msimonin> I don't get your point :)
15:51:59 <DinaBelova> well, adding decorators to oslo.messaging directly might not be an option we can support
15:52:31 <DinaBelova> but it's good for quick solution - that's all i'm saying
15:53:03 <DinaBelova> it might be a god idea to contact oslo.messaging community though
15:53:05 <DinaBelova> hm
15:53:15 <DinaBelova> i think tovin07 you did it already?
15:53:27 <DinaBelova> or am I messing this things?
15:53:35 <tovin07> hmm
15:53:39 <msimonin> hmm :)
15:54:07 <tovin07> I think that we should contact oslo.messaging for this idea
15:54:23 <DinaBelova> okay, so i'm just imagining things
15:54:32 <tovin07> :D
15:55:01 <DinaBelova> msimonin can you go further and contact oslo.messaging team and propose this to them?
15:55:02 <DinaBelova> to see their response?
15:55:09 <msimonin> I can do that
15:55:52 <DinaBelova> msimonin ack
15:55:52 <msimonin> While working on this last time
15:56:07 <msimonin> I raised two 'issues' with osprofiler
15:56:14 <tovin07> wow
15:56:22 <DinaBelova> #action msimonin contact oslo.messaging team and propose them direct osprofiler integration to the library
15:56:33 <DinaBelova> shoot
15:56:59 <msimonin> The first is related to the devstack/cell deployment : https://bugs.launchpad.net/osprofiler/+bug/1731856
15:56:59 <openstack> Launchpad bug 1731856 in osprofiler "[devstack plugin]cells1 conductor config file isn't modified by the plugin" [Undecided,New]
15:57:45 <msimonin> this one is fine, but I prefer the second one :)
15:58:02 <msimonin> this one : https://bugs.launchpad.net/osprofiler/+bug/1731864
15:58:02 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
15:58:26 <DinaBelova> looking
15:59:48 <msimonin> I narrow down a bit deeper the second one #1731864
16:00:00 <DinaBelova> okay, it looks like ilyashakhat has started looking to this issue
16:00:18 <msimonin> yes but I think our interpretation diverged a bit
16:01:01 <DinaBelova> tovin07 can you please take a look on it as well?
16:01:11 <tovin07> yes
16:01:12 <tovin07> wure
16:01:14 <tovin07> sure
16:01:48 <DinaBelova> #action tovin07 take a look on https://bugs.launchpad.net/osprofiler/+bug/1731864 and try to find out the root cause
16:01:48 <openstack> Launchpad bug 1731864 in osprofiler "class decorator isn't enabled in nova for some service" [Undecided,Confirmed]
16:02:31 <DinaBelova> okay, thank you msimonin
16:02:43 <msimonin> tovin07: I can share a quick/dirty fix
16:03:05 <tovin07> please publish it somewhere :D
16:03:34 <msimonin> If I remember correctly
16:03:53 <msimonin> In nova the class decorator is wrapped
16:04:07 <msimonin> the wrapper test wheter osprofiler is enabled
16:04:18 <msimonin> if it's enabled it will patch the method
16:04:35 <msimonin> But this is done at import time which is wrong
16:04:59 <msimonin> to do it at runtime (when the conf is populated) we should patch the class in a lazy manner
16:05:06 <tovin07> yes
16:05:19 <tovin07> exactly
16:05:21 <msimonin> to do so, my feeling is that we should go with a metaclass
16:05:25 <msimonin> https://github.com/openstack/osprofiler/blob/d741bffc3677cfa52a911a91558a97d5451b98db/osprofiler/profiler.py#L290-L316
16:05:37 <msimonin> and move that above code in the __call__ method
16:05:57 <msimonin> so the class is patched when an instance is actually built
16:06:57 <msimonin> that's my intuition
16:07:05 <DinaBelova> thanks msimonin
16:07:44 <ilyashakhat> (sorry for the late response) -- I agree, the current code in Nova looks strange
16:07:44 <tovin07> thanks msimonin for this idea
16:08:04 <ilyashakhat> but I read comments to patch set and such implementation was intentional
16:08:22 <msimonin> hi ilyashakhat
16:08:30 <ilyashakhat> cause they afraid to keep osprofiler always in the code path
16:09:16 <msimonin> yes I guess this was the intention, not patching the methos if osprofiler isn't enabled
16:09:23 <msimonin> methods*
16:10:39 <tovin07> yes, that's intentional
16:10:52 <tovin07> only patch method when osprofiler is enabled
16:10:55 <msimonin> sure
16:11:23 <msimonin> but the point is, even if osprofiler is enabled some methods won't get patched
16:11:40 <tovin07> yup
16:11:44 <ilyashakhat> agree
16:12:10 <tovin07> especially some methods in modules that loaded before oslo.config read the config file
16:12:33 <DinaBelova> okay, tovin07 - please try to take a look on this as well
16:12:40 <msimonin> tovin07:  yes everything that is evaluated before that
16:12:48 <ilyashakhat> is this behavior only in Nova?
16:13:00 <tovin07> or, sometimes it will be a circular import if I want to work around
16:13:01 <DinaBelova> it looks like we have enough intro information
16:13:22 <tovin07> I think this problem may appear in other project as well
16:13:23 <msimonin> ilyashakhat: honnestly I didn't check
16:13:51 <msimonin> I just realized it because I had trace points from oslo.messaging and not from nova rpcapi
16:14:58 <msimonin> Some meeting ago I had a question for you ilyashakhat, regarding os-fault
16:15:24 <ilyashakhat> it was on meeting that I missed
16:15:33 <ilyashakhat> what was the question?
16:16:00 <msimonin> It was about the license of os-fault
16:16:13 <msimonin> it's apache2 licence
16:16:25 <msimonin> but import some ansible (gplv3) code
16:16:27 <ilyashakhat> yes, it's tricky question cause it links directly with ansible
16:16:31 <msimonin> yes
16:16:32 <msimonin> :)
16:17:47 <ilyashakhat> don't know how to deal with that... make executor module pluggable could help
16:18:54 <msimonin> yes probably
16:19:05 <msimonin> nevermind I was just curious
16:19:18 <DinaBelova> while we have a pause i'll switch to open discussions
16:19:23 <DinaBelova> #topic Open Discussion
16:19:33 <DinaBelova> anything else to cover folks?
16:19:37 <DinaBelova> tovin07 ilyashakhat msimonin ?
16:19:43 <msimonin> Any chance we meet in PTG ?
16:19:48 <ilyashakhat> let's discuss testing
16:20:14 <tovin07> msimonin maybe a really small chance that I can go
16:20:36 <DinaBelova> msimonin not sure from my side, too many factors influencing
16:20:52 <ilyashakhat> probably may try to request.. but need strong agenda
16:21:01 <DinaBelova> ilyashakhat shoot ;)
16:21:17 <ilyashakhat> something besides Guiness :)
16:21:49 <msimonin> ilyashakhat: guiness not strong enough :)
16:23:12 <ilyashakhat> ... and coming back to testing - would be nice to have an integration job running with osprofiler enabled
16:23:36 <DinaBelova> no objections from my side :)
16:24:08 <msimonin> on each project ?
16:24:29 <ilyashakhat> but there're 2 questions: what driver to use (ceilometerclient will be retired soon) and do we need to patch tempest for this?
16:25:02 <DinaBelova> i fuess pure mongodb driver is a good option
16:25:05 <ilyashakhat> ideally would be nice to see that we have traces from every projects
16:25:33 <DinaBelova> as for the the tempest - no idea, it might be a chance it'll be needed
16:25:34 <tovin07> mongo or redis would be good choice
16:25:48 <ilyashakhat> DinaBelova, there was a recent email about removing mongodb from RDO...
16:26:04 <ilyashakhat> so I'd vote for redis
16:26:10 <DinaBelova> ilyashakhat well, then redis (as tovin07 proposed)
16:26:14 <tovin07> ilyashakhat can you give the link?
16:26:52 <ilyashakhat> tovin07, http://lists.openstack.org/pipermail/openstack-operators/2017-November/014608.html
16:27:04 <tovin07> thanks ilyashakhat
16:27:13 <ilyashakhat> (if I understood it correctly)
16:28:05 <ilyashakhat> ok, then I will update https://review.openstack.org/#/c/515108/ with Redis
16:28:16 <ilyashakhat> functional job would be a good start
16:29:17 <DinaBelova> ilyashakhat thank you sir
16:29:25 <DinaBelova> okay, we're running out of time folks
16:29:34 <DinaBelova> thanks msimonin tovin07 ilyashakhat for participating
16:29:34 <ilyashakhat> first time in history!
16:29:40 <ilyashakhat> thank you :)
16:29:41 <DinaBelova> not first :D
16:29:43 <DinaBelova> but rarely
16:29:45 <DinaBelova> true
16:29:46 <tovin07> :D
16:29:54 <DinaBelova> thank you folks
16:29:55 <DinaBelova> #endmeeting