15:30:05 <DinaBelova> #startmeeting Performance Team
15:30:06 <openstack> Meeting started Tue Aug 29 15:30:05 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:09 <openstack> The meeting name has been set to 'performance_team'
15:30:39 <DinaBelova> hello ilyashakhat o/
15:30:54 <DinaBelova> tovin07 o/
15:30:54 <ilyashakhat> hi!
15:31:00 <tovin07> o/
15:31:19 <DinaBelova> okay, so there are three of us so far :)
15:31:33 <rajulk> hi all o/
15:31:38 <DinaBelova> rajulk o/
15:31:47 <tovin07> hi rajulk
15:31:55 <DinaBelova> okay, so let's probably get started
15:31:59 <DinaBelova> #topic Action Items
15:32:10 <DinaBelova> first of all I want to say sorry for my action item
15:32:24 <DinaBelova> i was not able to review current patches in osprofiler
15:32:41 <DinaBelova> due to the high load on other internal tasks
15:32:47 <DinaBelova> so lemme keep it for the next time as well
15:33:14 <DinaBelova> #action DinaBelova review all patches in osprofiler
15:33:46 <DinaBelova> tovin07 - any updates from you side? On reviewing osprofiler bugs on the LP ?
15:33:59 <tovin07> there are a few :D
15:34:20 <tovin07> mostly on bugs and patches of ilyashakhat
15:34:21 <rcherrueau> o/
15:34:28 <tovin07> hi rcherrueau
15:34:36 <tovin07> long time :D
15:34:48 <rcherrueau> hi tovin07, yep
15:35:28 <tovin07> #link https://bugs.launchpad.net/osprofiler/+bug/1706299
15:35:30 <openstack> Launchpad bug 1706299 in osprofiler "OSProfiler does not catch DB error events" [Undecided,Confirmed]
15:35:58 <msimonin> (hi all :) )
15:36:05 <DinaBelova> msimonin o/
15:36:07 <ilyashakhat> o/
15:36:23 <DinaBelova> tovin07 please go ahead, sorry
15:36:31 <tovin07> and this one
15:36:34 <tovin07> #link https://review.openstack.org/#/c/492154/
15:36:34 <ilyashakhat> 1706299 requires some work, we are waiting for oslo.db release
15:36:46 <tovin07> hi msimonin
15:37:14 <tovin07> #link https://review.openstack.org/#/c/492498/
15:37:31 <tovin07> besides
15:37:39 <tovin07> there’a a patch from me
15:37:52 <tovin07> #link Filter for OSprofiler output https://review.openstack.org/#/c/496543/
15:38:05 <tovin07> msimonin, you should take a look at it
15:38:41 <msimonin> thanks, I just added myself :)
15:38:49 <tovin07> 496543 is a very first PoC for your case
15:39:31 <tovin07> that’s all from me for reviewing
15:39:59 <DinaBelova> tovin07 thanks for the update
15:40:00 <DinaBelova> #topic Current status
15:40:01 <DinaBelova> tovin07 let's proceed with current status
15:40:09 <DinaBelova> tovin07 please start :)
15:40:25 <tovin07> hmm, not much from last week
15:40:48 <tovin07> I publish a patch for filtration
15:41:25 <tovin07> working on monasca log API as an OSprofiler driver (forgot to publish it, will publish soon)
15:41:47 <tovin07> rajulk, do you have any news from your side?
15:41:58 <DinaBelova> tovin07 ack
15:42:21 <tovin07> for your blueprints?
15:42:22 <rajulk> nothing much. still working to merge the changes to osprofiler for sync
15:42:40 <rajulk> async call*
15:42:50 <DinaBelova> rajulk thanks
15:43:03 <DinaBelova> ilyashakhat anything to share?
15:43:28 <ilyashakhat> posted some patches on code removal :)
15:43:52 <ilyashakhat> now osprofiler is independent from oslo.messaging and doesn't require os-auth vars
15:44:04 <DinaBelova> ilyashakhat yeah, sorry :( this week was a bit crazy after returning from sick leave - will review for sure
15:44:37 <ilyashakhat> they are merged already
15:44:45 <ilyashakhat> thanks to tovin07 and Vipin
15:44:47 <DinaBelova> ilyashakhat well, you have more on review :D
15:45:51 <ilyashakhat> that's all I have for now :)
15:46:05 <DinaBelova> msimonin rcherrueau okay, so today we have you folks :) anu update from your side? Any news on distributed messaging routing you're working on?
15:46:47 <msimonin> yes
15:46:59 <msimonin> There are two directions actually
15:47:07 <msimonin> distributed messaging and distributed databases
15:47:47 <msimonin> regarding distributed messaging we started a test plan for this
15:48:00 <msimonin> #link https://review.openstack.org/#/c/491818/
15:48:09 <msimonin> it's still WiP
15:48:43 <msimonin> but feel free to check it (especially if you have some ideas regarding the resilience test cases)
15:48:45 <msimonin> :)
15:49:21 <DinaBelova> msimonin gotcha
15:49:43 <msimonin> In parallel, we need to code some specifix tool to experiment with qpid dispatch
15:49:58 <msimonin> the same it's progressing
15:50:16 <msimonin> rcherrueau:  want to speak about distributing the database?
15:50:23 <rcherrueau> yep
15:50:49 <rcherrueau> On my side, I am working (with an intern) on making OpenStack supports CockroachDB
15:51:12 <rcherrueau> CockroachDB is a *New*SQL Database
15:51:39 <rcherrueau> i.e., A database that scales and still offers ACID transactions.
15:52:08 <rcherrueau> We have a POC that deploys Keystone over CockroachDB
15:52:20 <rcherrueau> #link https://github.com/BeyondTheClouds/openstack-cockroachdb-dev
15:52:34 <rcherrueau> You can try it. You only need vagrant
15:52:48 <rcherrueau> then it deploys cockroacdb and keystone using devstack
15:53:04 <rcherrueau> I will make an announcement on the ml soon
15:53:32 <rcherrueau> Next step is doing performance analysis on CockroachDB vs Galera
15:54:00 <ilyashakhat> as a spoiler - did you face any issues on making Keystone work with it?
15:54:30 <rcherrueau> ilyashakhat: not that much. We have to patch one file in oslo.db
15:54:51 <ilyashakhat> sounds cool :)
15:54:54 <rcherrueau> Especially because that contains code that is backend specific
15:55:20 <DinaBelova> thanks rcherrueau msimonin
15:55:25 <ilyashakhat> there a lots of error-handling specific things
15:55:27 <rcherrueau> and we also have to add some python decorators into keystone, but only few
15:55:48 <msimonin> This will be fun to deploy at scale ;)
15:56:04 <DinaBelova> true :D
15:56:55 <DinaBelova> okay, it looks like we can proceed to the open discussion
15:57:00 <DinaBelova> #topic Open Discussion
15:57:20 <DinaBelova> ilyashakhat msimonin rcherrueau tovin07 rajulk - anything to share, that was not yet mentioned?
15:58:04 <tovin07> yep
15:58:06 <ilyashakhat> I have a question - do we plan to have sort of plan for the next release?
15:58:13 <msimonin> ilyashakhat: +1
15:59:12 <tovin07> i’m thinking of separating error traces (traces that contain a span with error/exception information) from normal trace.
15:59:20 <tovin07> in OSprofiler
15:59:58 <DinaBelova> ilyashakhat msimonin I suspect we do not have specific items so far - talking about osprofiler or test plans. Let's probably gather them to one place till next meeting?
16:00:07 <ilyashakhat> DinaBelova, could you make an etherpad to list our ideas
16:00:09 <ilyashakhat> yep
16:00:16 <DinaBelova> yep, one sec
16:00:23 <tovin07> that is a small change in idea, however, need to modify drivers
16:00:26 <tovin07> ilyashakhat: +1 too
16:00:28 <rajulk> tovin07 can you share the idea behind doing that
16:01:58 <DinaBelova> #action ilyashakhat msimonin rcherrueau tovin07 rajulk DinaBelova add ideas to https://etherpad.openstack.org/p/performance-team-q-release-ideas
16:02:42 <tovin07> rajulk: the idea is quite simple, we can use OSprofiler to trouble-shoot errors in our OpenStack services. I just want to separate error traces out of normal trace and store it in other place —> easy for query. i.e normal traces in redis db 0, error trace in redis db 1
16:02:50 <tovin07> DinaBelova: thanks
16:03:41 <rajulk> tovin07 got it. thanks
16:03:59 <DinaBelova> tovin07 I'm ok with this idea, but only if it's going to be an optional - not all people are ready to have multiple DBs for profiling and not everybody needs it
16:04:16 <tovin07> yes
16:04:33 <tovin07> it should be an option only
16:04:44 <DinaBelova> cool, thanks
16:05:31 <DinaBelova> okay, anything else?
16:05:45 <tovin07> none :d
16:05:58 <DinaBelova> it looks like we're done for todays
16:06:04 <DinaBelova> thank you folks for participating
16:06:10 <ilyashakhat> thanks!
16:06:11 <DinaBelova> have a nice day/evening
16:06:13 <DinaBelova> #endmeeting