15:30:02 <DinaBelova> #startmeeting Performance Team
15:30:03 <openstack> Meeting started Tue Aug 22 15:30:02 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:07 <openstack> The meeting name has been set to 'performance_team'
15:30:19 <tovin07> hi o/
15:30:23 <DinaBelova> tovin07 o/
15:30:24 <ilyashakhat> hi!
15:30:29 <DinaBelova> ilyashakhat good to see you :)
15:31:06 <DinaBelova> let's wait for a few moments :)
15:31:07 <ilyashakhat> you too :)
15:31:32 <DinaBelova> rajulk are you around as well? :)
15:31:46 <DinaBelova> it's goo to be finally back from a sick leave :)
15:32:37 <DinaBelova> okay, so it looks like all my sick leaves make people forget about meetings :)
15:32:41 <rajulk> hi
15:32:46 <rajulk> yes I am
15:33:06 <DinaBelova> rajulk o/
15:33:07 <DinaBelova> let's get started then
15:33:08 <DinaBelova> #topic Action Items
15:33:09 <DinaBelova> so rom action items perspective
15:33:12 <DinaBelova> we have several
15:33:25 <DinaBelova> tovin07 starting with you and PoC for osprofiler request filtering
15:33:37 <tovin07> Yes
15:33:41 <DinaBelova> you had bunch of time (thanks to me :D )
15:33:42 <tovin07> I have two :D
15:34:16 <tovin07> #link For a large trace: https://tovin07.github.io/osprofiler-filtration/very-large.html
15:34:43 <tovin07> #link For a simple trace: https://tovin07.github.io/osprofiler-filtration/pretty-simple.html
15:35:08 <DinaBelova> do you have links to the implementation as well?
15:35:11 <DinaBelova> to take a look?
15:35:28 <tovin07> I will push to gerrit (tomorrow)
15:35:34 <DinaBelova> tovin07 thanks
15:35:42 <DinaBelova> please add me as a reviewer :)
15:35:50 <tovin07> sure
15:36:12 <DinaBelova> from my perspective it looks quite ok for requests filtering
15:36:18 <DinaBelova> thank you
15:36:39 <DinaBelova> okay, so second action item was on myself and tovin07 again to review rajulk 's BPs
15:36:45 <DinaBelova> more particularly those ones
15:37:07 <DinaBelova> https://blueprints.launchpad.net/osprofiler/+spec/tail-based-coherent-sampling and https://blueprints.launchpad.net/osprofiler/+spec/asynchronous-trace-collection
15:37:11 <tovin07> we had some discussions in openstack-dev mailing list too
15:37:20 <DinaBelova> from my perspective they look ok, but I added you tovin07 as an approver for them
15:37:45 <tovin07> yes, I think it’s OK too
15:38:17 <tovin07> hope to see demo from rajulk side soon
15:39:06 <DinaBelova> tovin07 can you please add link to the openstack-dev discussion here as well? Cannot find it quickly >_<
15:39:25 * tovin07 finding too
15:40:17 <tovin07> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120614.html
15:40:25 <DinaBelova> thanks
15:40:28 <tovin07> #link http://lists.openstack.org/pipermail/openstack-dev/2017-August/120616.html
15:41:09 <DinaBelova> #info https://blueprints.launchpad.net/osprofiler/+spec/tail-based-coherent-sampling and https://blueprints.launchpad.net/osprofiler/+spec/asynchronous-trace-collection are preliminary approved. Waiting for the demo from rajulk to set final approvement
15:41:57 <tovin07> look like rajulk is afk for a while :D
15:42:02 <rajulk> sure. i am working on it and will push the changes soon
15:42:09 <DinaBelova> tovin07 you're wrong :D
15:42:12 <DinaBelova> rajulk thanks
15:42:24 <DinaBelova> okay, so it looks like we're done with the action items
15:42:28 <tovin07> sorry, i’m wong :D
15:42:32 <DinaBelova> if no questions here, let's proceed
15:42:44 <DinaBelova> #topic Current status
15:42:49 <DinaBelova> tovin07 the floor is yours
15:42:57 <rajulk> partialy right. was off for a while :D
15:43:34 <tovin07> last week, I tried to make monasca log API as a driver for OSprofiler
15:44:00 <tovin07> later this week I will push a simple patch for this work
15:44:42 <tovin07> besides, I received some good review from ilyashakhat and vipin for this patch
15:44:45 <tovin07> #link https://review.openstack.org/#/c/450072/
15:45:06 <tovin07> DinaBelova: I think that this can be merged
15:45:22 <DinaBelova> tovin07 agree
15:45:27 <DinaBelova> sorry for the review delays
15:45:41 <DinaBelova> all those sick leaves make me kinda crazy >_<
15:45:56 <tovin07> and, thanks ilyashakhat for some other patches that you published
15:46:24 <DinaBelova> #action DinaBelova review all patches from ilyashakhat that are currently pending reviews
15:46:29 <tovin07> DinaBelova: no problem, we still have time :D
15:46:53 <tovin07> and
15:47:06 <DinaBelova> it looks like ilyashakhat we're smoothly coming to you sir :)
15:47:10 <DinaBelova> tovin07 yep?
15:47:38 <ilyashakhat> yes, please review :)
15:47:39 <tovin07> Schedule for Sydney Summit is now live
15:48:00 <tovin07> #link https://www.openstack.org/summit/sydney-2017/summit-schedule/
15:48:40 <rajulk> congrats tovin07 for your talk
15:48:50 <tovin07> As I see, we have 3 approved talks
15:49:20 <tovin07> rajulk: thanks, but your talk...
15:49:40 <rajulk> It didn't made through
15:49:47 <rajulk> the one related to tracing
15:49:58 <tovin07> #link from jd and akrzos https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19198
15:50:15 <tovin07> #link from Inria guy https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19521
15:50:30 <tovin07> #link and from me https://www.openstack.org/summit/sydney-2017/summit-schedule/events/19057
15:50:56 <tovin07> I really hope that rajulk’s talk will be chosen
15:51:29 <tovin07> I like that a lot :’(
15:51:50 <DinaBelova> well, rajulk did you try to push it as some other type of session? previous summits used to have small sessions being available
15:52:24 <rajulk> not really. we were just looking to have as a tech talk
15:52:32 <DinaBelova> rajulk got it
15:53:07 <DinaBelova> well, sometimes it happens :(
15:53:15 <DinaBelova> thank tovin07 for the links
15:53:15 <tovin07> I think that this summit is a short summit (just 3 day from 6 - 8 Nov)
15:53:41 <DinaBelova> yeah, this most probably influenced a capacity
15:53:51 <tovin07> yep
15:54:07 <DinaBelova> ilyashakhat rajulk do you have something to share?
15:54:27 <rajulk> DinaBelova yeah. wait for it at Vancouver:)
15:54:40 <ilyashakhat> well... I have some clean-up patches on review
15:55:05 <ilyashakhat> mostly to reduce project dependencies
15:55:07 <DinaBelova> ilyashakhat yeah :( sorry, I'll review them
15:55:12 <DinaBelova> tovin07 please do it as well (if you did not have a chance so far)
15:55:16 <tovin07> yes
15:55:26 <tovin07> I put a +2 for ilyashakhat today
15:55:33 <ilyashakhat> could we also review bugs in Launchpad?
15:55:40 <ilyashakhat> there are some very outdated
15:55:51 <tovin07> I think we should
15:56:00 <DinaBelova> true. tovin07 can I ask you to lead this activity?
15:56:19 <tovin07> yes, I will :D
15:56:26 <DinaBelova> #action tovin07 review osprofiler bugs on the LP
15:56:29 <DinaBelova> thanks
15:56:55 <ilyashakhat> DinaBelova, now you are maintainer, it would be better to create a group and add tovin07 there
15:57:07 <DinaBelova> WILL DO TODAY
15:57:08 <DinaBelova> oops
15:57:11 <DinaBelova> sorry for the cups
15:57:15 <DinaBelova> caps*
15:57:33 <ilyashakhat> (i thought you were scary :)
15:57:43 <DinaBelova> nope :D
15:57:51 <DinaBelova> I'm brave enough
15:58:14 <DinaBelova> my recent activities included lots of crazy Jira maintenance, so nothing can scary me after this
15:58:24 <ilyashakhat> haha)
15:59:06 <DinaBelova> okay, so it looks like we may jump to open discussions
15:59:07 <DinaBelova> #topic Open Discussion
15:59:22 <DinaBelova> ilyashakhat tovin07 rajulk anything missed? any topics to raise?
15:59:58 <tovin07> nope :D
16:00:09 <ilyashakhat> nope
16:00:34 <rajulk> nothing
16:00:44 <DinaBelova> okay, it looks like we're done for today :) thanks for attending and sorry again for my sick leaves :)
16:00:57 <tovin07> np :)
16:01:06 <DinaBelova> thanks!
16:01:07 <DinaBelova> #endmeeting