15:30:27 <DinaBelova> #startmeeting Performance Team
15:30:28 <openstack> Meeting started Tue Aug  1 15:30:27 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:31 <openstack> The meeting name has been set to 'performance_team'
15:30:41 <DinaBelova> okay, let's see who is around :)
15:30:43 <tovin07> hi DinaBelova o/
15:30:46 <DinaBelova> tovin07 o/
15:30:55 <msimonin> o/
15:30:59 <DinaBelova> ilyashakhat akrzos msimonin o/
15:31:06 <tovin07> long time no see msimonin :D
15:31:09 <rajulk> hi tovin07
15:31:13 <akrzos> hello
15:31:17 <DinaBelova> wow :) msimonin did not see you for a while :)
15:31:18 <tovin07> rajulk o/
15:31:36 <rajulk> hello everyone, I am new to this communtity
15:31:44 <DinaBelova> rajulk o/
15:31:49 <DinaBelova> nice to see you :)
15:32:03 <rajulk> thanks
15:32:09 <msimonin> DinaBelova: It was vacation time :)
15:32:20 <DinaBelova> okay, so let's get started
15:32:26 <DinaBelova> with action items
15:32:32 <DinaBelova> #topic Action Items
15:32:45 <DinaBelova> tovin07 can you please proceed with your action item?
15:32:51 <DinaBelova> "take a look on the osprofiler filtering use cases #1 and #2 and share implementation ideas
15:32:51 <DinaBelova> "
15:33:03 <DinaBelova> and we have msimonin today :)
15:33:12 <tovin07> okay
15:33:42 <tovin07> lemme get the link about the requirements from msimonin
15:34:12 <msimonin> *resyncing my brain *
15:34:30 <tovin07> #link http://eavesdrop.openstack.org/meetings/performance_team/2017/performance_team.2017-06-20-15.30.log.html#l-27
15:35:49 <tovin07> for the first one, msimonin said that was easy :D (I agree)
15:36:21 <tovin07> for the second one, I have an idea, I will try to make an PoC for it next week
15:36:33 <tovin07> hope it will work
15:36:58 <DinaBelova> #action tovin07 prepare PoC for osprofiler request filtering
15:37:14 <msimonin> cool !
15:37:18 <DinaBelova> okay, so we should be good here
15:37:20 <msimonin> One question though
15:37:57 <msimonin> We mention the use of a higher langage to express filtering in the tree call
15:38:17 <msimonin> Did you check if such a langage exist ?
15:38:40 <DinaBelova> tovin07 ^^
15:39:31 <tovin07> I don’t think that we have to use other kind of language
15:39:56 <tovin07> do you mean programming language? or what?
15:41:02 <msimonin> We have a tree, they are some specialized langage (like xpath for xml) that could help (maybe)
15:41:53 <tovin07> oh, got it. I think that we may not need to use them.
15:42:13 <tovin07> I’ll try to use plain javascript
15:42:22 <DinaBelova> tovin07 anyway please check if that can help :)
15:42:37 <tovin07> yes DinaBelova
15:42:56 <DinaBelova> okay, so for my action item - on reviewing current osprofiler patches. Went through most of them, and going to finish review of the rest soon
15:43:18 <DinaBelova> okay, so it looks like we can go further for now
15:43:23 <DinaBelova> if no objections
15:43:48 <DinaBelova> #topic Current progress
15:43:49 <DinaBelova> okay, tovin07 - the floor is yours :)
15:44:18 <tovin07> currently
15:44:51 <tovin07> I still work on this patch OSprofiler with OpenTracing compatible https://review.openstack.org/#/c/480018/
15:45:23 <tovin07> and had some communications with with OpenTracing community
15:46:15 <DinaBelova> so now we have some py-3 libraries compatibility issues?
15:46:18 <DinaBelova> am I right?
15:46:27 <tovin07> a good news for OSprofiler in other OpenStack project is this patch https://review.openstack.org/#/c/358142/ in Ironic
15:47:04 <tovin07> DinaBelova: yes, a py-3 compatibility issue
15:47:22 <DinaBelova> okay, gotcha
15:47:47 <DinaBelova> anything else, tovin07 ?
15:47:54 <tovin07> besides, I have some other patches related to OSprofiler in Aodh, Panko and Swift
15:48:00 <tovin07> with no update
15:48:12 <tovin07> because of FFE last week
15:48:49 <DinaBelova> yeah, so waiting for new cycle to be open
15:48:49 <tovin07> #link Add results to trace info https://review.openstack.org/#/c/450072/
15:49:15 <tovin07> I think that this patch needs more attention from Vipin
15:49:44 <tovin07> we did not see Vipin online for a while :D
15:49:51 <DinaBelova> tovin07 cna you ping him through email?
15:49:53 <DinaBelova> can*
15:50:18 <tovin07> yes, last week, I sent an email (cc to DinaBelova)
15:50:29 <tovin07> however, still no reply
15:50:54 <msimonin> This patch is good from our side
15:51:13 <DinaBelova> oh, true. I guess he may be on PTO :)
15:51:23 <DinaBelova> this looks good to me as well
15:51:46 <tovin07> yes
15:51:47 <DinaBelova> okay, I set +2
15:51:50 <DinaBelova> if none will set -1, I guess we can merge it during this week
15:51:59 <tovin07> thanks DinaBelova :D
15:52:26 <tovin07> that’s all from my side
15:52:28 <DinaBelova> thanks tovin07 :)
15:52:36 <DinaBelova> okay, msimonin - anything to share sir?
15:53:18 <msimonin> Not so much
15:53:22 <tovin07> msimonin: I saw that you had a long time trip last month
15:53:35 <msimonin> not long enough :)
15:53:47 <DinaBelova> :D
15:53:48 <DinaBelova> okay, gotcha
15:54:04 <msimonin> one thing maybe
15:54:22 <msimonin> I'll start working actively on qpid dispatch router
15:54:59 <msimonin> we iterate with some folks on a test p^lan
15:55:35 <msimonin> kgiusti is the initiator
15:55:51 <DinaBelova> msimonin do you have the test plan draft already?
15:55:55 <msimonin> What do you think about adding this test + results (later) on the performance doc ?
15:56:03 <msimonin> for the moment it's just an etherpad
15:56:20 <msimonin> that needs to be formalize
15:56:24 <DinaBelova> msimonin I think it'll be a good action to be done (perf docs)
15:56:25 <msimonin> *formalized
15:56:29 <DinaBelova> link please :)
15:56:40 <msimonin> me too, I'll check with the other guys
15:57:26 <msimonin> yes give me 30s
15:57:58 <msimonin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118716.html
15:58:22 <DinaBelova> thank you sir
15:58:55 <msimonin> We'll work on it soon
15:59:06 <DinaBelova> anything else msimonin ? I'll take a look on the etherpad as well
15:59:13 <msimonin> most likely it'll be ready for Vancouver summit
16:00:08 <DinaBelova> thanks for the update
16:00:10 <msimonin> That's all from my side
16:00:32 <DinaBelova> akrzos ilyashakhat - do you have something to share on current progress?
16:00:47 <akrzos> DinaBelova: not at this current time
16:01:13 <DinaBelova> okay, it looks like ilyashakhat is afk for now as well
16:01:20 <DinaBelova> so we may proceed to the open discussion
16:01:24 <DinaBelova> #topic Open Discussion
16:01:47 <DinaBelova> rajulk so hello again :)
16:01:48 <tovin07> Vote for speaker is now live
16:01:55 <DinaBelova> can you please give a bit of details on what are you working on?
16:01:59 <DinaBelova> tovin07 true :)
16:02:11 <DinaBelova> can you give us link to your presentation voting?
16:02:13 <rajulk> hi we are a research group at Boston University
16:02:16 <tovin07> #link Vote for Speaker https://www.openstack.org/summit/sydney-2017/vote-for-speakers
16:02:20 <tovin07> hi rajulk
16:02:27 <rajulk> called Massachusetts Open Cloud
16:03:05 <DinaBelova> rajulk okay, great to see university communities being active in OpenStack
16:03:06 <rajulk> we are working on a long term idea of continuous tracing and automated analysis of openstack cluster
16:03:40 <rajulk> I have proposed two blueprints on osprofiler to begin with
16:03:48 <DinaBelova> rajulk do you have any materials to share? so other people can take a look on what are you working on?
16:04:11 <rajulk> https://blueprints.launchpad.net/osprofiler/+spec/asynchronous-trace-collection
16:04:12 <rajulk> https://blueprints.launchpad.net/osprofiler/+spec/tail-based-coherent-sampling
16:05:01 <DinaBelova> okay, it seems tovin07 and I need to review them :)
16:05:10 <rajulk> it will be great if we could get some reviews and comments on them
16:05:17 <DinaBelova> #action DinaBelova tovin07 review https://blueprints.launchpad.net/osprofiler/+spec/tail-based-coherent-sampling and https://blueprints.launchpad.net/osprofiler/+spec/asynchronous-trace-collection
16:05:18 <tovin07> for the asynchronous trace, I agree
16:05:23 <rajulk> thanks :)
16:05:35 <tovin07> and I love the `agent idea` too
16:05:47 <tovin07> :D
16:06:29 <tovin07> I saw it from Uber Jaeger implementation
16:06:53 <tovin07> okay, DinaBelova, I will comment on it
16:06:56 <rajulk> We have also proposed a talk for openstack summit called "advanced tracing in openstack"
16:07:05 <DinaBelova> link please :)
16:07:12 <rajulk> please have a look at that too :)
16:07:23 <rajulk> sure
16:07:29 <tovin07> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers/#/19608
16:07:51 <rajulk> https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19608
16:08:01 <DinaBelova> thank you :)
16:08:15 <tovin07> Whao, love to see Raja Sambasivan too
16:08:16 <DinaBelova> rajulk so let us take a look on your proposals and welcome :)
16:08:37 <rajulk> thanks a lot :)
16:09:11 <DinaBelova> okay, do we have anything else to be covered? tovin07 akrzos rajulk ?
16:09:14 <DinaBelova> msimonin ? :)
16:09:21 <rajulk> yeah Raja is working here in our group as well
16:09:37 <rajulk> that's all from me
16:09:48 <akrzos> just curious about ptg
16:09:53 <akrzos> also have a talk submitted
16:10:31 <DinaBelova> akrzos it looks like no active ptg will be processed from our side. Don't know about rally folks, they may have some ongoing initiative
16:10:51 <DinaBelova> not sure, as rally ptl left mirantis and I did not check it on continuous basis
16:11:32 <akrzos> gotcha
16:11:48 <DinaBelova> akrzos can you please give us link?
16:11:49 <DinaBelova> to your proposal?
16:12:26 <akrzos> digging for it
16:12:50 <akrzos> https://www.openstack.org/summit/sydney-2017/vote-for-speakers/#/19198
16:13:04 <DinaBelova> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers/#/19198
16:13:17 <DinaBelova> thank you sir
16:13:36 <msimonin> Could I link two proposals as well .
16:13:37 <msimonin> ?
16:13:46 <DinaBelova> sure :)
16:13:48 <DinaBelova> shoot
16:13:49 <msimonin> :)
16:14:00 <msimonin> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19515
16:14:08 <msimonin> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19521
16:14:14 <msimonin> done :)
16:14:28 <tovin07> #link https://www.openstack.org/summit/sydney-2017/vote-for-speakers#/19057
16:14:47 <tovin07> that’s all from my side :D
16:15:47 <DinaBelova> okay, thank you folks :)
16:15:48 <DinaBelova> wrapping up the meeting
16:15:54 <DinaBelova> have a nice day/evening
16:16:02 <DinaBelova> #endmeeting