15:30:20 <DinaBelova> #startmeeting Performance Team
15:30:21 <openstack> Meeting started Tue Jun 20 15:30:20 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:24 <openstack> The meeting name has been set to 'performance_team'
15:30:51 <DinaBelova> hello folks :)
15:30:52 <DinaBelova> let's see who is around
15:31:09 <tovin07> hello o/
15:31:17 <DinaBelova> msimonin tovin07 rama_y o/
15:31:19 <rama_y> hello
15:31:35 <rama_y> o/
15:31:41 <DinaBelova> msimonin akrzos are you around folks?
15:32:06 <msimonin> Hi all
15:32:08 <ilyashakhat> o/
15:32:51 <DinaBelova> ilyashakhat o/
15:32:52 <DinaBelova> okay, so let's get started
15:33:01 <DinaBelova> first of all sorry, for the closing last meeting
15:33:16 <DinaBelova> I had an unexpected issue to get solved
15:33:39 <DinaBelova> let's start with aciton items
15:33:43 <DinaBelova> #topic Action Items
15:34:09 <DinaBelova> tovin07 msimonin did you guys have an opportunity to think about osprofiler filtering ideas?
15:34:34 <tovin07> currently, no
15:34:36 <tovin07> :D
15:34:50 <tovin07> msimonin: do you have any starting idea?
15:35:04 <msimonin> Ok so I can start we one use case
15:35:10 <msimonin> with*
15:35:13 <DinaBelova> shoot
15:35:28 <msimonin> First one is :
15:36:07 <msimonin> I want to extract every event whose name match *RPC*
15:36:11 <msimonin> (easy)
15:36:23 <msimonin> Second is :
15:37:06 <msimonin> I want to extract every event whose name match *RPC* but also every parent events until the root
15:37:26 <msimonin> in other words I want to keep everything that causes an RPC
15:37:55 <msimonin> These are the 2 first use cases that comes into my mind
15:38:12 <DinaBelova> from what I remember this might be tricky due to the current calls tree structure within the osprofiler
15:38:20 <DinaBelova> it needs to be checked separately
15:38:22 <ilyashakhat> shouldn't this be done on database/consumer side?
15:38:28 <tovin07> ok msimonin
15:38:53 <tovin07> ilyashakhat: yes, filtering with a large trace should be done in server side
15:39:02 <DinaBelova> ilyashakhat yes, it should
15:39:18 <DinaBelova> so right now we are talking not about the client in fact
15:39:18 <ilyashakhat> so idea is for osprofiler client?
15:40:24 <DinaBelova> ilyashakhat it may be a case, but right now we have none :)
15:40:44 <msimonin> Is there any known langage to query such a trace ?
15:40:50 <DinaBelova> tovin07 may I ask you to take a look on this problem?
15:40:59 <msimonin> that could be exposed to the client
15:41:07 <tovin07> yep DinaBelova
15:41:54 <DinaBelova> #action tovin07 take a look on the osprofiler filtering use cases #1 and #2 and share implementation ideas
15:42:08 <DinaBelova> msimonin I guess this is something to investigate
15:42:14 <tovin07> got it :D
15:42:29 <msimonin> for the 2 examples above I have a code that go through the big json and give the result
15:42:50 <DinaBelova> please link here just in case
15:42:57 <msimonin> actually rcherrueau wrote it
15:43:19 <msimonin> #link https://github.com/BeyondTheClouds/osp-utils
15:43:23 <DinaBelova> msimonin thanks
15:43:31 <DinaBelova> anything else here before we proceed?
15:43:32 <msimonin> (check the code ;) )
15:44:09 <DinaBelova> msimonin :)
15:44:13 <tovin07> whao, it’s haskell :)
15:44:50 <DinaBelova> msimonin ok, thanks for the code :D
15:44:58 <DinaBelova> it looks like we may jump to "current progress"
15:45:03 <DinaBelova> #topic Current progress
15:45:22 <DinaBelova> msimonin any updates sir? what's Inria working on now?
15:46:45 <msimonin> We'll probably dive in qpid dispatch router during the summer
15:46:50 <DinaBelova> and msimonin is silent :)
15:47:10 <msimonin> so for now it's mainly premilinary work on it
15:47:46 <DinaBelova> ok, thank you sir. Please keep us updated
15:47:49 <msimonin> folks from red hat are working on kolla intergation, once it'll done we'll start experimenting
15:48:03 <DinaBelova> msimonin do you have link to the patch?
15:48:08 <msimonin> ah yes
15:48:12 <msimonin> let me check
15:48:27 <msimonin> #link https://review.openstack.org/#/c/468966/
15:48:39 <msimonin> #link https://review.openstack.org/#/c/469462/
15:48:50 <DinaBelova> thank you :)
15:48:52 <msimonin> first is about splitting notification/rpcs
15:49:09 <msimonin> second is about qpid integration in kolla
15:49:49 <DinaBelova> thanks!
15:50:05 <DinaBelova> tovin07 anything to share about your osprofiler / other projects progress?
15:50:17 <tovin07> first
15:50:27 <tovin07> this small patch has been merged
15:50:36 <tovin07> #link https://review.openstack.org/#/c/316799/
15:50:40 <tovin07> msimonin: :D
15:51:29 <msimonin> tovin07: oh yeah :)
15:51:58 <msimonin> thanks
15:52:23 <tovin07> core reviewers of ceilometer said that I should not add osprofiler to it, because of deprecated things in ceilometer project
15:53:04 <tovin07> there is no new review in osprofiler patch in swift
15:53:19 <DinaBelova> sad week :)
15:53:46 <tovin07> this week, I publish some patch like this to gerrit
15:53:52 <tovin07> #link https://review.openstack.org/#/c/475251/
15:54:14 <tovin07> simple, but helpful :D
15:54:28 <tovin07> *patches
15:54:49 <tovin07> that’s all from me
15:55:04 <DinaBelova> thanks
15:55:15 <DinaBelova> I see ilyashakhat has joined us (again)
15:55:27 <DinaBelova> how is your new place and what are your working on for now?
15:55:30 <ilyashakhat> yep, I have some interested in this area :)
15:55:54 <DinaBelova> any specific items?
15:56:47 <ilyashakhat> mostly around collecting trace data
15:56:57 <ilyashakhat> but nothing more specific at this moment
15:57:06 <ilyashakhat> will try to help polishing osprofiler
15:57:19 <DinaBelova> ilyashakhat ack, thanks :) it will be really appreciated
15:57:28 <tovin07> thanks ilyashakhat for your help
15:58:08 <DinaBelova> okay, from my side everything is sad and miserable :) our labs are under maintenance and suffering issues after going out of it, so nothing specific
15:58:38 <msimonin> do you have more freetime under those circumstance ?
15:59:17 <DinaBelova> msimonin nope :D in these circumstances I have to deal with architecture and product specifications white papers :D
15:59:28 <msimonin> sad indeed :)
15:59:51 <DinaBelova> and this is especially sad when I do not have practical info in hands (due to labs maintenances) :D
15:59:59 <DinaBelova> so it's a bit crazy for me now
16:00:12 <DinaBelova> #topic Open Discussion
16:00:25 <DinaBelova> msimonin ilyashakhat tovin07 rama_y anything to share in open discussion?
16:00:48 <msimonin> One thing from my side
16:01:00 <DinaBelova> sure, shoot :)
16:01:08 <msimonin> There is this
16:01:11 <msimonin> #link http://lists.openstack.org/pipermail/openstack-dev/2017-June/118540.html
16:01:44 <rama_y> From my side, this patch is almost there. It is in need of core reviews: https://review.openstack.org/#/c/358142/
16:01:59 <msimonin> It seems there are some people interested in evaluating cockroachDB as db backend
16:02:56 <msimonin> so we'll try to gather some people tomorrow during the FEMDC WG
16:03:00 <DinaBelova> msimonin interesting
16:03:04 <DinaBelova> I never tried it :)
16:03:16 <msimonin> and for sure we'll need to analyse the performance at some point
16:03:26 <rama_y> Review(s) from Core reviewers from this group would help move the patch :)
16:03:48 <DinaBelova> rama_y ack, let me create an action item
16:04:03 <tovin07> rama_y: yup
16:04:04 <DinaBelova> #action DinaBelova tovin07 review https://review.openstack.org/#/c/358142/
16:04:26 <rama_y> Thanks!
16:04:58 <DinaBelova> msimonin do you want to try cockroachDB evaluation?
16:05:12 <msimonin> yes
16:05:32 <msimonin> I'd like to be involved in the evaluation
16:06:05 <msimonin> so if you know some people interested as well :)
16:06:23 <DinaBelova> msimonin I won't be able to help you here, sorry :(
16:06:31 <DinaBelova> as said, crazy paper-work days
16:06:59 <DinaBelova> so probalby it's on you
16:07:35 <msimonin> DinaBelova: sure :)
16:07:36 <DinaBelova> sorry :)
16:08:18 <DinaBelova> msimonin anything else? Where I can say I can help you :D
16:08:25 <msimonin> But just in case if someone here know someone interested :)
16:08:50 <DinaBelova> msimonin ack
16:08:58 <DinaBelova> ilyashakhat tovin07 - anything on your mind before we're closing the meeting?
16:09:07 <tovin07> mine not
16:09:08 <ilyashakhat> nop
16:09:47 <DinaBelova> okay, thanks folks :)
16:09:56 <DinaBelova> have aa nice evening / day
16:09:59 <DinaBelova> #endmeeting