15:30:01 <DinaBelova> #startmeeting Performance Team
15:30:02 <openstack> Meeting started Tue Jan 24 15:30:01 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:05 <openstack> The meeting name has been set to 'performance_team'
15:30:27 <DinaBelova> ad_rien_ spn sai akrzos o/
15:30:35 <ad_rien_> o/
15:30:35 <DinaBelova> tovin07 o/
15:30:36 <tovin07_> \o/ hello all
15:30:38 <sai> Hello DinaBelova !
15:30:39 <spn> o/
15:30:45 <spn> Good morning
15:30:58 <DinaBelova> hello folks :) good evening / morning :)
15:30:59 <ad_rien_> Hi all, (DinaBelova: msimonin is offline today)
15:31:07 <DinaBelova> ad_rien_ ack!
15:31:09 <DinaBelova> a very quick announcement before we get started
15:31:12 <akrzos> o/
15:31:24 <DinaBelova> todays sadly I have only 30 minutes (unexpected meeting >_<)
15:31:32 <DinaBelova> so let's try to fit to this margin :(
15:31:36 <DinaBelova> sorry for inconvinience
15:31:38 <akrzos> sounds good
15:31:47 <spn> thats okay DinaBelova
15:31:49 <DinaBelova> we may start with action items :)
15:31:55 <DinaBelova> #topic Action Items
15:32:17 <DinaBelova> sai thanks for proposing a change with ml2/odl plugin testing :)
15:32:35 <sai> np, that work is going to start mostly mid february
15:32:42 <sai> i still need to update the test plan
15:32:58 <DinaBelova> sai ok, thanks, I'll take a look on it anyway this week :)
15:33:17 <DinaBelova> #action DinaBelova review sai 's ml2/odl plugin test plan
15:33:22 <DinaBelova> akrzos it looks like I need to keep your action item for a while?
15:33:34 <DinaBelova> regarding adding information regarding current telemetry researches progress to performance docs
15:34:00 <DinaBelova> oh, sorry
15:34:06 <DinaBelova> #link https://review.openstack.org/#/c/421461/
15:34:12 <DinaBelova> I see the change :)
15:34:16 <DinaBelova> akrzos thank you sir :)
15:34:54 <akrzos> yup
15:34:57 <DinaBelova> the only action item left was on me and ad_rien_ - regarding if we can have some common presentation this summit
15:35:01 <akrzos> results are pending review
15:35:06 <DinaBelova> akrzos ack
15:35:15 <DinaBelova> #action DinaBelova review https://review.openstack.org/#/c/421461/
15:35:58 <DinaBelova> ad_rien_ - sadly I was really sick last week :( had to take a sick leave for almost the whole week - so I did not manage to spend my time on this
15:36:13 <DinaBelova> ad_rien_ any ideas from your side?
15:36:36 <ad_rien_> DinaBelova:  I think you are talking to akrzos ?
15:36:59 <DinaBelova> ad_rien_ nope :) already with you :) regarding action item that was on us
15:37:06 <DinaBelova> "think about what common presentation might be shown on summit"
15:37:12 <ad_rien_> ok sorry
15:37:16 <ad_rien_> my bad
15:37:20 <DinaBelova> it's ok :D
15:37:43 <ad_rien_> From our side
15:38:02 <ad_rien_> we would like to propose a performance study about OpenStack in a WAN context
15:38:24 <DinaBelova> #info Inria would like to propose a performance study about OpenStack in a WAN context (next summit)
15:38:27 <ad_rien_> The idea is to evaluate the impact of network latency (and possible network disconnections) between the controller services and compute nodes
15:38:57 <DinaBelova> ad_rien_ really good topic to be proposed + will be interesting for operators
15:38:58 <ad_rien_> We are currently discussing with Orange Labs and folks from the Chameleon testbed (University of Chicago)
15:39:30 <ad_rien_> We should have more information by the end of the week (as right now we are mainly exchanging emails to clarify what we would like to propose).
15:39:41 <DinaBelova> ad_rien_ ack, thank you sir
15:39:46 <rook> ohh nice ad_rien_ are you using tc to sim a WAN?
15:39:46 <ad_rien_> The experiment will leverage latest ENOS capabilities
15:39:51 <ad_rien_> rook:  yes
15:40:03 <rook> ad_rien_: any automation work for this?
15:40:16 <rook> ie, standing up tc to sim X connection
15:40:26 <ad_rien_> #link  https://github.com/BeyondTheClouds/enos
15:40:28 <rook> Sat/4g/edge/etc
15:40:54 <ad_rien_> rook:  that is the objective of ENOS (further information from the aforementioned link)
15:41:04 <rook> thanks ad_rien_
15:41:06 <ad_rien_> there is a technical report available at
15:41:16 <ad_rien_> #link https://hal.inria.fr/hal-01415522
15:41:46 <ad_rien_> DinaBelova:  do you think we can submit the presentation
15:41:54 <ad_rien_> with a kind of ''performance WG'' approved ?
15:42:03 <DinaBelova> ad_rien_ I believe that yes!
15:42:07 <ad_rien_> s/approved/label
15:42:08 <DinaBelova> it's really interesting topic
15:42:32 <ad_rien_> how can we do that? It would be nice to flag this presentation according to some WGs?
15:42:57 <DinaBelova> and I truly believe it'll have its audience
15:42:58 <DinaBelova> ad_rien_ I did not check the tagging opportunities that were given this summit
15:43:09 <DinaBelova> ad_rien_ at least I believe you may mention it in the description
15:43:15 <ad_rien_> ok
15:43:28 <ad_rien_> Does anyone from the Performance WG want to take part to this action?
15:43:32 <rook> I need to send the Neutron API Performance results for the testplan I created
15:43:37 * rook adds that to his to-do
15:43:44 <ad_rien_> I don't know by investigating a particular aspect?
15:43:51 <DinaBelova> ad_rien_ also one thing to mention - let's use the right name Performance Team (technically we're part of LDT WG)
15:43:53 <ad_rien_> (can be discussed next week)
15:44:08 <ad_rien_> DinaBelova:  ack
15:44:35 <DinaBelova> ad_rien_ let's discuss it next time - when you'll have clarity on the proposed topic :)
15:44:48 <ad_rien_> sure
15:45:01 <ad_rien_> you can give me an action
15:45:14 <DinaBelova> #info let's go through Inria's proposed summit talk next time, let's help folks to get the best presentation :)
15:45:31 <DinaBelova> #action ad_rien_ prepare info about OpenStack in a WAN context presentation
15:45:52 <DinaBelova> ok, it looks like we need to proceed (15 minutes left, sorry)
15:45:58 <DinaBelova> #topic Current progress on the planned tests
15:46:15 <DinaBelova> I believe that we have almost covered this topic :D
15:46:28 <DinaBelova> anyway, ad_rien_ - any specific experiments news?
15:46:37 <ad_rien_> no yet
15:46:43 <ad_rien_> still preparing the experiments.
15:46:47 <ad_rien_> We can move forward DinaBelova
15:46:57 <DinaBelova> #action rook add  Neutron API Performance results for the testplan he created
15:47:03 <DinaBelova> rook just added the action item on you sir
15:47:38 <DinaBelova> ok, from Telemetry / odl plugin testing we also have patches on review (thanks sai and akrzos )
15:48:10 <DinaBelova> from Mirantis side - we are currently discussing with Intel folks what part of our workloads tests can we share with community
15:48:43 <ad_rien_> can you elaborate a bit more DinaBelova ?
15:48:57 <DinaBelova> after two months of pure sharing I got some signs we'll need to hide some info due to legal discussions
15:48:58 <DinaBelova> ad_rien_ sure
15:49:47 <DinaBelova> in fact we have started workloads testing activity in December - what we wnated to have, is to test containerized OpenStack control plane and check it health during some real applications workloads running against the cloud
15:50:00 <DinaBelova> we used a methodology, proposed by Intel folks
15:50:08 <DinaBelova> in terms of our co-dev activity
15:50:34 <DinaBelova> and last week I got a request to put some info that used to be public to private access
15:50:57 <DinaBelova> in fact the meeting I have in 10 minutes is about it :)
15:50:58 <DinaBelova> with Intel folks
15:51:02 <DinaBelova> I want to clarify asap what we can share, what not and actually why
15:51:06 <ad_rien_> ok
15:51:26 <ad_rien_> Is it related to the Spec Cloud benchmark or it is something new/different?
15:51:31 <DinaBelova> yeah, a bit unexpected thing, but still
15:51:34 <DinaBelova> ad_rien_ different
15:51:35 <ad_rien_> (we can move forward if you prefer to discuss about it next week? )
15:51:47 <DinaBelova> ad_rien_ I'll share info next time for sure
15:51:51 <ad_rien_> sure
15:51:53 <ad_rien_> go ahead
15:51:54 <ad_rien_> thanks
15:52:11 <DinaBelova> #action DinaBelova share status of workloads testing methodology/results sharing
15:52:18 <DinaBelova> #topic Open Discussion
15:52:24 <DinaBelova> tovin07 o/
15:52:28 <tovin07_> I have good news, OSprofiler in Nova is OK now. Thank rpodolyaka, DinaBelova.
15:52:29 <tovin07_> OSprofiler in Magnum got +2 from PTL
15:52:30 <tovin07_> One patch for DinaBelova to review before it get W+1 (stevemar said that) https://review.openstack.org/#/c/294535/
15:52:43 <ad_rien_> tovin07:  \o/
15:52:44 <rpodolyaka> thank you tovin07_ as well! ;)
15:52:57 <DinaBelova> tovin07_ oh yeah
15:52:58 <DinaBelova> keystone db tracing
15:53:05 <tovin07_> I hope that today (IRC meeting in magnum), we will get W+1
15:53:13 <rpodolyaka> I want to add a gate job which would trigger profiling of typical scenarios
15:53:18 <DinaBelova> tovin07_ I really believe this change should be ok, but lemme check it on the env
15:53:27 <DinaBelova> #action DinaBelova review before it get W+1 (stevemar said that) https://review.openstack.org/#/c/294535/
15:53:30 <tovin07_> DinaBelova: yes
15:53:30 <DinaBelova> rpodolyaka wow :)
15:53:35 <DinaBelova> it will be really cool
15:53:45 <tovin07_> rpodolyaka: +1
15:53:53 <tovin07_> And
15:53:57 <tovin07_> DinaBelova, OSprofiler in Murano current status?
15:54:08 <tovin07_> I plan to do it
15:54:13 <rpodolyaka> ran into a few bumps with osprofiler and panko devstack plugins so far, want to fix that first
15:54:17 <DinaBelova> tovin07_ yes, please proceed with it
15:54:26 <DinaBelova> there is no active work on that from Mirnatis side
15:54:32 <tovin07_> okay, I will do that :D
15:54:48 <ad_rien_> DinaBelova:  I would like to know whether there will be a Google Summer of Code Campaign for OpenStack this year ?
15:54:58 <DinaBelova> rpodolyaka ok, that's cool
15:55:07 <rpodolyaka> DinaBelova: np! thanks for the review! ;)
15:55:10 <DinaBelova> ad_rien_ frankly speaking I have no idea :)
15:55:19 <DinaBelova> rpodolyaka you are welcome!
15:55:30 <ad_rien_> #link https://wiki.openstack.org/wiki/GSoC2016 you are mentioned as a mentors for the last campaign
15:56:04 <ad_rien_> we are thinking about proposing something from the Inria side around OpenStack but it would be probably more relevant to come through the OpenStack perspective.
15:56:14 <DinaBelova> ad_rien_ I was a mentor for outreachy program, that had an intersection with GSoC
15:56:38 <DinaBelova> so mostly I was active in outreachy program for women
15:56:59 <DinaBelova> and all mentors for outreachy were copied as well there :)
15:57:03 <ad_rien_> ok
15:57:04 <ad_rien_> :)
15:57:23 <DinaBelova> as that was only matter of mentee financing
15:57:35 <DinaBelova> not of the topic the mentee will work on
15:57:54 <DinaBelova> ad_rien_ and can you share what exactly are you planning to propose?
15:57:54 <ad_rien_> so If you hear about something, We would be pleased to propose something through the performance team
15:58:10 <ad_rien_> Coupling OSProfiler and performance analysis
15:58:23 <DinaBelova> ad_rien_ ack, got it. Are you interested only in GSoC? or other mentoring programs as well?
15:58:37 <DinaBelova> like the outreachy, that I mentioned?
15:58:49 <ad_rien_> can be. do you have some links?
15:58:57 <DinaBelova> on secong
15:59:08 <DinaBelova> #link https://wiki.openstack.org/wiki/Outreachy
15:59:13 <DinaBelova> ad_rien_ ^^
15:59:15 <ad_rien_> We are a research institution and we are used to propose internships so
15:59:18 <ad_rien_> ok thanks
15:59:25 <ad_rien_> gonna give a look to
15:59:28 <DinaBelova> ok :)
15:59:37 <DinaBelova> it looks like I need to jump to the next meeting
15:59:43 <DinaBelova> thank you folks for understanding
15:59:46 <ad_rien_> The interest if GSoC is that people receive a salary support
15:59:49 <DinaBelova> and for the quick meeting
15:59:51 <ad_rien_> which is rather attracting
15:59:53 <DinaBelova> ad_rien_ outreachy too
15:59:56 <tovin07_> thanks!
15:59:58 <ad_rien_> ok gonna look
16:00:01 <ad_rien_> thanks for the meeting
16:00:04 <DinaBelova> thanks!
16:00:05 <DinaBelova> #endmeeting