15:30:04 <DinaBelova> #startmeeting Performance Team
15:30:05 <openstack> Meeting started Tue Jan 10 15:30:04 2017 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:08 <openstack> The meeting name has been set to 'performance_team'
15:30:25 <DinaBelova> ok, hello folks :)
15:30:33 <rpodolyaka> o/
15:30:38 <DinaBelova> rpodolyaka o/
15:30:48 <DinaBelova> akrzos msimonin o/
15:30:58 <DinaBelova> tovin07 o/
15:31:52 <DinaBelova> let's wait for a few moments to find out if rpodolyaka and I are the only brave souls today to visit this meeting :)
15:32:13 <akrzos> here, hello!
15:32:28 <DinaBelova> akrzos yay!
15:32:45 <tovin07> o/
15:32:58 <msimonin> o/
15:33:11 <DinaBelova> cool, it looks like we have a quorum :)
15:33:22 <DinaBelova> so as usually let's start with action items
15:33:27 <DinaBelova> #topic Action Items
15:33:36 <DinaBelova> last time we had only one action item on myself
15:34:00 <DinaBelova> regarding Fluentd option for logs collecting in our monitoring solution
15:34:24 <DinaBelova> sadly I did not have a chance to discuss it yet as almost all our team was on winter holidays :)
15:34:32 <DinaBelova> so lemme leave this item for the next time as well
15:34:38 <spn> o/
15:34:41 <DinaBelova> #action DinaBelova discuss Fluentd option for logs collecting in our monitoring solution
15:34:43 <DinaBelova> spn o/
15:34:58 <DinaBelova> while we're still in this part of the meeting
15:35:33 <DinaBelova> akrzos msimonin I see you had lots of comments to the https://review.openstack.org/#/c/415563/
15:35:57 <DinaBelova> any common opinion? akrzos msimonin did you love what we tried to do? :)
15:36:02 <msimonin> yes sure
15:36:04 <msimonin> :)
15:36:56 <DinaBelova> msimonin please feel free to add more comments or questions - Oleg was going to answer all of them this week
15:37:07 <msimonin> I guess some parts were still missing
15:37:16 <msimonin> (at the time I checke)
15:37:16 <DinaBelova> msimonin true
15:37:20 <msimonin> checked*
15:37:23 <DinaBelova> that's why it's still WIP
15:37:27 <msimonin> ok :)
15:37:34 <DinaBelova> something yet needs to be added and polished
15:37:44 <DinaBelova> so expect some new versions soon
15:37:58 <akrzos> DinaBelova: It looks good to me
15:38:25 <DinaBelova> akrzos basically the same relates to you - please expect new version to appear on review :)
15:38:48 <DinaBelova> ok, so we may jump to the next section
15:38:49 <akrzos> sounds good
15:38:57 <DinaBelova> #topic Current progress on the planned tests
15:39:06 <DinaBelova> msimonin the floor is yours :)
15:39:11 <msimonin> ok
15:39:29 <msimonin> So at Inria side we are still interested in multisite deployments
15:39:48 <msimonin> multisite includes multiregion (but not only)
15:40:09 <msimonin> there will be a patch to Kolla to appear soon to add a better support
15:40:18 <msimonin> rcherrueau is working on it
15:40:25 <msimonin> *better support of multiregion
15:41:25 <msimonin> We are currently refactoring some code in our deployment tools to support these new deployment modl
15:41:45 <msimonin> and hopefully this will be done soon
15:42:03 <DinaBelova> msimonin ack
15:42:34 <msimonin> So it's progressging surely :)
15:42:46 <DinaBelova> msimonin thanks for the update :)
15:43:20 <DinaBelova> akrzos sir, any news regarding telemetry testing? :)
15:43:42 <akrzos> I worked on using objecstorage nodes (swift) for the storage driver now
15:43:48 <akrzos> objectstorage*
15:44:06 <akrzos> I had some trouble getting this to deploy correctly and some general tuning
15:44:27 <akrzos> i was able to get it eventually working
15:44:45 <akrzos> and in comparsion to gnocchi with ceph it doesn't look good :(
15:44:58 <DinaBelova> oh, any numbers?
15:45:22 <akrzos> I think there is more tuning that swift could use however my "leases" on the hardware expired
15:45:49 <akrzos> basiclly with the setup i was able to get running i could only get to ~200 instances before gnochi backlog was growing
15:46:09 <akrzos> without ever decreases and eventually ceilometer collector grows in memory too
15:46:16 <akrzos> until controllers ran out of memory
15:46:36 <akrzos> in comparsion to ceph i got to 1k instances with some small tuning and a large number of metricd workers
15:47:05 <DinaBelova> oh, it does not look really well
15:47:14 <akrzos> i need to digest all of this data and create some publishable results
15:47:26 <akrzos> already opened one upstream bug around swift
15:47:29 <akrzos> and tripleo
15:47:59 <akrzos> ideally i can get some this digest into performance-docs
15:48:13 <akrzos> so i need that action item
15:48:24 <DinaBelova> akrzos this will be really cool
15:48:34 <DinaBelova> #action akrzos add information regarding current telemetry researches progress to performance docs
15:48:36 <DinaBelova> done
15:48:37 <DinaBelova> thanks
15:49:00 <DinaBelova> ok, anything else sir you'd like to share in this section?
15:49:04 <spn> how many compute nodes
15:49:14 <spn> for the 1k vms arkzos?
15:49:25 <DinaBelova> akrzos ^^
15:50:02 <akrzos> 10
15:50:06 <akrzos> spn: ^
15:50:22 <akrzos> so only a 100 instances per compute
15:50:38 <spn> over commit?
15:50:44 <akrzos> DinaBelova: nothing else from me for now
15:50:54 <akrzos> spn: yes, these are just idle instances to create load
15:51:03 <spn> ok cool
15:51:10 <akrzos> i adjust nova allocation ratios to allow many
15:51:34 <akrzos> i will be adding a scenario to create networks for the instances too
15:51:41 <akrzos> so we can get a bit more complete workload
15:52:24 <DinaBelova> akrzos thanks
15:52:25 <DinaBelova> ok, from my side it's not really a week with lots updates, as almost all team was on winter holidays last week :) basically we're going to continue two activities
15:52:27 <DinaBelova> 1) complete all items to performance docs on review
15:53:27 <DinaBelova> 2) continue current workloads testing, that we were not able to finish before new year (with all of those measurements being colelcted + real workloads run against containerized OpenStack to observe the overall cluster health during this action)
15:53:42 <DinaBelova> collected*
15:54:25 <DinaBelova> so basically that's all from my side today, nothing to add here
15:54:39 <DinaBelova> it looks like we may jump to Open Discussions
15:54:43 <DinaBelova> #topic Open Discussion
15:55:01 <DinaBelova> rpodolyaka tovin07 any updates regarding https://review.openstack.org/#/c/254703/ ?
15:55:20 <tovin07> Oh yes
15:55:24 <tovin07> http://lists.openstack.org/pipermail/openstack-dev/2017-January/109725.html
15:55:38 <rpodolyaka> DinaBelova: yeah, we sort of expect people will get to review it tomorrow
15:55:45 <DinaBelova> #link http://lists.openstack.org/pipermail/openstack-dev/2017-January/109725.html
15:55:46 <msimonin> cool ! :)
15:55:47 <DinaBelova> yaaaay
15:55:53 <rpodolyaka> there is +2 +W on the novaclient one
15:55:56 <DinaBelova> I feel so happy reading this :D
15:56:13 <rpodolyaka> well, I'd say it's a bit early to be happy ;)
15:56:21 <rpodolyaka> let's see how it goes
15:56:24 <tovin07> :v
15:56:28 <DinaBelova> rpodolyaka well :) at least I see activity around this
15:56:42 <DinaBelova> and that's something I really love to see :)
15:56:52 <rpodolyaka> heh, me too :)
15:56:59 <DinaBelova> rpodolyaka tovin07 thank you folks for this activity being pushed so far
15:57:03 <rpodolyaka> np!
15:57:08 <DinaBelova> let's see how the reviewing process will go
15:57:11 <tovin07> :D
15:57:43 <DinaBelova> akrzos spn msimonin anything else to share today?
15:57:52 <msimonin> Not from my side
15:57:54 <tovin07> I will be around tomorrow in #openstack-nova
15:58:09 <spn> I wanted to add spec topic to the etherpad for our discussion
15:58:25 <DinaBelova> #info so just a reminder - please add your items to https://etherpad.openstack.org/p/ptg-performance-team - we'll go through it next time
15:58:25 <akrzos> I think there was more added to the ptg etherpad
15:58:26 <DinaBelova> spn sure
15:58:32 <spn> but I am curious about the interest on it.  We in Dell are basically using spec for full performance analysis
15:58:40 <spn> of openstack
15:58:46 <tovin07> I will push some patch in magnum later this week to integrate osprofiler with magnum
15:58:53 <tovin07> #link https://blueprints.launchpad.net/magnum/+spec/osprofiler-support-in-magnum
15:59:18 <DinaBelova> spn it looks like in this group it's true for you, and I guess Intel folks are using it as well
15:59:32 <DinaBelova> but others did not have a chance to try it yet
15:59:32 <tovin07> Hope it will be finished in this O cycle
15:59:38 <DinaBelova> tovin07 ack
16:00:01 <DinaBelova> spn please add your item anyway
16:00:02 <spn> I can give details about it when we meet and also tell how the performance is measured on our architecture
16:00:11 <spn> Ok cool
16:00:25 <DinaBelova> let's have a plan deep dive to spec as well
16:00:40 <DinaBelova> ok, it looks like we're done for today :)
16:00:42 <spn> DinaBelova: sure. thank you
16:01:02 <akrzos> Thanks!
16:01:03 <DinaBelova> folks, once again - happy to work with you and see you next time :)
16:01:05 <DinaBelova> bye!
16:01:10 <DinaBelova> #endmeeting