15:30:01 <DinaBelova> #startmeeting Performance Team
15:30:02 <openstack> Meeting started Tue Nov  8 15:30:01 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:30:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:30:05 <openstack> The meeting name has been set to 'performance_team'
15:30:16 <DinaBelova> hey folks :)
15:30:23 <DinaBelova> welcome back to our meetings :)
15:30:33 <DinaBelova> let's see who's around :)
15:31:14 <DinaBelova> ad_rien_, sai ?
15:32:15 <ad_rien_> ye
15:32:16 <ad_rien_> s
15:32:19 <ad_rien_> sorry
15:32:37 <DinaBelova> ad_rien_ heh, I almost felt like none survived through the after-summit :D
15:32:37 * ad_rien_ is contacting other Inria folks
15:32:59 <ad_rien_> Actually we are debriefing since this morning.
15:33:00 <ad_rien_> ;)
15:33:08 <DinaBelova> haha :D
15:33:10 <ad_rien_> We are talking about new experiments :-P
15:33:10 <DinaBelova> that's true
15:33:19 <msimonin> o/
15:33:23 <DinaBelova> msimonin o/
15:33:33 <DinaBelova> ad_rien_ will be glad if you'll share them today :D
15:33:42 <DinaBelova> heh, so let's start with not so many people
15:33:47 <ad_rien_> msimonin was explaining that points.
15:33:59 <DinaBelova> as after-summit meetings are usually very lazy :D
15:34:04 <DinaBelova> #topic Summit recap
15:34:12 <DinaBelova> so first of all some summit recap
15:34:32 <DinaBelova> I've decided to add new section to the perf docs
15:34:34 <DinaBelova> https://review.openstack.org/#/c/393538/
15:34:43 <DinaBelova> dedicated to summit and other events recaps
15:35:19 <DinaBelova> @ad_rien_ @msimonin please feel free to update a commit
15:35:22 <DinaBelova> #link https://review.openstack.org/#/c/393538/
15:35:39 <DinaBelova> or at least review it - if there is something else you'd like to add, let's do it
15:35:59 <DinaBelova> I think this section is very beneficial for newcomers to take a look on
15:36:52 <DinaBelova> so that's all I wanted to mention regarding passed summit
15:37:05 <ad_rien_> Ok thanks. We can probably also mention the NFV Working group
15:37:11 <DinaBelova> ad_rien_ sure
15:37:17 <ad_rien_> especially because during the last meeting we talk about performance experiements
15:37:19 <DinaBelova> please feel free to update a change
15:37:28 <ad_rien_> please add the action
15:38:00 <DinaBelova> #action ad_rien_ update https://review.openstack.org/#/c/393538/ with the nfv group info
15:38:10 <ad_rien_> thanks
15:38:27 <DinaBelova> ok, so it looks like we may jump to the planned tests and progress around them
15:38:31 <DinaBelova> #topic Current progress on the planned tests
15:38:43 <sai> DinaBelova: hey, i took a week off after summit
15:38:48 <sai> so just back to work, not much updates
15:38:51 <DinaBelova> ad_rien_ msimonin do you want to start with your folks ideas regarding further experiments?
15:38:54 <DinaBelova> sai ack, thanks
15:39:16 <ad_rien_> The idea
15:39:33 <ad_rien_> is to evaluate several deployment scenarios regarding the multi regions concept
15:40:15 <ad_rien_> we released the ENOS software (the tool we used for the last experiments)
15:40:19 * ad_rien_ is looking for the link
15:40:39 <rcherrueau> #link https://github.com/BeyondTheClouds/enos
15:40:45 <DinaBelova> thanks rcherrueau
15:40:50 <ad_rien_> we want to add some topology informations and emulate them using TC.
15:41:11 <ad_rien_> Thanks to such extensions, we would be able to evaluate mutli-site deployments
15:41:25 <ad_rien_> with network constraints (BW, latency) between each node
15:41:33 <ad_rien_> (controller and compute nodes)
15:41:48 <ad_rien_> so this is, roughly, our goal
15:42:06 <ad_rien_> obviously we want to continue to contribute/collaborate to the WG.
15:42:19 <DinaBelova> also I believe huge part of the research will be around openstack configs tuning go find out what combo is leading to max performance and scalability
15:42:27 <ad_rien_> yes
15:42:32 <DinaBelova> ad_rien_ really good goal
15:42:56 <DinaBelova> ad_rien_ once you'll be able to submit a test plan, pleae go ahead and push it to review
15:43:04 <ad_rien_> basically we are discussing with redhat guys to evaluate QPID
15:43:17 <ad_rien_> we are also identifying the different deployment possibilities
15:43:25 <ad_rien_> (one AMQP vs several AMQP)...
15:43:41 <DinaBelova> I believe this research should become a huge part of Perf WG progress this cycle
15:43:41 <ad_rien_> so step 1: determine the deployment scenarios
15:43:52 <ad_rien_> step 2: determine the benchmark we want to perfor
15:43:59 <ad_rien_> step 3 perform the experiments
15:44:29 <DinaBelova> step 4 analyze everything :D
15:44:34 <ad_rien_> :)
15:44:37 <DinaBelova> yeah, good plan
15:44:41 <msimonin> DinaBelova: if you know people interested in messaging evaluation we will be happy to work with them
15:44:58 <DinaBelova> ad_rien_ please keep us updated on this way
15:45:01 <ad_rien_> I'm trying to combine efforts between the NFV WG and the Massively distributed one.
15:45:02 <DinaBelova> msimonin I'll check
15:45:08 <ad_rien_> sure
15:45:20 <DinaBelova> ok, cool
15:45:31 <ad_rien_> I was also wondering
15:45:38 <DinaBelova> yep?
15:45:42 <ad_rien_> whether such evaluations can be usefull for the LDT ?
15:45:52 <DinaBelova> ad_rien_ yes, they will for sure
15:46:11 <ad_rien_> If I'm right the last meeting/session in Barcelone did not conclude with concrete actions.
15:46:14 <DinaBelova> I think that one of the goals this cycle will be to keep LDT updated on what we're doing
15:46:20 <ad_rien_> Maybe you discussed offline with the LTD guys ?
15:46:49 <DinaBelova> ad_rien_ the discussion we had was a bit messed due to the overlapping sessions some LDT folks needed to attend
15:46:56 <ad_rien_> ok
15:47:35 <DinaBelova> so in short: they are really glad to see more researches shared, esp. on your case, regarding Neutron (what was done previous cycle) and telemetry
15:47:43 <ad_rien_> ok
15:47:59 <DinaBelova> sai afaik you folks have evaluated gnocchi during your researches?
15:48:20 <sai> DinaBelova: yes
15:48:30 <sai> my teammate did, hes not on the channel
15:48:33 <sai> ill get him to join:)
15:48:42 <DinaBelova> LDT team is really wishing to see what was discovered, what's the comparison with usual Ceilo etc.
15:49:07 <DinaBelova> sai ack, in short I may ask the following question: do you will to publish this data to performance docs?
15:49:32 <DinaBelova> as said, LDT folks are interested in this information to be publicly available
15:50:16 <sai> DinaBelova: i dont see why we shouldnt, as long ad we can get the formatting right
15:50:25 <sai> its realy abt time at this point, we have a fairly small team
15:50:25 <DinaBelova> sai right
15:50:29 <sai> but sure ill take this up
15:50:34 <DinaBelova> sai ack
15:50:35 <sai> and ask
15:51:03 <DinaBelova> #action sai find out when information about telemetry researched Red Hat has done can be published to performance docs
15:51:21 <DinaBelova> sai in fact you may publish the very first version of test plan / test results
15:51:34 <DinaBelova> and either I or someone from my team can polish it to get merged
15:51:43 <sai> ack we curently publish results to our blogs
15:52:12 <DinaBelova> sai that's good, but I believe having it in official openstack docs is also cool :)
15:52:19 <sai> understood
15:52:21 <sai> :)
15:52:24 <DinaBelova> anyway, let's think about it :)
15:52:28 <sai> sure
15:52:36 <DinaBelova> ok, so about Mirantis plans for further cycle
15:52:55 <DinaBelova> as said on summit, we want to focus on OpenStack on top of k8s deployments
15:53:17 <DinaBelova> and check how we can make them performant and scalable (on both k8s and OpenStack side :) )
15:53:51 <DinaBelova> this require from us very advanced monitoring of everything that's happening on the env on three layers
15:54:07 <DinaBelova> 1 system layer 2 k8s layer 3 OpenStack itself
15:54:34 <DinaBelova> right now we're working on how we may achieve that kind of monitroing and what we need to measure using Prometheus
15:54:42 <DinaBelova> as a monitoring solution
15:55:10 <DinaBelova> and also we're trying to identify what test cases do we want to use
15:55:25 <DinaBelova> in short that's all for now, as that's mostly research work :)
15:55:53 <ad_rien_> cool.
15:55:53 <DinaBelova> I'll keep you folks updated about where are we each week
15:56:11 <ad_rien_> Do you know whether current actions on osprofiler will keep going
15:56:25 <DinaBelova> ad_rien_ yes, they will :)
15:56:30 <msimonin> What tool are you usig to deploy openstack on kubernetes ? fuel ?
15:56:31 <DinaBelova> slow enough ,but will
15:56:59 <DinaBelova> ad_rien_ our nova team kindly agreed to help finish work on the Nova+OSproflier change
15:57:02 <ad_rien_> DinaBelova:  cool, we are interested by integrating OSprofiler with ENOS, we believe it will help to understand the performance results
15:57:11 <DinaBelova> rpodolyaka ^^
15:57:16 <DinaBelova> ad_rien_ sure :)
15:57:35 <DinaBelova> ad_rien_ I believe I'll cut new release of OSprofiler soon
15:57:59 <DinaBelova> it will contain elastic search, Log Insight and Redis drivers for osprofiler
15:58:22 <DinaBelova> that will make it more flexible for choosing the storage solution
15:58:49 <DinaBelova> sai do you want to share what do you guys are planning to do in nearest future
16:00:01 <DinaBelova> it looks like nope :D
16:00:16 <DinaBelova> ok, so we may jump to Open Discussions part
16:00:20 <DinaBelova> #topic Open Discussion
16:00:28 <DinaBelova> anything else to share?
16:00:35 <ad_rien_> We have one question regarding the cell v2
16:00:36 <ad_rien_> ?
16:00:52 <DinaBelova> sure
16:01:01 <ad_rien_> Actually, if we are correct Andrew left Mirantis ?
16:01:11 <DinaBelova> ad_rien_ yep, that's right
16:01:16 <ad_rien_> He was one of the key person of the cellV2? w
16:01:38 <ad_rien_> do you have any information regarding the future of cells V2 ?
16:01:44 <DinaBelova> ad_rien_ yeah... in fact I'm not sure what he will be focusing on in nearest future
16:01:58 <DinaBelova> dims do you know anything about this?
16:02:28 <DinaBelova> about cells V2 further development?
16:02:40 <DinaBelova> ad_rien_ lemme add action item on myself
16:03:07 <ad_rien_> At Inria we are definitely interested by all changes that the cell V2 feature implies.
16:03:12 <DinaBelova> #action DinaBelova check what's going on with cells V2 development and if Andrew Laski is going to continue contributing out of Mirantis
16:03:20 <DinaBelova> ad_rien_ ack, got it
16:03:35 <ad_rien_> Especially because it can help (or increase the complexity) of managing an openstack deployment between several sites
16:03:38 <DinaBelova> ad_rien_ I'll check it offline and will share as soon as will have something
16:03:45 <ad_rien_> ok thanks
16:04:10 <DinaBelova> ok, it looks like that's all for today
16:04:13 <ad_rien_> Ok second point
16:04:16 <DinaBelova> I have nothing to add
16:04:20 <DinaBelova> oh :)
16:04:21 <DinaBelova> please go ahead
16:04:22 <msimonin> :)
16:04:24 <DinaBelova> sorry :)
16:04:32 <msimonin> we can't stop ad_rien_
16:04:34 <ad_rien_> Will we try to target  a common goal as we did during the last cycle.
16:04:45 <ad_rien_> (if it makes sense obvisouly), I found this really cool.
16:05:04 <DinaBelova> ad_rien_ do you mean some common topic to work on, like 1000 node testing?
16:05:08 <ad_rien_> yes
16:05:36 <ad_rien_> by targetting a common goal, it motivates to collaborate and show the relevance of the WG.
16:05:56 <DinaBelova> ad_rien_ let's think about this :) right now all of us have their own priorities due to what companies we're working on want from us :D but I think that's possible for sure
16:06:23 <DinaBelova> ad_rien_ one thing I really want us to focus on is to have closer collaboration with LDT
16:06:28 <ad_rien_> great, I just wanted to raise that point just to be sure that we are not just doing on own actions on our side ;)
16:06:58 <DinaBelova> ad_rien_ well, in fact community is all about it :D and about people who want to work together on something :D
16:07:36 <DinaBelova> ad_rien_ let's try to find out what can be a common point for all of us
16:07:37 <ad_rien_> exactly, right now as you raised. Everyone (i.e. on his/her side) just presented the goals of his/her institutions
16:07:41 <ad_rien_> great ;)
16:07:48 <ad_rien_> Thanks DinaBelova
16:07:54 <DinaBelova> sure :)
16:07:59 <DinaBelova> ad_rien_ anything else?
16:08:10 <ad_rien_> no that's all thanks ;)
16:08:17 <DinaBelova> ahaha, np :)
16:08:22 <DinaBelova> thanks everyone for joining
16:08:25 <DinaBelova> #endmeeting