16:00:01 <DinaBelova> #startmeeting Performance Team
16:00:02 <openstack> Meeting started Tue May 31 16:00:01 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:05 <openstack> The meeting name has been set to 'performance_team'
16:00:22 <DinaBelova> hey folks!
16:00:29 <DinaBelova> are there people around? :)
16:03:51 <DinaBelova> interesting, it looks like nobody has joined yet :)
16:04:06 <AugieMena> here
16:04:11 <DinaBelova> AugieMena hey!
16:04:21 <DinaBelova> let's see if people will join :)
16:04:23 <DinaBelova> gokrokve o/
16:04:29 <gokrokve> o/
16:04:33 <AugieMena> hi
16:04:56 <DinaBelova> gokrokve, AugieMena - I know lezbar won't we able to join, as well as ilyashakhat and rohanion
16:05:04 <DinaBelova> not sure about others
16:05:55 <DinaBelova> let's see if we'll have quorum today :)
16:06:14 <gokrokve> three of us are here
16:06:21 <DinaBelova> although, gokrokve, AugieMena - I may go through the action items and agenda just for you :)
16:06:27 <DinaBelova> yeah, sure
16:06:29 <gokrokve> thanks
16:06:32 <AugieMena> ok, sure
16:06:37 <DinaBelova> ok, so let's get started
16:06:48 <openstack> DinaBelova: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
16:06:52 <DinaBelova> oh, sorry :)
16:06:57 <DinaBelova> #topic Action Items
16:07:03 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2016/performance_team.2016-05-24-16.00.html
16:07:12 <DinaBelova> first of all action items
16:07:22 <DinaBelova> rook are you around?
16:07:58 <DinaBelova> in the meanwhile - lezbar reached me before the meeting
16:08:21 <DinaBelova> so he had a quick conversation about MidoNet vs OVN comparison test plan sharing inside his company
16:08:39 <DinaBelova> right now this task is on hold, so he cannot share anything with community so far
16:09:05 <DinaBelova> he promised to check when the task will be reopened and raise this question asap
16:09:19 <DinaBelova> as for my action item - about Ironic scale and performance testing effort progress with Mirantis Ironic team
16:09:38 <DinaBelova> i had a chat with our Ironic team lead
16:10:00 <DinaBelova> they have performed primary scalability testing several weeks ago
16:10:11 <DinaBelova> against 1000 "virtual" HW nodes
16:10:26 <DinaBelova> and have plans to continue the research soon
16:10:43 <DinaBelova> so we agreed to publish this research and its results to the perofrmance-docs
16:11:01 <DinaBelova> no ETAs so far due to the lack of real HW to work as a test env
16:11:11 <DinaBelova> i hope to have some ETAs next week
16:11:41 <DinaBelova> #action DinaBelova check what ETAs can be used for Ironic tests/results publishing
16:12:11 <DinaBelova> as for the left action item - it's on rook and frankly speaking I don't know about its status
16:12:22 <DinaBelova> so let's leave it for the next time
16:12:27 <DinaBelova> #action rook ilyashakhat go through the offloading model suggestion
16:12:44 <DinaBelova> that's all regarding our action items from the last time
16:13:14 <DinaBelova> gokrokve, AugieMena - if no comments, let's proceed
16:13:35 <AugieMena> just a quick update on the Identity V3 Rally support issue
16:13:50 <DinaBelova> AugieMena - yes, sir?
16:14:11 <AugieMena> there was a comment just added to the bug this morning:  https://bugs.launchpad.net/rally/+bug/1441379
16:14:11 <openstack> Launchpad bug 1441379 in Rally "Need Rally deployment create support on domain_id or domain_name in order to support keystone v3 test (which needs domain scoped token). The current project scoped token only works in service API but not keystone v3 API (DTUG domain, user, group...)." [Medium,Fix committed]
16:14:29 <DinaBelova> #link https://bugs.launchpad.net/rally/+bug/1441379
16:14:43 <DinaBelova> oh, it looks like we have a volunteer :)
16:14:46 <DinaBelova> very cool :)
16:14:58 <rook> hey DinaBelova
16:14:59 <AugieMena> I've asked Kavitha (on our team) to add info to the bug in response to Michael's question on the work she's done so far, etc
16:15:10 <DinaBelova> AugieMena ack, thanks
16:15:32 <DinaBelova> ok, cool
16:15:40 <DinaBelova> moving on
16:15:46 <DinaBelova> #topic Current progress on the planned tests
16:16:07 <DinaBelova> during last week Mirantis team was working on the final lab preparation/automatizartion
16:16:56 <DinaBelova> #info today we started running data plane tests using the test plan: http://docs.openstack.org/developer/performance-docs/test_plans/tenant_networking/plan.html
16:17:24 <DinaBelova> right after this baseline rally tests and basic load tests are planned
16:17:38 <DinaBelova> listomin will add test plan on review before end of week
16:17:45 * ad_rien_ just joined the meeting sorry for the delay
16:17:50 <DinaBelova> ad_rien_ o/
16:18:24 <DinaBelova> so for now we're waiting for the data plane test results, once they will be ready, we'll switch to the next ones
16:19:08 <DinaBelova> I do not have any particular updates except the mentioned ^^
16:19:26 <DinaBelova> ad_rien_, do you have any news about your ZeroMQ research?
16:19:30 <ad_rien_> no
16:19:35 <DinaBelova> :D
16:19:36 <DinaBelova> ack
16:19:37 <ad_rien_> we postponed this action untill end of june
16:19:47 <ad_rien_> We are working on Rally/Openstack on G5K
16:19:56 <ad_rien_> as discussed we want to identify all bottleneck
16:20:01 <ad_rien_> I was offline last week
16:20:14 <DinaBelova> #info ad_rien_ 's team has postponed additional ZeroMQ research till the end of June
16:20:21 <ad_rien_> but the week before we ended the meeting with the idea of trying to mutualize the effort
16:20:25 <ad_rien_> on that point.
16:20:29 <ad_rien_> we can discuss it later
16:20:37 <DinaBelova> ad_rien_ - very nice, thank you
16:20:57 <DinaBelova> in fact we may cover this topic now
16:21:25 <DinaBelova> ad_rien_ - we're going to publish our variant of baseline rally scenarios before the end of the week
16:21:34 <ad_rien_> ok nice.
16:21:38 <DinaBelova> I mean test plan with these scenarios
16:21:49 <DinaBelova> once I'll have the review number I'll ping you here, sir
16:22:13 <ad_rien_> ok my idea was to share the effort on the engine that performs all the tests
16:22:18 <DinaBelova> in fact we wanted to start this activity 1 week earlier, but had several issues with lab preparation / automatization
16:22:24 <ad_rien_> ok
16:22:37 <ad_rien_> If I'm correct you are doing that on your own testbed
16:22:55 <ad_rien_> our idea is to complete these experiments by conducting the same ones on Grid'5000
16:23:09 <DinaBelova> we're using rally for testing, but Jenkins for automatic jobs running
16:23:20 <DinaBelova> i mean rally for these types of tests
16:23:26 <ad_rien_> we have an experiments engine : http://execo.gforge.inria.fr/doc/latest-stable/
16:23:41 <DinaBelova> #link Inria's  experiments engine : http://execo.gforge.inria.fr/doc/latest-stable/
16:24:04 <ad_rien_> yes but I guessed you need to customize everything (i.e. deployment of specific version of OpenStack, Rally, … and then launch rally)
16:24:09 <DinaBelova> ad_rien_ - I need to go through the docs
16:24:17 <ad_rien_> ok
16:24:18 <DinaBelova> ad_rien_ - sure, we use jenkins for this purpose
16:24:22 <ad_rien_> ok
16:24:27 <DinaBelova> so I need to compare the effort
16:24:41 <DinaBelova> ok, lemme create an action item for myself
16:24:50 <ad_rien_> ok it would be great if we can share our scripts and see the best of the two worlds
16:25:03 <DinaBelova> #action DinaBelova go through the http://execo.gforge.inria.fr/doc/latest-stable/ and compare it with the approach used inside Mirantis
16:25:10 <DinaBelova> ad_rien_ agreed
16:25:30 <DinaBelova> gokrokve - do you think we can make the jobs / scripts we are using publicly available?
16:25:36 <ad_rien_> :-) ?
16:25:50 <gokrokve> sure
16:25:53 <DinaBelova> as a part of some new repo (to be created)
16:25:55 <DinaBelova> cool
16:26:01 <DinaBelova> I think this is a great approach
16:26:09 <gokrokve> we need to make them  available
16:26:45 <DinaBelova> #action DinaBelova check current status of internal Mirantis JJ and python scripts - if they can be made public right now. Evaluate what needs to be done otherwise
16:27:03 <DinaBelova> ad_rien_ - I'll try to complete this research before next meeting
16:27:35 <ad_rien_> on our side, we have an engine to deploy on demand an openstack infrastructure and then have an engine to setup the rally server and start the benchs
16:27:48 <DinaBelova> sadly I'm a bit busy with my current Mirantis OpenStack release managere role, so I cannot guarantee this.. I'll try
16:28:00 <ad_rien_> #link https://www.grid5000.fr/mediawiki/index.php/OpenStack_deployment_on_Grid5000
16:28:06 <DinaBelova> ad_rien_ can this engine to be modified to run not only rally?
16:28:10 <ad_rien_> yes
16:28:25 <DinaBelova> very cool - for instance, right now rally cannot process data plane tests
16:28:32 <DinaBelova> therefore I asked :)
16:28:55 <DinaBelova> thanks, I'll go through the links you published before next meeting
16:28:55 <ad_rien_> the goal of execo is to run a complete experimental protocol with different parameters
16:29:20 <ad_rien_> It is quite hard for Inria people to attend meetings each week,
16:29:33 <DinaBelova> ad_rien_ - where is source code of this engine stored?
16:29:41 <ad_rien_> I think that you can put such an action for middle of June
16:29:48 <DinaBelova> ack, cool
16:29:54 <DinaBelova> anyay, I'll try to do this asap
16:30:03 <DinaBelova> and let's see when we'll be able to intersect
16:30:24 <ad_rien_> https://github.com/asimonet/rally-g5k/blob/master/rally-g5k.py
16:30:31 <DinaBelova> #link https://github.com/asimonet/rally-g5k/blob/master/rally-g5k.py
16:30:33 <DinaBelova> ack, thanks
16:30:56 <DinaBelova> it looks like that's all for this particular topic
16:31:19 * hockeynut apologizes, just got done with another meeting
16:31:24 <DinaBelova> hockeynut :D
16:31:35 <DinaBelova> ad_rien_, hockeynut - is the time of the meeting not ok for you?
16:31:41 <DinaBelova> we may try to rearrange it
16:31:55 <hockeynut> DinaBelova normally this is fine with me.  Just not today
16:32:01 <DinaBelova> hockeynut ack
16:32:03 <DinaBelova> ad_rien_ ?
16:32:09 <ad_rien_> please keep in mind that the engine has been done for Grid'5000 (i.e. we are using our own baremetal deployment tool, called kadeploy)
16:32:25 <ad_rien_> time is ok, frequency rather hard right now
16:32:31 <DinaBelova> ad_rien_ ok, thanks
16:32:36 <ad_rien_> our FTE will join us by end of June
16:32:43 <DinaBelova> I'll keep this in mind
16:32:47 <ad_rien_> right now we have only postdoc and Phd guys
16:33:16 <ad_rien_> and Mathieu (msimonin) is for the moment working only 40% on the project
16:33:27 <DinaBelova> ok, I got it
16:33:31 <DinaBelova> good to know
16:34:26 <DinaBelova> I think that's all regarding the test plans / test runs for now. I think we may skip next topic (OSprofiler updates) as no major things happened since previous week
16:34:39 <DinaBelova> and rohanion is on vacation (he works on the new drivers structure)
16:35:00 <DinaBelova> so most probably I'll jump to Open Discussion if no objections
16:35:05 <ad_rien_> DinaBelova:  just a last #link for Execo (can be easier than RTFM) : https://hal.inria.fr/hal-00861886/en
16:35:24 <DinaBelova> #info  Execo (can be easier than RTFM) : https://hal.inria.fr/hal-00861886/en
16:35:28 <DinaBelova> thanks you sir
16:35:38 <DinaBelova> #topic Open Discussion
16:35:47 <DinaBelova> so jumping to the Open Discussion part
16:36:00 <DinaBelova> as said, no major updates from my side so far
16:36:14 <ad_rien_> same on the Inria side
16:36:17 <DinaBelova> probably someone would like to raise his/her own topic
16:36:25 <DinaBelova> hockeynut, gokrokve, AugieMena ?
16:36:40 <gokrokve> I dont have any
16:36:44 <AugieMena> nothing new
16:36:46 * hockeynut is working on some rally+barbican integration to get up to speed with rally plugins
16:37:14 <DinaBelova> hockeynut - may you please share link to the patches (if any of them ready)?
16:37:22 <gokrokve> As I know Alex is working on 1000 nodes results document
16:37:30 <gokrokve> It should be published in our docs
16:37:31 <hockeynut> DinaBelova I certainly will
16:37:46 <DinaBelova> gokrokve ack. Hope to see this plan published soon :)
16:37:49 <DinaBelova> hockeynut ack
16:38:19 <DinaBelova> hockeynut - now? :)
16:38:35 <hockeynut> DinaBelova hoping to have them up later today...nothing yet
16:38:51 <DinaBelova> hockeynut ok, I just wanted to add #link if you have the links now :)
16:38:58 <DinaBelova> if no - it's also ok
16:39:10 <DinaBelova> it looks like we covered all important topics for today
16:39:21 <DinaBelova> thanks for attending and see you later
16:39:24 <DinaBelova> bye!
16:39:30 <DinaBelova> #endmeeting