16:00:05 <DinaBelova> #startmeeting Performance Team
16:00:06 <openstack> Meeting started Tue Feb 23 16:00:05 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'performance_team'
16:00:14 <DinaBelova> o/
16:00:36 <DinaBelova> I think this time we won't have too many people presented dues to Russian holidays
16:00:45 <gokrokve> o/
16:01:01 <DinaBelova> so some updates from several people I'll try to give myself
16:01:04 <DinaBelova> gokrokve o/
16:01:19 <gokrokve> Last time most of participants were from US :-)
16:01:31 <DinaBelova> gokrokve that's true as well :)
16:01:47 <DinaBelova> let's wait for a few minutes
16:01:57 <gokrokve> What do we have in the agenda?
16:01:59 <gokrokve> Sure
16:02:21 <DinaBelova> gokrokve we have standard agenda for today
16:02:31 <DinaBelova> Test plans statuses
16:02:31 <DinaBelova> Status of Huawei lab
16:02:31 <DinaBelova> OSProfiler weekly update
16:02:36 <gokrokve> Last week there was an e-mail discussion about DVR testing.
16:02:53 <DinaBelova> gokrokve interesting - may you please find the link to it?
16:02:58 <gokrokve> IT will be great if we discuss a place to share these test results.
16:03:48 <gokrokve> http://lists.openstack.org/pipermail/openstack-dev/2016-February/086933.html
16:03:51 <DinaBelova> my personal feeling is that performance-docs is a good enough place for that, but sadly I missed this thread
16:03:52 <DinaBelova> ack
16:04:42 <DinaBelova> gokrokve ok, so about this specific thread
16:04:56 <DinaBelova> these are folks from DragonFlow
16:05:10 <DinaBelova> and they'll share their results through performance-docs
16:05:31 <DinaBelova> but they wonder if there were published any DVR tests results simply to have something to compare with
16:06:03 <DinaBelova> gokrokve as you remember we wanted to ask our internal QA performance team to give us their 8.0 results
16:06:05 <DinaBelova> and use them
16:06:10 <DinaBelova> anyway
16:06:22 <DinaBelova> #action DinaBelova answer to http://lists.openstack.org/pipermail/openstack-dev/2016-February/086933.html
16:06:30 <DinaBelova> gokrokve thanks!
16:06:43 <DinaBelova> ok, so let's go back to the agenda
16:07:10 <DinaBelova> last time we had very quick meeting due to the lack of people, so no action items observed
16:07:25 <DinaBelova> so let's jump to the next section
16:07:25 <DinaBelova> #topic Test plans statuses
16:08:16 <DinaBelova> the short update from mirantis part of the team will be the following: we have DB testing in progress, MQ tests are under automation for now
16:08:36 <DinaBelova> and we have preparation work going on on the Mirantis-Intel lab
16:09:17 <DinaBelova> Ilya Sh. has demonstrated me how his automatization tool https://review.openstack.org/#/c/275092/ will work
16:09:44 <DinaBelova> pretty impressive - it allows automate both tests run and results collection
16:10:15 <DinaBelova> the last our decision was to abandon this patch and move the tool to the separated repo
16:10:35 <gokrokve> cool
16:10:50 <gokrokve> We definetely need this automation to make sure results are repeatable
16:10:50 <DinaBelova> I'll ask him to prepare short demo of what this tool will be used for, and share with wider audience
16:10:57 <DinaBelova> gokrokve indeed
16:10:57 <gokrokve> nice
16:11:13 <DinaBelova> so he has shown me the DB testing automation
16:11:17 <DinaBelova> very interesting
16:12:01 <DinaBelova> we have discussed several technical things, so he has the idea of what needs to be implemented now to make the performa working for all our cases
16:12:24 <DinaBelova> #action ilyashakhat share small demo about performa with community
16:13:02 <DinaBelova> so that's all news for now from mirantis part of the team
16:13:06 <DinaBelova> any comments?
16:13:31 <gokrokve> nope
16:13:58 <DinaBelova> ok, so let's jump to the next section
16:14:00 <gokrokve> I am thinking about Nova scheduler testing with Fake drivers
16:14:24 <DinaBelova> gokrokve ok, do you want to share some details?
16:14:37 <gokrokve> SpamapS mentioned that this method he used in his testing.
16:14:40 <DinaBelova> SpamapS was doing the similar effort
16:14:53 <DinaBelova> gokrokve indeed
16:14:56 <gokrokve> Just wonder if it is possible to publish tests and results
16:15:01 <DinaBelova> SpamapS btw are you around?
16:15:16 <gokrokve> To enable openstack developers and nova team specifically
16:15:45 <DinaBelova> 2 weeks ago you mentioned you did not have sharable results, did something change from that time?
16:15:51 <gokrokve> I think we can reproduce this quite easily but I don't want to hijack this work from others :-)
16:16:03 <DinaBelova> gokrokve indeed
16:16:26 <DinaBelova> last time we had lots of people presented, SpamapS mentioned that he did not have sharable results yet
16:16:36 <DinaBelova> and last time we did not have many people around
16:16:49 <DinaBelova> it looks like SpamapS is out of laptop now
16:17:07 <DinaBelova> #action DinaBelova check with SpamapS the status of hi stesting
16:17:21 <DinaBelova> gokrokve thanks for reminding
16:17:42 <DinaBelova> #topic Huawei lab status
16:17:47 <DinaBelova> kun_huang o/
16:17:51 <DinaBelova> are you around?
16:18:47 <DinaBelova> due to the previous estimations Huawei lab should become available either very soon or already
16:18:59 <DinaBelova> btw
16:19:05 <DinaBelova> #link https://review.openstack.org/#/c/280843/1/doc/source/labs/huawei_lab.rst
16:19:29 <DinaBelova> kun_huang has published some draft about their lab, but I set -1 with several comments
16:20:05 <DinaBelova> so in short: right now it's too vague description of the HW that will be used in fact
16:20:19 <DinaBelova> #action kun_huang update  https://review.openstack.org/#/c/280843/1/doc/source/labs/huawei_lab.rst
16:20:50 <DinaBelova> it looks like it is too late for kun_huang and he won't be able to answer lab-specific questions
16:21:03 <DinaBelova> so I'll ping him separately from the meeting
16:21:23 <SpamapS> I'm mobile right now, laptop in 30
16:22:05 <DinaBelova> SpamapS ack - so can you please share the current status of your testing once you'll be able to
16:22:06 <DinaBelova> thanks
16:22:22 <SpamapS> Been redirected into another area for the moment, I hope to be able to publish my perf work in a few weeks
16:23:10 <DinaBelova> SpamapS: we can split this effort by the way to two steps: publishing the methodology of fake driver testing and example of specific test plan / results you did
16:23:45 <DinaBelova> SpamapS I think this will be very helpful - as lots of Nova developers are thinking about how to use fake driver for such testing processes
16:24:53 <DinaBelova> ok, cool
16:25:01 <DinaBelova> thanks for sharing the news
16:26:05 <DinaBelova> ok, so let's go forward
16:26:21 <DinaBelova> #topic OSProfiler weekly update
16:26:47 <DinaBelova> last week several bug fixes were landed
16:27:08 <DinaBelova> including the one, that will enable Neutron testing
16:27:35 <DinaBelova> and I think this will fix neutron gates results for the neutron change as well
16:27:49 <DinaBelova> boris-42 promised to cut the release on Friday
16:28:18 <DinaBelova> it looks like this was done
16:28:22 <DinaBelova> #link https://github.com/openstack/osprofiler/tree/1.1.0/osprofiler
16:28:39 <DinaBelova> so I'll need to check if the requirements changes were merged
16:28:56 <DinaBelova> if yes, I'll update all needed commits
16:29:25 <DinaBelova> also interesting fact
16:30:00 <DinaBelova> I was pinged by several girls, that would like to take part in OPW program
16:30:30 <DinaBelova> so right now we're going through what they want to do in terms of the topics I proposed
16:31:00 <DinaBelova> so there is on dev and docs-related work that can be done for our team
16:31:17 <DinaBelova> so let's see if they are going to be chosen and continue the effort
16:31:42 <DinaBelova> any questions regarding osprofiler?
16:32:18 <DinaBelova> ack
16:32:20 <DinaBelova> #topic Open Discussion
16:32:41 <DinaBelova> gokrokve do you have something else to raise on the meeting?
16:34:35 <DinaBelova> ok, it looks like nope
16:34:38 <DinaBelova> #endmeeting