16:00:02 <DinaBelova> #startmeeting Performance Team
16:00:07 <openstack> Meeting started Tue Jan 12 16:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:10 <openstack> The meeting name has been set to 'performance_team'
16:00:13 <DinaBelova> Hello guys!
16:00:14 <DinaBelova> o/
16:00:16 <mriedem> o/
16:00:38 <DinaBelova> first of all I'm very glad to see everyone who'll be around today after long holidays
16:00:59 <DinaBelova> and it's good to be back :)
16:01:26 <DinaBelova> todays agenda as usually can be found here https://wiki.openstack.org/wiki/Meetings/Performance#Agenda_for_next_meeting
16:01:54 <DinaBelova> while folks are coming, I'll go quickly through the  3weeks old action items :)
16:02:06 <DinaBelova> #topic Action Items
16:02:15 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2015/performance_team.2015-12-15-16.00.html
16:02:58 <DinaBelova> as for the doc from kun_huang - in fact he shared one with me, although afaik it was not shared publicly yet
16:03:24 <DinaBelova> I hope kun_huang will be around during the needed topic to cover this point
16:03:40 <DinaBelova> all other stuff is ok I believe
16:03:53 <DinaBelova> template change was proposed to performance-docs
16:04:07 <DinaBelova> everyone is welcome to review it
16:04:11 <DinaBelova> #link https://review.openstack.org/#/c/265896/
16:04:50 <boris-42> hi hi
16:04:54 <DinaBelova> after it'll be merged, I'll compose one more commit with already merged test plans modifications + automated tests to verify plan-to-template mapping
16:04:56 <DinaBelova> boris-42 o/
16:05:17 <DinaBelova> and in fact that's everything interesting from past action items
16:05:42 <DinaBelova> ok, I'll go to the next topic
16:05:50 * DinaBelova hopes kun_huang will appear :)
16:05:58 <DinaBelova> #topic Test plans statuses
16:06:10 <DinaBelova> currently we have 2 test plans already merged
16:06:16 <DinaBelova> #link http://docs.openstack.org/developer/performance-docs/test_plans/index.html
16:06:33 <DinaBelova> and JeffBuell has published one more https://review.openstack.org/#/c/263523/
16:06:36 <DinaBelova> #link https://review.openstack.org/#/c/263523/
16:06:43 <klindgren> o/
16:06:47 <DinaBelova> klindgren o/
16:06:56 <ikhudoshyn> hi
16:07:10 <DinaBelova> so everyone (esp. kun_huang) are welcome to go through it and comment
16:07:41 <DinaBelova> JeffBuell - one moment here, sir, is about making this test plan to fit template https://review.openstack.org/#/c/265896/
16:07:59 <DinaBelova> JeffBuell - I hope this will be merged soon and either you or I will change your commit
16:08:21 <JeffBuell> Yes, it doesn't fit the template very well, I can tweak it after the merge and others look at it.
16:08:31 <DinaBelova> JeffBuell - thank you sir
16:09:09 <DinaBelova> in fact we did not have a chance to run none of the merged test plans against any lab yet
16:09:42 <DinaBelova> the Huawei lab is more or less ready, but I think we need to publish access rules to performance-docs first
16:10:05 <DinaBelova> also Mirantis is close to have our own Intel lab
16:10:24 <DinaBelova> there will be 200+ nodes there for performance testing
16:10:33 <DinaBelova> ping gokrokve for the details :)
16:11:11 <DinaBelova> gokrokve - I believe you can tell in few words what is the lab about and when probably it'll be ready to be used
16:11:12 <gokrokve> @DinaBelova We should have the lab on next week. At least that what was promised
16:11:44 <gokrokve> This is a 250 nodes lab currently hosted at Rackspace
16:11:53 <DinaBelova> gokrokve - I believe we can add some details about this lab to performance-docs
16:12:00 <DinaBelova> as well as Huawei one
16:12:03 <gokrokve> Sometime next week we should be able to start using it
16:12:16 <DinaBelova> just to have all stuff at one place
16:12:27 <DinaBelova> gokrokve - I can write something up about the lab
16:12:34 <DinaBelova> will add you to the reviewers
16:13:12 <DinaBelova> ok, so it looks like almost all news about test plans
16:13:38 <DinaBelova> I'll share details about Mirantis-Intel lab asap when I'll have the full picture :)
16:13:56 <DinaBelova> ok, so moving forward
16:14:07 <DinaBelova> #topic Huawei lab status
16:14:24 <DinaBelova> ok, and here we need kun_huang to appear :)
16:14:48 <DinaBelova> if that won't be successful, we'll just post the details about access doc here after the meeting
16:15:36 <DinaBelova> ok :)
16:16:07 <DinaBelova> it looks like kun_huang is somewhere else, just forgot to tell us :)
16:16:16 <DinaBelova> I'll ping him after the meeting
16:16:30 <DinaBelova> #topic OSProfiler weekly update
16:16:37 <DinaBelova> hey, so good news here :)
16:16:58 <DinaBelova> boris-42 and I did some effort and osprofiler 0.4 release was cut
16:17:27 <boris-42> DinaBelova: yaa!
16:17:29 <DinaBelova> change to global requirements is in progress
16:17:34 <boris-42> DinaBelova: and OSprofiler spec is merged
16:17:44 <DinaBelova> boris-42 yay :)
16:18:00 <DinaBelova> here it is btw
16:18:00 <boris-42> DinaBelova: and I will make soon DevStack plugin at least I hope so
16:18:04 <DinaBelova> #link https://review.openstack.org/#/c/103825/
16:18:10 <DinaBelova> boris-42 - that is super cool
16:18:12 <DinaBelova> :)
16:18:24 <boris-42> DinaBelova: and maybe we will be able to use for DevStack testing
16:18:33 <boris-42> DinaBelova: so osprofiler-dsvm job
16:18:39 <DinaBelova> although even without this devstack plugin osprofiler *should* work now on the prepared env
16:18:44 <DinaBelova> boris-42 - that will be SUPER COOL
16:18:57 <DinaBelova> right now it's a bit tricky to test everything, hehe
16:19:16 <DinaBelova> so hope you'll be able to do that soon :)
16:19:27 <DinaBelova> although please sleep sometimes still :D
16:20:00 <DinaBelova> as for me, multi-drivers change is in progress now as well as Ceilometer driver
16:20:13 <DinaBelova> boris-42 - I added new patch set today
16:20:23 <DinaBelova> did not test it yet on the env though
16:20:35 <DinaBelova> will do it either today or tomorrow
16:21:28 <DinaBelova> also boris-42 has added one small change to cinder to use the metaclass introduced in 0.4 osprofiler https://review.openstack.org/#/c/266288/
16:21:53 <DinaBelova> boris-42 - although you have a little issue there
16:22:06 <DinaBelova> you need to do the same hack I've don for nova
16:22:21 <DinaBelova> to avoid metaclass conflicts
16:22:36 <boris-42> DinaBelova: hm ?
16:22:49 <DinaBelova> one minute, Im fighting with Gerrit ЖВ
16:22:50 <DinaBelova> :D
16:23:00 <DinaBelova> https://review.openstack.org/#/c/254703/15/nova/manager.py - line 74
16:23:12 <DinaBelova> one of the parent classes already has the metaclass
16:23:19 <DinaBelova> therefore you cannot simply add it as you did
16:23:38 <boris-42> DinaBelova: omg that looks odd
16:23:50 <boris-42> DinaBelova: oh
16:23:54 <DinaBelova> you're catching the metaclass conflict - so you need to specify one metaclass
16:24:12 <DinaBelova> and use it
16:24:54 <DinaBelova> otherwise TypeError: metaclass conflict: the metaclass of a derived class must be a (non-strict) subclass of the metaclasses of all its bases
16:24:55 <DinaBelova> :)
16:24:59 <boris-42> DinaBelova: so why not just
16:25:21 <boris-42> @six.add_metaclass(OurMeta, super(Manager))
16:25:29 <boris-42> where super(Manager) should be resolved
16:25:32 <boris-42> to Timer.Timer
16:25:41 <DinaBelova> interesting, need to try
16:26:44 <DinaBelova> although I doubt that will work like that, need to try
16:27:08 <DinaBelova> anyway, something needs to be done there :D
16:27:49 <DinaBelova> ok, so it looks like all news about osprofiler
16:28:24 <DinaBelova> and that means we're quick today and it's open discussion
16:28:26 <DinaBelova> #topic Open Discussion
16:28:46 <DinaBelova> not sure, do we have something else now? NY holidays were destructive :D
16:29:22 <boris-42> nothing from my side
16:29:39 <DinaBelova> #action DinaBelova ping kun_huang about Huawei lab access doc status
16:30:11 <DinaBelova> #action DinaBelova share details about Mirantis-Intel lab (mailing list + performance-docs)
16:30:19 <DinaBelova> ok, hehe :)
16:30:39 <DinaBelova> it looks like people are still under holidays pressure and did not recover yet
16:30:54 <DinaBelova> I'll wait for a few minutes and end the meeting
16:32:24 <DinaBelova> ok, so thanks everyone who was brave enough to appear today :)
16:32:29 <DinaBelova> see u!
16:32:30 <DinaBelova> #endmeeting