16:00:02 <DinaBelova> #startmeeting Performance Team
16:00:03 <openstack> Meeting started Tue Dec 15 16:00:02 2015 UTC and is due to finish in 60 minutes.  The chair is DinaBelova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:07 <openstack> The meeting name has been set to 'performance_team'
16:00:10 <DinaBelova> hey folks!
16:00:42 <DinaBelova> is somebody around? :)
16:00:48 <mriedem> o/
16:00:50 <DinaBelova> harlowja_, klindgren, kun_huang, andreykurilin ? :)
16:00:57 <andreykurilin> hi hi
16:01:00 <andreykurilin> I'm here_
16:01:01 <andreykurilin> )
16:01:11 <DinaBelova> that's good :)
16:01:23 <DinaBelova> let's wait for a few moments :)
16:01:54 <DinaBelova> regXboi? :)
16:02:13 <regXboi> I'm here - just lurking
16:02:19 <regXboi> again - too many windows
16:02:29 <DinaBelova> yeah :)
16:02:36 <DinaBelova> k, so todays agenda
16:02:37 <DinaBelova> https://wiki.openstack.org/wiki/Meetings/Performance#Agenda_for_next_meeting
16:02:41 <kun_huang> o/
16:02:46 <DinaBelova> kun_huang, o/
16:02:53 <DinaBelova> so let's start with action items
16:02:58 <DinaBelova> #topic Action Items
16:03:06 <DinaBelova> #link http://eavesdrop.openstack.org/meetings/performance_team/2015/performance_team.2015-12-08-16.00.html
16:03:20 <DinaBelova> the first item was on regXboi - about hyper scale doc
16:03:27 <DinaBelova> it was merged today to the repo :)
16:03:31 <regXboi> yep - the code was submitted ;)
16:03:48 <DinaBelova> sadly I cannot understand when it should land to the docs.openstack.org
16:04:02 <DinaBelova> http://docs.openstack.org/developer/performance-docs/#
16:04:10 <DinaBelova> I see we're currently having the right namespace
16:04:18 <oanufriev> hi all
16:04:23 <DinaBelova> oanufriev o/
16:04:34 <DinaBelova> but I'm not sure when publish job will run
16:04:44 <DinaBelova> mriedem, regXboi - don't you know?
16:05:03 <mriedem> not sure
16:05:07 <mriedem> usually seems pretty quick
16:05:09 <ilyashakhat> zuul says the job is in queue
16:05:12 <mriedem> one could ask in -infra
16:05:22 <DinaBelova> ilyashakhat - oh, cool - it was not there about 30 mins ago
16:05:35 <DinaBelova> ok, so we just need to wait a bit :)
16:05:37 <DinaBelova> cool :)
16:05:47 <DinaBelova> about other action items
16:05:48 <ilyashakhat> now it is with 1h 18 minutes of being in
16:06:24 <DinaBelova> ilyashakhat - oh, ok
16:06:47 <DinaBelova> so probably I just had outdated zuul page for some reason
16:07:18 <DinaBelova> I see that klindgren added some very quick notes to the https://etherpad.openstack.org/p/remote-conductor-performance
16:07:44 <DinaBelova> but I'm not sure if he had a chance to make more dumps as it was discussed last time
16:07:59 <DinaBelova> it looks like he had some more fires last week as well :)
16:08:16 <DinaBelova> kun_huang - any news about access status to the lab?
16:08:33 <DinaBelova> afair we had a plans to create some draft doc about it last week
16:08:38 <kun_huang> DinaBelova: 6 servers are installed, today
16:08:50 <DinaBelova> kun_huang - oh, that's very cool :)
16:09:03 <DinaBelova> so let's postpone this lab related items for this week
16:09:04 <kun_huang> access means your public key now ;(
16:09:21 <kun_huang> we don't have run public lab before
16:09:32 <DinaBelova> #action kun_huang write some simple doc describing the access to the Huawei lab
16:09:39 <DinaBelova> #action DinaBelova kun_huang define the queue of test plans to start testing on the Huawei lab
16:09:43 <DinaBelova> kun_huang - even if so
16:09:49 <DinaBelova> we need that somehow documented
16:10:02 <DinaBelova> as well as define a queue somehow - even on the etherpad
16:10:20 <DinaBelova> but let's discuss that during the needed topic
16:10:36 <DinaBelova> so that's it with action items from last time
16:10:50 <DinaBelova> let's move forward to the test plans topic
16:10:56 <DinaBelova> #topic Test plans statuses
16:11:17 <DinaBelova> we have some changes to the performance-docs repo opened :)
16:11:20 <DinaBelova> #link  https://review.openstack.org/#/q/status:open+project:openstack/performance-docs,n,z
16:11:31 <DinaBelova> two of them are in fact test plans
16:11:46 <DinaBelova> #link https://review.openstack.org/#/c/254693/ - provisioning systems
16:11:54 <DinaBelova> kun_huang ^^ waiting your review :)
16:12:15 <DinaBelova> and published just today MQ test plan
16:12:17 <DinaBelova> #link https://review.openstack.org/#/c/257417/
16:12:41 <DinaBelova> so I'm encouraging everyone to spend some time on their reviewing
16:12:44 <kun_huang> DinaBelova: looking at it
16:12:52 <DinaBelova> kun_huang - thank :)
16:13:32 <DinaBelova> and if somebody is having the test plan idea - please do not be too shy to publish it to the Gerrit :)
16:14:02 <DinaBelova> any questions regarding the test plans?
16:14:27 <andreykurilin> DinaBelova: what about adding some template for test plans ?
16:14:41 <DinaBelova> andreykurilin - very good idea..
16:14:58 * DinaBelova adding this item to the https://etherpad.openstack.org/p/perf-zoom-zoom
16:15:30 <DinaBelova> andreykurilin - thank you sir
16:16:04 <DinaBelova> #action DinaBelova add test plan template to the performance-docs repo
16:16:19 <DinaBelova> anything else?
16:16:19 <andreykurilin> also it would be nice to add some python tests to CI. it will allow to write some hacks to check that docs correctly extend templates
16:16:59 <andreykurilin> I suppose there are such tests for specs
16:17:05 <DinaBelova> andreykurilin - hm, what kind of python tests for the docs are you expecting to see?
16:18:03 <DinaBelova> andreykurilin - ah, I got your message about specs
16:18:07 <DinaBelova> I'll take a look
16:18:14 <andreykurilin> DinaBelova: I suppose it will be easy to write some python test that checks new test plans corresponds template
16:18:33 <DinaBelova> andreykurilin - yeah, I got what you meant
16:18:41 <andreykurilin> #link https://github.com/openstack/nova-specs/blob/master/tests/test_titles.py
16:18:42 <DinaBelova> just not from the first moment :)
16:18:47 <DinaBelova> andreykurilin - thanks
16:19:21 <DinaBelova> #action DinaBelova add tests to check test plans are implementing the template ok
16:19:32 <DinaBelova> ok, very good input
16:19:37 <DinaBelova> andreykurilin - thank you sir :)
16:19:49 <andreykurilin> you are welcome
16:20:12 <DinaBelova> andreykurilin - something else? I love your ideas :)
16:20:39 <andreykurilin> heh. no more ideas)
16:20:41 <DinaBelova> :D
16:20:49 <andreykurilin> they are finished for this topic
16:20:58 <DinaBelova> ok, so it looks like we can proceed :)
16:20:59 <DinaBelova> #topic Huawei lab status
16:21:15 <DinaBelova> kun_huang - ok, so you installed the 6 servers today?
16:21:29 <kun_huang> not me, the servers are not in my city
16:21:51 <DinaBelova> kun_huang, yeah, sorry, I meant not you personally but Huawei :)
16:21:56 <kun_huang> and it's monitor is not accessable for me (ssh is accessable)
16:22:34 <kun_huang> huawei guys have done the installation job today
16:22:45 <DinaBelova> kun_huang - ok, so may you please create some draft for the "Lab Usage Doc" this week? Is that possible?
16:22:59 <DinaBelova> it can be an etherpad I believe
16:23:03 <kun_huang> yes, no problem
16:23:09 <DinaBelova> kun_huang, thank you sir
16:23:35 <DinaBelova> ok, so the next step will be to merge test plans that are currently on review and try something on the lab :)
16:24:00 <kun_huang> +100
16:24:03 <DinaBelova> kun_huang - therefore I believe your reviews are essential here, as you're representing the lab owner :)
16:24:41 <DinaBelova> ok, very cool
16:25:01 <kun_huang> I know that, I will finish the access doc this week ;)
16:25:07 <DinaBelova> kun_huang, thank you sir
16:25:17 <DinaBelova> any questions regarding the lab?
16:25:57 <DinaBelova> ok
16:26:18 <DinaBelova> I believe we may skip "Nova-conductor performance issues" topic as I don't think klindgren is around
16:26:38 <DinaBelova> and also I suppose he did not have a chance to make some more dumps
16:26:47 <DinaBelova> so let's go to the osprofiler
16:26:49 <DinaBelova> #topic OSProfiler weekly update
16:27:06 <DinaBelova> ok, so frankly speaking I don't have some breaking news
16:27:19 <DinaBelova> my changes are on review
16:27:27 <DinaBelova> and I have several issues..
16:27:46 <DinaBelova> the most annoying is that when I'm enabling nova or keystone DB tracing
16:27:59 <DinaBelova> some of the wsgi/rpc points are absent from the trace tree
16:28:06 * DinaBelova is very angly on that stuff
16:28:32 <DinaBelova> and I was able to find out that Ceilometer collectors receives these events
16:28:46 <DinaBelova> but some of them are lost during the writing to the Db
16:28:50 <DinaBelova> and no errors at all
16:29:14 <DinaBelova> if I'll change Ceilometer events publishing from the DB to simple file everything is ok
16:29:30 <DinaBelova> but is we're writing to the SQL-based DB....
16:29:40 <DinaBelova> some events info is lost
16:29:51 <DinaBelova> so I'm debugging that stuff...
16:29:57 <DinaBelova> pretty much no news..
16:30:44 <DinaBelova> so if someone will try do the same I'll be really happy :D
16:30:48 <boris-42_> DinaBelova: btw are you going to update your patches
16:30:50 <boris-42_> DinaBelova: in osprofiler?
16:30:56 <boris-42_> DinaBelova: so we will be able to merge them
16:30:58 <DinaBelova> boris-42_ - yes, I'm going to
16:31:04 <DinaBelova> but I want to find this issue
16:31:13 <DinaBelova> as it's pretty annoying
16:31:41 <DinaBelova> also afair you, boris-42_ , said that you want see the trace with DB points to approve my changes :)
16:31:59 <DinaBelova> and this issue is separating me from this aim as well as your -1s :)
16:32:42 <boris-42_> DinaBelova: ok
16:32:49 <DinaBelova> or am I wrong and you'll merge my changes if I'll just update them to our current vision without finding out whats going on to the events? :)
16:33:09 <DinaBelova> boris-42_^^ lol
16:34:04 <boris-42_> DinaBelova: so seems like problem is not in osprofiler the problem is in ceilometer
16:34:10 <boris-42_> DinaBelova: so we can merge those
16:34:15 <DinaBelova> or even in oslo.db 0_o
16:34:19 <DinaBelova> boris-42_ - ok
16:34:26 <DinaBelova> I'll update my changes asap
16:34:30 <boris-42_> DinaBelova: not sure about oslo.db
16:34:41 <DinaBelova> boris-42_ - yeah, that looks pretty strange..
16:34:50 <boris-42_> DinaBelova: btw I need to do sample patch in oslo.db and oslo.messaging
16:35:09 <boris-42_> DinaBelova: so if oslo team will agree this time we will remove part of copy pasted from all projects
16:35:22 <DinaBelova> boris-42_ - a-ha, gotcha
16:35:31 <DinaBelova> will you be able to do that this week?
16:37:29 <DinaBelova> ok, so let me hope you'll do that this week :)
16:37:59 <DinaBelova> some questions probably regarding osprofiler?
16:39:12 <DinaBelova> ok, so it looks like we can proceed to the holidays topic :)
16:39:17 <DinaBelova> #topic Last meeting?
16:39:33 <DinaBelova> I wanted to understand if we need to have more meetings before the NY
16:39:47 <andreykurilin> boris-42_: rpodolyaka said that he dislike the way how we do profiling of sqlalchemy and he have ideas how it can be improved. Also he ready to contribute to osprofiler to fix db related stuff
16:39:50 <DinaBelova> the next Tuesday is Dec 22nd
16:40:00 <DinaBelova> andreykurilin - very cool
16:40:06 <DinaBelova> rpodolyaka, you're welcome
16:40:57 <DinaBelova> andreykurilin, kun_huang, harlowja_ , mriedem, regXboi, boris-42_, Kristian_ - what do you think about holidays schedule?
16:41:09 <DinaBelova> do we want this meeting to be the last one this year?
16:41:15 <mriedem> yeah
16:41:24 <mriedem> i guess, idk, doesn't matter to me really
16:41:30 <mriedem> i'm not a crucial part of this meeting
16:41:40 <Kristian_> <DinaBelova> i'm fine to have one more
16:41:43 <boris-42_> andreykurilin: and what he disliked?
16:41:55 <andreykurilin> boris-42_: I don't know the details
16:42:08 <DinaBelova> ok, so it looks like we can move the holidays schedule to the email list
16:42:09 <boris-42_> andreykurilin: it's really basic way to trace sql
16:42:09 <boris-42_> =)
16:42:44 <DinaBelova> #action DinaBelova send the email about IRC meetings schedule - let's define the last meeting this year and the first one in 2016
16:42:44 <andreykurilin> DinaBelova: as far as I understand, if thi meeting will be the last before the NY, the next one will be in one month. right?
16:42:58 <DinaBelova> andreykurilin - yeah, that's the issue
16:43:13 <DinaBelova> but some of the community teems already agreed it's ok
16:43:30 <DinaBelova> therefore I wanted to know if somebody is having the immediate opinion on this topic
16:43:42 <DinaBelova> although it looks like nothing too defined yet
16:43:57 <DinaBelova> so I'll send the email to openstack-dev and openstack-operators mailing list
16:44:18 <DinaBelova> let's find out if people are ok to have one more meeting this year and define the first date for 2016
16:44:45 <AugieMena> DinaBelova:  i'm not a crucial part of this meeting either, but not having a meeting over the holidays (next two weeks) seems reasonable to me
16:44:45 <DinaBelova> ok, cool
16:45:24 <DinaBelova> AugieMena - ok, thanks! I'll list current opinions to the email as well
16:46:13 <AugieMena> would the first one in 2016 be on Jan 5?
16:46:49 <andreykurilin> AugieMena: no
16:47:15 <DinaBelova> AugieMena - dunno yet... The issue is that in Russia we do not have X-mas holidays, but NY ones. So we'll be working these next 2 weeks, but we'll have 10 days after the NY
16:47:24 <regXboi> DinaBelova: sorry - had people picking up donated furniture here - I'm out the next two weeks
16:47:30 <regXboi> I can drop in if needed
16:47:40 <DinaBelova> regXboi, ok, thanks
16:47:41 <AugieMena> DinaBelova:  ah, makes sense
16:48:02 <DinaBelova> so it looks like lots of people won't be able to be 100% available next two weeks
16:48:16 <DinaBelova> so probably we need to finalize the 2016 date and that's it :)
16:48:32 <andreykurilin> DinaBelova: and only Ukrainians works 2 weeks before NY, and the next days after New Year
16:48:36 <andreykurilin> eh
16:48:42 <DinaBelova> the most realistic date will be Jan 12
16:49:03 <DinaBelova> andreykurilin - I'm really sad you're having so small winder holidays period :(
16:49:35 <DinaBelova> #info most probably today is the last meeting in 2015 (to be finalized in the email lists)
16:49:55 <DinaBelova> #info most probably the Jan 12 will be first meeting in 2016 (to be finalized in the email lists)
16:50:07 <DinaBelova> ok, very cool
16:50:34 <DinaBelova> anything else to add here?
16:51:04 <DinaBelova> ok, cool
16:51:07 <DinaBelova> #topic Open Discussion
16:51:19 <DinaBelova> probably some other topics to be covered?
16:52:23 <DinaBelova> if nope, let's finish the meeting :)
16:53:21 <DinaBelova> thanks everyone for coming :)
16:53:42 <DinaBelova> #endmeeting