13:03:18 <irenab> #startmeeting pci-passthrough
13:03:19 <openstack> Meeting started Tue Aug 19 13:03:18 2014 UTC and is due to finish in 60 minutes.  The chair is irenab. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:03:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:03:22 <openstack> The meeting name has been set to 'pci_passthrough'
13:03:26 <irenab> hi
13:03:42 <rpothier> hi
13:04:26 <heyongli> hi
13:05:06 <irenab> let's wait few mins for others to join
13:05:53 <sadasu> Hello!
13:06:12 <irenab> hi!
13:06:23 <irenab> let's start
13:06:28 <sadasu> I have uploaded a new changeset
13:06:48 <sadasu> irenab: I have taken care of all of your comments afsik
13:06:59 <sadasu> please take a look and provide comments
13:07:19 <heyongli> any topic relate to me, i'm afraid i will leave soon
13:07:37 <irenab> sadasu: Thank you. I will try to review later today.
13:07:51 <sadasu> irenab: gr8. thanks
13:08:16 <irenab> I wanted to discuss what next development we want to promote as part of the team
13:08:40 <irenab> heyongli: is there anything you want to raise?
13:08:53 <heyongli> none for today
13:09:39 <irenab> rpothier: I think that nova side is quite in a good shape, feels like will be merged soon
13:10:26 <heyongli> irenab, yeah, nova part is good now
13:11:14 <irenab> as for the additional tasks, anything someone want to iniutially discuss here, shall we set an agenda or send to ml?
13:11:27 <rpothier> irenab: Robert is looking into a test failure, otherwise in good shape
13:11:28 <heyongli> mail list is good
13:11:46 <heyongli> pull more attention, maybe
13:12:47 <irenab> I think we need to provide a way to define VM with SR-IOV vNIC, did someone considered HEAT?
13:12:58 <sadasu> any other specific item in the agenda?
13:13:21 <irenab> not for me
13:13:45 <rpothier> irenab: I can look into HEAT
13:14:20 <irenab> rpothier: great, so if possible share your understanding next week
13:14:42 <rpothier> irenab: ok
13:15:23 <irenab> sadasu:we have a refactoring at neutron side for code consolidation as future item
13:15:28 <sadasu> any insights from NFV that has relevance to sr-iov?
13:15:41 <sadasu> irenab: correct
13:15:44 <irenab> sadsu: exactly what I wanted to ask :-)
13:16:24 <sadasu> irenab: haven't had a chance to take a look into latest in NFV
13:16:55 <irenab> I'll follow heyongli suggestion and send a question to  ml, I do not think it was something specific, but we may get some information at ml
13:17:06 <sadasu> ok
13:17:25 <irenab> I'll look at NFV till next week as well
13:17:34 <heyongli> copy us from ml. or topic as pci?
13:18:13 <irenab> heyongli: sure
13:18:20 <irenab> #action rpothier to investigate HEAT for VM with SRIOV config
13:18:46 <irenab> #action irenab to send mail to openstack-dev on next SR-IOV netowrking requests
13:19:04 <irenab> #action irenab to look at NFV requirements
13:19:22 <irenab> any other ideas, suggestions?
13:19:48 <sadasu> support for multi-segment networks?
13:19:56 <sadasu> and security groups?
13:20:00 <irenab> sadsu: which means?
13:20:27 <sadasu> those were questions that were raised during my BP
13:20:43 <irenab> sadasu:do you think securuty group support can impact non vendor part ?
13:21:03 <sadasu> I responded saying that we will investigate for the next release
13:21:42 <sadasu> irenab: depends on what solution we pick...
13:21:52 <irenab> I am not sure about multi-segment networks, but for security groups seems it should be resolved and neutron ML2 MD(MDs) level
13:22:03 <sadasu> actually it may not affect the sr-iov mech drivers at all
13:22:21 <irenab> sadsu: but let's put 2 these topics in the list
13:22:43 <sadasu> it will have to be configured on the upstream switch and handled by a diff mech driver
13:22:58 <sadasu> but that config may have to be triggered by the sr-iov mech drivers
13:23:08 <sadasu> very initial thoughts on this
13:23:30 <irenab> sadasu: ok, just seems it won't impact nova side
13:23:41 <sadasu> irenab: agreed. thats why I brought it up
13:24:04 <sadasu> irenab: correct. I can take this as my action item
13:24:15 <sadasu> but currently focussed on getting my code upstream
13:24:41 <irenab> #action sadasu to investigate on security groups and multi-segment networks
13:24:51 <irenab> sadsu: sure
13:25:10 <irenab> do you see any other pieces we need to push for Juno?
13:25:24 <irenab> at client side?
13:25:37 <sadasu> for Juno mech driver refactoring
13:25:38 <irenab> we defenitly need documentation...
13:26:09 <irenab> sadsu: I think it is better to push after your MD is merged
13:26:48 <sadasu> irenab: yes and adding sr-iov specific tempest tests
13:27:00 <irenab> sadsu: +2
13:27:29 <sadasu> I think they have their own process which I am not completely aware of...so chances are tempest tests would make it only in kilo
13:28:07 <irenab> I'll follow up with all tasks mentioned and asking more at ML
13:28:45 <sadasu> cool
13:28:56 <irenab> any more issues to discuss or we can finish early?
13:29:55 <sadasu> I think we are good to finish early
13:30:10 <irenab> I think once patches are merged we can be back to white noard and see wha agenda to promote for kilo
13:30:25 <irenab> s/noard/board
13:30:56 <irenab> great, I am going to close the meeting.
13:31:08 <irenab> Good luck with reviews!
13:31:27 <irenab> #endmeeting