14:02:30 <mrhillsman> #startmeeting osops
14:02:30 <openstack> Meeting started Mon Mar 27 14:02:30 2017 UTC and is due to finish in 60 minutes.  The chair is mrhillsman. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:33 <openstack> The meeting name has been set to 'osops'
14:02:45 <mrhillsman> #topic RollCall
14:03:42 <yankcrime> hi mrhillsman
14:06:14 <mrhillsman> hey
14:06:22 <mrhillsman> lost interwebs for a moment :(
14:07:15 <mrhillsman> #topic Previous Agenda
14:07:21 <mrhillsman> #link https://etherpad.openstack.org/p/osops-meeting
14:07:39 <mrhillsman> i think we covered most of this stuff previously
14:08:14 <mrhillsman> robputt you around?
14:09:11 <mrhillsman> guess not hehe, will have to check with him on that monitoring matrix idea
14:10:31 <izaakk> o/ sorry for being late
14:10:45 <mrhillsman> no worries
14:11:09 <mrhillsman> going to change topic because previous items are old except one
14:11:26 <mrhillsman> #topic Ops Midcycle Review
14:11:44 <mrhillsman> one of the things from the midcycle was around new projects
14:12:04 <mrhillsman> #link https://github.com/openstack-infra/project-config/blob/master/gerrit/projects.yaml
14:12:14 <mrhillsman> that link was provided as a way to find out about new projects
14:12:33 <mrhillsman> along this same line there was discussion about the project team guide
14:12:59 <mrhillsman> #link https://etherpad.openstack.org/p/MIL-ops-osops
14:13:48 <mrhillsman> wondering if anyone has any ideas about what could be added to the project team guide to potentially address some operational items
14:14:14 <mrhillsman> #link https://docs.openstack.org/project-team-guide/
14:15:20 * yankcrime reads
14:15:21 <mrhillsman> #action mrhillsman start a thread on the ML around ops content for project team guide
14:15:45 <mrhillsman> yankcrime hehe, you will need some time :)
14:15:57 <izaakk> Probably some "operational requirements" kind of section?
14:16:08 <yankcrime> yup
14:16:11 <mrhillsman> requirements is a hard case to make
14:16:16 <yankcrime> operational considerations perhaps
14:16:18 <izaakk> Things that Operators look at a project before adopting it
14:16:20 <mrhillsman> yeah
14:16:22 <mrhillsman> something like that
14:16:26 <izaakk> not as a strict requirement but lique a guide
14:16:30 <yankcrime> at least some kind of "engage operators early to ensure their concerns are captured" or something
14:16:40 <mrhillsman> some guidelines
14:16:43 <mrhillsman> agreed
14:16:55 <mrhillsman> we also have the ops tags
14:17:04 <mrhillsman> which we need some more visibility into
14:17:07 <yankcrime> there's an issue of awareness that needs to be thought through really
14:17:15 <yankcrime> how should operators / interested parties be made aware
14:17:16 <mrhillsman> but that could be a way to ensure "requirements"
14:17:22 <yankcrime> should the onus be on the project team
14:17:32 <mrhillsman> i think so
14:17:35 <mrhillsman> cannot say for sure
14:17:36 <yankcrime> or should it be up to the operators community to organise and interact
14:17:37 <izaakk> Yeah operational minimal viable product
14:17:41 <yankcrime> probably a bit of both
14:17:44 <mrhillsman> but if there is already say an email that goes to openstack-dev
14:17:52 <mrhillsman> should probably go to openstack-operators as well
14:18:10 <yankcrime> yeah, i think that should be the minimum tbh mrhillsman
14:18:21 <mrhillsman> probably a combination as you suggest yankcrime
14:18:27 <yankcrime> even just some notional "try and canvas operatos opinions via an email"
14:18:31 <izaakk> this links to logging standardization as an example I think
14:18:34 <mrhillsman> definitely a notification at least
14:18:41 <yankcrime> good shout izaakk
14:18:56 <mrhillsman> yeah
14:19:17 <mrhillsman> i'll start a thread on the ML
14:19:30 <izaakk> Cool
14:19:34 <yankcrime> sounds good
14:19:47 <mrhillsman> will probably need quite a bit of input and perspectives on this one
14:19:53 <mrhillsman> at least to get started
14:20:05 <yankcrime> and some delicate moderation no doubt ;)
14:20:30 <mrhillsman> hehe
14:21:15 <mrhillsman> we also discussed at the midcycle addressing the larger needs of operators versus just tooling
14:21:34 <mrhillsman> this is going to be quite an undertaking as i was reviewing the wiki
14:21:43 <mrhillsman> which definitely gives way for that
14:22:01 <mrhillsman> as it has operations and then ops tooling
14:22:12 <mrhillsman> i wonder how can we get buy-in
14:22:44 <izaakk> Buy-in in what?
14:22:48 <mrhillsman> i think we need to consider amongst many things that are a concern for operators
14:22:52 <mrhillsman> what are the top 3
14:23:01 <mrhillsman> izaakk participation
14:23:10 <mrhillsman> looking at the operations wiki
14:23:28 <mrhillsman> #link https://docs.openstack.org/project-team-guide/
14:23:31 <mrhillsman> bah
14:23:44 <mrhillsman> #link https://wiki.openstack.org/wiki/Operations
14:24:01 <mrhillsman> there are quite a few areas
14:24:09 <mrhillsman> i was looking at the use cases one for example
14:24:19 <mrhillsman> and it has stuff there from 2012
14:25:01 <mrhillsman> so i think addressing the larger needs of operators warrants a few folks taking a step back and thinking about this at large
14:25:30 <mrhillsman> i think a good starting place is getting a group together who can
14:25:43 <mrhillsman> within osic our group is focused primarily on the tooling
14:26:06 <mrhillsman> branching outside of this subset is probably too much for us to take on
14:26:12 <mrhillsman> alone :)
14:26:48 <mrhillsman> right now we have i can say in terms of working groups/teams as noted on the wiki
14:26:58 <mrhillsman> ops meetups and tooling
14:27:42 <mrhillsman> personally i do not know how to tackle it and need some guidance on it
14:28:15 <izaakk> Yes, also, Monty made a good point on the repo. I think a good framework that allow the operators community to have the opportunity to get ATCs. Probably help from docs people to unify all this concepts?
14:28:44 <mrhillsman> agreed
14:29:12 <mrhillsman> so it is something i think we need to hash out in terms of expectation/purpose/motive/etc and get some feedback
14:29:17 <izaakk> Because from the docs session, a lot of people doesn't even look at this guide, either is not updated or is not clear how to even start to contribute
14:29:38 <mrhillsman> so if we are more than just tooling
14:29:53 <mrhillsman> what are we <- this needs to get structured
14:30:49 <izaakk> Question: is Operators Tools and Monitoring the same as OSOps WG?
14:31:25 <mrhillsman> good question :)
14:32:02 <mrhillsman> i do not have the answer :)
14:32:16 <yankcrime> i think addressing the wider needs of 'operators' is going to be a case of asking what people expect from the ops community
14:32:18 <mrhillsman> i would say no in terms of the definition
14:32:23 <mrhillsman> because a working group is temporary
14:32:31 <yankcrime> which is basically what you're saying by "thinkinbg about this at large" mrhillsman
14:32:33 <mrhillsman> good point yankcrime
14:32:40 <mrhillsman> yep
14:33:30 <mrhillsman> so i think possibly an email is in order for this
14:33:50 <yankcrime> there's different levels of interaction - what are our inputs (experience, developer / project lifecycle interaction), what are our outputs (code, docs), and how to get involved
14:33:51 <mrhillsman> something like we are streamlining what we do, what we are, and are requesting help in defining that
14:34:47 <mrhillsman> maybe an etherpad instead yankcrime ?
14:35:02 <mrhillsman> flushing out those in/outs and how to get involved
14:35:19 <mrhillsman> allow folks to comment/discuss
14:36:17 <yankcrime> good idea, at the very least just a grab-bag of ideas to discuss and formalise for a session in boston
14:36:24 <mrhillsman> ok cool
14:37:36 <mrhillsman> so it sounds like we have a couple of things to tackle
14:37:47 <izaakk> +1
14:38:03 <mrhillsman> #action work on getting the repos to a place where they are relevant to ATC/AUC
14:38:32 <mrhillsman> #action setup etherpad for brainstorming around ops community ins/outs/involvement
14:39:01 <mrhillsman> last thing and then we can drop :)
14:39:11 <mrhillsman> #topic Ops Hangout Sessions
14:39:46 <mrhillsman> these were discussed in NYC or BCN i know and someone said they were doing them but i have not seen anything on the mailing list
14:40:46 <mrhillsman> i think an etherpad for ideas is a good way to start this
14:40:49 <mrhillsman> thoughts?
14:40:57 <yankcrime> not seen anything about this tbh
14:41:04 <mrhillsman> same here
14:41:23 <mrhillsman> i think there is potential value here
14:41:31 <mrhillsman> would depend on the sessions
14:41:42 <izaakk> Google Hangouts?
14:41:45 <mrhillsman> yeah
14:42:01 <mrhillsman> like 30-40 minute workshop/walk-through/how-to/etc
14:42:01 <izaakk> The problem can be people from china
14:42:16 <mrhillsman> is there any other option they can use?
14:42:34 <mrhillsman> i think a pool of session ideas
14:42:42 <mrhillsman> and shared content is best approach
14:42:47 <izaakk> Nemat is exploring different services that are also available in chaina, I can provide more input on this. Need to talk to him
14:42:52 <mrhillsman> this way it does not have to be all english #1 :)
14:43:03 <mrhillsman> and could address your concern as well
14:44:22 <izaakk> cool
14:44:50 <mrhillsman> yankcrime thoughts?
14:45:33 <yankcrime> hmm, could be good - needs some proposals and a pool of ideas like you say
14:45:42 <mrhillsman> ok cool
14:46:09 <mrhillsman> #action create etherpad for capturing ops hangout sessions
14:46:09 <yankcrime> be nice to tease out some "ops best practices" and then have demos / sessions
14:46:20 <mrhillsman> +1
14:46:43 <mrhillsman> well, if there is nothing else, i'll end the meeting and give y'all back some time
14:46:57 <yankcrime> for every ops midcycle there's usually at least a couple of things that someone mentions and then a load of people pipe up and say they're interested in knowing more
14:47:20 <mrhillsman> true
14:47:36 <mrhillsman> #action scour ops etherpads for potential hangout sessions
14:47:53 <mrhillsman> anything else genglemen
14:48:45 <yankcrime> nothing from me
14:48:56 <izaakk> I'm good
14:49:00 <mrhillsman> #endmeeting