14:59:26 <rmascena> #startmeeting oslo-config-plaintext-secrets
14:59:27 <openstack> Meeting started Tue May 29 14:59:26 2018 UTC and is due to finish in 60 minutes.  The chair is rmascena. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:59:31 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
14:59:43 <rmascena> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
14:59:44 <moguimar> o/
15:00:57 <rmascena> #topic roll call
15:01:09 <rmascena> ping dhellmann, spilla
15:01:17 <rmascena> ping bnemec
15:01:19 <spilla> o/
15:02:28 <rmascena> ok, so let's start it :)
15:02:34 <rmascena> #topic current status
15:02:56 <rmascena> moguimar, I believe that you can talk more about that for us :)
15:03:14 <rmascena> #link https://review.openstack.org/#/c/554316
15:04:27 <moguimar> since our call last week I was able to fix the return type of the ConfigurationSource::get() method
15:04:46 <bnemec> o/
15:04:49 <moguimar> I'm currently working on the additional test cases
15:05:09 <moguimar> I had a setback with my computer last friday, only got it back working today.
15:06:29 <moguimar> I'll add more tests to cover the option value discovery in multiple sources, to make sure that they follow the spec
15:07:26 <rmascena> moguimar, thanks for the status :)
15:07:39 <rmascena> #topic owners for remaining work for Rocky-2
15:08:03 <moguimar> what is our deadline for Rocky-2?
15:08:11 <rmascena> so besides the current stuff that moguimar is taking care of, we still have two steps in the working items list remaining
15:08:39 <rmascena> Rocky-2: something closer to Jun 04
15:09:02 <rmascena> so, it's will be pretty hard to have this done for rocky-2 =/
15:09:40 <rmascena> #link https://releases.openstack.org/rocky/schedule.html
15:11:29 <rmascena> bnemec, dhellmann well, I would like to confirm that still not feasible having at least this INI driver as a FFE, which means finishing the steps 7-8 on the work items list
15:11:47 <rmascena> Ensure the sample generator emits an example group
15:11:53 <rmascena> and add a separate cache for values coming from external sources
15:12:50 <bnemec> So feature freeze isn't technically until R-3, although IIRC Oslo generally observes feature freeze a couple of weeks before that to allow time for adoption of new features.
15:13:38 <bnemec> I think this ended up being somewhat less invasive to the existing code than we originally expected, so it's possible we could land it as long as it happens before feature freeze.
15:14:03 <bnemec> We'd need to take a closer look and see what the risk is.
15:14:17 <rmascena> bnemec, gotcha, I think that since we reduce our scope, will be nice to have that as an "experimental" for this release
15:14:36 <rmascena> and we can fix everything that is needed and add the castellan driver for the next release
15:15:10 <bnemec> Yeah, I think that sounds good.
15:15:23 <bnemec> The ini driver by itself isn't the end goal here anyway.
15:15:36 <rmascena> yeah, exactly
15:16:17 <rmascena> ok, so let's keeping work to finish this final steps ASAP and we can evaluate if make sense to ask for a FFE for this ini driver
15:16:49 <bnemec> So that might be another work item - to make sure the documentation says this is an experimental feature in Rocky.
15:17:10 <rmascena> bnemec, ++ I'll add that to the list
15:17:55 <bnemec> In fact I don't know if we have a documentation bullet point yet, so that's a missing item anyway.  This will require doc updates in general.
15:18:45 <rmascena> bnemec, yeah, that's something that I had in mind, document our to use the ini driver and how to implement a new driver
15:20:26 <bnemec> Yep, sounds good.
15:21:44 <rmascena> #action raildo to starting documenting how to use the INI driver and how to implement a new one
15:21:49 <dhellmann> /me slips in the back late
15:22:23 <rmascena> dhellmann, hey :)
15:22:49 <dhellmann> apologies for being late
15:22:54 <spilla> also got pulled into a meeting and am catching up, sorry!
15:23:17 <rmascena> so, based on our current status, we still need to define the owners for topic 7 and 8 in the etherpad, some volunteer?
15:24:18 <moguimar> I'm curretly working on item 5, but I can take one of them as soon as I'm done with item 5
15:25:35 <dhellmann> I like the idea of finishing the work we have and then picking up the next task
15:25:53 <dhellmann> that way we aren't waiting on someone to finish 4 things
15:26:25 <rmascena> dhellmann, yeah, I believe that we maybe have to many opening tasks right now
15:26:45 * dhellmann nods
15:27:10 <moguimar> rmascena: any suggestion on marking tasks done?
15:27:38 <rmascena> moguimar, so, if the patch is not set as WIP, it should be ready for review
15:27:43 <rmascena> and kind of done on our side
15:28:30 <rmascena> moguimar, also, you can add more details in the etherpad if needed
15:28:50 <rmascena> so everyone can be aware if it's missing some step in the work item
15:29:29 <rmascena> #open discussion
15:29:53 <rmascena> we only have one minute remaining, something else?
15:30:32 <moguimar> not on my end
15:30:54 <rmascena> so, thanks everyone, have a good week!
15:30:59 <rmascena> #endmeeting