14:59:56 <raildo> #startmeeting oslo-config-plaintext-secrets
14:59:57 <openstack> Meeting started Tue Mar 27 14:59:56 2018 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:59:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:01 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
15:00:05 <raildo> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
15:00:48 <raildo> hey dhellmann, how's it going?
15:00:57 <raildo> #chair dhellmann
15:00:58 <openstack> Current chairs: dhellmann raildo
15:01:24 <dhellmann> hi, raildo! good, how are you?
15:01:30 <raildo> all good
15:01:55 <raildo> spilla, ping, are you around?
15:02:57 <spilla> hello
15:03:04 <spilla> o/
15:03:34 <raildo> #topic owners decision for Work Items
15:03:53 <raildo> spilla, do you have updates on this topic?
15:04:19 <spilla> so dhellmann talked me through a lot last friday
15:04:46 <spilla> and it was very helpful (thanks again!)
15:04:55 <raildo> fwi, I spoke with the guys from my team, and we'll bring another folk to work with us on this feature, hope to have him to start work on this in the next days
15:05:27 <spilla> as for new people i think most of mine are pretty occupied for now
15:05:39 <spilla> i will bug them consistently tho :)
15:06:06 <dhellmann> nice. some of the early bits really only need 1 person but as we get later I think we can probably divide tasks up. and it will be good to have more people helping with reviews all along the way
15:06:25 <raildo> dhellmann, agreed
15:06:53 <raildo> spilla, so, should I get the first item?
15:08:10 <spilla> if you want yea! i can help too and start on 2 as well
15:08:51 <raildo> spilla, sounds great, I added your name in the first two topics, so we can keep talking during the week
15:09:03 <spilla> thanks :)
15:09:24 <raildo> dhellmann, I'm supposing that you don't have time to implement it and will review those patches when we have that done, sounds right?
15:09:47 <dhellmann> raildo : for right now, yes, it's better if you just rely on me for reviews
15:10:05 <raildo> dhellmann, all good :)
15:10:06 <dhellmann> I have the lower-constraints stuff in process and that's consuming a fair amount of my time, among other things
15:10:32 <raildo> #action raildo to work in define the base class for a configuration driver
15:10:58 <raildo> #action spilla to help raildo in the previous topic and work to Define the ConfigurationSource base class
15:12:33 <raildo> ok, so I'll go dig into the spec/code to understand all the details related to that, any doubt that I have, I'll ping you guys on irc :)
15:12:49 <dhellmann> good plan
15:13:01 <spilla> sounds good
15:13:09 <raildo> #topic open discussion
15:13:11 <dhellmann> we talked about using the abc module to define it as an abstract base class; and the spec includes some method signatures for the pieces that drivers would override
15:13:21 <dhellmann> we = spilla and myself
15:13:36 <raildo> got it, makes sense for me
15:14:48 <raildo> spilla, if you fell more comfortable in implement this first tasks, I'm totally fine with that as well
15:15:13 <raildo> I just got it to start implement something :)
15:15:24 <dhellmann> :-)
15:15:59 <spilla> sound good, ill let you know :)
15:16:48 <raildo> ok, anyway, I think that we can save some of our time for now, and talk more on irc, if needed
15:17:09 <raildo> thanks guys for your time and have a good week!
15:17:16 <spilla> alright thanks!!
15:17:19 <spilla> you too
15:17:25 <raildo> #endmeeting