16:03:10 <raildo> #startmeeting oslo-config-plaintext-secrets
16:03:11 <openstack> Meeting started Tue Jan 30 16:03:10 2018 UTC and is due to finish in 60 minutes.  The chair is raildo. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:15 <openstack> The meeting name has been set to 'oslo_config_plaintext_secrets'
16:03:31 <raildo> Hello folks :)
16:03:46 <dhellmann> o/
16:03:46 <raildo> #link https://etherpad.openstack.org/p/oslo-config-plaintext-secrets
16:03:53 <raildo> #topic roll call
16:03:58 <raildo> o/
16:04:05 <spilla> o/
16:04:15 <raildo> #chair dhellmann
16:04:16 <openstack> Current chairs: dhellmann raildo
16:04:29 <gagehugo> o/
16:04:34 <raildo> #topic action items from last week
16:04:58 <raildo> so, I've created a topic for us in the next oslo meeting
16:05:06 <raildo> Monday, 05-Feb-2018 - 1500 UTC in #openstack-oslo
16:05:58 <dhellmann> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:06:12 <spilla> i need to schedule the meeting to start splitting up the work on oslo.config
16:06:20 <spilla> ill send that invite out before lunch
16:06:27 <raildo> I had a misunderstanding based in the wiki page from oslo that pointed for 1400 UTC on #openstack-meeting-3, so I lost the last meeting, but anyway, we have the right time and place now :)
16:07:12 <raildo> spilla, do you want to do a videoconferencing meeting for that?
16:07:24 <spilla> that would probably be best
16:07:45 <spilla> thinking bluejeans if thats okay with everyone
16:07:52 <raildo> spilla, great, Do you guys have some free time, late this week?
16:08:08 <raildo> spilla, sure, we can use my bluejeans link for that
16:08:08 <spilla> yes, thursday and friday are fairly open for me
16:08:16 <spilla> thanks!
16:09:47 <raildo> #topic status check
16:10:26 <raildo> I have the script to install custodia and test with castellan almost done, I just didn't send it upstream, since I found a few bugs in the current implementation
16:10:50 <raildo> so I'm working to fix that stuff and I'll update the patch soon
16:11:20 <raildo> but anyway that was the idea to make this script, make sure that everything is ok :)
16:11:36 <dhellmann> good idea
16:12:01 <dhellmann> do you think that script can be turned into the basis of a functional test job, eventually?
16:12:20 <raildo> dhellmann, absolutely
16:12:25 <dhellmann> great
16:12:53 <spilla> addressing dhellmann's comment as well as adding more tests to the current oslo.config patch
16:13:15 <raildo> since I'm creating something similar to what was done for vault, the idea will be to have some tox specific call for test this scenario
16:13:25 <raildo> something like tox -e functional-custodia
16:13:41 <raildo> so we will just need a test job to call this function
16:13:52 <spilla> that'd be really nice
16:13:59 <dhellmann> I'm sure we have other projects with similar functional test jobs, so we can follow that pattern
16:14:15 <raildo> dhellmann, makes sense
16:15:18 <raildo> ok, I have added a comment about that in the etherpad to keep that on track
16:15:24 <raildo> dhellmann, thanks for the idea :)
16:15:56 <raildo> spilla, any update in the oslo.config driver side?
16:16:14 <spilla> pushed a little patch up last week
16:16:27 <dhellmann> raildo : sure thing. setting up the new job with zuulv3 should be a little simpler, too.
16:16:28 <spilla> addressing dhellmann's comment to add a config option
16:16:44 <raildo> spilla, great
16:16:48 <spilla> and also more tests with that, should have a patch (or a few) this week
16:16:51 <gagehugo> yeah adding a job in repo now is nice
16:19:16 <raildo> #topic open discussion
16:20:35 <raildo> I was thinking about asking in the ptg if anyone else are interested in this feature and have some free time to help us on that
16:21:12 <raildo> might be a good idea send an email to openstack-dev to check that possibility before the PTG?
16:21:41 <spilla> agreed, give them a heads up before so they can prep
16:23:38 <dhellmann> ++
16:24:05 <spilla> since feb 8th is coming up, would anyone like to present at the vancouver summit about these changes?
16:24:37 <gagehugo> it would be a good topic to discuss, a more refined talk about secret management
16:24:57 <raildo> #action raildo will send an email to openstack-dev explain the current status and asking for help in the implementation
16:25:53 <raildo> I'm really interested on give some presentation about that in the Summit, I'm just not sure that feature will be ready for Vancouver deadline
16:26:35 <dhellmann> yeah, that's the question
16:26:48 <dhellmann> it might be better to wait and plan to discuss this in berlin, when it's something we can demonstrate
16:27:24 <spilla> good points
16:27:36 <raildo> dhellmann, exactly
16:28:26 <raildo> and maybe be deployed using tripleO/ansible/puppet that will make the operators much happier to adopt that
16:28:45 <dhellmann> ++
16:29:06 <raildo> so, my suggestion is skip this summit and focus on Berlin as dhellmann have said
16:29:24 <spilla> sounds good!
16:31:47 <raildo> I think we are running out of time, thanks everyone and let's set up that bluejeans meeting by email in the next few days
16:31:53 <raildo> #endmeeting