15:01:40 <bnemec> #startmeeting oslo
15:01:40 <openstack> Meeting started Mon Apr 20 15:01:40 2020 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:41 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, stephenfin, kgiusti, johnsom, e0ne, redrobot, bcafarel, smcginnis
15:01:41 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:44 <openstack> The meeting name has been set to 'oslo'
15:01:52 <moguimar> o/ from Brazil
15:01:57 <hberaud> o/
15:02:02 <smcginnis> o/
15:02:03 <johnsom> o/
15:02:08 <bcafarel> o/
15:02:33 <jungleboyj> o/ in multiple meetings
15:02:37 <kgiusti> o/
15:02:41 <ansmith> o/
15:04:26 <bnemec> It's a good thing this isn't a video meeting because I think my headset may be dying. :-/
15:04:43 <bnemec> #topic Red flags for/from liaisons
15:05:45 <bnemec> I think the only thing we released last week was castellan.
15:05:59 <bnemec> So hopefully all is quiet.
15:06:03 <johnsom> Nothing really from Octavia. A slightly related to oslo.db issue in that sqlalchemy changed how sqlite transactions work in 1.3.16 that broke some of our tests. We are skipping those for now as it's limited to testing issues.
15:06:14 <bcafarel> all clear from neutron
15:06:38 <moguimar> we're fixing the castellan and barbican gates
15:06:45 <moguimar> some stuff is still running py27
15:07:17 <bnemec> moguimar: Oops, that's no good. Do you need reviews on anything for castellan?
15:07:36 <moguimar> redrobot, ^
15:08:50 <moguimar> I don't think so bnemec
15:09:22 <bnemec> Okay
15:09:34 <bnemec> Thanks for the heads up.
15:09:54 <bnemec> #topic Releases
15:10:05 <bnemec> As noted, not much happening on the release front.
15:10:17 <bnemec> Just the castellan fix.
15:10:29 <bnemec> I expect this to be quiet until Ussuri ships.
15:10:52 <bnemec> #topic Action items from last meeting
15:11:15 <bnemec> "redrobot request Castellan FFE on openstack-discuss"
15:11:18 <bnemec> Done, thanks
15:11:25 <bnemec> "bnemec request castellan 3.0.1 release once Vault fix has merged"
15:11:26 <bnemec> Done
15:11:33 <bnemec> "bnemec send email about oslo.policy cli change"
15:11:55 <bnemec> I think I'm going to hold off on this one.
15:12:24 <bnemec> Feature freeze doesn't seem like a good time to be throwing stuff at teams.
15:12:34 <bnemec> And if it turns out that a project is broken, we should be able to backport a fix.
15:12:44 <bnemec> So I'll keep this on my todo list for later.
15:13:30 <jungleboyj> Sorry Late, but nothing from Cinder.  :-)
15:14:12 <bnemec> np
15:14:19 <bnemec> #topic Virtual PTG
15:14:39 <bnemec> We had not originally requested space at the PTG because it was not clear anyone would be there.
15:14:59 <bnemec> However, now that the PTG is virtual we could change our minds on that.
15:15:54 <moguimar> +1
15:16:29 <bnemec> I'm thinking maybe we should create an etherpad for topics and if there's enough to discuss we can move forward on a vptg.
15:16:43 <bnemec> Is there anyone who definitely does or does not want to do one?
15:18:38 <bnemec> Okay, I'll get the etherpad created and send an email to the list.
15:18:56 <bnemec> I'll have to check when the deadline to request PTG space is, although worst case we just meet on our own like we did last cycle.
15:19:04 <bnemec> #action bnemec create etherpad for virtual ptg
15:19:15 <bnemec> #topic Branch devstack plugins?
15:19:25 <bnemec> kgiusti: ansmith: Glad you're here today. :-)
15:19:38 <johnsom> April 28th
15:19:41 <kgiusti> bnemec: and so am I :)
15:19:45 <bnemec> I think we had this discussion last cycle too.
15:20:05 <bnemec> There isn't a whole lot of activity in these repos AFAIK, so do we still need to keep branching them?
15:21:03 <kgiusti> I don't believe we need to continue branching - what say ye, ansmith?
15:21:19 <ansmith> +1
15:21:29 <bnemec> For those who are not familiar with this, I'm referring to https://opendev.org/openstack/devstack-plugin-kafka and https://opendev.org/openstack/devstack-plugin-amqp1
15:21:57 <bnemec> Cool, something to remove from the PTL guide then. :-)
15:22:01 <bnemec> Thanks!
15:22:07 <smcginnis> Is there ever any reason we would want to backport a bugfix specifically for a train version of these?
15:22:50 <bnemec> Not that I know of. The reason we started branching them in the first place was so we didn't break the stable branches with changes focused on master.
15:23:03 <bnemec> Since there haven't really been changes to these plugins lately that seems unlikely.
15:23:19 <kgiusti> agreed
15:23:28 <smcginnis> OK, if they are pretty stable now then sounds like no need to maintain that.
15:23:33 <smcginnis> Thanks for the explanation.
15:24:23 <bnemec> #topic contributor documentation goal
15:25:00 <bnemec> We had discussed this last week, and I was going to take a look at what Cinder did and figure out a plan to move this forward in Oslo.
15:25:08 <bnemec> Apparently I didn't action myself on that though. :-)
15:25:49 <bnemec> Anyway, it looks like Cinder did something similar to what I was thinking, which is put the central doc in cinder itself and then have references to the other projects.
15:26:21 <bnemec> I think for Oslo we would need to add it as a policy in oslo-specs since that's really the only central repo that we have.
15:26:22 * hberaud need to review last meeting logs
15:27:02 <bnemec> TLDR: I got pinged because we didn't do the project-specific contributor docs goal.
15:27:20 <hberaud> ack
15:27:48 <bnemec> Because we have so many repos I don't think it's reasonable to do it separately for each repo.
15:28:04 <bnemec> So I want a central doc that the repos can reference.
15:28:28 <bnemec> I did notice that the cinder central doc includes links to all of the other repos too.
15:29:08 <bnemec> I think we already had something like that on the wiki, so maybe we want to replace the wiki page with this new doc?
15:29:38 <bnemec> Yeah, this is what I was thinking of: https://wiki.openstack.org/wiki/Oslo#Libraries
15:30:14 <bnemec> Or maybe we just refer to that page in the document since it's already written.
15:31:40 <bnemec> I guess the main thing is that I haven't found anything about this that changes my original suggestion to write it up as a policy and have CONTRIBUTING.rst in the repos refer to that.
15:32:23 <bnemec> If anyone has other suggestions or wants to tackle that please let me know.
15:33:13 <bnemec> I have no idea if/when I will have time to sit down and write something up.
15:34:26 <bnemec> Okay, so I'll reply to Kendall that we at least have a plan for this.
15:34:55 <bnemec> #action bnemec to reply to diablo_rojo about contributor docs goal
15:35:20 <bnemec> Still skipping weekly wayward review for now...
15:35:22 <bnemec> #topic Open discussion
15:35:29 <bnemec> Anything else this week?
15:36:20 <bnemec> Apparently it's now official that I'm still PTL: https://review.opendev.org/#/c/718655/
15:36:22 <bnemec> :-)
15:36:31 <johnsom> Congrats? lol
15:36:33 <bcafarel> congrats :)
15:37:07 <hberaud> :)
15:38:02 <bnemec> It'll work until my manager gets annoyed that I'm not fully on the project I'm supposed to be working on now. ;-)
15:39:22 <bnemec> Alright, sounds like we're done.
15:39:27 <bnemec> Thanks for joining, everyone!
15:39:31 <bnemec> #endmeeting