15:01:49 <bnemec> #startmeeting oslo
15:01:49 <bnemec> Courtesy ping for bnemec, jungleboyj, moguimar, hberaud, kgiusti, redrobot, stephenfin, johnsom
15:01:49 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:01:50 <openstack> Meeting started Mon Jun 24 15:01:49 2019 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:54 <openstack> The meeting name has been set to 'oslo'
15:03:12 <hberaud> yo
15:03:18 <gsantomaggio> yo
15:03:29 <ansmith> o/
15:03:33 <moguimar> o/
15:04:25 <kgiusti> o/
15:05:42 <bnemec> #topic Red flags for/from liaisons
15:06:23 <moguimar> None from Barbican
15:06:24 <jungleboyj> o/
15:06:29 <jungleboyj> Nothing from Cinder.
15:06:45 <bnemec> Last week was pretty quiet from the Oslo side too.
15:06:50 <bnemec> Nothing I can think of to highlight.
15:07:17 <bnemec> #topic Releases
15:07:29 <bnemec> Just a couple last week.
15:07:55 <bnemec> Of note is that I held off on releasing oslo.messaging since the transport options feature is only partially merged.
15:08:29 <bnemec> kgiusti: gsantomaggio: If you have something that needs to be released anyway we can certainly do that though.
15:08:59 <gsantomaggio> I'm proceeding by steps
15:09:11 <bnemec> Other than that, I will take a look at the necessary releases again this week.
15:09:15 <kgiusti> I've got nuthin'  - hberaud - anything?
15:09:29 <hberaud> nope
15:09:43 <gsantomaggio> I am waiting for approving this: https://review.opendev.org/#/c/666241/
15:10:14 <gsantomaggio> then I can add the handle the mandatory flag client side and then server side
15:10:15 <kgiusti> gsantomaggio: I'll take a look
15:10:22 <hberaud> +1
15:10:25 <bnemec> Yep, that's what I'm waiting the release on.
15:11:00 <bnemec> Or maybe the actual mandatory implementation.
15:11:19 <bnemec> I guess the main point is that I intentionally didn't release oslo.messaging last week, but if you need a release just let me know.
15:11:26 <gsantomaggio> as you prefer
15:12:23 <stephenfin> Not entirely relevant for this section, but I went and abandoned a load of seemingly stale patches/specs this morning. Hopefully I didn't catch anything I shouldn't have in the process
15:12:49 <bnemec> The ones I saw looked fine.
15:13:04 <bnemec> I know pluggably policy is pretty much off the table at this point.
15:13:37 <moguimar> yep
15:13:42 <bnemec> It's always okay to restore an abandoned patch if you still have interest in it.
15:13:52 <moguimar> I even tried to help ozz on that one
15:13:54 <bnemec> And if you're not the owner, feel free to ping an Oslo core to do it.
15:14:26 <bnemec> moguimar: Yeah, based on the discussions I've had with people it sounds like that was kind of a side project that didn't end up going anywhere.
15:14:43 <bnemec> Doug does have a patch up to allow integration with external policy engines.
15:14:52 <bnemec> It's not pluggable though.
15:15:19 <bnemec> #link https://review.opendev.org/#/c/658675/
15:15:23 <bnemec> for anyone who is interested.
15:16:00 <bnemec> #topic Action items from last meeting
15:16:48 <bnemec> "bnemec reply to unicode project description thread"
15:16:50 <bnemec> Done
15:16:56 <bnemec> "bnemec update liaison documentation with new ping list details"
15:17:08 <bnemec> Turns out we didn't document the ping list in the liaison docs, so this was a noop
15:17:16 <bnemec> "bnemec retire courtesy ping script in oslo.tools"
15:17:21 <bnemec> Proposed.
15:17:38 <gsantomaggio> > but if you need a release just let me know.
15:17:38 <gsantomaggio> No I don't need a release thank you, I work always on `master` branch
15:17:38 <bnemec> #link https://review.opendev.org/666057
15:17:54 <bnemec> gsantomaggio: Sounds good.
15:17:59 <bnemec> "bnemec to point kafka functional test patch at apache mirror"
15:18:12 <bnemec> Turns out the mirrors don't include the archive content, so we couldn't do this.
15:18:32 <bnemec> I believe we did merge the patch to switch it to archive.a.o so we could unblock those functional tests though.
15:18:46 <bnemec> "Cores to review https://review.opendev.org/648727"
15:18:50 <openstackgerrit> Merged openstack/oslo.tools master: Remove ping_me script  https://review.opendev.org/666057
15:19:10 <bnemec> I took a look, but it didn't quite fix the bug entirely.
15:19:44 <bnemec> I should probably go -1 that since at the very least it shouldn't be marked Closes-Bug. Partial-Bug might be okay.
15:19:47 <hberaud> bnemec: I saw comments
15:20:29 <hberaud> s/I saw/I just saw/
15:20:36 <bnemec> hberaud: It's possible we could merge that as an improvement and iterate on the full fix.
15:20:45 <bnemec> I'm not sure whether it regresses any cases that were working before.
15:20:54 <hberaud> bnemec: ack
15:21:05 <bnemec> If not, it's an improvement even if not a 100% solution.
15:21:24 <hberaud> I'll move from Closes to Parial
15:21:32 <hberaud> partial
15:21:43 <bnemec> Sounds good, thanks.
15:22:09 <bnemec> "bnemec to follow up on oslo.service reload bug"
15:22:15 <bnemec> Not done. Still on my todo list though.
15:22:37 <moguimar> I tried to test it
15:22:38 <bnemec> Last week ended up being a bit busy, so hopefully I'll have more time this week to do this.
15:22:47 <moguimar> but even master is failing tox on my machine
15:22:51 <bnemec> moguimar: The oslo.service patch?
15:22:55 <moguimar> the pbr
15:23:06 <bnemec> Ah
15:23:39 <bnemec> moguimar: What is the error?
15:23:58 <bnemec> The pbr unit tests _should_ be pretty stable since we fixed the wsgi issue.
15:24:21 <bnemec> (that was the end of action items from last week, BTW)
15:24:25 <moguimar> lots of testtools.matchers._impl.MismatchError: '1.2.3.dev1' does not start with '1.2.3.0a2.dev1'.
15:24:38 <moguimar> and some pgp failed to sign the data
15:24:50 <moguimar> I have to dig more into it
15:25:15 <moguimar> testing that review I had 13 fails
15:25:23 <moguimar> I'm hitting 11 on master
15:25:40 <moguimar> It is probably something in my machine
15:25:41 <bnemec> Have you tried wiping .tox? That's always my first step when I get unexpected test failures. :-)
15:26:26 <moguimar> I usually do a "git clean -fdX"
15:26:47 <moguimar> trying it right now
15:27:46 <bnemec> Okay, we can follow up after the meeting too.
15:28:05 <bnemec> I don't have any topics for this week, so we'll go straight to
15:28:05 <bnemec> #topic Weekly Wayward Review
15:28:28 <bnemec> #link https://review.opendev.org/#/c/577614
15:28:35 <bnemec> Looks like this just got rebased.
15:28:42 <bnemec> It's a pretty simple change, so hopefully we can just merge it.
15:31:37 <bnemec> And approved.
15:31:47 <hberaud> I'll +2
15:31:48 <bnemec> One more off the review pile of shame. :-)
15:31:58 <bnemec> #topic Open discussion
15:32:02 <hberaud> lol ok
15:32:08 <bnemec> Anything else this week?
15:32:25 <bnemec> hberaud: Thanks for looking. :-)
15:33:00 <hberaud> if someone can take a look to => https://review.opendev.org/#/c/663074/ and https://review.opendev.org/#/c/661314/ (the eventlet heartbeat stuff)
15:34:07 <bnemec> hberaud: What's the status on that? Last I heard kgiusti had concerns and you said something about tpool not working the way we needed.
15:34:24 * kgiusti - re-looks...
15:35:13 <hberaud> bnemec: I've submit 2 solution, 1 with tpool, 1 without tpool (the current patch set) and the instructions to test it
15:35:26 <hberaud> (the both)
15:36:01 <bnemec> hberaud: Okay, thanks. Do you have a recommendation on which we should go with?
15:36:20 <hberaud> bnemec: yeah I propose to use the current patch set
15:36:21 <kgiusti> bnemec: hberaud: I didn't have a technical objection - just concerned about the scope of work in general.
15:36:47 <kgiusti> but I'm definitely interesting in this problem.
15:37:06 <bnemec> hberaud: Sounds good. I'll try to take a look this week.
15:37:07 <hberaud> bnemec: but if you want to observe the result with tpool you can us the patch set 3 to test it
15:37:21 <hberaud> (cf. the commit message)
15:37:21 <bnemec> kgiusti: Yeah, we just never really resolved that discussion that I can recall.
15:38:02 <hberaud> also I suppose it's better to keep the spec too
15:38:22 <hberaud> to keep a track of  all puzzle pieces
15:38:36 <hberaud> bnemec: kgiusti; thoughts?
15:38:53 <bnemec> Given that this is technically a bug fix I don't think we _need_ a spec, but if it helps to coordinate the work then I'm fine with keeping it.
15:39:12 <bnemec> Just don't do it solely for the sake of more bureaucracy. :-)
15:39:40 <hberaud> the main of the spec part is to justify some technical choice in the doc after that => https://review.opendev.org/#/c/666863/
15:39:55 <hberaud> s/the main/the main goal/
15:40:34 <kgiusti> hberaud: I'll spend more time reviewing what you've currently done
15:41:13 <kgiusti> hberaud: I'll try to get that done today.
15:41:14 <hberaud> bnemec: yeah sure "not a bureaucracy" choice :)
15:41:26 <hberaud> kgiusti: thanks
15:41:59 <bnemec> #action kgiusti and bnemec to review rabbit heartbeat changes
15:42:08 <bnemec> There, now it's official.
15:42:16 <hberaud> :)
15:42:31 <bnemec> Anything else?
15:42:42 <hberaud> not on my side
15:43:16 <moguimar> neither on mine
15:43:33 <gsantomaggio> nothing here !
15:44:47 <bnemec> Sounds like we're done. Thanks for joining, everyone!
15:44:49 <bnemec> #endmeeting