15:04:00 <bnemec> #startmeeting oslo
15:04:01 <openstack> Meeting started Mon Nov  5 15:04:00 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:04:06 <openstack> The meeting name has been set to 'oslo'
15:04:08 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:04:08 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:04:08 <bnemec> courtesy ping for hberaud, jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_
15:04:08 <bnemec> courtesy ping for moguimar, njohnston, raildo, redrobot, sileht, sreshetnyak, stephenfin
15:04:10 <bnemec> courtesy ping for stevemar, therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:04:15 <bnemec> #link https://wiki.openstack.org/wiki/Meetings/Oslo#Agenda_for_Next_Meeting
15:04:18 <moguimar> o/
15:04:21 <phuongnh> o/
15:04:25 * stephenfin lurks
15:04:26 <hberaud> o/
15:04:30 <ansmith> o/
15:04:36 <ducnv_> o/
15:04:37 <kgiusti> o/
15:05:30 <dhellmann> o/
15:05:58 <bnemec> I think this is the right time for the meeting.
15:06:01 <bnemec> Stupid time changes.
15:06:27 <bnemec> #topic Red flags for/from liaisons
15:07:00 <bnemec> We've had a number of reports of issues with SSL and rabbit in Pike.
15:07:48 <kgiusti> :(
15:08:04 <jungleboyj> o/
15:09:00 <bnemec> Obviously that isn't affecting any development though or someone would have reported it before now.
15:09:10 <kgiusti> I've not been able to reproduce the issue reported about ocata->pike locally
15:10:08 <kgiusti> I'm not sure if zigo's problem is the same - need to reach out to him today
15:10:50 <bnemec> kgiusti: Okay, sounds good (or not good ;-). Thanks for looking into this.
15:11:16 <kgiusti> pike's been out for awhile now if this is a hard failure I would've expected to hear about this sooner.
15:11:34 <kgiusti> Something is rotten in the state of Oslo  (Messaging)
15:12:28 <bnemec> kgiusti: Yeah, although you would be surprised how long it takes people to adopt new releases.
15:12:39 <kgiusti> true that
15:12:40 <bnemec> Having major bugs reported a year and a half after release isn't as uncommon as you might expect.
15:14:07 <dhellmann> this smells like an openssl (or other library) upgrade problem
15:15:10 <bnemec> Could be. That would also explain why no one has reported it until now.
15:15:13 <kgiusti> dhellmann: good point, I seem to recall a breaking change at some point in the openssl release history...
15:15:23 <zigo> kgiusti: I'm here !
15:15:36 <kgiusti> Hi zigo!
15:15:47 <kgiusti> Did you have any luck getting your SSL config working?
15:16:00 <zigo> It's working, no problem.
15:16:10 <zigo> Though my trouble was: no report at all that something was going wrong.
15:16:17 <zigo> It took me a real long time to understand.
15:16:33 <zigo> I would have very much prefer not to loose all of that time with something in my log...
15:16:57 <zigo> In my case, there was absolutely nothing in heat-api and heat-engine saying it wouldn't connect to rabbit.
15:16:58 <kgiusti> Yeah I'll work on a fix for that - SSL failures are a pain to debug (even with logs!)
15:17:21 <zigo> I had to double-guess that it wouldn't connect and that it was the root cause.
15:18:11 <kgiusti> zigo: what release are you using?  We've had a report of problems with SSL going from ocata->pke
15:18:15 <kgiusti> pike, that is
15:18:28 <zigo> kgiusti: Queens, then more recently, Rocky.
15:18:32 <zigo> Both had the problem.
15:19:07 <kgiusti> zigo: thanks
15:19:15 <zigo> My pleasure.
15:19:52 <kgiusti> I suspect the ocata->pike failures may be different, since the same SSL config worked on ocata failed when upgrading to pike
15:20:11 <kgiusti> I'lll continue to work on it
15:20:41 <bnemec> kgiusti: I think I saw a patch on pike that moved some parameters around too, and I think it may have dropped some deprecated_names in the process.
15:21:02 <bnemec> Maybe people were still relying on the deprecated stuff and it broke when that went away?
15:21:13 <bnemec> (assuming I read the patch correctly, which you shouldn't ;-)
15:21:54 <bnemec> Anyway, we should probably revisit this after the meeting.
15:22:00 <kgiusti> +1
15:22:09 <bnemec> #topic Releases
15:22:21 <bnemec> Completely forgot to do these last week. :-(
15:22:39 * bnemec blames a certain TLA for interrupting his weekly routine
15:23:01 <bnemec> I'll get that done today.
15:23:29 <bnemec> I anticipate no releases next week since it will be Summit.
15:24:39 <bnemec> #topic Action items from last meeting
15:24:51 <dhellmann> bnemec : I feel like we had a couple of things go in late last week that would be good to release
15:25:20 <bnemec> dhellmann: Yeah, I'll propose releases today.
15:25:26 <dhellmann> the oslo.config env stuff from cdent, and something that landed over the weekend as a fix that I can't quite put my finger on
15:25:27 <dhellmann> ok, cool
15:25:57 <bnemec> It just slipped my mind last week and by the time I remembered it was late enough in the week that I figured I'd just wait until this week.
15:26:12 <bnemec> "bnemec send email about project update video"
15:26:27 <bnemec> As it turns out, I didn't have to because we got a project update slot.
15:26:28 <bnemec> \o/
15:26:40 <moguimar> did the oslo.config env stuff merged?
15:26:53 <bnemec> moguimar: I believe so.
15:27:26 <moguimar> yup
15:27:28 <moguimar> merged
15:28:00 <bnemec> I have some slides made up for the project update and I'll be sending those out today as well for people to review/make additions.
15:28:56 <bnemec> "bnemec to investigate oslomotw"
15:29:16 <bnemec> Still on my todo list, but not done. Probably going to have to wait until after Summit.
15:29:38 <bnemec> "lbragstad to ping jaypipes about oslo.limit API"
15:29:54 <bnemec> I saw some discussion around this, but I don't recall exactly where it stands.
15:32:55 <bnemec> Will have to follow up on that later.
15:32:58 <bnemec> #topic No meeting next week
15:33:17 <bnemec> It's Summit, so I expect a lot of the people attending this will be travelling.
15:33:42 <bnemec> #action bnemec to send meeting cancellation email to list
15:34:01 <bnemec> #topic Oslo project update
15:34:08 <bnemec> #link https://www.openstack.org/summit/berlin-2018/summit-schedule/events/22952/oslo-project-onboarding
15:34:27 <bnemec> It's Thursday at 2:05.
15:35:03 <bnemec> Hope to see everyone there. :-)
15:35:27 <bnemec> #topic Weekly Wayward Review
15:35:34 <bnemec> Let's see what we need to look at this week...
15:36:53 <bnemec> There's a hacking patch for those of you who are hacking cores: https://review.openstack.org/#/c/602464/
15:37:57 <bnemec> There's also a kafka messaging patch, but that might be too big to get through right now: https://review.openstack.org/#/c/603190/
15:39:28 <bnemec> If someone wanted to write unit tests for https://review.openstack.org/#/c/612376/ we could get that one in.
15:40:18 <bnemec> Shouldn't be too difficult. There's only one branch in the function.
15:41:57 <bnemec> So the fact that I'm struggling to find a patch we can resolve during the meeting is kind of a good thing.
15:42:12 <bnemec> Almost everything in my top 15 list is related to large feature work that just takes time to review.
15:42:29 <bnemec> Which I take to mean that we're doing a reasonably good job of keeping up with reviews overall.
15:42:38 <moguimar> There is an oslo.policy patch by ozz: https://review.openstack.org/#/c/613313
15:43:03 <bnemec> moguimar: That's approved. :-)
15:43:40 <moguimar> a few minutes ago =D
15:43:59 <bnemec> Only 21 patches out of 116 are waiting on reviewer, so high fives all around.
15:44:02 <bnemec> o/\o
15:44:27 * lbragstad wanders in late
15:44:59 <bnemec> So I guess my conclusion for this week is keep up the good review work.
15:45:13 <bnemec> And we'll keep chipping away at the feature reviews.
15:45:20 <bnemec> #topic Open discussion
15:45:27 <lbragstad> about the oslo.limit bits
15:45:49 <lbragstad> we have discussion on the API in oslo.limit happening in a few different places
15:45:57 <lbragstad> #link https://review.openstack.org/#/c/596520/
15:46:01 <lbragstad> #link https://review.openstack.org/#/c/615180/5/nova/compute/utils.py
15:46:06 <lbragstad> and
15:46:08 <lbragstad> #link https://review.openstack.org/#/c/600266/6
15:47:49 <bnemec> Ah yes, the first one is where I had seen discussion this week.
15:48:21 <lbragstad> kinda of a lot to keep a pulse on.. but johnthetubaguy is a little concerned about the initial complexity of the API
15:48:28 <lbragstad> specifically with the context manager
15:48:45 <lbragstad> which means it had the opposite effect we were shooting for :)
15:49:09 <bnemec> Yeah, I'm a little surprised to hear that.
15:49:19 <bnemec> The context manager was supposed to make it easier to interact with quota code.
15:49:28 <lbragstad> but the feedback is good
15:49:31 <lbragstad> right
15:49:51 <bnemec> Yeah, as long as there is good discussion happening we're making progress.
15:49:54 <lbragstad> ultimately supposed to hide the verify in the __exit__ of the context manager
15:50:32 <lbragstad> but it sounds like john want's the verification to be optional - so i'm going to be tinkering with his review today to see if i can experience the pain first hand
15:50:52 <lbragstad> hopefully, we'll have something more concrete by the EOW is that's alright
15:51:37 <bnemec> I'm curious what quota is supposed to do if it's optional, but I'll try to go read those reviews and then maybe it will make sense.
15:52:35 <lbragstad> the verification on __exit__ is mainly to protect against races conditions between clients
15:52:35 <bnemec> lbragstad: Thanks for the update.
15:52:40 <lbragstad> no problem
15:53:04 <phuongnh> hi bnemec, dhellmann, as we discussed in Denver, we in Fujitsu would like the oslo config migrator feature have more attention. The time does not support us. Please help us. Thanks.
15:54:01 <bnemec> phuongnh: Yeah, we're getting close. I'm struggling a bit to understand the last patch in the series right now.
15:54:34 <bnemec> I suppose we could merge the rest of the code as-is, but I assume there would be a bug present if we did.
15:54:49 <phuongnh> thanks, ducnv has updated source code and answer your comments. Please tell us if you have more question.
15:55:03 <phuongnh> I know that :)
15:55:26 <bnemec> This is the review I'm talking about, for those playing along at home: https://review.openstack.org/#/c/603060/
15:56:10 <phuongnh> yes, ducnv has updated on this patch
15:56:14 <bnemec> So I'll try to take another look at that this week.
15:56:27 <phuongnh> thank you a lot
15:56:35 <ducnv_> bnemec, thanks :))
15:57:13 <bnemec> Okay, we have about three minutes. Anything else?
15:57:29 <phuongnh> and do you need our support in preparing slide for Oslo project update ?
15:57:40 <phuongnh> about oslo config migrator feature?
15:59:28 <bnemec> phuongnh: I have that in my slides already, but if you had information you specifically want included feel free to send it to me.
16:00:02 <phuongnh> general information is ok for us
16:00:09 <phuongnh> that is all for me, thanks
16:00:20 <bnemec> Alright, we're out of time anyway.
16:00:22 <dhellmann> phuongnh : will you or ducnv be able to make it to berlin next week for the summit?
16:00:38 <bnemec> Thanks for joining everyone!
16:00:40 <bnemec> #endmeeting