15:03:20 <bnemec> #startmeeting oslo
15:03:21 <openstack> Meeting started Mon Jul 16 15:03:20 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:24 <openstack> The meeting name has been set to 'oslo'
15:03:38 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:03:38 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:03:38 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, njohnston
15:03:38 <bnemec> courtesy ping for raildo, redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar
15:03:38 <bnemec> courtesy ping for therve, thinrichs, toabctl, zhiyan, zxy, zzzeek
15:03:49 <jungleboyj> o/
15:04:03 <ansmith> o/
15:04:03 <johnsom> o/
15:04:06 <dhellmann> o/
15:04:40 <raildo> o/
15:06:00 <bnemec> #topic Red flags for/from liaisons
15:06:26 <stephenfin> o/
15:06:28 <bnemec> Hopefully we haven't broken anything since it's coming down toward the end of the cycle.
15:06:29 <jungleboyj> Nothing from Cinder.
15:06:59 <bnemec> Although I did approve the oslo.config drivers tree on Friday.
15:07:10 <dhellmann> we have that oslo.policy thing in glance
15:07:11 <redrobot> o/
15:07:16 <johnsom> We had some challenges with privsep, but I think those were worked out.  Thanks for the support there.
15:07:19 <bnemec> That didn't affect much existing functionality so it should be pretty safe, but you never know.
15:07:19 <dhellmann> the unit tests are broken with the latest release
15:07:25 <bnemec> johnsom: Cool, thanks.
15:07:35 <bnemec> dhellmann: Oops, I haven't seen that yet.  Is it on the mailing list?
15:07:52 <dhellmann> there's some discussion on the requirements patch to update the constraint, let me find that
15:07:58 <openstackgerrit> Merged openstack/oslo.config master: add detail to driver options in config generator  https://review.openstack.org/578461
15:08:04 <dhellmann> https://review.openstack.org/#/c/582418/
15:08:05 <bnemec> johnsom: Do you have a brief summary of what you needed to do to get it working?
15:08:36 <johnsom> bnemec Sadly I don't, it was another team member working on it.  xgerman
15:08:54 <jungleboyj> That is one thing to mention from Cinder.  We are holding on doing more on privsep until some of the throughput issues were taken of.
15:09:02 <jungleboyj> eharney was going to look into it.
15:09:06 <johnsom> It was an issue with when the client thread was spawning, that is all I know
15:09:29 <bnemec> johnsom: Okay, thanks.
15:10:28 <bnemec> jungleboyj: Throughput issues?  As in it can't communicate with the daemon fast enough?
15:11:32 <jungleboyj> bnemec:  Problems with if one long process is running it will block all others in Cinder.
15:11:45 <bnemec> dhellmann: Hmm, so it sounds like the problem is glance is passing a mock for the context?
15:12:22 <bnemec> jungleboyj: Ah, yeah I suppose that's a problem.
15:12:44 <dhellmann> bnemec : yeah. I think we probably want to fix the glance tests. That may mean helping to create a fixture or something to replace that mock
15:12:53 <jungleboyj> bnemec:  Yes.  Because we have some processes that can be long running.  So, if that happens all of Cinder will just kind of stop.
15:13:15 <bnemec> dhellmann: Sounds good.  We've done similar things in the past for other projects.
15:13:16 <jungleboyj> bnemec:  So, I have that as a subject for the PTG and Eric is looking into it.
15:13:53 <dhellmann> bnemec : yeah, we just need to work with jokke_ & the glance team on what is needed. maybe lbragstad can help drive that.
15:14:36 <bnemec> jungleboyj: Sounds good.
15:14:37 * lbragstad lingers
15:14:58 <bnemec> #action work with the Glance team to address unit test failures with new oslo.policy
15:15:30 <lbragstad> ahh - was that related to the patch we had to make oslo.policy accept context objects?
15:15:41 <bnemec> lbragstad: Yeah
15:15:46 <lbragstad> got it
15:15:46 <dhellmann> bnemec : keep in mind the requirements freeze is coming up next week
15:16:13 <lbragstad> yeah - i can help dig into that, afaik glance it's using the new oslo.policy rule defaults yet either
15:16:17 <bnemec> dhellmann: lbragstad: How important is it that this gets in this cycle?
15:16:29 <bnemec> I anyone planning to use it right now?
15:16:33 <bnemec> *Is
15:16:57 <lbragstad> it was something we were going to start using for incorporating scope_types into services
15:17:02 <dhellmann> bnemec : it's going to mess with management of the stable branch if that release isn't actually used in rocky
15:17:31 <dhellmann> so if we aren't going to fix it in time, we may need to revert the change and release a new policy lib before branching
15:17:32 <lbragstad> (e.g. instead of each service mapping scope to different things in the creds dictionary for policy enforcement, they can just pass in the oslo.context
15:17:49 <dhellmann> unless there are no real changes other than that since the previous release, in which case we can use that one as the branch point
15:17:59 <lbragstad> i can investigate today and bump it up my queue
15:18:20 <bnemec> I'm fine with fixing it, but if it isn't going to be used this cycle anyway I'd be inclined to revert and re-merge it early next cycle.
15:18:31 <bnemec> Feature freeze for everyone else is coming up pretty soon now.
15:19:31 <lbragstad> i think we're planning on using it in keystone - ozz had some stuff up that would consume it
15:20:08 <bnemec> lbragstad: Okay, maybe we revisit this once you've had a chance to investigate.
15:20:18 <dhellmann> yeah, let's see how bad the fix is
15:20:30 <bnemec> #action lbragstad to investigate oslo.policy issues
15:20:55 <lbragstad> thanks - i'll get something up today or have more information by EOD
15:21:06 <bnemec> Sounds good, thanks
15:21:24 <lbragstad> these are specific to glance, yeah?
15:21:31 <lbragstad> is there an open bug report yet?
15:21:45 <bnemec> Or any project that passes mocks as context to oslo.policy.
15:22:12 <bnemec> But so far it looks like it is only an issue in glance.
15:22:28 <lbragstad> ack
15:22:32 <dhellmann> I don't think there's a bug report, just the discussion on the constraints update patch
15:22:57 <bnemec> Yeah, we should open one.
15:23:11 <bnemec> We'll need a bug to link to the fix anyway now that we're in feature freeze.
15:23:33 <bnemec> #action open bug for oslo.policy unit test failures in glance
15:24:47 <bnemec> Okay, anything else on the red flags?
15:26:15 <bnemec> Alright then.
15:26:16 <bnemec> #topic Releases
15:26:42 <bnemec> There were a couple that happened out of the normal weekly schedule last week.
15:27:02 <bnemec> Mostly to get new features out there so people could start consuming them.
15:27:29 <bnemec> I'll take a look for anything else that needs releasing this week as usual.
15:27:38 <bnemec> This should be the last set of releases with new features for this cycle.
15:29:19 <bnemec> #topic Action items from last meeting
15:29:28 <bnemec> "bnemec to contact storyboard team about doing test import of oslo projects"
15:29:35 <bnemec> Bah, I still haven't done that.
15:30:13 <bnemec> Now that we're in feature freeze maybe I'll remember to do it.
15:30:31 <bnemec> "resolve interaction between oslo.policy and oslo.context"
15:30:39 <bnemec> I don't remember what that one was about.
15:30:47 <bnemec> It came from the wayward review topic...
15:31:28 <bnemec> Oh, this had to do with the type checking of context objects, which it sounds like we resolved.
15:31:45 <dhellmann> is that the thing that broke glance's unit tests? :-)
15:31:52 <bnemec> Yep. :-)
15:32:08 <bnemec> So I guess partial credit for that one.
15:32:30 <dhellmann> one step forward, one step back
15:33:25 <bnemec> We have multiple new action items related to that so I think we're done with this one though.
15:33:31 <bnemec> #topic Oslo feature freeze
15:33:42 <bnemec> A reminder that we are now in feature freeze for Oslo.
15:34:04 <bnemec> We should only be merging bug fixes from here on out this cycle.
15:35:03 <bnemec> I believe we are now listed on the release schedule too: https://releases.openstack.org/rocky/schedule.html#r-oslo-feature-freeze
15:35:26 <bnemec> Not much else to say about that, I guess.
15:35:34 <bnemec> #topic PTG planning etherpad
15:35:40 <bnemec> #link https://etherpad.openstack.org/p/oslo-stein-ptg-planning
15:36:35 <bnemec> Seems like everyone is starting this discussion now so there you go.
15:36:55 <bnemec> We're still a couple of months out so I'll try to remember to remind everyone of this as we get closer too.
15:37:05 <bnemec> I realize we may not know exactly what we need to talk about yet.
15:37:52 * jungleboyj is afraid the PTG will be here before I know it.
15:38:26 * dhellmann is too
15:38:37 <bnemec> Well, the intervening time is mostly summer, and as every schoolkid knows summer is too short. ;-)
15:39:25 <jungleboyj> :-)
15:40:10 <bnemec> That's it for topics.
15:40:15 <bnemec> #topic Weekly Wayward Review
15:40:32 <bnemec> The next one is a feature, so I wonder if we should suspend this section during feature freeze.
15:41:01 <bnemec> Maybe just use this time for anyone to raise high priority bug fix reviews that need to be done?
15:41:23 <dhellmann> it does make sense to focus on bug reviews after the freeze
15:43:20 <bnemec> We do have one review that's been open for a long time that could probably merge:
15:43:22 <bnemec> #link https://review.openstack.org/#/c/574360
15:43:55 <bnemec> It's not technically a feature, although I don't know if we want to be messing around with testenvs at this point either.
15:44:34 <bnemec> I guess hacking is a separate team now too so technically not Oslo.
15:45:49 <dhellmann> it will be a priority to fix that up for next cycle, but we don't need to worry about it now if you think there's risk
15:46:13 <bnemec> I'm not too concerned.  hacking is pretty low activity these days.
15:46:32 <bnemec> I went ahead and +2'd it.
15:47:20 <bnemec> And since it's technically not part of Oslo it's technically not in feature freeze yet so that doesn't matter. :-)
15:47:33 <dhellmann> and approved
15:47:55 <bnemec> Cool, one more off the list.  Thanks.
15:48:02 <bnemec> #topic Open discussion
15:48:11 <bnemec> Anything before we close?
15:49:41 <dhellmann> nothing from me
15:50:23 <bnemec> Okay, thanks for joining everyone!
15:50:25 <bnemec> #endmeeting