15:00:42 <bnemec> #startmeeting oslo
15:00:42 <openstack> Meeting started Mon Apr 30 15:00:42 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:46 <openstack> The meeting name has been set to 'oslo'
15:01:04 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:04 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:04 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:01:04 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:01:04 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:01:11 <dhellmann> o/
15:01:13 <stephenfin> o/
15:01:14 <ansmith> o/
15:01:15 <kgiusti> o/
15:03:06 <bnemec> #topic Red flags for/from liaisons
15:03:06 <jungleboyj> O/
15:03:17 <jungleboyj> Peripherally here.
15:03:28 <jungleboyj> No red flag.
15:03:45 <bnemec> I don't recall anything going on from the Oslo side.
15:04:30 <bnemec> #topic Releases for Rocky
15:04:50 <bnemec> Still business as usual here too.
15:05:03 <bnemec> I think all the eventlet uncapping releases have happened at this point.
15:05:27 <bnemec> And I do still need to make releases for the stable Oslo branches.
15:05:45 <bnemec> #action bnemec to release Oslo stable branches
15:05:54 <jungleboyj> Smcginnis is working on resolving the table Henderson issues for continuing options.
15:06:58 <bnemec> jungleboyj: Cool
15:07:08 * bnemec guesses Henderson is autocorrect at work ;-)
15:07:39 <bnemec> It would be good to get https://review.openstack.org/#/c/561928/ and https://review.openstack.org/#/c/543498/ in on the stable branches first.
15:08:27 <dhellmann> that second one sounds weird
15:08:54 <jungleboyj> *generation
15:09:19 <jungleboyj> Sorry, was on my phone for a little bit there.
15:09:20 <bnemec> dhellmann: Basically the initial implementation was backward, so it doesn't do what it says it does.
15:09:28 <bnemec> jungleboyj: np
15:09:35 <kgiusti> heh
15:10:03 <dhellmann> ok, I've approved both of those patches
15:10:17 <bnemec> dhellmann: Great, thanks!
15:10:39 <bnemec> I think that's it for release-related stuff.
15:10:42 <dhellmann> jungleboyj : and here I thought that was some sort of slang
15:10:58 <bnemec> #topic Action items from last meeting
15:11:05 <dhellmann> bnemec : it would be good if we could get https://review.openstack.org/#/c/564627/ into an oslo.policy release this week
15:11:20 <bnemec> "Investigate why pika is in so many lower-constraints files"
15:11:30 <bnemec> dhellmann: Yeah, sorry I didn't get back to that Friday.
15:11:35 <bnemec> It's still on my list.
15:11:43 <dhellmann> np, mriedem added tests today so it was worth waiting
15:12:01 <bnemec> I think we actually resolved the pika question during the meeting.
15:12:12 <bnemec> dhellmann: Yeah, but this just reinforces my procrastination habit. :-)
15:12:37 <bnemec> "Send email about pip-check-reqs to gauge interest in keeping it"
15:12:49 <kgiusti> crickets
15:12:51 <bnemec> I haven't seen any responses to that yet, although I haven't gotten through my email yet this morning.
15:13:13 <dhellmann> it's easy to restore if we want it again later
15:13:25 <kgiusti> no response to either my message on -dev nor the upstream project on git.
15:13:30 <kgiusti> "He's dead, Jim"
15:13:42 <kgiusti> dhellmann: +1
15:13:58 <bnemec> Yeah
15:14:29 <bnemec> So do we want to rip out all those tox checks then?
15:14:44 <bnemec> Or just leave them since nobody is using them anyway?
15:15:07 <bnemec> Theoretically it would be possible to run them using an older version of pip.
15:15:24 <kgiusti> that's a fair point
15:16:22 <dhellmann> if we can make the tox configuration work, we should. otherwise, we should remove it.
15:16:38 <dhellmann> if someone wants to resurrect it, they can look at the git history and restore it then fix it
15:16:52 <dhellmann> but if we leave it there, it will always be a question of "does this work? should it? why is it here?"
15:17:00 <dhellmann> let's keep the tox file tidy
15:17:20 <kgiusti> even if we made it work with old pip, the tool is essentially abandoned
15:17:43 <dhellmann> yeah, so we are going to just have more things breaking it over time it sounds like
15:17:59 <bnemec> Okay, sounds like we want to remove it.  Any volunteers?
15:18:01 <dhellmann> the best way to find missing dependencies is to be strict about what we install in test jobs and have good test coverage
15:18:15 <kgiusti> +1 to pulling it from the tox files.   I'll take a crack at patching it
15:18:29 <bnemec> I think we're getting better at that now.  The test VMs have a lot less installed by default.
15:18:35 <dhellmann> yep
15:18:37 <kgiusti> for oslo projects that is
15:18:46 <dhellmann> kgiusti : is it used elsewhere?
15:19:06 <bnemec> #action kgiusti remove pip-check-reqs from tox.ini
15:19:40 <kgiusti> dhellmann: http://codesearch.openstack.org/?q=pip_check_reqs&i=nope&files=&repos=
15:19:45 <dhellmann> a few other projects do seem to use it
15:19:45 <dhellmann> yeah
15:19:46 <dhellmann> http://paste.openstack.org/show/720146/
15:20:23 <kgiusti> dhellmann: not much work - I'll take them all.
15:20:32 <dhellmann> sounds good, thanks
15:20:44 <bnemec> Oh good, we were inconsistent about how we named this: http://codesearch.openstack.org/?q=pip-missing-reqs&i=nope&files=&repos=
15:21:22 <kgiusti> ugh
15:21:28 <bnemec> Hmm, or is that a different project altogether?
15:21:34 <dhellmann> is pip_missing_reqs a different thing from pip_check_reqs?
15:22:31 <bnemec> No, it links to https://github.com/r1chardj0n3s/pip-check-reqs from pypi.
15:22:46 <dhellmann> there are 2 tools
15:22:53 <dhellmann> https://pypi.org/project/pip_check_reqs/#history
15:22:59 <dhellmann> https://pypi.org/project/pip_missing_reqs/#history
15:23:03 <dhellmann> yay
15:23:11 <dhellmann> uses of the other one: http://paste.openstack.org/show/720147/
15:23:39 <bnemec> "2.0 renamed package to pip_check_reqs"
15:23:52 <dhellmann> ah
15:23:59 <dhellmann> so we just have some that are really old
15:24:05 <dhellmann> combined uses: http://paste.openstack.org/show/720150/
15:24:14 <dhellmann> way more oslo libraries there
15:24:31 <bnemec> Yeah
15:25:02 <kgiusti> kk - I'll start with the oslo ones first.
15:25:03 <bnemec> Maybe we can start an etherpad to track which have been done.
15:25:15 <kgiusti> epad +1
15:25:19 <dhellmann> this would be a great use of storyboard, if we were migrated :-)
15:25:42 <dhellmann> but yeah, an etherpad works for now
15:26:02 <dhellmann> kgiusti : are you interested in us trying to recruit some help for authoring those?
15:26:27 <kgiusti> dhellmann: sure
15:26:41 <kgiusti> but to be honest it looks like a small job
15:26:58 <kgiusti> let's see what I can get done today
15:27:28 <dhellmann> ok. I'm interested in exploring ways to recruit some of the folks who regularly +1 lots of patches to help with tasks like this, so if you want we can brainstorm on that we can
15:28:07 <kgiusti> if you've got folks in mind I'm good with that
15:28:12 <bnemec> +1
15:28:23 <bnemec> Wait, did I just volunteer?
15:28:25 <bnemec> :-)
15:28:44 <dhellmann> names I've seen lately are melissaml and pippo but I don't know them other than by their gerrit user names
15:29:22 <kgiusti> I'll reach out to them.
15:29:43 <dhellmann> and nguyen hai responded to a bunch of the lower-constraints job patches, even taking over a few of them iirc
15:30:09 <kgiusti> dhellmann: I'll set up the epad and we can track who's doing what from there
15:30:09 <dhellmann> kgiusti : that would be great, thanks. and let me know how it goes
15:30:12 <dhellmann> ++
15:30:17 <kgiusti> will do
15:30:25 <dhellmann> I'll be ready to help with +2s
15:30:35 <bnemec> Likewise
15:30:36 <kgiusti> great!
15:31:00 <dhellmann> maybe if we have good turn-around on reviews from our end that will encourage folks to do more of these
15:31:14 <kgiusti> one could only hope!
15:31:33 <dhellmann> kgiusti : it would also be a good idea to follow up to that ML thread to let folks know the plan. that would also give us something to point to in commit messages for more details about why we're doing the cleanup
15:31:49 <kgiusti> good idea
15:31:59 <kgiusti> will do that today.
15:32:19 <dhellmann> we still have lots of people not reading the ML, but if we at least get into a habit of posting messages about these sorts of things there maybe we can train them to skim it
15:32:36 <dhellmann> the tc is also looking into other ways to highlight some of these sorts of threads, so if you have ideas about that let me know
15:32:37 <bnemec> #action kgiusti to do a recruiting drive
15:33:03 * bnemec is getting the hang of this delegation thing ;-)
15:33:12 <dhellmann> it's especially important for these multi-repo cleanup initiatives
15:33:21 * dhellmann gives bnemec a thumbs-up
15:33:36 <bnemec> Somebody else did a bunch of those last week for the tox_install.sh stuff.
15:33:42 <dhellmann> oh, nice
15:34:00 <bnemec> There were a bunch of these from Elod: https://review.openstack.org/#/c/564840/
15:34:44 <dhellmann> maybe include Elod in the recruiting for this one
15:35:24 <dhellmann> although having them work on stable branches might be a better use of their time
15:36:25 <bnemec> Oh, there are a few of those patches that haven't merged yet too.
15:36:47 <dhellmann> I approved 2 more
15:36:49 <bnemec> One is failing ci though.
15:36:59 <bnemec> Okay, that's probably all of them then.
15:37:06 <dhellmann> the taskflow one has an error
15:37:13 <dhellmann> https://review.openstack.org/564133
15:37:34 <dhellmann> that looks like all of the oslo ones
15:39:20 <bnemec> Okay, we can follow up on the taskflow one after the meeting.
15:39:21 <openstackgerrit> Erik Olof Gunnar Andersson proposed openstack/oslo.db master: Deprecate min_pool_size  https://review.openstack.org/565090
15:39:39 <bnemec> The last two action items from last time were:
15:39:40 <bnemec> bnemec to request room at Denver PTG
15:39:40 <bnemec> bnemec to start attending oslo.config drivers meeting
15:39:46 <bnemec> Both of those are done.
15:40:03 <bnemec> We should have a room in Denver and the driver meeting is on my calendar.
15:40:28 <bnemec> #topic oslo-config-migrator command (namnh)
15:40:42 <bnemec> I didn't get back to this one last week either. :-/
15:40:44 <dhellmann> it looks like raildo cancelled the oslo.config drivers meeting for tomorrow
15:40:54 <bnemec> Ah, good to know.
15:41:07 <dhellmann> yeah, I haven't had the time to review that work this cycle either :-(
15:41:27 <raildo> dhellmann, just because tomorrow will be a holiday in a bunch of places
15:41:43 <dhellmann> raildo : I figured that's what it was, but thanks for confirming
15:41:53 <raildo> #link https://en.wikipedia.org/wiki/Labor_Day
15:42:15 <raildo> dhellmann, sure, np, we will be back on it next week :)
15:42:19 <dhellmann> ++
15:43:28 <bnemec> Haven't seen namnh this meeting so I'm guessing this was just a review request.
15:43:52 * dhellmann wishes the US celebrated Labor Day on 1 May like most of the rest of the world
15:44:30 <namnh> hi ben and dhellman
15:45:01 <namnh> i am here, sorry, today is public holiday in my country
15:45:05 <namnh> :)
15:45:24 <bnemec> namnh: No problem.
15:45:51 <bnemec> I'm generally not available on public holidays so I don't expect anyone else to be. :-)
15:45:53 <dhellmann> wait, yes, that's a problem -- no working on holidays on this team!
15:46:00 <dhellmann> :-)
15:46:04 <namnh> i updated a new patch last week, and waiting your review
15:46:04 <bnemec> Good point
15:46:41 <bnemec> Yeah, I spent a lot of last week distracted by TripleO problems so I didn't get to everything.
15:47:38 <dhellmann> I apologize. Between TC tasks and preparing for the summit I'm not likely to have a lot of time over the next few weeks. :-/
15:47:38 <namnh> understood, when you are free, please help me to review the patch.
15:47:56 <bnemec> Ooh, right.  Summit is coming up.
15:48:11 <bnemec> I need to get together with gcb and come up with slides for the project update.
15:48:12 <dhellmann> 3 weeks, right?
15:48:20 <bnemec> Yeah
15:48:35 <namnh> dhellmann: no problem, i know all of you are so busy for now.
15:48:51 * jungleboyj Needs to start thinking about presentations.
15:49:02 <jungleboyj> First need to figure out which ones were accepted.  :-)
15:50:36 <bnemec> Okay, so we'll try to review as much as we can but this month is likely to be a bit slower due to Summit prep and Summit itself.
15:50:54 <bnemec> #topic oslo.service python 3 work
15:51:19 <kgiusti> fyi: pip-check-reqs epad:  https://etherpad.openstack.org/p/pip_(missing|check)_reqs
15:51:20 <bnemec> oslo.service has some issues in python 3, which is problematic since we need to start fully supporting it.
15:51:30 <bnemec> kgiusti: Thanks
15:51:37 <bnemec> #link https://etherpad.openstack.org/p/pip_(missing|check)_reqs
15:52:10 <bnemec> Should be interesting to see how that shows up in the meeting notes since my IRC client isn't linking it right.
15:53:15 <dhellmann> urlencoding ftw
15:53:36 <bnemec> Anyway, there are a bunch of tests being skipped on py3 in oslo.service because they don't work: https://github.com/openstack/oslo.service/blob/master/oslo_service/tests/test_wsgi.py#L282
15:53:53 <bnemec> It seems likely we need to resolve those soon.
15:54:32 <bnemec> It's been on my todo list since I found out we were skipping tests, but I haven't had a chance to dig into this either.
15:54:47 <bnemec> My fear is it will be a whole can of worms, but hopefully I'm wrong.
15:55:25 <dhellmann> wait, that's for our home-grown wsgi server?
15:55:41 <bnemec> Not sure
15:55:51 <dhellmann> it sure looks like it
15:55:57 <dhellmann> if that's the case, we should see if anyone is using it
15:56:10 <dhellmann> because we should have everyone using real wsgi servers by now, we had that as a goal a while back
15:56:18 <dhellmann> and so we could deprecate the whole thing and drop support
15:56:32 <bnemec> That would be nice.
15:56:39 <bnemec> The whole test file is full of conditional skips.
15:56:53 <dhellmann> we should look into who is using the thing being tested
15:57:23 <bnemec> Okay, that's probably our first step then.
15:57:32 <bnemec> #action investigate if anyone is using oslo.service wsgi module
15:58:19 <dhellmann> the bug was filed against manila & neutron originally
15:58:21 <bnemec> I'm not sure if there was anything else blocking the py3 tests from voting in that repo.
15:58:31 <dhellmann> in 2015, so wow
15:59:14 <dhellmann> #link https://bugs.launchpad.net/manila/+bug/1482633
15:59:16 <openstack> Launchpad bug 1482633 in oslo.service "requests to SSL wrapped sockets hang while reading using py3" [High,Triaged]
16:00:22 <bnemec> Yeah, it would be good to finally put this one to bed.
16:00:28 * dhellmann has to drop offline to make a lunch appointment
16:00:45 <bnemec> Yeah, I guess that's it for our meeting time.
16:00:52 <bnemec> Thanks for joining everyone!
16:00:57 <bnemec> #endmeeting