15:00:18 <bnemec> #startmeeting oslo
15:00:20 <openstack> Meeting started Mon Apr 23 15:00:18 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:24 <openstack> The meeting name has been set to 'oslo'
15:00:27 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:00:27 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:00:27 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:00:27 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stephenfin, stevemar, therve
15:00:27 <bnemec> courtesy ping for thinrichs, toabctl, zhiyan, zxy, zzzeek
15:00:40 <gcb> o/
15:00:42 <e0ne> hi
15:00:43 <namnh> o/
15:00:49 <kgiusti> hi!
15:00:55 <ansmith> o/
15:01:02 <stephenfin> o/
15:01:20 <jungleboyj> o/
15:02:09 <bnemec> #topic Red flags for/from liaisons
15:02:24 <jungleboyj> Nothing from Cinder.
15:03:37 <bnemec> I can't think of anything we've done that should cause anyone grief, so we can probably move on then.
15:03:47 <bnemec> #topic Releases for Rocky
15:04:10 <bnemec> The usual set last week.  Expect a bunch more this week for the eventlet uncapping changes.
15:04:52 <bnemec> I also need to go through the stable branches and release those.  I'm pretty sure there are some changes piled up on them.
15:05:11 <bnemec> #topic Action items from last meeting
15:05:24 <bnemec> "finish merging eventlet uncapping patches"
15:05:29 <bnemec> I believe that's done.
15:05:43 <bnemec> I didn't see any more oslo projects in the topic.
15:05:49 <bnemec> https://review.openstack.org/#/q/status:open++topic:uncap-eventlet
15:05:58 <bnemec> "Oslo cores to single approve python 3 tox changes"
15:06:23 <bnemec> Also done.  I +1'd the project-config patch Friday to switch all of our repos over to run gate jobs using python 3.
15:06:33 <bnemec> I didn't notice if it merged yet, but expect that to be coming soon.
15:06:55 <bnemec> "fix up any python 3 tox changes that need additional work"
15:07:02 <bnemec> Must have been done since we merged all the things. :-)
15:07:09 <bnemec> "bnemec to check on missing onboarding session"
15:07:18 <bnemec> Done: https://www.openstack.org/summit/vancouver-2018/summit-schedule/events/21645/oslo-project-onboarding
15:07:32 <bnemec> Apparently there was a problem on the backend that caused it to get lost.
15:07:52 <bnemec> But it's back now so we should be good to go.
15:08:05 <bnemec> "kgiusti to look into pip-check-reqs with pip 10"
15:08:17 <kgiusti> https://github.com/r1chardj0n3s/pip-check-reqs/issues/17
15:08:37 <kgiusti> Looks to me that this project may be pushing up the daisies
15:09:08 <kgiusti> If that's indeed the case, what should we do going forward?
15:09:14 <bnemec> Hmm, yeah.
15:09:27 <kgiusti> drop the test, or fork and fix (and own) :(
15:09:54 <bnemec> I guess it depends on how much we value the ability to automatically check for missing reqs.
15:09:55 <kgiusti> I did not look for a supported alternative
15:10:46 <kgiusti> I would imagine if folks found it valuable there'd be an effort (or an alternative)?
15:11:04 <kgiusti> seems like a pretty nice tool to have IMHO
15:11:34 <stephenfin> kgiusti: I'm guessing the alternative is pipfiles
15:11:53 <stephenfin> (side note: morded's recent comments on same on openstack-dev are worth a read)
15:12:22 <kgiusti> stephenfin: ah - didn't see that...
15:13:07 <stephenfin> tbh, I don't think anyone is really using it. Only today I saw a patch adding pika to a project because oslo.db (I think?) dropped it
15:13:18 <bnemec> Does that have functionality for checking missing requirements?
15:13:44 <bnemec> oslo.messaging dropped pika because we didn't think anyone was using it. :-/
15:14:12 <stephenfin> bnemec: It works somewhat differently. You've got the handwritten Pipfile to track what you think are your dependencies (usually versioned in a range or unversioned)
15:14:28 <kgiusti> fyi: http://lists.openstack.org/pipermail/openstack-dev/2018-April/129187.html
15:14:28 <stephenfin> then a Pipfile.lock file which has _all_ the dependencies + specific versions
15:14:51 <stephenfin> aye, mordred really details it well in that post
15:15:02 <bnemec> Yeah, I've seen the thread, but I have to admit I haven't gotten all the way through it.
15:15:18 <stephenfin> I guess it doesn't solve the problem but it would mitigate it, assuming you're using Pipfile.lock
15:15:27 <bnemec> It's kind of above my pay grade as far as requirements management goes. :-)
15:15:42 <stephenfin> and I only care because of pbr :)
15:16:18 <dhellmann> pipfiles solve a different problem than this
15:16:25 <dhellmann> they solve the problem we've solved by using a constraints list
15:16:35 <dhellmann> the problem we have is that we depend on things that we don't realize
15:16:40 <dhellmann> pika is a great example
15:16:58 <dhellmann> why is anyone using pika if oslo.messaging's driver is no longer supported?
15:17:04 <dhellmann> are they using it directly?
15:17:20 <bnemec> That's a good question
15:17:23 <dhellmann> or are they using it indirectly via another project (taskflow?) that doesn't have the dependency listed?
15:18:05 <dhellmann> or that *does* have it listed but uses an extras entry and they don't know how to use that?
15:18:08 <stephenfin> dhellmann: I'm not sure. It was a random networking project
15:18:29 <dhellmann> pika appears in the lower constraints for *tons* of projects
15:18:30 <stephenfin> I only saw it because I was reviewing a sphinxcontrib-apidoc patch
15:18:40 <dhellmann> http://paste.openstack.org/show/719753
15:19:08 <kgiusti> dhellmann: http://codesearch.openstack.org/?q=pika%3A%2F%2F&i=nope&files=&repos=
15:19:29 <kgiusti> leads me to believe these pika deps are not oslo.messaging related
15:19:51 <kgiusti> since there's no obvious use of the pika:// o.m. transport driver
15:20:24 <bnemec> Or they didn't document it
15:20:43 <dhellmann> I see it in a bunch of charm files; I wonder if charms are configuring oslo.messaging to use it?
15:20:47 <dhellmann> http://codesearch.openstack.org/?q=pika&i=nope&files=requirements.txt&repos=
15:21:15 <dhellmann> networking-cisco seems to use it directly
15:21:18 <dhellmann> http://codesearch.openstack.org/?q=pika&i=nope&files=.*%5C.py&repos=
15:21:51 <stephenfin> dhellmann: Ha, that was the one I reviewed :)
15:21:55 <dhellmann> anyway, I didn't mean to side-track things
15:21:55 <stephenfin> https://review.openstack.org/557307
15:22:08 <stephenfin> yeah, likewise
15:22:12 <kgiusti> that's a possibility, but we've never seen activity on the pika driver in terms of dev, bugs, etc beyond the devs IIRC
15:22:39 <bnemec> Ah, good, so they're not using the o.m driver at least.
15:22:52 <bnemec> It looks like charms are using pika directly too.
15:23:12 <bnemec> http://git.openstack.org/cgit/openstack/charm-ceilometer/tree/charmhelpers/contrib/openstack/amulet/utils.py
15:23:13 <dhellmann> so maybe the charms use it because that's how juju works? I don't know
15:23:42 <bnemec> "Establish and return a pika amqp connection to the rabbitmq service running on a rmq juju unit."
15:23:45 <bnemec> Sounds like it.
15:24:00 <kgiusti> yep
15:24:29 <dhellmann> I wonder why so many projects have it in their lower-constraints.txt list now, but that may be because they're using an older version of oslo.messaging that still has it as a dependency
15:25:29 <bnemec> It's possible.  Maybe we stopped syncing requirements before we removed pika from o.m.
15:26:22 <dhellmann> well, those lower-bounds can be pretty low in some cases
15:27:09 <bnemec> It looks like quite a few of them only have it in their test-requirements too.
15:27:49 <kgiusti> looks like no one hardcoded pika as an oslo.messaging transport, but perhaps the deps are there to allow deployers to configure pika via transport_url cfg item?
15:28:40 <bnemec> Oh, actually all of the test-requirements are also charms.
15:29:00 <kgiusti> if that's the case, they'd need to modify the config to use rabbit in transport_url instead - as described in the release notes.
15:29:46 <kgiusti> Assuming they've been ignoring the big scary log message telling them to use rabbit for the last two releases....
15:29:49 <bnemec> Okay, well maybe we need to pick this up after the meeting.
15:29:57 <kgiusti> +1
15:30:10 <bnemec> #action Investigate why pika is in so many lower-constraints files
15:30:29 <kgiusti> Have we settled the missing req issue :) ?
15:30:55 <kgiusti> should we at least remove the test from tox.ini?
15:31:12 <bnemec> I'm kind of inclined to leave it be for the moment and see if anyone complains or provides a fix PR.
15:31:26 <bnemec> Technically the issue has only been open a week.
15:31:30 <kgiusti> ok, let's do that then.
15:31:42 <stephenfin> I'd kill it as it seems like cruft. However, I'm happy to be overruled :)
15:31:46 <bnemec> Although given that Richard seems to have kind of disappeared for the past couple of years I don't feel great about the chances of it getting fixed.
15:32:51 <bnemec> I guess I don't feel strongly about it.  Maybe start an ML thread and see if anyone cares enough about it to own it?
15:32:55 <bnemec> If not, remove.
15:35:28 <dhellmann> here's the source of those lower-constraints entries: "Collecting pika-pool>=0.1.3 (from oslo.messaging==5.36.0)"
15:35:38 <bnemec> #action Send email about pip-check-reqs to gauge interest in keeping it
15:35:42 <dhellmann> so those are OK
15:36:31 <bnemec> Cool
15:37:15 <bnemec> #topic PTG attendance
15:37:32 <bnemec> The Foundation wants to know if we need a room at the PTG in Denver.
15:37:57 <bnemec> I realize it's pretty early, but I assume enough of us will be there that I should request one?
15:38:19 <kgiusti> Denver?  I thought it was Berlin....
15:38:32 <bnemec> That's the Forum.
15:38:41 <kgiusti> ack - thanks
15:39:05 <jungleboyj> I have registered the Cinder team.  I am assuming we will have enough people again.
15:39:38 <bnemec> Huh, I can't find the email that announced it.
15:39:42 <dhellmann> I'll definitely be in Denver in september
15:39:45 <dhellmann> week of the 10th I think
15:39:58 <bnemec> Oh, they spelled out PTG: http://lists.openstack.org/pipermail/openstack-dev/2018-April/129564.html
15:40:13 <bnemec> Yeah, the 10th-14th.
15:40:25 <dhellmann> yeah, we're also likely to see that rebranded since we'll have some operator sessions going on that week, too
15:40:53 <bnemec> Note the early deadline for cheap-ish tickets too.
15:41:09 <bnemec> After May 11 it costs twice as much.
15:41:22 <dhellmann> register early and often
15:41:24 <bnemec> Even the early bird rate is double what it used to be.
15:41:34 <dhellmann> yes, that's part of making the event more sustainable
15:41:45 <dhellmann> still a work-in-progress
15:41:59 <bnemec> Yeah, I can't imagine how $100 covered everything.
15:42:03 <bnemec> Obviously it didn't. :-)
15:42:10 <dhellmann> it didn't, that sort of the point :-)
15:42:11 <dhellmann> yeah
15:42:39 <bnemec> Okay, I'll ask for a room.  I _assume_ I'll be there too, although I almost didn't go to the last Denver PTG so who knows?
15:42:59 <bnemec> Which is funny because it's geographically the closest to me.
15:43:10 <bnemec> #action bnemec to request room at Denver PTG
15:43:17 <dhellmann> I'm sure we can find things for bnemec to do to make it worth the trip
15:44:23 <bnemec> Sounds good
15:44:25 <bnemec> #topic oslo.config driver update
15:44:47 <bnemec> I have forgotten when this meeting is held, but I was wondering what the status on the pluggable drivers is.
15:45:12 <bnemec> I looked at the existing patches a bit last week but they looked pretty preliminary so far.
15:45:12 <dhellmann> it's on tuesdays at the same time as this meeting
15:45:22 <dhellmann> the work done so far is quite early, yes
15:45:42 <bnemec> I just wanted to follow up because I know we wanted to try to get that in as early in the cycle as possible.
15:45:46 <dhellmann> we have a new contributor joining that little team, and I'm hoping for more significant contributions soon
15:45:54 <dhellmann> yes, progress has been slow
15:46:22 <bnemec> I obviously haven't been very engaged with it myself. :-/
15:46:33 <dhellmann> https://review.openstack.org/562746 is the start of a driver
15:47:35 <bnemec> I feel like maybe that's something we would want to try to merge by R-2?  Is that reasonable and/or possible?
15:47:51 <dhellmann> it is a reasonable request (the original goal was r-1)
15:48:13 <dhellmann> I'm hesitant to say whether it's likely, since I'm not doing the work myself
15:48:35 <bnemec> Maybe I should just join the meeting tomorrow.
15:48:46 <dhellmann> that would be good
15:48:53 <bnemec> Probably not going to nail anything down without everyone present anyway.
15:48:59 <dhellmann> right
15:49:10 <bnemec> #action bnemec to start attending oslo.config drivers meeting
15:49:43 <bnemec> dhellmann: Okay, thanks for the update.
15:49:53 <bnemec> #topic Open discussion
15:50:21 <bnemec> That was it for the agenda.  Anything else in the last 10 minutes?
15:50:23 <dhellmann> I could use another review on https://review.openstack.org/557516
15:50:38 <dhellmann> it's not pressing, but it would be nice to clear it off the board
15:50:50 <dhellmann> this one, too: https://review.openstack.org/562724
15:51:59 <bnemec> That one was previously approved, so we could probably just go ahead with it.
15:51:59 <namnh> bnemec: Hi Ben
15:52:06 <bnemec> namnh: Hi
15:52:11 <namnh> bnemec: All of your comments was solved, and the output was chageds as your expectation [1], could you take a look the patch again [1] https://review.openstack.org/#/c/526314/
15:53:14 <bnemec> namnh: Okay, will try to take another look this week.
15:53:41 <namnh> bnemec: cool, thanks
15:55:10 <bnemec> Anything else?
15:55:34 <dhellmann> that's it from me
15:55:46 <jungleboyj> Nothing from me.  :-)
15:56:05 <bnemec> Okay, thanks for joining everyone.
15:56:06 <bnemec> #endmeeting