15:01:31 <bnemec> #startmeeting oslo
15:01:31 <openstack> Meeting started Mon Apr  9 15:01:31 2018 UTC and is due to finish in 60 minutes.  The chair is bnemec. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:34 <openstack> The meeting name has been set to 'oslo'
15:01:41 <bnemec> courtesy ping for amotoki, amrith, ansmith, bnemec, dansmith, dhellmann, dims
15:01:41 <bnemec> courtesy ping for dougwig, e0ne, electrocucaracha, flaper87, garyk, gcb, haypo
15:01:42 <bnemec> courtesy ping for jd__, johnsom, jungleboyj, kgiusti, kragniz, lhx_, raildo
15:01:42 <bnemec> courtesy ping for redrobot, sileht, spamaps, sreshetnyak, stevemar, therve, thinrichs
15:01:42 <bnemec> courtesy ping for toabctl, zhiyan, zxy, zzzeek
15:02:06 <jungleboyj> o/
15:02:19 <ansmith> o/
15:02:31 <namnh> o/
15:03:22 <kgiusti> o/
15:04:08 <bnemec> #topic Red flags for/from liaisons
15:04:28 <bnemec> Nothing is coming to mind immediately for me.
15:04:37 <jungleboyj> Nothing that I am aware of from Cinder but I have been a little out of touch the last week.
15:04:46 <bnemec> We did some major releases last week, but I haven't heard of any trouble with them.
15:05:37 <jungleboyj> \o/
15:06:32 <bnemec> #topic Releases for Rocky
15:06:53 <bnemec> Last week was a little quieter.  Mostly just bugfix releases.
15:07:05 <bnemec> So when I say we did major releases I actually mean we got major releases into u-c.
15:07:41 <bnemec> Planning to do the regular set of releases again this week.
15:08:04 <kgiusti> bnemec: hey just fyi - this landed in o.m since last week  https://review.openstack.org/#/c/557591/
15:08:46 <kgiusti> bnemec: assuming this will be released this week, right?
15:08:58 <bnemec> kgiusti: That's the plan.
15:09:10 <kgiusti> bnemec: thanks
15:10:19 <bnemec> #topic Action items from last meeting
15:10:55 <bnemec> The only one we had was reviewing https://review.openstack.org/#/c/520043
15:11:15 <bnemec> Which I did, so I'm calling that one completed. :-)
15:11:37 <bnemec> We will eventually need other reviews on that spec, but I think we're getting close.
15:12:05 <dhellmann> bnemec : do you have the agenda link handy?
15:12:16 <bnemec> dhellmann: https://wiki.openstack.org/wiki/Meetings/Oslo
15:12:20 <dhellmann> thank you
15:12:27 <bnemec> np
15:12:50 <bnemec> #topic Configuration change handling over releases (namnh) https://review.openstack.org/#/c/520043 and https://review.openstack.org/#/c/526314
15:13:05 <namnh> bnemec, dhellmann: here is the patch set for testing: https://review.openstack.org/#/c/549672/
15:14:04 <namnh> bnemec: i appended this item several weeks ago, so do i need to remove this one for next weekly meeting
15:14:26 <bnemec> namnh: Yeah, I can do that too.  I've mostly been leaving it as a reminder to myself to review it. :-)
15:14:43 <namnh> bnemec: :))
15:14:50 <bnemec> I suppose I shouldn't use the meeting agenda as my personal review list though. ;-)
15:14:55 <dhellmann> I had some personal stuff come up last week so I wasn't able to review it either. It's still on my list.
15:15:19 <bnemec> dhellmann: Sounds good, thanks
15:15:35 <bnemec> #topic Move pep8 to python3 - http://lists.openstack.org/pipermail/openstack-dev/2018-April/129025.html
15:15:54 <bnemec> There was some discussion on the list last week about running pep8 in python 3.
15:16:13 <bnemec> Seems like the consensus was that we should switch to doing that since it's more strict.
15:16:43 <bnemec> It'll probably be a fair bit of work in Oslo since we have so many projects to switch, and there may be fixes needed.
15:17:07 <bnemec> Any objections to doing that?
15:18:13 <dhellmann> we should go ahead and do it
15:18:27 <kgiusti> agreed
15:18:33 <dhellmann> when I finish the lower-constraints work I'm going to start pushing for all projects to update the docs and pep8 builds to py3
15:18:58 <bnemec> #action Switch Oslo pep8 test jobs to python 3
15:19:03 <bnemec> Sounds good
15:19:49 <bnemec> #topic Split oslo.messaging requirements into extra
15:20:00 * bnemec looks for the link
15:20:08 <kgiusti> https://review.openstack.org/#/c/525319/6
15:20:17 <bnemec> Thanks
15:20:46 <kgiusti> np - this latest patch will always install the rabbit deps,
15:20:54 <bnemec> We're looking to make use of the extra requirements functionality for oslo.messaging so everyone doesn't have to install all the deps for everything.
15:21:06 <bnemec> Apparently this is particularly useful for kafka, which pulls in a lot of other stuff.
15:21:40 <bnemec> The one issue we've run into is that removing anything from the default deps list could break existing users unless they update their requirements to list the correct extra.
15:22:02 <bnemec> As kgiusti notes, the current approach is just to leave the rabbit deps in the main list.
15:22:15 <bnemec> zmq is also removed, but since we think that's broken anyway it's not as much of a concern.
15:22:56 <bnemec> I _think_ that should work, but I was wondering if anyone had any alternate strategies for this.
15:23:16 <bnemec> It would be nice to get to a place where non-rabbit users could avoid installing kombu and friends.
15:23:55 <bnemec> We don't really have a deprecation method for requirements changes though. :-/
15:24:09 <kgiusti> luckily rabbitmq's deps are pretty lightweight (when compared to the other drivers)
15:26:34 <kgiusti> ansmith: I'd esp. like you're input - you've done lots with triple-o and other deployment tooling
15:27:22 <bnemec> TripleO is largely unimpacted by this since they install from RPM.
15:28:04 <bnemec> Their requirements are mostly tracked in spec files, which are based on requirements.txt but don't track it exactly.
15:29:47 <bnemec> I think the current approach is low-risk and gets us most of the benefits of optional deps, so maybe we just leave this as an open question and deal with it if/when it becomes a problem.
15:30:41 <kgiusti> I'm good with that.
15:30:49 <bnemec> #action Split all optional oslo.messaging requirements except rabbit into extras
15:30:58 <bnemec> It's an action item now so we have to do it. ;-)
15:31:21 <bnemec> I'll take another look at https://review.openstack.org/#/c/525319/ but I think it's probably good to go now.
15:31:34 <kgiusti> thanks
15:32:11 <bnemec> #topic oslo.service uncapping eventlet
15:32:44 <bnemec> The requirements team is looking to uncap eventlet, but apparently there are some issues in oslo.service preventing that.
15:33:08 <bnemec> I haven't had a chance to dig into this yet so I don't have a lot more detail.
15:33:16 <bnemec> There's an openstack-dev thread on it.
15:33:35 <bnemec> #link http://lists.openstack.org/pipermail/openstack-dev/2018-April/129096.html
15:34:21 <bnemec> It sounds like we need some changes in oslo.service to allow it.
15:36:41 <bnemec> Anyway, help is welcome on that front too.
15:37:03 <bnemec> Will probably have to revisit this next week when hopefully more progress has been made.
15:37:21 <bnemec> #topic Open discussion
15:37:29 <bnemec> That was it for the agenda.  Anything else?
15:40:20 <bnemec> Okay, that's it for this week then.
15:40:25 <bnemec> Thanks for joining everyone.
15:40:27 <bnemec> #endmeeting