16:00:13 <harlowja_at_home> #startmeeting oslo
16:00:14 <openstack> Meeting started Mon Apr 20 16:00:13 2015 UTC and is due to finish in 60 minutes.  The chair is harlowja_at_home. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <openstack> The meeting name has been set to 'oslo'
16:00:19 <bknudson> hi
16:00:21 <jecarey> o/
16:00:23 <harlowja_at_home> courtesy ping for jd__, dims, bnemec, flaper87, dhellmann, viktors, rpodolyaka, zzzeek, sileht, kgiusti, dansmith
16:00:26 <ihrachyshka> o/
16:00:28 <harlowja_at_home> courtesy ping for redrobot, jungleboyj, zhiyan, therve, amotoki, GheRivero, bknudson, ihrachyshka, jogo, dougwig, sreshetnyak, amrith
16:00:31 <harlowja_at_home> yo yo yo
16:00:37 <amrith> ./
16:00:38 <bnemec> o/
16:00:41 <kgiusti> o/
16:00:56 <harlowja_at_home> i'm your pilot for today, the other copilots are on vacation or something
16:00:57 <dansmith> Oj
16:01:04 <sileht> o/
16:01:14 <jungleboyj> o?
16:01:17 <jungleboyj> o/
16:01:27 <harlowja_at_home> #link https://wiki.openstack.org/wiki/Meetings/Oslo
16:01:27 <ihrachyshka> harlowja_at_home, single pilot... scary
16:01:36 <harlowja_at_home> ihrachyshka, if i hit a mountain, sorry
16:01:42 <ihrachyshka> lol
16:01:56 <harlowja_at_home> the exits are forward, and they may be behind u, so check for your local exit
16:02:22 <harlowja_at_home> alright let's see here
16:02:31 <amrith> place a mask over your mouth and nose befor helping others.
16:02:35 <harlowja_at_home> :)
16:02:59 <harlowja_at_home> #topic Review action items from previous meeting
16:03:09 <harlowja_at_home> #link http://eavesdrop.openstack.org/meetings/oslo/2015/oslo.2015-04-13-16.00.txt
16:03:21 <harlowja_at_home> who's been naughty and who's been nice, let's see
16:03:40 <harlowja_at_home> looks like most of the action items go to dhellmann who's not even around
16:04:03 <ihrachyshka> harlowja_at_home, you should be our all-time chairman. a good laugh won't hurt on Monday.
16:04:03 <bknudson> did you bring your baton to canada?
16:04:16 <harlowja_at_home> bknudson, i got it ready to go
16:04:23 <harlowja_at_home> but i didn't get to canada last week
16:04:25 <harlowja_at_home> maybe this week :-/
16:04:47 <harlowja_at_home> ihrachyshka,  thx, the pilot joke was all original harlowja_at_home material :)
16:05:08 <harlowja_at_home> bknudson, if i start walking from CA -> canada i might make it this week right?
16:05:24 <harlowja_at_home> *california
16:06:00 <ihrachyshka> harlowja_at_home, no way, there is a border where you'll spend a week
16:06:15 <harlowja_at_home> hmmm, guess i'm screwed then
16:06:48 <harlowja_at_home> release oslo.db master (and  oslo.policy stable/kilo ) for dhellmann  i think happened though, anyone know about that one?
16:06:59 <harlowja_at_home> pretty sure copilot dhellmann did that
16:07:08 <bknudson> google maps says 13 days to walk from san francisco.
16:07:19 <harlowja_at_home> bknudson, crap
16:07:46 <harlowja_at_home> #action harlowja_at_home bring baton to canada via smuggling donkeys
16:07:49 <jd__> o/
16:07:59 <harlowja_at_home> jd__, sup
16:08:12 <harlowja_at_home> there smuggling donkeys will get it there in time for the summit
16:08:15 <jd__> wesh gro
16:08:53 <harlowja_at_home> something like https://tinyurl.com/mzldn85 should do it
16:09:26 <harlowja_at_home> ok next topic! since i guess those action item(s) are hard to discern at the curren time
16:09:42 <jungleboyj> Wow, that just happened.
16:10:05 <harlowja_at_home> :)
16:10:22 <ihrachyshka> red flags?
16:10:25 <harlowja_at_home> #topic Red flags for/from liaisons
16:10:27 <harlowja_at_home> yup
16:10:35 <ihrachyshka> comrades, I have a huge red oslo.policy flag, so let's start the revolution: http://lists.openstack.org/pipermail/openstack-dev/2015-April/061783.html
16:10:46 <ihrachyshka> I need moar public api
16:10:51 <bknudson> none for keystone... stable/ branches are broken so I don't know how it's been working for oslo.
16:10:52 <ihrachyshka> I -> neutron
16:11:03 <harlowja_at_home> hmmm, reading (gives few seconds for others to look at)
16:11:12 <ihrachyshka> that's a long read
16:11:27 <jungleboyj> No red flags from Cinder.
16:11:38 <bknudson> anyone can propose changes to oslo.policy.
16:11:45 <harlowja_at_home> ihrachyshka, agreed, so whats the general gist of that email :)
16:11:53 <ihrachyshka> but basically, neutron made a mistake in adding a coll new feature to its policy machinery, and now we need some symbols from oslo.policy to continue providing the feature
16:11:55 * harlowja_at_home didn't expect such a long read (wholly moley)
16:12:02 <ihrachyshka> *cool
16:12:10 <bknudson> cool features can go right into oslo.policy
16:12:14 <ihrachyshka> like AndCheck, RoleCheck, RuleCheck
16:12:22 <ihrachyshka> nah, the feature cannot
16:12:28 <bknudson> then everyone can use them.
16:12:34 <ihrachyshka> since it's not in line with oslo.policy design, and would break other consumers
16:12:48 <harlowja_at_home> what was the original reason for hiding them (if anyone knows?)
16:12:49 <ihrachyshka> and why is also covered by that email
16:13:12 <ihrachyshka> stevemar,
16:13:13 <bknudson> it's easier to make things public than to go from public -> private.
16:13:38 <harlowja_at_home> fair enough, so seems like something that can be tweaked pretty easily i would assume
16:13:39 <morganfainberg> bknudson, ++
16:13:48 <ihrachyshka> bknudson, right, but neutron was ok with doing feature work in oslo.policy, and we originally thought it will just take time but is doable. now we don't
16:14:15 <ihrachyshka> harlowja_at_home, if oslo.policy team is ok with making stuff public, then yes, a matter of several lines + unit tests
16:14:39 <ihrachyshka> if not, neutron is in bad position to implement its own policy machinery in parallel to what oslo.policy provides
16:14:50 <bknudson> I don't think there's any reason it needs to be kept private... I think it was just made private initially since it's easier to make public.
16:14:59 <ihrachyshka> from neutron side, it's obvious what we would choose, but oslo team can have its valid reasons not to be kind
16:15:04 <stevemar> bknudson, yep, that was why
16:15:05 <harlowja_at_home> i'd hope we can avoid the recreation of things ihrachyshka if we can :)
16:15:07 <morganfainberg> ihrachyshka, how much is your policy machinery used? what cases does it solve that oslo.policy doesn't provide?
16:15:15 <ihrachyshka> bknudson, we asked to make those public before, and was rejected
16:15:25 <morganfainberg> if it is a generic case maybe it *should* be moved into oslo.policy now.
16:15:29 <bknudson> ihrachyshka: do you have a note that says it can't be public?
16:15:38 <bknudson> or a review?
16:15:41 <morganfainberg> bknudson, it was on the review to make them public
16:15:51 <morganfainberg> i remember the "we shouldn't make it public" coment
16:16:04 <ihrachyshka> morganfainberg, have you read the email? I think there are some answers (compatibility concern), but maybe they are not valid, some comments are appreciated
16:16:07 <bknudson> https://review.openstack.org/#/c/163163/
16:16:20 <morganfainberg> ihrachyshka, which email. recent or older one?
16:16:25 <bknudson> I -1d it since I didn't think the documentation was adequate.
16:16:27 <morganfainberg> ihrachyshka, have a ton of emails to sift through.
16:16:47 <ihrachyshka> bknudson, that was discussed around https://review.openstack.org/#/c/159525/
16:16:50 <ihrachyshka> see prev patchsets
16:17:04 <ihrachyshka> morganfainberg, http://lists.openstack.org/pipermail/openstack-dev/2015-April/061783.html
16:17:24 <ihrachyshka> I know that's a huge one to choke, sorry guys, I owe you my life
16:17:39 <morganfainberg> hold on i need to reboot my router...
16:17:43 <bknudson> it was dhellmann who said he thought it didn't need a change...
16:17:53 <morganfainberg> be back in a few. 1000-2000ms ping is making the internet unusable
16:17:56 <bknudson> "Registering options at runtime should work fine. Did you try that and see a failure? Maybe something else is wrong?" -- and no answer
16:18:16 <harlowja_at_home> so maybe dhellmann (when he gets back) should get poked with stick about that one?
16:18:32 <ihrachyshka> bknudson, register probably works, not sure the patch is relevant here
16:18:50 <harlowja_at_home> *not literally a stick
16:18:52 <ihrachyshka> harlowja_at_home, that's possible. I guess I won't be there to poke though since I leave to vac too next week
16:19:11 <ihrachyshka> harlowja_at_home, a stick and a kind word is always better than a kind word only!
16:19:17 <harlowja_at_home> #action harlowja_at_home poke dhellmann with stick about https://review.openstack.org/#/c/163163/
16:19:24 <harlowja_at_home> i poke him if i can remember :)
16:19:28 <ihrachyshka> thanks man
16:19:40 <harlowja_at_home> ihrachyshka, that sounds like a wise word/saying, i agree, lol
16:19:48 <bknudson> https://review.openstack.org/#/c/163163/ doesn't seem relevant to the discussion...
16:19:50 <ihrachyshka> I know that's something requiring time to digest, so let's give people time to read it and move forward :)
16:19:56 <bknudson> was there another review I was supposed to be looking at?
16:20:20 <ihrachyshka> bknudson, check https://review.openstack.org/#/c/159525/
16:20:37 <ihrachyshka> there are comments from Ian asking not to publicize those symbols
16:21:08 <stevemar> we could try registering new options at run time, and if that fails we could publicize them
16:21:11 <bknudson> but it's merged.
16:21:27 <bknudson> so I don't think this is about registering options, but new special checks.
16:21:46 <ihrachyshka> bknudson, it's merged in without those symbols originally asked to become public. so those now public are still not enough
16:21:54 <ihrachyshka> see first patchsets before Ian's comment
16:21:56 <bknudson> https://review.openstack.org/#/c/159525/ is already merged.
16:21:57 <harlowja_at_home> so it seems like we just need to have some kind of agreement on public/not for those, maybe something that can be shout out on the ML? maybe in response to http://lists.openstack.org/pipermail/openstack-dev/2015-April/061783.html ?
16:22:27 <ihrachyshka> harlowja_at_home, no need to shout, just use _ convention (as oslo.policy already does)
16:22:29 <bknudson> I think a review is required that shows what changes are needed.
16:22:43 <harlowja_at_home> seems fair
16:22:46 <ihrachyshka> bknudson, ok, I will post one tomorrow
16:22:51 <bknudson> thanks!
16:23:26 <harlowja_at_home> #topic Releases for this week
16:23:47 <harlowja_at_home> so this one i'll just touch on, sdague are u around, u might have more context about what should or shouldn't be releasing (if anything)
16:23:47 <bknudson> I'm not a fan of projects registering their own special checks since it makes using policy more difficult than it should be.
16:24:26 <harlowja_at_home> #link https://etherpad.openstack.org/p/the-big-thaw is something i saw recently
16:24:51 <harlowja_at_home> but i'm not sure how / if any oslo libraries are so much affected by that
16:25:25 <harlowja_at_home> anyone planning any releases might just want to consult with the powers that be ( sdague ) and others just to make sure
16:25:56 <sdague> harlowja_at_home: they are impacted, we need new releases of all of them with updated requirements :)
16:26:20 <harlowja_at_home> well thats an impact for sure then :)
16:26:56 <harlowja_at_home> sdague,  is that just for stable releases ?
16:28:06 <sdague> harlowja_at_home: no, master
16:28:13 <harlowja_at_home> k
16:28:31 <harlowja_at_home> guess we'll learn about this as it progresses, so just something to be aware of folks :)
16:28:51 <sdague> dhellmann is aware of what's needed, but I don't think ttx and I realized he would be out today
16:29:03 <harlowja_at_home> sdague,  np
16:29:54 <harlowja_at_home> dims is out also ( not on the same vacation as dhellmann afaik) but hopefully they can help soon
16:30:08 <harlowja_at_home> * if they are on the same vacation thats cool to, lol
16:30:46 <harlowja_at_home> #topic Ongoing work & Review priorities
16:31:24 <harlowja_at_home> so anyone need any special review attention (besides the ones already mentioned?)
16:32:08 <harlowja_at_home> also make sure to checkout https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z
16:32:20 <harlowja_at_home> so that people can talk about them at the summit
16:32:22 <harlowja_at_home> #link https://review.openstack.org/#/q/status:open+project:openstack/oslo-specs,n,z
16:32:42 <harlowja_at_home> *summit not that far away actually (woah)
16:34:21 <harlowja_at_home> thought on https://review.openstack.org/#/c/142659/ would be interseting, since I know alot of projects use/depend on that
16:35:27 <harlowja_at_home> alright, going once one any other reviews :)
16:35:44 <harlowja_at_home> twiceeeeee
16:36:03 <harlowja_at_home> sold to jd__ who now has to review everyones code
16:36:17 <harlowja_at_home> congrats jd__ u are the winner
16:36:22 <harlowja_at_home> #topic Open discussion
16:36:48 <harlowja_at_home> anything else for people to discuss (or we can get 20 minutes of fun time back)
16:37:58 <jungleboyj> *crickets*
16:38:01 <harlowja_at_home> lol
16:38:06 <harlowja_at_home> the crickets want to talk
16:38:08 <harlowja_at_home> oh goodie
16:38:31 * harlowja_at_home waits for crickets to speak up
16:38:56 <jd__> what what what did I win?
16:39:01 <jd__> I shouldn't be AFK
16:39:03 <harlowja_at_home> lol
16:39:08 <harlowja_at_home> u won
16:39:10 <harlowja_at_home> it all
16:39:16 <harlowja_at_home> all the things!
16:39:18 * jungleboyj has to go get his son from school anway.  Later.  :-)
16:39:25 <harlowja_at_home> :)
16:39:28 <harlowja_at_home> lata
16:39:51 <harlowja_at_home> ok, short meeting today, have 20 minutes back to do some reviews and make some code better and such :)
16:39:57 <harlowja_at_home> and jd__ collect your prize later
16:40:01 <harlowja_at_home> ha
16:40:07 <jd__> fair enough
16:40:09 <stevemar> yay for 20 minutes back :\
16:40:15 <harlowja_at_home> :)
16:40:24 <harlowja_at_home> #endmeeting