#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:01 UTC (full logs).

Meeting summary

  1. Review action items from previous meeting (dhellmann, 16:01:54)
    1. dhellmann talk to sileht about bug 856764 (dhellmann, 16:02:07)
    2. sileht post summary of the rabbit heartbeat issue to the mailing list so we can pick a solution - DONE (dhellmann, 16:02:40)
    3. http://lists.openstack.org/pipermail/openstack-dev/2014-November/050782.html (dhellmann, 16:02:40)
    4. we'll proceed with i159's patch and refine it if we need to later (dhellmann, 16:08:36)
    5. https://review.openstack.org/126330 (dhellmann, 16:08:53)
    6. rpodolyaka2 talk to #openstack-infra about setting up a bot to announce new oslo bugs (dhellmann, 16:09:01)
    7. http://git.openstack.org/cgit/openstack/oslo-incubator/tree/tools/list_oslo_projects.py (dhellmann, 16:11:45)
    8. dims to prepare oslo.utils release (dhellmann, 16:13:11)
    9. http://lists.openstack.org/pipermail/openstack-dev/2014-November/051271.html (dhellmann, 16:13:11)
    10. bnemec talk to dhellmann about updating review dashboard links (dhellmann, 16:14:06)
    11. https://review.openstack.org/#/c/135032/ (bnemec, 16:14:41)
    12. viktors talk to dhellmann about fixing up oslo.db launchpad - DONE (dhellmann, 16:15:21)
    13. harlowja_at_home talk to dhellmann about updating taskflow's bug tracker and milestones - DONE (dhellmann, 16:15:22)
    14. dhellmann clean up oslo-incubator kilo-next page - DONE (dhellmann, 16:15:22)
    15. flaper87 start a mailing list thread on a job/bot to email bugs for triage to volunteers - DONE (dhellmann, 16:15:22)
    16. http://lists.openstack.org/pipermail/openstack-dev/2014-November/050767.html (dhellmann, 16:15:22)
    17. dhellmann fix meeting time link - DONE (dhellmann, 16:15:23)

  2. Red flags for/from liaisons (dhellmann, 16:15:42)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/051206.html (dhellmann, 16:21:31)
    2. ACTION: dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs (dhellmann, 16:22:13)

  3. Invite liaisons to the cross-project meeting (dhellmann, 16:22:35)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/051153.html (dhellmann, 16:22:36)
    2. https://wiki.openstack.org/wiki/Meetings#OpenStack_Project_.26_Release_Status_meeting (dhellmann, 16:22:36)

  4. Reviews for config option discovery functions in incubator (dhellmann, 16:26:18)
    1. https://review.openstack.org/#/c/113940/ (dhellmann, 16:26:18)
    2. it looks like that merged since I put it on the agenda (dhellmann, 16:26:28)

  5. Identify release manager for each library (dhellmann, 16:26:39)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/051277.html (dhellmann, 16:27:39)
    2. https://wiki.openstack.org/wiki/Oslo/ReleaseProcess (dhellmann, 16:28:43)
    3. ACTION: dhellmann to release cliff (dhellmann, 16:29:47)
    4. ACTION: bnemec to release oslo.concurrency (dhellmann, 16:30:24)
    5. ACTION: dims to release oslo.utils (dhellmann, 16:30:29)
    6. ACTION: dhellmann to release oslo.config (dhellmann, 16:31:15)
    7. ACTION: sileht to release oslo.messaging (dhellmann, 16:31:31)
    8. ACTION: viktors to release oslo.db (dhellmann, 16:32:42)
    9. ACTION: dims to release oslo.1i8n (dhellmann, 16:33:52)
    10. ACTION: jd__ to release oslo.middleware (dhellmann, 16:35:28)
    11. ACTION: dhellmann to release oslo.rootwrap (or talk to ttx about doing it) (dhellmann, 16:36:06)
    12. ACTION: bnemec to release oslo.serialization (dhellmann, 16:37:19)
    13. ACTION: dims to release oslo.vmware (dhellmann, 16:38:49)
    14. ACTION: dhellmann to release oslosphinx (dhellmann, 16:39:13)
    15. ACTION: dhellmann to release oslotest (dhellmann, 16:39:29)
    16. ACTION: talk to harlowja_away about releasing taskflow (dhellmann, 16:40:44)

  6. Spec reviews (dhellmann, 16:41:36)
    1. https://review.openstack.org/#/c/131666/ (sileht, 16:42:13)
    2. https://review.openstack.org/#/c/124847/ also has one +2 but could use some more votes (dhellmann, 16:43:18)

  7. Stable maintenance liaison (dhellmann, 16:44:45)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/050390.html (dhellmann, 16:44:45)
    2. ACTION: dhellmann sign up as documentation liaison (dhellmann, 16:46:47)

  8. Need help with bug triage work - one person for each lib? (dhellmann, 16:48:10)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-November/051281.html (dhellmann, 16:50:17)
    2. proposed sprint day 4 December (dhellmann, 16:50:29)

  9. Ongoing work & Review priorities (dhellmann, 16:53:31)
    1. https://launchpad.net/oslo/+milestone/next-kilo (dhellmann, 16:53:32)
    2. https://launchpad.net/oslo/+milestone/kilo-1 (dhellmann, 16:53:32)
    3. rabbit heartbeat review (dhellmann, 16:54:15)
    4. https://review.openstack.org/126330 (dhellmann, 16:54:15)
    5. ACTION: sileht talk to devstack team about updating to not install oslo from source in stable branches (dhellmann, 16:56:15)
    6. https://review.openstack.org/132551 (dhellmann, 16:58:55)
    7. https://review.openstack.org/124847 (dhellmann, 16:59:08)


Meeting ended at 17:02:04 UTC (full logs).

Action items

  1. dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
  2. dhellmann to release cliff
  3. bnemec to release oslo.concurrency
  4. dims to release oslo.utils
  5. dhellmann to release oslo.config
  6. sileht to release oslo.messaging
  7. viktors to release oslo.db
  8. dims to release oslo.1i8n
  9. jd__ to release oslo.middleware
  10. dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
  11. bnemec to release oslo.serialization
  12. dims to release oslo.vmware
  13. dhellmann to release oslosphinx
  14. dhellmann to release oslotest
  15. talk to harlowja_away about releasing taskflow
  16. dhellmann sign up as documentation liaison
  17. sileht talk to devstack team about updating to not install oslo from source in stable branches


Action items, by person

  1. bnemec
    1. bnemec to release oslo.concurrency
    2. bnemec to release oslo.serialization
  2. dhellmann
    1. dhellmann make sure instructions for creating a new library are up to date with stable requirements jobs
    2. dhellmann to release cliff
    3. dhellmann to release oslo.config
    4. dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
    5. dhellmann to release oslosphinx
    6. dhellmann to release oslotest
    7. dhellmann sign up as documentation liaison
  3. dims
    1. dims to release oslo.utils
    2. dims to release oslo.1i8n
    3. dims to release oslo.vmware
  4. jd__
    1. jd__ to release oslo.middleware
  5. sileht
    1. sileht to release oslo.messaging
    2. sileht talk to devstack team about updating to not install oslo from source in stable branches
  6. ttx
    1. dhellmann to release oslo.rootwrap (or talk to ttx about doing it)
  7. UNASSIGNED
    1. viktors to release oslo.db
    2. talk to harlowja_away about releasing taskflow


People present (lines said)

  1. dhellmann (189)
  2. bnemec (22)
  3. dims (16)
  4. sileht (15)
  5. rpodolyaka1 (12)
  6. shardy (9)
  7. bknudson (9)
  8. i159 (5)
  9. jungleboyj (4)
  10. uvirtbot (4)
  11. kgiusti (4)
  12. openstack (3)
  13. viktors|wfh (3)
  14. jd__ (2)
  15. GheRivero (2)
  16. dstanek (1)
  17. zzzeek (1)
  18. ttx (1)
  19. ozamiatin (1)
  20. kragniz (1)


Generated by MeetBot 0.1.4.