16:07:32 <dhellmann> #startmeeting oslo
16:07:33 <openstack> Meeting started Fri Oct 24 16:07:32 2014 UTC and is due to finish in 60 minutes.  The chair is dhellmann. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:07:36 <openstack> The meeting name has been set to 'oslo'
16:07:43 <dhellmann> sorry for starting a bit late!
16:07:46 <dhellmann> who else is here?
16:07:47 <rpodolyaka1> o/
16:07:49 <shardy> o/
16:07:51 <harlowja_at_home> yo
16:07:54 <viktors> o/
16:07:56 <beekneemech> My calendar failed to remind me too.
16:08:04 <beekneemech> Guess it's Friday for everyone. :-)
16:08:19 <bknudson> hi
16:08:21 <dhellmann> #action dhellmann send an email reminder of the time change before our next meeting
16:08:22 <kgiusti> o/
16:08:38 <ihrachyshka> o/
16:08:50 <dhellmann> we don't have a lot to go over this week
16:08:57 <dhellmann> did everyone have a chance to review the summit schedule?
16:09:08 <jecarey> o/
16:09:12 <bknudson> link?
16:09:22 <dhellmann> #link http://kilodesignsummit.sched.org/overview/type/oslo#.VEp5rr5hUts
16:10:06 <bknudson> what's reqd for liasons?
16:10:09 <dhellmann> I tried to avoid known conflicts, but as usually we can only do so much
16:10:30 <dhellmann> bknudson: we'd like you to be there for the wed 11:00 session "oslo graduation schedule" for sure
16:10:40 <dhellmann> other than that one, I think it's safe for you to pick based on interest
16:11:02 <bknudson> y, and lack of conflict with our own proj schedule
16:11:27 <dhellmann> the thurs 17:20 session "moving oslo away from namespace packages" will have an impact, but we'll be making the migration plan clear so it's safe to miss that one
16:12:01 <dhellmann> bknudson: right. If there's something you especially want to be present for, I can try to juggle, but our options are pretty limited (I have at least 3 sessions I can't move because of other known conflicts)
16:12:44 <bknudson> I'll just have 4 or 5 etherpads open
16:12:47 <dhellmann> between now and the summit, we should review the existing specs because I anticipate having quite a few more after the summit
16:13:14 <dhellmann> #link https://review.openstack.org/#/q/project:openstack%2Foslo-specs+is:open,n,z
16:13:54 <dhellmann> does anyone have any red flags to raise this week?
16:14:52 <harlowja_at_home> nopers
16:14:56 <beekneemech> Are we going to require the lib name prefix on specs you and ttx were discussing earlier?
16:15:15 <dhellmann> oh, bknudson, the proposed session on encrypting/obscuring config files didn't make the cut in part because of lack of info -- do you and morganfainberg have a spec planned?
16:15:21 <bknudson> not really a red flag but keystone is held back in the switch to oslo.config.
16:15:37 <bknudson> dhellmann: I hope to have time to put together a spec.
16:15:45 <dhellmann> bknudson: what's holding you up? the config generator?
16:15:56 <bknudson> dhellmann: y, switching to the config generator
16:16:03 <shardy> actually, that's holding Heat up too
16:16:19 <shardy> I wasn't sure how to migrate the generate_sample script
16:16:20 <bknudson> there are reviews / bugs for the issues... I think there's a review for missing opts in oslo-incubator
16:16:27 <shardy> Are there examples of how to handle that?
16:16:42 <bknudson> and then there's the bug I wrote up for the order of options in the generated file.
16:16:56 <dhellmann> bknudson: I think https://review.openstack.org/#/c/113940/ should fix that, right?
16:16:57 <bknudson> shardy: let me point you to dolphs work in keystone.
16:17:04 <shardy> bknudson: thanks!
16:17:12 <bknudson> dhellmann: yes, https://review.openstack.org/#/c/113940/ is needed
16:17:25 <dhellmann> ok, cores, let's see if we can review ^^ today or monday
16:17:34 <beekneemech> ack
16:17:44 <dhellmann> oh, hrm, that's blocked on the patch for removing the log module
16:17:45 <bknudson> shardy: https://review.openstack.org/#/c/113905/ is the keystone work to switch
16:17:59 <dhellmann> I should rebase that and add the logging options back to it
16:18:10 <bknudson> The bug is https://bugs.launchpad.net/oslo.config/+bug/1356591 -- "oslo-config-generator alphabetizes options"
16:18:12 <uvirtbot> Launchpad bug 1356591 in oslo.config "oslo-config-generator alphabetizes options" [Medium,Triaged]
16:18:28 <bknudson> but I can live without the bug fix since we're early in K.
16:18:35 <shardy> bknudson: most helpful, thanks :)
16:19:44 <dhellmann> bknudson: yeah, I think we could just emit the options in the order they are registered to give projects control over that
16:20:14 <dhellmann> beekneemech: good question about the spec prefix, I wanted to ask the group before proposing that we do it. Thoughts?
16:20:31 <beekneemech> dhellmann: Seems like a good idea to me.
16:21:57 <beekneemech> I don't know if everyone knows what we're talking about though. :-)
16:22:17 <dhellmann> beekneemech: oh, good point
16:22:32 <beekneemech> Basically the suggestion was to keep the single oslo-specs repo, but require that lib-specific changes have their title prefixed with the name of the lib.
16:22:59 <dhellmann> we already include the name of the lib in the spec, but this would make it easier to scan the list of reviews
16:23:08 <beekneemech> Yep
16:23:43 <dhellmann> we can go through gerrit and update the existing copies, but if someone submits an update they would have to preserve that change
16:24:23 <beekneemech> Yeah, I'm sure it will get missed a few times, but it's a start.
16:24:48 <dhellmann> how about if we give it a try and see if it makes reviews easier or harder
16:25:01 <dhellmann> can I get a volunteer to update the existing reviews through the gerrit UI?
16:25:01 <beekneemech> wfm
16:25:32 <beekneemech> I can do that.  There aren't too many open right now.
16:25:37 <dhellmann> beekneemech: thanks
16:25:48 <dhellmann> #action beekneemech add lib name prefixes to titles for existing specs
16:26:13 <dhellmann> we should also make sure that each spec refers to its blueprint
16:26:36 <dhellmann> I see a few that don't have the topic set, so I think that means they don't refer to the bp in their commit message
16:27:01 <beekneemech> Hmm, yeah
16:27:35 <dimsum_> o/ sorry for the delay
16:27:48 <dhellmann> hi, dimsum_. no worries, we started a little late.
16:28:30 <dhellmann> I don't see any specs ready to be approved, yet, but some seem like they're close. I'll check Monday to see where things stand after we've had a chance to review more.
16:28:59 <dhellmann> are other people going to be travelling next friday? I was considering cancelling the meeting, since it's right before the summit
16:29:56 <beekneemech> I'm not, but that doesn't seem like the most productive meeting time either.
16:30:01 <dhellmann> yeah
16:30:23 <dhellmann> does anyone object to cancelling the meeting on oct 31?
16:30:29 <beekneemech> Probably better if everyone spends the time brushing up on the summit topics.
16:30:36 * dhellmann nods
16:30:45 <beekneemech> +1 to no meeting
16:30:48 <dimsum_> +1 to cancel
16:31:10 <rpodolyaka1> +1
16:31:27 <viktors> +1
16:31:39 <dhellmann> ok,  liaisons we'll still (mostly) be on IRC so hit us up informally if you run into issues
16:31:48 <dhellmann> #info no IRC meeting on Oct 31
16:32:04 <beekneemech> Maybe I'll go trick-or-treating instead ;-)
16:32:10 <dimsum_> yay
16:32:17 <dhellmann> #info next IRC meeting 17 Nov 16:00 UTC in #openstack-meeting-alt
16:32:34 <dhellmann> beekneemech: haha
16:32:51 <dhellmann> ok, big question: who is going to be able to make it to the summit?
16:33:00 <harlowja_at_home> me
16:33:03 <dhellmann> o/
16:33:03 * shardy will be there
16:33:05 <beekneemech> o/
16:33:15 <ihrachyshka> o/
16:33:25 <dimsum_> o/
16:33:29 <kgiusti> o/
16:33:34 <bknudson> \o
16:33:45 <dhellmann> oh, good, we'll have a nice turnout
16:33:46 <rpodolyaka1> o/
16:33:49 <dhellmann> rpodolyaka1, viktors: ?
16:33:56 <viktors> dhellmann: o/
16:33:58 <dhellmann> cool
16:34:15 <dhellmann> I know zzzeek said he wasn't going to make it this time around, but we can still talk about plans
16:34:32 <dhellmann> I expect sileht and jd__ will be there, since it's only across town for them
16:34:38 <rpodolyaka1> :)
16:35:23 <dhellmann> ok, I think that covers everything we need to talk about this week, unless someone has another topic they would like to raise?
16:35:56 <shardy> dhellmann: I was wondering if there's a defined deprecation proces for oslo-incubator?
16:36:10 <shardy> ref the request_id issues I ran into
16:36:11 <dhellmann> shardy: sort of, yes, let me get that link
16:36:46 <dhellmann> ah, ok, that was a special case because it shows up in config files
16:37:07 <dhellmann> #link https://wiki.openstack.org/wiki/Oslo#Graduation
16:37:26 <dhellmann> hrm, that's actually out of date with what we said we would do for kilo
16:38:07 <dhellmann> we ran into issues holding old code in the incubator after graduation, because code that wasn't graduated didn't use the libraries so we had a few cases where multiple copies of code were in play in an app
16:38:20 <shardy> dhellmann: Yeah I guess it was, I was just thinking if deprecation warnings typically landed before the first milestone, it would (probably) maximize the chances of most projects syncing it
16:38:28 <dhellmann> so for kilo we decided that after the first release of a library we would delete the incubator version and update the other code to refer to the lib
16:38:43 <shardy> Or, a checkpoint for removal of code from incubator could be a sanity check that projects sync'd the warning
16:38:56 <shardy> I guess in non-config-impacting cases, it doesn't matter so much though
16:39:03 <dhellmann> shardy: we are actually trying to minimize the number of syncs a project needs to do at all, so once something starts graduating we try to cut down on changes
16:39:05 <beekneemech> A lot of projects will never sync the warning though.
16:39:15 <dhellmann> right ^^
16:39:23 <shardy> beekneemech: Yeah, that's the problem I'm trying to solve :)
16:39:35 <dhellmann> one of the reasons for the big push to graduate is that projects have stopped syncing
16:39:40 <shardy> at first I thought only Heat failed to, but it was everyone :-O
16:39:51 <dhellmann> once we get them onto the library, they get bug fixes without having to do anything
16:39:52 <bknudson> at some point there's not much in oslo-incubator so might as well auto-propose.
16:40:12 <shardy> we normally sync less regularly in the latter half of the cycle, which is why we missed it
16:40:20 <bknudson> auto-propose would probably work for keystone once we're synced to current
16:40:42 <shardy> bknudson: I thought that too, but in many cases there's API breaks which need project code fixup
16:40:43 <dhellmann> yep, this is one of the important roles the liaisons play -- keeping projects informed of what's going on in oslo
16:40:50 <shardy> or at least, historically that's been my experience
16:40:58 <beekneemech> We really don't want to be in a place with incubator where auto-propose even works.
16:41:05 <dhellmann> shardy: right, that's the point of the incubator is it's safe to break apis in incubated modules
16:41:06 <beekneemech> If an API is stable enough for that, we should graduate it.
16:41:12 <dhellmann> beekneemech: ++
16:41:35 <beekneemech> If we end up with no code in oslo-incubator, \o/
16:42:38 <harlowja_at_home> +1
16:43:16 <dhellmann> ok, let's call the meeting early and spend 15 minutes reviewing specs
16:43:39 <beekneemech> Sounds good.
16:43:54 <shardy> see you in Paris everyone :)
16:44:16 <dhellmann> yes, I'm looking forward to it!
16:45:32 <dhellmann> thanks everyone!
16:45:34 <dhellmann> #endmeeting