#openstack-meeting-alt: oslo

Meeting started by dhellmann at 16:00:08 UTC (full logs).

Meeting summary

  1. Review action items from previous meeting (dhellmann, 16:02:23)
    1. ACTION: dhellmann approach the other integrated projects who have not started work on oslo.i18n (dhellmann, 16:02:31)
    2. bknudson file a bug about timeutils mocking issue (dhellmann, 16:03:12)
    3. https://bugs.launchpad.net/oslo/+bug/1354521 (bknudson, 16:04:02)
    4. everyone review the repo being imported as oslo.concurrency (dhellmann, 16:04:23)

  2. Red flags for/from liaisons (dhellmann, 16:11:07)
    1. https://review.openstack.org/#/c/113940/ (dhellmann, 16:12:13)
    2. https://bugs.launchpad.net/oslo/+bug/1356591 (bknudson, 16:14:15)

  3. Need someone to run the meeting for the next 2 weeks (dhellmann) (dhellmann, 16:16:46)
    1. dimsum to chair the meeting next week (dhellmann, 16:17:56)
    2. beekneemech to chair the meeting in 2 weeks (dhellmann, 16:18:18)

  4. Adoption status (dhellmann, 16:18:27)
    1. https://etherpad.openstack.org/p/juno-oslo-adoption-status (dhellmann, 16:18:32)
    2. https://review.openstack.org/#/c/78614/ (jd__, 16:22:01)

  5. oslo.serialization graduation status (dhellmann, 16:24:42)
    1. https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-serialization (dhellmann, 16:24:48)
    2. https://review.openstack.org/112994 (beekneemech, 16:26:37)

  6. oslo.concurrency graduation status (dhellmann, 16:27:46)
    1. https://blueprints.launchpad.net/oslo/+spec/graduate-oslo-concurrency (dhellmann, 16:28:07)
    2. https://review.openstack.org/#/c/109417/ (dhellmann, 16:28:07)
    3. https://review.openstack.org/#/c/109469/ (dhellmann, 16:28:07)
    4. https://review.openstack.org/#/c/110933/ (dhellmann, 16:28:08)
    5. https://wiki.openstack.org/wiki/Oslo#Graduation (dhellmann, 16:28:35)
    6. http://lists.openstack.org/pipermail/openstack-dev/2014-August/043090.html (YorikSar, 16:31:07)
    7. https://etherpad.openstack.org/p/lockutils-issues (dhellmann, 16:31:50)

  7. bug fix for mask_password (dhellmann, 16:42:25)
    1. https://review.openstack.org/#/c/113407/ (dhellmann, 16:42:25)
    2. https://review.openstack.org/114579 (dhellmann, 16:43:24)
    3. ACTION: dimsum_ propose patch adding mask_password to oslo.utils.strutils (dhellmann, 16:49:20)

  8. oslo.db release review (dhellmann, 16:49:58)
  9. review priorities for this week (dhellmann, 16:55:52)
    1. https://review.openstack.org/#/q/status:open+project:openstack/oslo.db,n,z (rpodolyaka, 16:56:28)

  10. open discussion (dhellmann, 16:59:05)
    1. ACTION: make sure oslo.concurrency is in the graduating libs query for the dashboard (dhellmann, 16:59:40)


Meeting ended at 17:01:40 UTC (full logs).

Action items

  1. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  2. dimsum_ propose patch adding mask_password to oslo.utils.strutils
  3. make sure oslo.concurrency is in the graduating libs query for the dashboard


Action items, by person

  1. dhellmann
    1. dhellmann approach the other integrated projects who have not started work on oslo.i18n
  2. dimsum_
    1. dimsum_ propose patch adding mask_password to oslo.utils.strutils


People present (lines said)

  1. dhellmann (159)
  2. YorikSar (33)
  3. beekneemech (26)
  4. dimsum_ (22)
  5. bknudson (19)
  6. rpodolyaka (16)
  7. jd__ (14)
  8. openstack (5)
  9. pblaho (2)
  10. fungi (2)
  11. uvirtbot (2)
  12. jecarey (2)
  13. bnemec (1)
  14. dims (1)


Generated by MeetBot 0.1.4.