#openstack-meeting: oslo

Meeting started by dhellmann at 14:01:13 UTC (full logs).

Meeting summary

    1. https://wiki.openstack.org/wiki/Meetings/Oslo (dhellmann, 14:01:28)

  1. adopting cliff and stevedore into oslo (dhellmann) (dhellmann, 14:02:13)
    1. ACTION: dhellmann work with infra team to move cliff and stevedore into oslo (dhellmann, 14:06:06)
    2. http://j.gs/3Nkb ! (Mellissa93xOxO, 14:06:24)

  2. adopting taskflow (dhellmann/jharlow) (dhellmann, 14:06:44)
  3. log translations (dhellmann) (dhellmann, 14:08:43)
    1. http://lists.openstack.org/pipermail/openstack-dev/2014-January/025572.html (dhellmann, 14:08:49)
    2. ACTION: bring up log translation at the next project meeting to poll the other PTLs (dhellmann, 14:12:18)
    3. http://lists.openstack.org/pipermail/openstack-dev/2014-January/025828.html (bnemec, 14:13:31)
    4. AGREED: we will advocate for translation of log messages at INFO level and above (dhellmann, 14:20:46)
    5. ACTION: dhellmann amend patches to reflect INFO/DEBUG log translation split (dhellmann, 14:21:01)
    6. https://wiki.openstack.org/wiki/LoggingStandards (sdague, 14:22:28)
    7. https://wiki.openstack.org/wiki/LoggingStandards (sdague, 14:22:32)
    8. ACTION: dhellmann update LoggingStandards in wiki with info about using translation functions for log messages (dhellmann, 14:23:13)

  4. parallelizing tests (dhellmann) (dhellmann, 14:23:35)
    1. https://bugs.launchpad.net/oslo/+bug/1272035 (dhellmann, 14:24:37)
    2. ACTION: dhellmann check on qpid unit tests for oslo.messaging and open a bug if there are none (dhellmann, 14:30:26)
    3. https://bugs.launchpad.net/oslo.messaging/+bug/1255239 (bnemec, 14:31:21)
    4. ACTION: bnemec to investigate splitting test suite into parallel and serial passes (dhellmann, 14:32:44)

  5. policy for maintaining graduating code in the incubator (dhellmann) (dhellmann, 14:33:13)
    1. AGREED: follow the stable branch rules for changes to graduated code that is still in the incubator (dhellmann, 14:39:10)

  6. oslo.db graduation status (viktors) (dhellmann, 14:39:26)
    1. https://blueprints.launchpad.net/oslo/+spec/oslo-db-lib (viktors, 14:39:40)
    2. https://wiki.openstack.org/wiki/Oslo/Dependencies (dhellmann, 14:42:31)

  7. oslo.config futures question from sdague (dhellmann, 14:53:20)
    1. ACTION: dhellmann open bug to document type arg to config options (dhellmann, 14:58:36)


Meeting ended at 15:04:15 UTC (full logs).

Action items

  1. dhellmann work with infra team to move cliff and stevedore into oslo
  2. bring up log translation at the next project meeting to poll the other PTLs
  3. dhellmann amend patches to reflect INFO/DEBUG log translation split
  4. dhellmann update LoggingStandards in wiki with info about using translation functions for log messages
  5. dhellmann check on qpid unit tests for oslo.messaging and open a bug if there are none
  6. bnemec to investigate splitting test suite into parallel and serial passes
  7. dhellmann open bug to document type arg to config options


Action items, by person

  1. bnemec
    1. bnemec to investigate splitting test suite into parallel and serial passes
  2. dhellmann
    1. dhellmann work with infra team to move cliff and stevedore into oslo
    2. dhellmann amend patches to reflect INFO/DEBUG log translation split
    3. dhellmann update LoggingStandards in wiki with info about using translation functions for log messages
    4. dhellmann check on qpid unit tests for oslo.messaging and open a bug if there are none
    5. dhellmann open bug to document type arg to config options


People present (lines said)

  1. dhellmann (165)
  2. sdague (40)
  3. bnemec (38)
  4. jd__ (28)
  5. viktors (20)
  6. Daisy (11)
  7. dims (9)
  8. ttx (5)
  9. Mellissa93xOxO (4)
  10. flaper87 (4)
  11. openstack (3)
  12. zyluo (1)
  13. ozstacker (1)


Generated by MeetBot 0.1.4.