18:00:56 <mfisch> #startmeeting Operations
18:00:56 <openstack> Meeting started Wed Jan  7 18:00:56 2015 UTC and is due to finish in 60 minutes.  The chair is mfisch. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:00:58 <dvorak> yeap
18:01:00 <openstack> The meeting name has been set to 'operations'
18:01:02 <mdorman> o/
18:01:12 <mfisch> a lovely snowy day here, who's around???
18:01:19 <klindgren> o/
18:02:13 <mfisch> okay we dont have many topics today
18:02:27 <mfisch> #link https://etherpad.openstack.org/p/openstack-operators-meeting-070115-agenda
18:02:58 <mfisch> The main topic is the mid-cycle meet-up which is March 9-10 in Philadelphia
18:03:08 <mfisch> anyone here planning to go?
18:03:20 <mdorman> i figure on going, assuming my boss says i can
18:03:24 <klindgren> I hope to - haven't actaully discussed it yet
18:03:30 <rickerc> I am
18:03:43 <mfisch> I am going as is dvorak
18:03:58 <dvorak> yeap
18:04:11 <mfisch> the main thing is that everyone should work on adding topics to the Etherpad:
18:04:14 <mfisch> #link https://etherpad.openstack.org/p/PHL-ops-meetup
18:04:20 <mfisch> not sure that link is working but thats the etherpad
18:04:57 <serverascode____> I'm going to the Philly meetup as well
18:05:00 <mdorman> also need people to volunteer to lead/guide the sessions and owrking groups
18:05:04 <mdorman> fwiw
18:05:41 <mfisch> what does that entail?
18:05:56 <mdorman> really just taking that from Tom’s notes at the top of hte etherpad
18:06:08 <mdorman> "We also need Moderators, who lead the discussions, ususally in areas they are interested in."
18:06:37 <jlk> oh hi. Missed the start.
18:06:43 <mfisch> I hoped tom could make it today, but I dont see him
18:07:24 <mfisch> crinkle: will you be there?
18:07:45 <crinkle> mfisch: I haven't brought it up with my company yet, will do asap
18:07:51 * mfisch notes that puppet has a lot of votes
18:08:13 <emagana> I will be at the meet up as well
18:08:43 <emagana> mdorman: I already signed up as moderators
18:08:49 <jlk> this is the operators meet up this March?
18:08:56 <mdorman> cool, yeah saw that emagana
18:09:01 <mdorman> jlk: yes
18:09:03 <mfisch> I see furious editing going on so thats good
18:09:20 <jlk> yeah I plan to be there with a couple others from my company
18:09:23 <mfisch> Anything we should know or prep for the meet-up for those who've attended?
18:10:01 <jlk> come with an agenda, be prepared to pitch it, also be prepared to be completely overwhelmed with data :)
18:10:30 <mdorman> yaeh i’d agree.  try to get things you’re most interested in the etherpad so the agenda accurately reflects what people want to get out of it
18:11:29 <mfisch> thanks
18:11:54 <mfisch> This will be an ongoing process and ML discussion
18:12:01 <mfisch> unless there's anything else on this we can move on?
18:12:09 <rickerc> are particulars (time, address, etc) firmed up yet? adding those to the wiki will help people booking travel
18:12:25 <mdorman> yeah there was a ML post about that
18:12:39 <mdorman> but its mar 9-10 in philadelphia
18:12:41 <mfisch> rickerc: March 9 - 10, ending early enough on the 10th to catch planes
18:12:59 <mfisch> I'm planning on leaving early on the 11th since I have a long flight
18:13:09 <mdorman> +1
18:13:29 <dvorak> we've booked travel, we're staying at the Windsor Suites, which is a block or two away
18:13:29 <mfisch> rickerc: its hosted at the Comcast building
18:13:47 <dvorak> also, the Comcast building has a subway station in the basement, so it's easy to get to from the airport or Amtrak
18:14:11 * mfisch notes he can spur discussion simply by threatening to change the topic
18:14:52 <markvoelker> Is someone setting up an eventbrite, or should we just register via etherpad?
18:15:24 <mfisch> good ML question, can you reply to Tom?
18:15:40 <markvoelker> sure
18:16:02 <mdorman> there was a question about registration on the ML this morning.  i imagine tom will reply soon
18:16:30 <markvoelker> AH, so there was. Cool.
18:17:36 <mfisch> would things like ovs work as topics?
18:17:46 <mfisch> I wonder if that's too low level
18:17:48 <mdorman> don’t see why not
18:17:53 <mdorman> it’s relevant to people
18:18:04 <markvoelker> mdorman: +1
18:18:26 <klindgren> Are we still using the github repo for ops tools? or did we get an "offical" one?
18:18:38 <rickerc> throw it in the wiki, see how many votes it gets
18:18:42 <mdorman> no official one yet as far as i know
18:18:46 <mfisch> to my knowledge we dont have an official one yet
18:19:35 <markvoelker> Nothing official AFAIK. Even the osops repo has seen relatively little traffic.
18:19:53 <klindgren> Can people update what they have in the current one (I know I have some updates that need to get pushed)
18:19:56 <mdorman> yeah i htink everyone likes the idea, but kinda difficult to get momentum going on contributions
18:21:14 <mfisch> I've been meaning to contribute some db upgrade stuff but I've not found the time
18:21:19 <mfisch> assume thats everyones issue
18:21:37 <mfisch> thanks for the segue klindgren
18:21:41 <mfisch> #topic tools
18:22:26 <mfisch> I don't see Xav here, but he was going to start working on sharing some of his tools/processess
18:23:00 <mfisch> has anyone else considered that?
18:23:55 <mdorman> there have been a few people put stuff in there.
18:24:32 <mdorman> i feel like it might make more sense to just have everybody kinda do a ‘dump’ there, and then we can start looking for commonalities, dups, etc.
18:24:45 <mfisch> what do you think about company specific stuff?
18:24:54 <mfisch> everyone has quirks that their code accomadates
18:24:56 <mdorman> so i guess what i’m saying is i think there is value in people just sending in a PR of their directory of stuff, rather than trying to to patches against what’s in there at the moment.
18:24:58 <mfisch> undocumented usually
18:25:26 <mdorman> well my personal opionin on that stuff is that generally it should stay out of the community tools.  and/or have it be configurable so it’s disabled by default, etc.
18:26:02 <mfisch> I need to consider that when writing tools like ansible code
18:26:12 <mfisch> or at least make it so that its easy to see where that stuff is and remove
18:26:25 <mdorman> right.  it’s tricky
18:26:35 <mfisch> okay lets move along
18:26:39 <mfisch> #topic sample config follow-up
18:26:51 <mfisch> did anyone see any follow-up about sample configs?
18:26:57 <mfisch> there was supposed to be a proposal and ML post
18:27:21 <dvorak> I didn't see anything.  I'm guessing it got lost over the holiday
18:27:34 <mfisch> does anyone remember who agreed to do that?
18:27:37 <mdorman> yeah i am not sure wehre that got left either
18:28:22 <mfisch> mdorman: can you look back at that meeting minutes and see who agreed to do the work?
18:28:27 <mfisch> I'm blanking on the name
18:28:28 <mdorman> yeah doing that now
18:28:32 <mfisch> I can ping him or you can
18:29:04 <mfisch> okay we can take that offline
18:29:09 <mfisch> #action follow-up on sample config proposal
18:29:16 * mfisch is pretty sure meeting bot is ignoring me
18:30:00 <mfisch> okay the only other topic is packaging follow-up but thats in the same boat as tools
18:31:10 <mfisch> I will ping xavprince about tools and what not after this
18:31:30 <mfisch> mdorman: can you ping on the sample config?
18:31:57 <mdorman> digging through the log now.  http://eavesdrop.openstack.org/meetings/crossproject/2014/crossproject.2014-12-16-21.01.log.txt  there were no specific actions from it last time, so trying to find the name
18:32:34 <mfisch> I think it was fungi
18:33:00 <dvorak> I believe so
18:33:11 <mfisch> 21:29:53 <fungi> so i think as a takeaway we can at least summarize some of these options as doable and take the temperature on the ml thread>?
18:33:20 <mfisch> mdorman: can you ping him?
18:33:22 <fungi> yeah
18:33:27 <mfisch> ah, done!
18:33:27 <fungi> i did that
18:33:34 <mdorman> yeah i was goign to say, pretty sure that already happened
18:33:42 <fungi> not many people followed up on the mailing list to my summary
18:33:59 <mfisch> fungi: which ml?
18:35:14 <mfisch> if I missed it, I apologize
18:35:19 <fungi> operators ml
18:35:23 <fungi> digging up a link now
18:35:30 <mfisch> thanks
18:36:25 <fungi> #link http://lists.openstack.org/pipermail/openstack-operators/2014-December/005742.html
18:36:47 <mfisch> okay then I missed it, my fault
18:37:41 <mfisch> okay anything else for today?
18:38:36 <markvoelker> Just one quick reminder I think
18:39:07 <markvoelker> Since folks here have an interest in ops, some of you may also be interested in work being done in the "Win The Enterprise" teams
18:39:17 <markvoelker> #link https://wiki.openstack.org/wiki/Win_the_Enterprise
18:39:44 <markvoelker> There are some folks there interested in operations, monitoring, deployment, etc
18:39:55 <markvoelker> So just wanted to raise awareness for those who didn't know.
18:40:20 <barrett1> The Win The Enterprise teams are looking for more Operators to participate
18:41:24 <barrett1> The Win The Enterprise teams are looking to create reference architectures, best practices, documentation patches and blueprints for new capabilities
18:42:13 <markvoelker> barrett1: might be good to get those meetings listed/linked to from the official Meetings wiki page to raise awareness
18:42:17 <markvoelker> https://wiki.openstack.org/wiki/Meetings
18:42:53 <dvorak> mfisch dropped offline, let's give him a minute and we can wrap up if he can't get back online shortly.
18:43:22 <mdorman> more soil samples at the office? :)
18:43:33 <dvorak> heh, I think he's WFH today
18:44:06 <mfisch> sorry, I lost networking for a bit
18:44:07 <mdorman> (context: https://twitter.com/tadowguy/status/543077687409905664 )
18:44:08 <mfisch> uh, I was showing a repair guy something and unplugged the router ;)
18:44:10 <mfisch> anyway, I dont know what I missed but we were about done?
18:44:22 <mfisch> #funtimes
18:44:32 <mdorman> i think so.  unless there were other topics anyone was going to call out.
18:44:52 <barrett1> You can find a list of the Win The Enterprise Teams and meeting times on the WTE wiki: https://wiki.openstack.org/wiki/Win_the_Enterprise. Will add to meetings Wiki too
18:45:16 <barrett1> What's the location for the tools repository?
18:45:52 <klindgren> barrett1, https://github.com/osops
18:48:11 <mfisch> unless there's anything else? I'll close out
18:48:25 <fungi> oh, i meant to add, the takeaway from the sample configs discussion on the ml needs to result in a volunteer to draft a cross-project spec
18:48:39 <fungi> which i mention in my follow-up e-mail in that thread
18:48:54 <fungi> but anyway, that's the "how to get something done about it" once there's some consensus
18:49:09 <mfisch> thanks fungi
18:49:35 <fungi> yw
18:49:57 <mfisch> thanks all
18:50:12 <mfisch> hopefully we'll get some follow-up on that thread, I'll go look at it later this week
18:50:59 <mfisch> #endmeeting