19:09:02 <stevemar> #startmeeting openstackclient
19:09:03 <openstack> Meeting started Thu Mar 17 19:09:02 2016 UTC and is due to finish in 60 minutes.  The chair is stevemar. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:09:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:09:07 <openstack> The meeting name has been set to 'openstackclient'
19:09:21 <stevemar> dtroyer, dhellmann, stevemar, terrylhowe, lhcheng, dstanek, rtheis, MeganR << ping for osc meeting
19:09:44 * dhellmann listens partially
19:10:37 <stevemar> i think osc is long overdue for a bug triage
19:11:02 <stevemar> but that's aside the point
19:11:15 <stevemar> let's do reviews / bugs / open discussion
19:11:26 * stevemar pokes rtheis
19:11:52 <rtheis> bug triage ... yes that would be good
19:12:16 <rtheis> sorry, I was drifting off to a review
19:12:19 <stevemar> rtheis: we could do it together at the summit, or maybe all go on hangouts and do it together
19:12:25 <stevemar> rtheis: it's all good :)
19:12:29 <stevemar> #topic reviews
19:12:38 <stevemar> rtheis: speaking of reviews, any you have in mind?
19:12:51 <stevemar> any i should put on my queue that are ready to go?
19:13:03 <rtheis> https://review.openstack.org/#/c/292541/
19:13:19 <stevemar> ah yeah
19:13:24 <stevemar> i saw that earlier
19:13:32 <stevemar> i still want to create a basic osc plugin package
19:13:34 <rtheis> Trying to better understand OSC plugin for neutron stadium transition
19:13:57 <stevemar> it just works (TM)
19:14:20 <rtheis> what would the osc plugin package contain?
19:14:39 <stevemar> everything under common and tests/common
19:15:09 <stevemar> rtheis: i hadn't updated it in a year :( https://github.com/stevemart/osc-base
19:16:04 <rtheis> Idea is for plugins to include that in requirements.txt?
19:16:06 <stevemar> rtheis: a lot of projects/plugins ended up either calling osc.common.utils.find_resource or... copying and pasting the entire thing
19:16:28 <stevemar> yeah, include osc-base in requirements instead of full OSC
19:16:34 <stevemar> (for a plugin)
19:16:44 <rtheis> I've seen a mix of plugins including OSC in requirements, test-requirements or neither
19:16:45 <stevemar> so they don't pull in every single dependency we do
19:16:55 <stevemar> yeah, thats dangerous
19:17:04 <rtheis> what should be done today?
19:17:09 <stevemar> maybe dhellmann has some thoughts on that?
19:17:25 <stevemar> rtheis: i think plugins should be listing it in requirements
19:17:36 <rtheis> ok
19:17:37 <stevemar> but jeez that is a huge dependency
19:18:07 <rtheis> yes
19:18:10 <terrylhowe> sure is the simplest thing to do; it would confusing if osc was installed without something and someone tried to use it
19:18:34 <terrylhowe> I wrote a plugin a while back and that is what I did
19:18:41 <stevemar> thats the other side... all these plugins *need* osc to work
19:18:54 <stevemar> so... they should like osc as a dependency
19:19:00 <dhellmann> yeah, listing osc in the requirements for a plugin makes sense
19:19:12 <dhellmann> it also gives them a place to declare the version of osc they work with
19:20:01 <stevemar> dhellmann: yeah, i should send an email blast to all osc plugins telling them to do that
19:20:10 <dhellmann> stevemar : ++
19:20:33 <stevemar> #action stevemar to send mailing list blast to osc consumers
19:20:48 <stevemar> what... action didn't work.. damn
19:20:56 <stevemar> oh well :)
19:21:23 <stevemar> if folks go and use osc in requirments.txt then creating an osc_base package is pointless
19:21:46 <stevemar> rtheis: any other reviews?
19:21:53 <rtheis> nothing else
19:22:18 <stevemar> i think i had one...
19:22:31 <stevemar> we've got https://review.openstack.org/#/c/276350/ chalked up
19:22:51 <stevemar> apparently it needs a new KSA release to work
19:23:33 <stevemar> but we can't release that til after RC period happens
19:23:38 <terrylhowe> important stuff, but broken atm
19:24:01 <stevemar> terrylhowe: rtheis i think once that merges we'll have to do a major version bump
19:24:14 <stevemar> and warn everyone that things may not be backward compatible
19:24:32 <terrylhowe> probably a good idea stevemar
19:24:35 <stevemar> i'm wondering if we can rename our project at the same time :D
19:24:44 <stevemar> drop the python-
19:24:49 <rtheis> stevemar: seems like that patch set should have a release note then
19:24:58 <stevemar> rtheis: oh for sure
19:25:54 <stevemar> rtheis: hehe, thanks for the comment on the patch
19:26:00 <rtheis> yw
19:26:20 <stevemar> i think there is more to be removed, mordred had a similar patch
19:26:30 <stevemar> https://review.openstack.org/#/c/225318/1
19:28:23 <stevemar> anyone brave enough to tackle that patch? :)
19:29:21 <rtheis> not I :)
19:29:32 <stevemar> damn
19:29:41 <stevemar> #bugs
19:29:44 <stevemar> #topic bugs
19:29:48 <rtheis> https://review.openstack.org/#/c/276350/ would go in first ?
19:29:51 <stevemar> any major bugs to talk about?
19:29:57 <rtheis> then https://review.openstack.org/#/c/225318/ ?
19:30:06 <stevemar> rtheis: i believe the two are doing the same thing
19:30:27 <rtheis> ok
19:31:15 <rtheis> I don't have any major bugs to discuss
19:31:29 <stevemar> the bugs looks mostly OK
19:31:40 <stevemar> i somewhat regret going along with the bug per command
19:31:49 <stevemar> its creating a lot of bugs :)
19:31:51 <rtheis> yeah
19:32:08 <terrylhowe> the only reason I started that is so people could jump in and work on things
19:32:10 <rtheis> hopefully that should be wrapping up for network
19:32:18 <stevemar> but.. it's alright, everyone is kinda working on them, so it's cool
19:32:37 <stevemar> yeah, of all the problems to have it's one i can live with
19:32:50 <stevemar> #topic open discussion
19:32:57 <stevemar> anything else?
19:33:23 <stevemar> i think by now dtroyer has the info on the amount of workrooms/ fishbowls / meetups we'll have at the summit
19:33:36 <stevemar> and any other summit-y details
19:33:53 <rtheis> stevemar: do you know the schedule for those ?
19:34:11 <stevemar> rtheis: not yet, probably won't come out for another week or two
19:34:19 <rtheis> ok
19:34:22 <stevemar> i haven't been told anything for keystone yet
19:34:39 <stevemar> oh sheel is still working
19:34:47 <stevemar> that's not good, it's super late for him
19:34:56 <stevemar> he is trying to fill the gap for cinder commands
19:35:10 <sheel> stevemar:  hey
19:35:18 <stevemar> sheel: hey!
19:35:25 <stevemar> sheel: we have the openstackclient meeting at this time
19:35:36 <rtheis> yeah, looks of good stuff going in these days
19:35:37 <stevemar> sheel: it's super late for you :\
19:35:44 <rtheis> * lots
19:35:53 <sheel> stevemar: yeah
19:36:10 <rtheis> I don't have any other topics
19:36:12 <stevemar> sheel: did you have anything you wanted to chat about ? i don't want to keep you up unnecessarily
19:36:29 <sheel> stevemar: I think no
19:36:40 <sheel> stevemar:  thanks
19:36:41 <stevemar> sheel: alright, i'll just review your patches :)
19:36:48 <sheel> stevemar: thank you...
19:36:51 <sheel> :)
19:36:51 <stevemar> np
19:37:07 <stevemar> terrylhowe: rtheis: anything else?
19:37:13 <rtheis> nope
19:37:20 <stevemar> we can cut this early and throw tomatoes at dtroyer for skipping
19:37:31 <terrylhowe> nothing here :)
19:37:57 <stevemar> alright, proceed with pelting our ptl with plump tomatoes
19:38:00 <stevemar> #endmeeting